Jump to content
devries

Thac and Zé's KDE 3.4 rpms

Recommended Posts

nevermind, the problem was not in ~/session it was a problem with kmail/kontact/whatever that package is called. If it starts everything freezes, i can only move the pointer, and the only way out is ctrl+alt+bkspace. I will figure this out...somehow. Maybe a reinstall of the o'l kmail could do it.

Share this post


Link to post
Share on other sites

new release of kde-3.4.0 for mdk-10.2 or 2005 limited edition

with lots of fixes

and all language files avilable

update urpmi repository

 

/Torbjörn Turpeinen (Thac)

Share this post


Link to post
Share on other sites

just wanted to say thanks a lot for all your hard work, thac - I don't use KDE myself but it's definitely appreciated and it'll make the lives of everyone who tries to help MDK users much easier when we get the flood of 'where can we get KDE 3.4 for 2005?!' after it's released :)

Share this post


Link to post
Share on other sites
Guest ambrice

Thac,

 

There doesn't seem to be a kdevelop 3.2 rpm for KDE 3.4, when I urpmi kdevelop it picks up the 3.1.2 version that comes with kde 3.3

Share this post


Link to post
Share on other sites
Thac,

 

There doesn't seem to be a kdevelop 3.2 rpm for KDE 3.4, when I urpmi kdevelop it picks up the 3.1.2 version that comes with kde 3.3

 

That is what I though, and I will try to upgrade 3.3 since I got 4 CDs from Manddrakeclub. And, I am going to try KDE 3.3 before attempt for 3.4... Be god with me!

 

let you know the results

Share this post


Link to post
Share on other sites
new release of kde-3.4.0 for mdk-10.2 or 2005 limited edition

with lots of fixes

and all language files avilable

 

Great work. The only remaining bugs I can see are with the desktop right-click -> Configure Desktop (no big loss there), and with Knode causing an error when Kontact starts.

 

Edit: It turns out that Kontact needs knode-devel. Might want to add a require to the spec file.

Edited by Dyslexic

Share this post


Link to post
Share on other sites
just wanted to say thanks a lot for all your hard work, thac - I don't use KDE myself but it's definitely appreciated and it'll make the lives of everyone who tries to help MDK users much easier when we get the flood of 'where can we get KDE 3.4 for 2005?!' after it's released :)

Where can we get Gnome 2.10 for 2005? ;)

Share this post


Link to post
Share on other sites
new release of kde-3.4.0 for mdk-10.2 or 2005 limited edition

with lots of fixes

and all language files avilable

update urpmi repository

 

/Torbjörn Turpeinen (Thac)

 

Excellent news Thac. Although the upgrade from your 3.3 to 3.4 didn't work for me I am very much looking forward to whatever new release MandrakeSoft decides to release. :) The parts of 3.4 that did work left a very big impression on me. I started a new thread since I reinstalled 10.1 and want to at least get up to date with your version of X.org, ATi drivers, and KDE 3.3.

 

Thanks again and great job. :drum:

Share this post


Link to post
Share on other sites

Anyone can give me a hint since I downloaded and installed KDE 3.4 and restart it, it came up with "terminal" like local login:.... What shall I type to get KDE desktop?

 

Help appreciate....

Share this post


Link to post
Share on other sites
Guest ambrice

Here are the problems that I ran into, and what I did to fix it. Most of them were not related to the KDE update, but due to updates to other packages (xorg, etc) required by the new KDE. I started with a standard Mandrake 10.1 installation with KDE 3.2 (don't have the MandrakeClub disk).

 

1) I added the five repositories (plf-free, plf-nonfree, main, contrib, thac)

2) I ran "urpmi kdebase"

3) After all that stuff, I did the urpme mdkkdm, urpme kdm, urpmi kdm, urpmi mdkkdm as suggested

4) Ran urpmi on kdeutils, kdemultimedia and some others

 

Problem:

- Keyboard would intermittently not work at all when kdm or startx was run

Solution:

- Somehow there were two keyboard InputDevice sections in the XF86Config file. I removed one of the sections and removed the duplicate InputDevice from the ServerLayout section.

 

Problem:

- System would hang during boot after the alsa drivers were loaded

Solution:

- There was a line in /etc/init.d/sound:

if [ ! -d /proc/asound ] || grep -q "no soundcards" /proc/asound/cards;then

the grep part would hang forever. If I do a "cat /proc/asound/cards" it shows the following two lines in an infinite loop:

0 [iCH5 ]: ICH - Intel ICH5

Intel ICH5 at 0xfc480400, irq 17

I changed the line to:

if [ ! -d /proc/asound ]; then

which isn't a good generic solution but gets my system to boot

 

Problem:

- All the menu items had disappeared

Solution:

- update-menus -v did not work, reported some errors. Had to "urpmi menu", then update-menus -v worked according to previous suggestions

 

Everything is working fine for me now, but I don't use KMail or Konqueror

Share this post


Link to post
Share on other sites
has any one succuessfully installed kde 3.4 under mandrake 10.1 ? maby a tutorial is in order ?

 

Nearly successful ... apart from some of the MDK menu items are still missing after the above fixes, and I have no sound ( a problem I thought I'd kissed goodbye with 10.0 :( )

 

Generally lovin' it, though.

Share this post


Link to post
Share on other sites

 

I made it! :banana: just simple startx! ha... Many thanks!

 

Let me review what I have done and success it... Since I have done tons of times!

 

Thanks and be back for process to success 3.4...

Share this post


Link to post
Share on other sites

ok i just insalled kde 3.4, this is what i did. firt of all some background info.

 

i have mandrake 10.1 about a month or two ago i updated the starndard 3.2 to 3.3 from thac's repositorys all was fine updated perfectly. no need to install any thing just need to add thacs repositys and updatde kdebase. thats it

 

then toaday i found that 3.4 is out from thac so i updated. heres what i did

 

i added these repositorys

 

1.mandrake main

2.mandrake contrib

3. plf 10.1 free

4. plf non-free

5. thacs rpm

 

then i updated xorg to 6.8.2

 

then i installed the new kde "kdebase3.4" and restartd x. and x didnt restart so i just rebooted. and that worked fine, however i got the login porblem where the login screen pops up but just loops, it also adds at lest 20 user entrys.

 

so i just cntrl-alt-backspace, login as a user, then type kde, and kde boots up fine,

 

my taskbar short cuts were all gone, no big problem i re-added them, it has a cool new feature when u leave you mouse poiter over the shortcuts now :)

 

the side image on the taskbar menu still said 3.3 even though i updated to 3.4 so i istalled this

 

mandrakelinux-kde-config-file

 

just go to mcc serch for "mandrakelinux" and slect mandrakelinux-kde-config-file its from thac's repository.

 

the side bar image now says 3.4 ( i think u may need to restart x for this to take effect.

 

also mu taskbar menus all had double entrys, also some were missing such as the configure>kde menu was completly gone. doing this...

 

su
*password*
urpme mdkkdm
urpme kdebase-kdm
urpmi mdkkdm

Reboot and everything *should* be fine. urpme is the command for uninstalling an rpm file.

 

 

did not work at for me at all.

 

however doing this fixed the double entrys

 

open a console or log in via cli

type: mv ~/.local ~/.local-bak

Run update-menus -v

Once that is done, everything should work for you

 

how ever the KDE menu where u can configure kde still dose not show up.

 

EDIT: i just rebooted my computer and i still have alot of menu entrys however it lets me login now without looping at all, so something i typed here worked !

Edited by flightcrank

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...