Jump to content
devries

Thac and Zé's KDE 3.4 rpms

Recommended Posts

Im planning on running 3.4 and Manrake 10.2

 

Should I install 10.2 with the packaged KDE, and then upgrade to 3.4?

 

Or should I install 10.2 without KDE, and then URPMI KDE 3.4 in?

Share this post


Link to post
Share on other sites

Im running kde-3.4.0 in mandrake-10.2 now

and i did upgrade.

building new version now applying patches.

Edited by thac

Share this post


Link to post
Share on other sites

i must say that even if kde-3.4.0 i new and has a few bugs compared to 3.3.2.

its still worth the upgrade because of all the new features and most of all

the speed increase.

 

/Torbjörn Turpeinen (Thac)

Share this post


Link to post
Share on other sites
Guest xavierh
i must say that even if kde-3.4.0 i new and has a few bugs compared to 3.3.2.

its still worth the upgrade because of all the new features and most of all

the speed increase.

 

/Torbjörn Turpeinen (Thac)

 

Thac do you kown how to fix the issues with the mdkkdm or shold I switch to kdm as the display manager. also is there a way to fix the menu problems that I reported on a previous message?

Share this post


Link to post
Share on other sites
Menus: After the latest pakages that some items on my menus have disappeared, specially drakconf and kcontrol. If I open menudrake I can see the entries listed in the menu but even after saving the menu in menudrake and / or doing update-menus -v those entries still don't appear. Also iafter installing software (for example superkaramba) the only way of making the menu entry appear on the menu is to use the update-menus command.

 

Follow my instructions for this one. Open a terminal, mv ~/.local/ ~/.local-bak/ then run update-menus -v

 

After that, your menus should be complete.

 

And from what I can see, you need to remove mdkkdm and kdebase-kdm then reinstall mdkkdm (and the other files that are removed during the removal) and everything should work.

 

Alternatively, if you have it installed, you can switch to gdm. That's what I did and I have no problems with the dm

Edited by LiquidZoo

Share this post


Link to post
Share on other sites
Guest xavierh

Thanks for the help LiquidZoo but I tried that yesterday. The only think that I did not do was the mv command I actually used konqueror and move that particular directory out of the my home directory and ran the command. I will try this at home for lunch to see if somehow that situation changes doing it as you just said. I'm using mandrake 10.1.

 

I also did the urpme and urpmi stuff yesterday and that helpme get things going again....

Share this post


Link to post
Share on other sites
Guest xavierh
Thanks for the help LiquidZoo but I tried that yesterday. The only think that I did not do was the mv command I actually used konqueror and move that particular directory out of the my home directory and ran the command. I will try this at home for lunch to see if somehow that situation changes doing it as you just said. I'm using mandrake 10.1.

 

I also did the urpme and urpmi stuff yesterday and that helpme get things going again....

 

Tried it and the same result happened. I have noticed also that menudrake crashes with a segmentation fautl error everytime I try to run it....

Share this post


Link to post
Share on other sites
Extra panels: Rightclick on kicker, add, panels, whatever you want, lets say extra taskbar. Ricghtclick kicker again, choose configure panel, make up, on the build tab, click on the new dropdown menu and choose extra taskbar. Now put it at the top of the screen. (translated from dutch actual wording might be different)

 

Menu transparancy: Open kde control center, look & feel, style, tab effects and use the slide to adjust the transparancy.

 

Reset the menus: try first resetting the icons, kde control center, look and feel, icons. The duplicate folder just remove in menudrake or kdemenuedit.

 

Dmzeplin: a kernel upgrade will not help you with KDE. If you're unsure about urpmi just read the faqs again or tell us about your problems.

 

Well.. about the menu, I tried that, nothing in the style section seems to change my menu transparencies. I can even turn it off, it doesn't matter, its still like 75% transparent...

As far as the menus.. I tried resetting the icons, that didn't do it, I tried removing the folders in menudrake but they don't go away, they're things I need anyways. Basicailly. I have two More Applications folders.

When I go to /var/lib/menu-xdg or whatever it is, theres a "Moreapplications" and "MoreApplications", both of which have different, yet no duplicate entries.. Also, I'm missing my "Video" entry in the Multimedia section... So that doesn't seem to work out so well...

Other than that, everything is great.. I just hope I can figure those out..

Well, that, and X is leaking ram, and I can't figure out why, and I've upgraded & downgraded X multiple times yet it still does it.... Oh well

 

If anyone has any ideas I'm all ears.

Thanks!

Share this post


Link to post
Share on other sites

Thac, thank you very much for taking the time to compile the rpm's for us :)

 

I'm a Linux noob (I only switched last week with no previous Linnux experience) and I'm running 10.2 with KDE3.4 as per my preferences.

 

I only imagine how hard this task would have been to undertake without your rpm's.

 

Cheers mate

Share this post


Link to post
Share on other sites
The safest way is to know what you are doing :). And urpmi is quite easy to get to know.  :)

 

For the alsa problem press ctrl - c. The boot process should continue.

 

Thac: I had the same problem as described here with one of my email accounts (http://bugs.kde.org/show_bug.cgi?id=97139). I solved it by installing the sasl plugin pachages but I guess kmail is dependent on it so these packages should be installed as dependencies.

 

devries, this is my 4th attempted! after I have upgrade 3.4 and I had to shut down and reboot, and it stopped at alsa 1.0.6, so I press ctrl and c. But seems nothing to keep fully through...??

Edited by dmzeplin

Share this post


Link to post
Share on other sites

If you install KDE it is not neccesary to reboot, just restart X (ctrl-alt-backspace), or start X if you installed KDE from a terminal.

 

Then go to the Mandrake Control Center, hardware, hardware, configure soundcard and load the oss module. Make sure in the MCC, system, services alsa is shut down and disabled at boot. Now if you start your pc alsa will not start.

 

Good luck.

 

edit: and just to make it clear: KDE is not dependent on the kernel. You don't have to upgrade to Mandrake 10.2 to install KDE 3.4.

Share this post


Link to post
Share on other sites

Also, from what I've found on the bug reports, upgrading to kernel 2.6.11-5mdk seems to fix the issue with alsa. I cannot confirm this myself as I have not tried it yet.

Share this post


Link to post
Share on other sites
Guest anon
Also, from what I've found on the bug reports, upgrading to kernel 2.6.11-5mdk seems to fix the issue with alsa.  I cannot confirm this myself as I have not tried it yet.

For me it doesn't. :wall:

It did fix it so i was able to continue booting, (prior to that the OS would freeze at loading Alsa ) but although it now boots OK, Alsa fails to load.

Tried it with Alsa version 1.06 and also the latest 1.08 version.

Share this post


Link to post
Share on other sites

Strange that the bug was closed then...

 

I have kernel 2.6.11-2mdk and Alsa 1.0.8. I use the patches that were made available in the bug report for my emu10k1 based card. Anyone else using this same kernel and driver can pm me for the modules, I can't find the bug report.

 

I have no problem on boot, just on shutdown...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...