Jump to content
devries

Thac and Zé's KDE 3.4 rpms

Recommended Posts

im not using mandrake much, and not definitely not kde, but thacs you are a gun! keep the packages up :D

Share this post


Link to post
Share on other sites
Installation failed:

       qt3-common = 3.3.3-27.1.101mdk is needed by (installed) libqt3-3.3.3-27.1.101mdk

 

This means that urpmi isn't setup correctly (not all sources/repositories arre available) or the sources are not up to date (urpmi.update -a). If something loke this happens don't uninstall but run urpmi.update and try again.

 

Your problem: could be config problems so rename the .kde folder and start kde again.

 

 

Hey, thanks for the reply. I ended up just reinstalling 3.2 back on to the system. But since all I would have had to do was update the urpmi database, maybe I'll try it again.

 

As for the menudrake problem, I tried renaming my .kde folder and the menu started having 3 copies of every entry. Menudrake was still crashing. Maybe menudrake doesn't like KDE 3.4?

 

Is there a way to dump menudrake and if so what does KDE have that'll do the same thing natively?

 

Nate

 

BTW: THAC, you are awesome. Compiling all that stuff must have taken forever. Not to mention the specialized know-how. I am extremely jealous.

Edited by nchancock

Share this post


Link to post
Share on other sites

For the 3 entry problem: delete $HOME/.local

For kmenu, open menusdrake, click menu style and choose 'native' (or something ike that. can't remember the exact wording).

Share this post


Link to post
Share on other sites

Sorry i dont think i read your first post carefully enogh but now i did.

i should guess that your problem is caused by the fact that you dowloaded

all in kde-3.4.0 dir an installed from there.

But since the qt rpm has not changed is theese still in the kde-3.3.2 folder this goes

for the new xgd menu system and not to forget the xorg-6.8.2 rpms.

 

So a proper urpmi database setup is the most important thing to manage then the install is very simple

 

as root type urpmi kdebase

 

/Torbjörn Turpeinen (Thac)

Share this post


Link to post
Share on other sites

argh!

I got in a dependency hell with xorg-x11-devel

kdebase requires it, and when I try to install the xorg-devel I get asked for devel(libexpat), freetype6, etc. I completely screwed up my fonts and had to reinstall mdk twice when trying to completely follow the dependency requests. And it seems that even urpmi --force is not allowing me to install xorg-devel :(

Share this post


Link to post
Share on other sites

once again ceck the required urpmi repositorys.

you must have 5 of them

1.mandrake main

2.mandrake contrib

3. plf 10.1 free

4. plf non-free

5. thacs rpm

 

if not there will be failed dependencys

 

and yes kde-3.4.0 requires xorg-6.8.2

Edited by thac

Share this post


Link to post
Share on other sites

Well i installed it... Its very cool..There are acouple of little things like i had a great screensaver called Kfireworks that's gone it was part of 3.3 but not part of 3.4?? anyway there is also an issue with Kontact i can't send out any emails, but my mozilla messenger is working fine. does anyone know where i can get that firework screensaver??

oh ya ,

Thac you the Man!!!!!!!

keep up the great work!

-Shadowchaser

opps the name of the screensaver is KFiresaver3D ....

Edited by Shadowchaser

Share this post


Link to post
Share on other sites

Added a new package

mandrakelinux-kde-config-file

that contains the updated splash and ksidebar images for kde 3.4

enjoy

 

/Torbjörn Turpeinen (Thac)

Share this post


Link to post
Share on other sites
Go get them at http://anorien.csc.warwick.ac.uk/mirrors/t...RPMS/kde-3.4.0/

 

(I'm done downloading so the bandwith is all yours (download size about half a gig). :)

 

I am not famaliar with upgrade, since I click the link and there sare tons of lists, and I was wondering which one that will upgrade from 3.2 to 3.4? I looked and I think if kde-i18n-ar-3.4.0-1.mdk10.1.thac.noarch.rpm the one that will upgrade to 3.4?

Share this post


Link to post
Share on other sites
once again ceck the required urpmi repositorys.

you must have 5 of them

1.mandrake main

2.mandrake contrib

3. plf 10.1 free

4. plf non-free

5. thacs rpm

 

if not there will be failed dependencys

 

and yes kde-3.4.0 requires xorg-6.8.2

 

I have those lists, except the thacs rpm, how did you add to MCC? what kind of methods to download from?

Share this post


Link to post
Share on other sites

from my site on

http://rpm.nyvalls.se/index10.1.html

 

Type this in a console as root, to add my RPMS to the urpmi database.

urpmi.addmedia thacs.rpms http://rpm.nyvalls.se/10.1/RPMS with hdlist.cz

 

Check this page to add some more RPM resources to the urpmi database.

Easy urpmi config for Mandrake

 

or from

 

http://anorien.csc.warwick.ac.uk/mirrors/thac/index10.1.html

 

Type this in a console as root, to add my RPMS to the urpmi database.

urpmi.addmedia thacs.rpms http://anorien.csc.warwick.ac.uk/mirrors/thac/10.1/RPMS with hdlist.cz

 

Check this page to add some more RPM resources to the urpmi database.

Easy urpmi config for Mandrake

Edited by thac

Share this post


Link to post
Share on other sites

thac me, it works...!

 

Umm, I never saw owt like the above. Perhaps that's only if you were using the default splash by default (I go for that cheeky 'Redmond' one myself :) )

 

Mind you, the side-image on the KMenu (which didn't change when I upped to 3.3) is now looking appropriately show-offish. :banana:

 

My custom taskbar buttons for Firefox and Tbird disappeared, and I'm not too sure about the MASSIVE tooltips for those buttons, but otherwise nothing blew up so I'm happy.

 

Thac you very much.

 

BTW - Knoppix3.7 (KDE3.3.2) has XP-style file info tooltips when you mouseover a file on desktop / in Konqueror. Me like. How to get?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...