Jump to content

Random Freezing?

Lord Kenneth

Recommended Posts

Everything freezes. Mouse won't move, keyboard won't work. Must do a hard reset.




Athlon XP 2500+ (oc'ed to 3000+)

Nvidia GeForce4 Ti4200

A7N8X Deluxe (it's an nForce2 Chipset, btw)




Any ideas on how I can pinpoint the culprit, whether it's software or hardware? Perhaps I need to change some settings?

Link to comment
Share on other sites

  • Replies 63
  • Created
  • Last Reply

Top Posters In This Topic

try using nvpart instead of agpart ..or the other way around. using nvpart worked for me.


It's an option in yout XF86Config-4-file. I can work for you ...


in the device-section:

Option "NvAGP" "1"


I also think it's video-related. Can depedend on tyour motherboard/chipset I think. Like my via-chipset. I read it doesn't perform good on agp. I'm not sure of this ..anyway, I think it's a matter if your chipset is supported well I think and more ..finding out what to use :).

Link to comment
Share on other sites

That would seem to be the right one then.


How bout the video card fan or the chip fan (on motherboard). I just experienced some freeze ups and found those two fans were blocked up with dirt and not running and causing an overheat condition. I took them off and things have been fine since (tho I don't run my machine overnight anymore)

Link to comment
Share on other sites

I have the AMD XP2500+ also (overclocked to 2200 MHz, which is I guess what you mean by yours is oc'd to 3000+) and a GeForce4 MX440 64MB DDR video card using the NVidia driver right before the one you are using (the newest one just gives me a black screen for some reason). Anyway, I have the random freezes too, but they are very far apart...maybe two a month. In my case, I have a computer that I can use to ssh into this box and kill and restart X, so it is mostly a video-related problem. I have an Asus A7V600 MoBo with a Via chipset. Anyway, I have not found the cause or fix for it. Sorry, just thought I would share a simliar experience in case anyone can find a correlation.

Edited by Steve Scrimpshire
Link to comment
Share on other sites

I was having the same problems with nforce2 and MDK 9.2

Using the patched nvidia (video helped)

but I think the main prob is the nforce2 drivers....


Sorry its running deb now....

I used knoppix to boot up and try and download the nforce source since i couldn't do it in mandrake and the rpms just kept locking it up.

I tried alsorts including leaving it at a console overnight.....

(fine) but it always locked up when using the NIC....


I downloaded and went to bed and woke up and knoppix was still up...

Went to work, came back and it was still up....


So did a HDD install a week ago and its still hasn't crashed once.


Unless anyone has really got this working otherwise I think compiling a new kernel might be the only way....

It seems to have worked with deb based kernels but always crashed on the RH/Mandrake trees.


However to make things more complex I have a gig and the RPM's don't wanna work when using kernel enterprise.

Link to comment
Share on other sites

I find that nforce2/nvidia card/nvidia driver is very picky in what irq they want. I solve my X freezing problem in my nforce2 board by using a certain version of the bios. If that is not possible, you may need to reserve certain irqs so that the nvidia card is forced to use the "safe irqs" so X freezing can be lessened, or alleviated entirely.

Link to comment
Share on other sites

still doesn't explain why uptime on knoppix/deb is now over a week wheras Mandrake was locking twice a day!!!! (or more)


No bios change or anything just hellishly good HW detection.....

Perhaps your right on the IRQ's and its just detecting them better in knoppix????

Link to comment
Share on other sites

  • 2 weeks later...
I'm still having this problem.  What should I do to fix the possible IRQ problem, if that is indeed the culprit?

I had identical problems on my nforce2 system. Since I set noapic and nolapic in lilo it has been very stable. I believe this limits the IRQ channels to 0 - 15 (ie <10 hex) I do still have problems however with a USB card reader which I have abandoned for now.


This is part of my lilo.conf. If you try this, don't forget to type lilo after editing to register the changes.



append="noapic nolapic devfs=mount hdc=ide-scsi acpi=ht resume=/dev/hda5 splash=silent"

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...