Jump to content
yossarian

Problem with Mandriva 2008.0 and nVidia driver

Recommended Posts

Hi all,

 

I upgraded my MDV 2007.1 to 2008.0 from the CD's with no special problem. Of course the nVidia proprietary driver was not upgraded. After I logged in I changed my driver to the nVidia GeForce 3-4 (96xx) one - the same as I ran in 2007.1 with no problem (including the 3-D effects and all that jazz). After installation of the package and activation of the proprietary driver I got the following message:

An error occurred:
(EE) NVIDIA(0): Failed to initialize the NVIDIA kernel module! Please ensure
(EE) NVIDIA(0):	 that there is a supported NVIDIA GPU in this system, and

Try to change some parameters

After approval I was asked to log out and in. After logging out I got a message in text mode saying it can't start the X-server, asking me to try another driver. So for the meanwhile I'm running with the non-proprietary one.

 

I also tried running from the Live CD, and got all the 3-D effects out of the box. Of course I prefer not to do a fresh installation from the live CD.

 

Maybe I need to re-compile the kernel? Any advice? Thanks!

Share this post


Link to post
Share on other sites

You need to recompile the nvidia kernel module note the whole kernel. And you have to do it every time you upgrade\update the kernel. To do that automatically there's a package called dkms-nvidia. For recompiling this module you also need the kernel-source-devel package or the whole kernel-source matching to your kernel.

Share this post


Link to post
Share on other sites
You need to recompile the nvidia kernel module note the whole kernel. And you have to do it every time you upgrade\update the kernel. To do that automatically there's a package called dkms-nvidia. For recompiling this module you also need the kernel-source-devel package or the whole kernel-source matching to your kernel.

 

From this message by Adam I understood the whole process was supposed to take place automatically.

 

Could you please be more specific with the names of the packages I need?

 

I looked at the MCC - Software installation tool. I found a package called dkms-nvidia96xx already installed. Besides I found kernel-source-2.6.17.13mdv and the kernel-source-2.6.17.22 is not installed (but kernel-desktop-devel-2.6.22.9-1mdv is installed), and no package as kernel-source-devel of any sort, installed or in the repos. Should I install something, like the kernel-source-2.6.17.22, could that be the reason? Wasn't it supposed to be installed on the upgrade? And how can I make sure there aren't any other important packages missing?

 

Sorry for all the questions, I'm a bit lost here.

Share this post


Link to post
Share on other sites
From this message by Adam I understood the whole process was supposed to take place automatically.

 

Could you please be more specific with the names of the packages I need?

 

I looked at the MCC - Software installation tool. I found a package called dkms-nvidia96xx already installed. Besides I found kernel-source-2.6.17.13mdv and the kernel-source-2.6.17.22 is not installed (but kernel-desktop-devel-2.6.22.9-1mdv is installed), and no package as kernel-source-devel of any sort, installed or in the repos. Should I install something, like the kernel-source-2.6.17.22, could that be the reason? Wasn't it supposed to be installed on the upgrade? And how can I make sure there aren't any other important packages missing?

 

Sorry for all the questions, I'm a bit lost here.

You have some kernels and sources but they do not match. If you want to run the 2.6.17.22 kernel then you should also have kernel-source-2.6.17.22 or kernel-source-stripped-2.6.17.22 (there may be small changes where .22 becomes -22 -- I do not yet have installed 2008 so haven't checked). The 'source-stripped' version is a lot smaller and sufficient for recompilation of kernel-modules. Your first priority should be to get matching sources & kernel versions (check your repositories to be sure they are all for 2008).

 

Another requirement is that you have all the development tools installed (gcc, make etc).

 

kernel-source-2.6.17.13mdv comes from 2007 or 2007.1.

 

Two ways exist to manually build an NVIDIA kernel module: with the script provided by NVIDIA (see their website). Alternatively you can use DKMS. Commands take the form 'dkms action lots-of-options':

  • dkms status: to see what modules are build. Compare with uname-a to check versions
  • dkms add -m nvidia -v version-number: to add a module tree for a new version (maybe requires a -k kernelnumber)
  • dkms build -m nvidia -v version: to build the binary module from the tree
  • dkms install -m nvidia -v version: to install the binary module (wehn starting X, the nvidia module will be installed automatically)

Note that this is not only for nvidia moduels but also for other kernel-modules. This is (at least in 2007) done automatically during booting when a new kernel-version is detected; it is not uncommon for it not to work without helpfull output.

Share this post


Link to post
Share on other sites

First of all, thank you. I still have a few more questions:

  1. If I updated my system from the repos (through urpmi), should I still update make, gcc etc. manually?
  2. How do I install the new kernel? Just mark it on MCC and things will be updated automatically?

Thanks.

Share this post


Link to post
Share on other sites

Vossarian:

1: No you should have the latest versions. I added this because dkms refuses to run without it, but doesn't give clear error messages...

2. Exactly -- Start MCC, Software, Add, look for kernel and scroll down to the kernel of your choice.

Share this post


Link to post
Share on other sites

I installed kernel-source-2.6.22.9-1mdv, but still no luck. When I try to activate the proprietary driver and test it, I get the same error message. Now I have both kernel-source-2.6.22.9-1mdv and kernel-source-2.6.17.13mdv. the only two available for me. Any more ideas?

Share this post


Link to post
Share on other sites

You're having a hell of a time downloading, and now upgrading to 2008. :)

 

So lets start with some new info, please post the output of

uname -a

rpm -qa | grep kernel

rpm -qa | grep nvidia

Share this post


Link to post
Share on other sites

Something I just worked out myself. Had the same problem.

Uninstall the kernel-source snce it does not work that way anymore.

 

Do install the kernel called :- kernel-desktop-devel-2.6.29.2-1mdv

I had the following already installed.....kernel-desktop....... and kernel desktop-latest...

 

Reboot then do the Nvidia install process and it will work like a charm.

 

When you read the info on the devel package you will see why.

Unfortunately unless one reads everything in all packages one doesn't know why.

Mandriva could have pointed this out more clearly in installations instructions.

The move is a good one because it is a hell of a lot smaller than a source but obviously has all that is necessary for a lot of programs.

One - but two ++ 's to Mandriva for that one.

 

Cheers. John.

Edited by AussieJohn

Share this post


Link to post
Share on other sites
You're having a hell of a time downloading, and now upgrading to 2008. :)

 

So lets start with some new info, please post the output of

uname -a

rpm -qa | grep kernel

rpm -qa | grep nvidia

 

Yeah, I'm a known trouble-maker. All the law enforcement agencies are after me. :)

 

uname -a:

Linux localhost 2.6.17-13mdvlegacy #1 SMP Fri Mar 23 19:05:24 UTC 2007 i686 Intel(R) Celeron(R) CPU 2.80GHz GNU/Linux

 

rpm -qa | grep kernel:

nvidia-current-kernel-2.6.22.9-desktop-1mdv-100.14.19-1mdv2008.0
nvidia96xx-kernel-2.6.17-13mdvlegacy-9631-1mdk
nvidia71xx-kernel-2.6.17-13mdvlegacy-7184-1mdk
nvidia96xx-kernel-desktop-latest-1.0-1.20071003.9639.4mdv2008.0
nvidia71xx-kernel-2.6.22.9-desktop586-1mdv-1.0-7185.5mdv2008.0
madwifi-kernel-2.6.17-13mdvlegacy-0.9.2-1mdk
kernel-desktop-latest-2.6.22.9-1mdv2008.0
nvidia96xx-kernel-2.6.22.9-desktop-1mdv-1.0-9639.4mdv2008.0
kernel-source-2.6.17.13mdv-1-1mdv2007.1
nvidia71xx-kernel-2.6.22.9-desktop-1mdv-1.0-7185.5mdv2008.0
kernel-desktop-2.6.22.9-1mdv-1-1mdv2008.0
kernel-desktop-devel-2.6.22.9-1mdv-1-1mdv2008.0
nvidia96xx-kernel-2.6.22.9-desktop586-1mdv-1.0-9639.4mdv2008.0
nvidia-current-kernel-desktop586-latest-100.14.19-1.20071003.1mdv2008.0
nvidia71xx-kernel-desktop-latest-1.0-1.20071003.7185.5mdv2008.0
kernel-source-2.6.22.9-1mdv-1-1mdv2008.0
hcfpcimodem-kernel-2.6.17-13mdvlegacy-1.10full-1mdk
kernel-legacy-2.6.17.13mdv-1-1mdv2007.1
kernel-desktop586-2.6.22.9-1mdv-1-1mdv2008.0
nvidia96xx-kernel-desktop586-latest-1.0-1.20071003.9639.4mdv2008.0
nvidia71xx-kernel-desktop586-latest-1.0-1.20071003.7185.5mdv2008.0
ati-kernel-2.6.17-13mdvlegacy-8.34.8-1mdk
hsfmodem-kernel-2.6.17-13mdvlegacy-7.47.00.03full-1mdk
kernel-desktop586-latest-2.6.22.9-1mdv2008.0
nvidia-current-kernel-2.6.22.9-desktop586-1mdv-100.14.19-1mdv2008.0
nvidia97xx-kernel-2.6.17-13mdvlegacy-9755-1mdk
slmodem-kernel-2.6.17-13mdvlegacy-2.9.11-1mdk
kernel-desktop-devel-latest-2.6.22.9-1mdv2008.0
nvidia-current-kernel-desktop-latest-100.14.19-1.20071003.1mdv2008.0

 

rpm -qa | grep nvidia:

nvidia-current-kernel-2.6.22.9-desktop-1mdv-100.14.19-1mdv2008.0
nvidia96xx-kernel-2.6.17-13mdvlegacy-9631-1mdk
nvidia71xx-kernel-2.6.17-13mdvlegacy-7184-1mdk
nvidia96xx-kernel-desktop-latest-1.0-1.20071003.9639.4mdv2008.0
nvidia71xx-kernel-2.6.22.9-desktop586-1mdv-1.0-7185.5mdv2008.0
dkms-nvidia96xx-1.0-9631.6plf2007.1
nvidia96xx-kernel-2.6.22.9-desktop-1mdv-1.0-9639.4mdv2008.0
x11-driver-video-nvidia96xx-1.0-9639.4mdv2008.0
nvidia71xx-kernel-2.6.22.9-desktop-1mdv-1.0-7185.5mdv2008.0
dkms-nvidia-current-100.14.19-1mdv2008.0
dkms-nvidia96xx-1.0-9639.4mdv2008.0
nvidia96xx-kernel-2.6.22.9-desktop586-1mdv-1.0-9639.4mdv2008.0
nvidia-current-kernel-desktop586-latest-100.14.19-1.20071003.1mdv2008.0
nvidia71xx-kernel-desktop-latest-1.0-1.20071003.7185.5mdv2008.0
nvidia96xx-1.0-9631.6plf2007.1
x11-driver-video-nvidia-current-100.14.19-1mdv2008.0
nvidia96xx-kernel-desktop586-latest-1.0-1.20071003.9639.4mdv2008.0
nvidia71xx-kernel-desktop586-latest-1.0-1.20071003.7185.5mdv2008.0
dkms-nvidia71xx-1.0-7185.5mdv2008.0
nvidia-current-kernel-2.6.22.9-desktop586-1mdv-100.14.19-1mdv2008.0
nvidia97xx-kernel-2.6.17-13mdvlegacy-9755-1mdk
x11-driver-video-nvidia71xx-1.0-7185.5mdv2008.0
nvidia-current-kernel-desktop-latest-100.14.19-1.20071003.1mdv2008.0

 

John - I'll be with you right after dinner. Thanks for your advise.

Share this post


Link to post
Share on other sites
Something I just worked out myself. Had the same problem.

Uninstall the kernel-source snce it does not work that way anymore.

 

Do install the kernel called :- kernel-desktop-devel-2.6.29.2-1mdv

I had the following already installed.....kernel-desktop....... and kernel desktop-latest...

 

Reboot then do the Nvidia install process and it will work like a charm.

 

Hi John,

 

I already have installed a package called kernel-desktop-devel-2.6.22.9-1mdv, and not 2.6.29.2 like you mentioned. But I believe mine is the one suitable to the kernel I'm running.

Share this post


Link to post
Share on other sites
uname -a:

Linux localhost 2.6.17-13mdvlegacy #1 SMP Fri Mar 23 19:05:24 UTC 2007 i686 Intel(R) Celeron(R) CPU 2.80GHz GNU/Linux

You're still running an old kernel, this is the problem.

 

Does the grub menu give you a choice to boot 2.6.22.-whatever?

Share this post


Link to post
Share on other sites
You're still running an old kernel, this is the problem.

 

Does the grub menu give you a choice to boot 2.6.22.-whatever?

 

Greg, we are actually heading somewhere! I hope it's not backwards.

 

OK, my bad: there was an option to choose the newer kernel in Grub (some other time you are going to show me how to change the "Mandriva 2008.0" option to run the new kernel), so I chose it and now uname -a gives me:

Linux localhost 2.6.22.9-desktop586-1mdv #1 SMP Thu Sep 27 03:58:17 CEST 2007 i686 Intel(R) Celeron(R) CPU 2.80GHz GNU/Linux

 

After that I re-installed the driver, got the test screen working fine, and... no 3-D effects. I activated the option from the MCC, both with native support and Xgl, bet neither worked. Furthermore, all my fonts on the screen are really tiny, so I guess I still have a problem with my graphic card. Do you have any more good ideas in the place where the first one came from?

Share this post


Link to post
Share on other sites
no 3-D effects. I activated the option from the MCC, both with native support and Xgl, bet neither worked. Furthermore, all my fonts on the screen are really tiny

I'd suggest just getting your graphic card working properly, before trying to enable the 3D desktop.

 

Do you have your proper display resolution set? What is the output of

glxinfo |grep rendering

and what is your average FPS from

glxgears

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...