Jump to content

pindakoe

Members
  • Content Count

    186
  • Joined

  • Last visited

Community Reputation

-1 Poor

About pindakoe

  • Rank
    frequent
  1. Morning Bertrand, I find this a good initiative. The website looks good as well (though I did not check the videos). Don't think many people realise the transparancy that internet communication entails.I still find it surprising that we hand over whatever details to the unknown simply because it goes into a computer (which then somehow makes it trustworthy). Having said that I must admit that I also do not encrypt my email as I still haven't quite been able to get encryption fully up and running on my own system (Mandriva Linux; using Claws as mail user agent with the PGP/Mime plugin to handle the communication with GPG). Lack of others who write/accept encrypted always caused this to be one of the projects that never made it to the top of the list. I do sign my email though -- only to find out that some corporate incoming email scanners get upset by that. Will dig again into it (as it can't be that hard) and report back once I cracked it. One other comment though -- your tutorial makes also clear to users that the internet knows little privacy, yet you ask posters to use their real name and not their alias. Personally I never use my own name, but always one of my aliases. I know that I will always be traceable by IP to within a few miles of my home anyway and that anybody who can convince my ISP (i.e. ideally only with backing of the law) can convert the IP into my name. That gives me enough visibility me thinks... So I will go back to my email system and once and for all sort out encryption in Claws and can then may be contribute that to your site.
  2. Mandi is only needed for the interactive firewall AFAIK -- I haven't got it runnign (nor installed), but do have shorewall running... ACPID does something for ACPI, but I have been running without it for years (but my PC is 2004 vintage and is not a big user of ACPI -- suspend/hibernate never worked so may be that is why I can get away without it) CUPS, only if you print
  3. Suggest to simply start with xfdrake. It will pull in packages as needed and allow you to select card, monitor etc. In case this does not work manual repairs are need, first establish what sort of Nvidia card do you have; nvidia has three different drivers for different groups of cards (very old, old and current cards). The package summary will explain what is for what (urpmq --summary -a x11-driver-video-nvidia). You may know, or can spot this during booting. Also believe that the command 'lspci' will help you further. Then check that you have all the necessary software installed: X11-driver for nvidia, nvidia kernel module, DKMS (kernel module management system) and kernel source. The key is to ensure the following four things: Your x11-driver-nvidia package should be suitable for the card you have (description lists that). Note the version number, here 173.14 The dkms-nvidia package also should be version 173.14 The kernel module, nvidia...-kernel should be version 173.14 AND should include the kernel version of the current kernel (uname -a) You have the kernel sources for the current kernel version installed Below is what I have on my 2010.2 installation: dkms-nvidia173-173.14.28-2mdv2010.2 dkms-minimal-2.0.19-20mdv2010.1 installed dkms-2.0.19-20mdv2010.1 installed nvidia173-kernel-2.6.33.7-desktop-2mnb-173.14.25-3mdv2010.1 x11-driver-video-nvidia173-173.14.28-2mdv2010.2 kernel-desktop-devel-2.6.33.7-2mnb Use rpm -qa | grep 'nvidia\|dkms\|kernel' to see what you got. In addition you will require a dozen or so packages for software development (gcc, make, multiarch-utils, some other -devel software). Urpmi selects this when you select the kernel-devel sources. During install some software will be prepared and after reboot system should load the new nvidia kernel module and later other driver files. Usually either the version numbers mismatch somewhere or the driver rebuil fails. Can you check your system with this info and see if that helps enough?
  4. I have since years been rsnapshot to maintain a (limited) set of previous versions of /home and and selected parts of / and below. Since a year this is to a NAS in my own local LAN, all to full satisfaction. I would like to add a second level of protection by starting offsite backup. I am not hopefull that I will maintain the discipline to do this manually be external harddisk, so am looking to online possibilities. I have browsed around and seen many tools and storage offers, but they all seem to fall short on what I believe my requirements to be: Data gets encrypted before leaving my HD Runs as root so that can access whole file-system (large parts will be excluded, but I do for instance backup /root and other parts requiring root access) Can be run from cron, i.e. command-line. A UI to get started and define backup sets has limited to no value for me as the likely client will be a headless NAS (running Debian). Ability to define (large) in/excludes with globbing like rsync Software available for PowerPC (my NAS runs on this ancient but frugal hardware) Full / incremental backups, preferably using rsync like approach Scalable; at moment I probably need 20 Gb, but this number continues to grow I am interested in your experiences on these requirements (is there something that I am overlooking), recommendations for software and experiences with storage providers. Realise that some software means one storage provider only (or vice-versa) and have no preference for all-in-one packages (spideroak, crashplan) vs free things (duplicity). Free would be nice, but pay-as-you go is OK as well, provided we talk consumer rates.
  5. No clue what would be causing this, but one way to sometimes find out more is to start programs from the command-line. Start, login and open a terminal and then start control center (type drakconf). Good chance you will get some more output that at least puts you on the right track.
  6. I have collected a bunch of MP3 and put them on my NAS (Bubba -- running Debian). Below is output of /proc/mounts for the share in question: //bubba/home /home/pindakoe/bubba cifs rw,mand,relatime,unc=\\bubba\home,username=pindakoe,uid=1001,forceuid,gid=100,forcegid,addr=192.168.0.2,file_mode=0755,dir_mode=0755,serverino,rsize=16384,wsize=57344 0 0 > ls -ld bubba/ drwxr-xr-x 1 pindakoe users 0 2010-07-05 18:57 bubba// The UID/GID options are passed to ensure that UID/GID match between my Linux box and the NAS. I have some sort of weird access issue if I try to get the ID3 tag info when files are on the NAS: mp3info complains about a missing ID3 tag and corrupt info at end of file; Thunar only shows an empty tag. Alsaplayer can read the file, but refuses to play it ('no stream; the module for mp3s cannot open the file). Audacious opens the file and plays it. I can copy the files from the NAS to my HD and mp3info, Thunar, alsaplayer work OK; the file is complete (including tags) and plays normally. Anybody who has got a clue where this issue comes from?
  7. pindakoe

    mageiausers.org

    I second that Ixthusdan.The key reason for me to check this board (and Mandrivaclub.nl) daily and ignore the official Mandriva board is that the latter one has low signal to noise ratio (except for AdamW's post at the time as the one ray of light).
  8. Not being a KDE user I am not overly enthusiastic about this, but I understand that a smaller team means have to focus on something instead of trying to be everything for all people. More importantly: is what isadora already said -- I regard MCC as neat one-stop-shopping for (maybe beginning) sysadmin. A clear advantage over distro's which rely on the DE to provide this. I have no real experience with other distro's (apart from Debian on a NAS), but have tried Fedora a few times and lacked an MCC replacement to get started.
  9. Is there any meaning in the fact that the two images have different aspect ratio's: 2010.1 568 x 360 px 2010.0 626 × 423 px If these shots cover the whole screen then it suggests that Spring is addressing your monitor with different aspect ratio. As the (no doubt) LCD panel is for a given aspect ratio (determined by physics) it tries to recalc. This never works without artifacts (staircase effect). But the difference in file dimensions may have other causes...
  10. My printer is an HP Laserjet 1010 which is via USB connected to my NAS ('Bubba', see here for more info). The NAS has a 'raw' queue (i.e. only forwards bytes to the printer); it needs to be fed with printer commands by the computer who print to the NAS. Two windows clients (one running XP Pro SP3, the other running 7 HP) can print to the NAS w/o issues, using HP's printer driver for the LJ1010. My main workstation could also print to the NAS when running 2009.1, but not longer since I upgraded to 2010.1. The upgrade was by means of a clean install of / (including re-format as I re-sized partitions). The /home partition and its contents were not touched. I have installed a print queue on the workstation for the HP which points to the raw queue on the NAS; this was also the setup I had before the upgrade. When I print I see the job appearing in CUPS on my workstation and being finished. I then see the job apepearing on CUPS on the NAS and also completing. In parallel the LED on my printer starts blinking, but never stops. There are no error messages in CUPS on the workstation; on the NAS I get the following messages in CUPS error_log and syslog: ==> /var/log/syslog <== Jul 18 14:56:19 bubba kernel: usblp0: nonzero write bulk status received: -71 ==> /var/log/cups/error_log <== E [18/Jul/2010:14:56:19 +0200] [Job 85] Unable to write print data: Input/output error These messages do appear for all print-jobs, i.e also if printing from the Windows clients. The key difference is that printing from the Win-clients results in a correct print-out and the printer-LED stops blinking when the last page has come out. I have tried the following scenario's: Connect printer direct to my host and install printer using MCC. Can print test-pages and several types of documents (Open office, graphics, Gnumeric) Re-connected back to NAS and try the same document. Doesn't work Change the USB cable between NAS & printer. No change Change printer driver from hp-cups 3.10.2 to CUPS + Gutenprint simplified or Foomatic/gutenprint-ijs-simplified.5.2. No change Connecting to NAS-printer via Samba instead of IPP (option during install), does first result in a print-out of HP error message: PCL XL error Subsytem: KERNEL Error: IllegalTag Operator: 0xff Position: 11 This seems to be likely 'debris' from previous failures. Trying a second time, does prompt me for username/passwd (before I can print), but then gives me a good print. I have verified the above scenarios twice, but they al;l persist, i.e. no print-out. At this point I have the believe that the CUPS upgrade (2009.1 was 1.3.x; 2010.1 is on 1.4) results in files which do not transfer well to the printer (get stuck in CUPS on the NAS?). The IPP-protocol doesn't work; Samba does. Any takers for this challenge?
  11. Thanks John -- this was the right track (though the cause was slightly different): my fstab had an entry to mount an external HDD (vfat file systeem) in a known place. This had been defined with the option noauto, i.e. do not mount during booting, but mount on request. This was the drive fsck was probing and got stuck on (as it was not connected). Not quite clear whether this is really the right behaviour but as I didn't need it anymore have removed the line and am now booting as per normal (still much slower than 2009.1; being investigated and may be hardware related).
  12. The screenshot I attached shows a full boot (i.e. after pressing Esc). The upgrade was by means of complete re-install (root partition got formatted). I have added some more debug statements to rc.sysinit and think it tries to fsck something with wrong arguments. Not quite clear what though (need to study code and the output in more detail). Have established that rc,sysinit did not change materially between 2009.1 and 2010.1. request: can somebody post /etc/fstab -- want to check that what I have is OK. Believe it to be OK (as telinit 5 runs OK, mounts all missing partitions and results in a working system), but just to eliminate this as cause.
  13. Just upgraded (by remains of re-installing /) from 2009.1 to 2010.1 and have one major issue (in addition to the usual changes to get used to): PC hangs during the early stage of booting. I get the option to login as root and am then dumped in run-level 1. At this stage rsyslog is not yet running; starting it (service rsyslog start) causes the bootlog to be written to syslog & messages, but no clues as to what happened. A telinit 5 causes my system to continue booting normal and system functions correctly. Attached picture shows the error message. I have been able to trace this back to following lines in /etc/rc.sysinit (line 890 and below): # Check filesystems # (pixel) do not check loopback files, will be done later (aren't available yet) if [ -z "$fastboot" ]; then gprintf "Checking filesystems\n" Fsck -T -R -A -a -t noopts=loop $fsckoptions fi This causes an fsck on all file systems apart from root and it somehow fails on my /home partition (which is an XFS file system). A manual xfs_check shows it is in good shape - no errors. I can obviously comment this out, but I would like to understand what is happening here and why it fails. Any advice? More info available on request.
  14. You have reducedthe path (list of places BASH looks for the program you want to start) to the Java DK only. The default PATH is /bin:/usr/bin:/usr/local/bin:/usr/games: (the ':' is used as separator). Mandriva sets defaults like this via a whole bunch of files. Following should in your .bashrc to get htis fixed (but I am not 100% that this actually covers the PATH variable): if [ -f /etc/bashrc ]; then . /etc/bashrc fi Other files that are relevant are /etc/bashrc obviously and /etc/profile
  15. Similar experiences with the 32 bit version for 2009.1 -- crashed several times. I have returned to Picasa for managing my collection and making quick/basic edits.
×
×
  • Create New...