Jump to content
yossarian

Problem with Mandriva 2008.0 and nVidia driver

Recommended Posts

Yossarian,

 

editing your xorg.conf only makes sense being user "root", no matter which method applied (to be able to use gksu you probably have to "urpmi gksu" before). Of course you can work your way through on this way using gedit, but it's really stony.

 

As you're obviously trying different options/settings manually (which must not bad in general) I'm advising a different approach:

 

- Start by disabling the display manager service ("service dm stop" as root)

 

(- If needed: Relogin as user and "su" to root. )

 

- Make changes to /etc/X11/xorg.conf using a small terminal editor like joe, nano or with mc.

 

- Write changes to the file, but let the editor opened with the file still loaded

 

- Switch to a fresh terminal with "Ctrl-Alt-F2", or "Ctrl-Alt-F3"...

 

- Login as normal user

 

- Try your changes by simply typing "startx". If you chose a user login you're used to work with GNOME, the GNOME desktop should load

 

- Check wether your changes to xorg.conf have been successful

 

- If you're not satisfied, shutdown the GNOME display and repeat editing in other terminal (hit "Ctrl-Alt-F1" to switch back again)

 

- When all went fine, logout from your "testing terminal" and (optionally) restart your display manager as root with "service dm restart"

 

Maybe this sounds a little complicated, but once you get used to this method you'll be able to apply changes much faster than before (no shutdown/reboot necessary with short time feedback to your changes). You'd also need to close X completely to be able to compile your driver anyway.

 

You don't have to recompile the kernel if you do not *want* to - regardless of your 3D experience. Note the difference? You need the kernel sources to actually build the driver, not the kernel! (cf. dexter's posting from the beginning)

 

Another word to your driver version: I doubt that you have to rely on the 96xx legacy driver - unless your gfx card is really old. But you can check by yourself on this list of supported products:

 

http://www.nvidia.com/object/IO_18897.html

 

If you find your card/gfx chip in here, you can go on with the recent 100.14.19 driver, and you *should* do so. Compiling the that (unfortunately proprietary) driver is easy:

 

- Download driver file NVIDIA-Linux-x86-100.14.19-pkg1.run

 

- Shutdown X

 

- Login as user, "su" to root

 

- Urpmi kernel sources for your kernel (AussieJohn already gave good advice which file to pick above)

 

- Enter download location/directory of the driver file

 

- Enter "sh NNVIDIA-Linux-x86-100.14.19-pkg1.run" and follow the interactive installation

 

- At the end let the driver file apply changes to /etc/X11/xorg.conf automatically

 

- Logout (root) and use the new driver

 

(There's no need to even reboot once.)

 

Generally, I must admit although considering rpmdrake very useful, it's still ailing when it comes to kernel, dkms and gfx driver issues - which provide basic functions btw. I (partially) know good reasons for the difficulties, but that doesn't help early learners to get all the plenty of fun a linux system of today can provide with acceptable effort.

 

Regards,

 

scoonma

Edited by scoonma

Share this post


Link to post
Share on other sites

I believe that you (with help from many other points of view... and that's not a bad thing later when you understand this more) have made this much more complex than it has to be. As I have already noted; the 96xx are not old legacy modules, and will work fine with your card.

 

Please install gksu with (as root)

urpmi gksu

then try again.

 

Please note: Do 'not' log into your desktop gui as root, as it will cause an extreme fscking up of your system. If you must use a gui app (as root), such as gedit, use (as user) gksu or kdesu app-name.

 

If it happens again... I will notify the Mossad! :cheeky:

Share this post


Link to post
Share on other sites

scoonma,

 

I appreciate your help very much, it's a bit late mow, but I promise to try your way tomorrow and see if it helps. I have no problem with "complicated" instructions; vice versa - I'm here to learn, and enjoy every minute of it. Anyway, for sure you are not the one who should apologize for the system's disadvantages. Furthermore, even with all its cons I like it a lot and prefer it much better, so you are not going to get rid of me so easily. :P

 

I believe that you have made this much more complex than it has to be.

Of course I have. I am a male, after all. Besides, otherwise it wouldn't be a challenge.

 

Please note: Do 'not' log into your desktop gui as root, as it will cause an extreme fscking up of your system. If you must use a gui app (as root), such as gedit, use (as user) gksu or kdesu app-name.

I did not login as root even once to the full gui. From my user I opened a terminal, su'd to root, and used gedit.

I also followed your advice and installed gksu and used it. The file is now correct (the lines you referred to are not there any more), but the display is the same, even after a reboot:

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce 3 - GeForce 4 (96xx)"
Driver "nvidia"
Option "DPMS"
Option "RenderAccel" "true"
EndSection

 

If it happens again... I will notify the Mossad! :cheeky:

You understood it totally wrong: It's the Mossad working for me, not the other way around.

 

Bu-ha-ha-ha-ha!

[-Laughing like Dr. Evil-]

Share this post


Link to post
Share on other sites
I believe that you (with help from many other points of view... and that's not a bad thing later when you understand this more) have made this much more complex than it has to be. As I have already noted; the 96xx are not old legacy modules, and will work fine with your card.

 

Sorry, but I cannot see your point. What does legacy actually mean then? Why should yossarian use a legacy driver when he could use a "normal" one?

 

Puzzled,

 

scoonma

Share this post


Link to post
Share on other sites
Sorry, but I cannot see your point. What does legacy actually mean then? Why should yossarian use a legacy driver when he could use a "normal" one?

OK, I do see your point now, and I must admit that you are correct now about the use of the term 'legacy' in the 2008 repos. Prior to version 2008 they called the package 'nvidia_legacy' in the repos. From the package-

nvidia_legacy - NVIDIA proprietary X.org driver and libraries for old cards?

 

NVIDIA proprietary X.org graphics driver, related libraries and configuration tools for old NVIDIA video cards. Supported products are TNT2 based cards, Vanta based cards, original Quadro based cards, Quadro2 Pro/EX based cards, GeForce 256/DDR based cards and GeForce2 GTS/Pro/Ti/Ultra based cards. For newer cards please use the drivers provided in the nvidia package instead.

However for 2008 they have removed the 'legacy' from the package name of 'nvidia71xx' modules for old cards.

 

Sorry for trying to spread my confusion to others. :oops:

 

That said, I'm using the nvidia96xx with my old GF4 without any problems. If yossarian has a GeForce FX or newer card, he 'should' use the latest module. He could do that with (as root)

urpmi dkms-nvidia-current

then use XFdrake to set it up. This would give him the nvidia 100.14.19-1 module from the repos.

Edited by Greg2

Share this post


Link to post
Share on other sites
That said, I'm using the nvidia96xx with my old GF4 without any problems. If yossarian has a GeForce FX or newer card, he 'should' use the latest module. He could do that with (as root)
urpmi dkms-nvidia-current

then use XFdrake to set it up. This would give him the nvidia 100.14.19-1 module from the repos.

I ran it. I got the message:

Package dkms-nvidia-current-100.14.19-1mdv2008.0.i586 is already installed

Furthermore, I tried installing the driver I downloaded from nVidia manually using the sh command, but got the original error message from the MCC:

Failed to initialize the NVIDIA kernel module! Please ensure that there is a supported NVIDIA GPU in this system

 

So the driver is installed from the repos, I can't install it manually, and the xorg.conf file looks ok. Unless you have some other idea, I think I'll do a fresh installation of 2008.0 tomorrow .

 

Thank you all for all the support, especially Greg, scoonma and John. Don't worry, give me a day or two, I'll be back with some new problems. :)

Share this post


Link to post
Share on other sites
Guest V-man

I've got a similar problem here......

 

I've installed Mandriva 2008 on a Dell C840 laptop with a Nvidia 440 Go video card. I've tried both the offered during install proprietary driver and the driver from Nvidia's site. When booting, at the point where X starts, the screen goes black and stays there. Mandriva continues to boot into KDE, because I can hear the sound that plays when it is finished loading. If I hit the power button, the laptop shuts down as it should.

 

I can boot into safe mode and when I type startx, it does the same thing.

 

I know very little about working at the console and the needed syntax to get around, so humor the noob. ;)

 

Thanks,

Share this post


Link to post
Share on other sites
Guest V-man

Yes, I should have also stated that if choosing not to install the proprietary driver during install or the driver from Nvidia's site, it works fine. You just have no 3D acceleration then.

 

Thanks

Edited by V-man

Share this post


Link to post
Share on other sites
Guest Rick

Hi,

 

I'm using an Nvidia fx5200 card in my Myth box (Mandriva 2008) and had to do a few symbolic link adjustments to get it to work. I'm not sure if all of them were needed exactly, but this worked none-the-less. Before doing this I too had the NVIDIA driver load errors. I hope this can help you...

 

Here are my rpms for nvidia

dkms-nvidia-current-100.14.19-1mdv2008.0.i586.rpm

x11-driver-video-nvidia-current-100.14.19-1mdv2008.0.i586.rpm

kernel-desktop-2.6.22.9-1mdv-1-1mdv2008.0.i586.rpm

kernel-desktop-devel-2.6.22.9-1mdv-1-1mdv2008.0.i586.rpm

kernel-desktop-latest-2.6.22.9-1mdv2008.0.i586.rpm

 

 

I had to copy this:

cp /etc/nvidia-current/ld.so.conf /etc/ld.so.conf.d/nvidia.conf

 

Plus I put this in the modprobe.conf:

alias nvidia nvidia-current

 

 

Here's the links I have (some I added manually):

 

/usr/lib/xorg/modules/drivers/nvidia_drv.so -> nvidia-current/nvidia_drv.so

/usr/lib/xorg/modules/extensions/nvidia-current/libglx.so -> libglx.so.100.14.19

/usr/lib/xorg/modules/extensions/nvidia-current/libGLcore.so.1 -> /usr/lib/nvidia-current/libGLcore.so.1

/usr/lib/xorg/modules/extensions/libGLcore.so.1 -> /usr/lib/nvidia-current/libGLcore.so.1

/usr/lib/xorg/modules/libGLcore.so.1 -> /usr/lib/nvidia-current/libGLcore.so.1

/usr/lib/nvidia-current/libGL.so.1 -> libGL.so.100.14.19

/usr/lib/nvidia-current/libGLcore.so.1 -> libGLcore.so.100.14.19

/usr/lib/nvidia-current/libXvMCNVIDIA_dynamic.so.1 -> libXvMCNVIDIA.so.100.14.19

/usr/lib/nvidia-current/libnvidia-cfg.so.1 -> libnvidia-cfg.so.100.14.19

/usr/lib/nvidia-current/libnvidia-tls.so.1 -> libnvidia-tls.so.100.14.19

/usr/lib/nvidia-current/tls/libnvidia-tls.so.1 -> libnvidia-tls.so.100.14.19

/lib/modules/2.6.22.9-desktop-1mdv/kernel/drivers/char/drm/nvidia.ko.gz -> nvidia-current.ko.gz

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...