Jump to content
yossarian

Problem with Mandriva 2008.0 and nVidia driver

Recommended Posts

I'd suggest just getting your graphic card working properly, before trying to enable the 3D desktop.

 

Do you have your proper display resolution set? What is the output of

glxinfo |grep rendering

and what is your average FPS from

glxgears

 

glxinfo |grep rendering:

direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

 

average FPS:

1725 frames in 5.4 seconds = 320.907 FPS
1820 frames in 5.4 seconds = 339.660 FPS
1690 frames in 5.2 seconds = 323.634 FPS
1690 frames in 5.1 seconds = 328.795 FPS
1170 frames in 5.3 seconds = 220.295 FPS
1170 frames in 5.1 seconds = 230.382 FPS
1430 frames in 5.1 seconds = 278.125 FPS
1430 frames in 5.2 seconds = 277.499 FPS
1430 frames in 5.1 seconds = 281.984 FPS

 

What does the doctor have to say, what is the diagnosis? And what's next?

Share this post


Link to post
Share on other sites
That's not good.

 

But I'll make it, right? Please doctor, tell me what are my chances! :)

 

xorg.conf:

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce 3 - GeForce 4 (96xx)"
Driver "nvidia"
Option "DPMS"
Option "RenderAccel" "false"
Option "AddARGBGLXVisuals"
Option "IgnoreEDID" "1"
EndSection

 

I also have a file called xorg.conf.old (not sure if it's relevant):

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce 3 - GeForce 4 (96xx)"
Driver "nv"
Option "DPMS"
EndSection

Share this post


Link to post
Share on other sites

Just a last sugegstion --check xorg.conf, module section. Mine reads:

 

Section "Module"

Load "dbe" # Double-Buffering Extension

Load "v4l" # Video for Linux

Load "extmod"

Load "type1"

Load "freetype"

Load "glx" # 3D layer

EndSection

 

 

Have you got the glx command?

Share this post


Link to post
Share on other sites

To setup which kernel to load automatically in the boot manager (GRUB by default) launch the Mandriva Control Center (goes by the name "Configure your computer" in the menu) and on the Boot tab choose the the monitor with a wrench icon. It says something like "Setting up system boot". Sorry but I don't use English here you have to find that by yourself. When that starts you should see a window where you can choose which boot manager to choose and the time delay before the automatic boot starts etc. By default GRUB is chosen. You don't have to change here anything click on Next. Here you can change which kernel to load when you change "linux" in GRUB. So choose it and click modify.

To make things clearer the option "linux" always points or at least should point to your latest kernel. So when you upgrade your kernel next time choosing linux will automatically load that.

Share this post


Link to post
Share on other sites
Just a last sugegstion --check xorg.conf, module section. Mine reads:

 

Section "Module"

Load "dbe" # Double-Buffering Extension

Load "v4l" # Video for Linux

Load "extmod"

Load "type1"

Load "freetype"

Load "glx" # 3D layer

EndSection

Have you got the glx command?

Under root - glx: command not found.

 

To setup which kernel to load automatically in the boot manager (GRUB by default) launch the Mandriva Control Center (goes by the name "Configure your computer" in the menu) and on the Boot tab choose the the monitor with a wrench icon. It says something like "Setting up system boot". Sorry but I don't use English here you have to find that by yourself. When that starts you should see a window where you can choose which boot manager to choose and the time delay before the automatic boot starts etc. By default GRUB is chosen. You don't have to change here anything click on Next. Here you can change which kernel to load when you change "linux" in GRUB. So choose it and click modify.

To make things clearer the option "linux" always points or at least should point to your latest kernel. So when you upgrade your kernel next time choosing linux will automatically load that.

Thanks a lot - found it in the MCC.

Share this post


Link to post
Share on other sites
Under root - glx: command not found.

 

I'm pretty sure pindakoe meant the glx entry his xorg.conf is reflecting within the Module section. I'd recommend using it, too.

 

BTW: Is there any good reason why the option "RenderAccel" is set to "false" in the Device section? I'd set this to true or delete the option line.

 

Also make sure there's no double entries of options within xorg.conf. Some config program generated these here, located in different sections, but no complaint form Xorg!

 

You may also need this entry:

 

Section "Extensions"

Option "Composite"

EndSection

 

Good luck!

Share this post


Link to post
Share on other sites
I'm pretty sure pindakoe meant the glx entry his xorg.conf is reflecting within the Module section. I'd recommend using it, too.

My bad. I already have in the module section the glx entry.

 

BTW: Is there any good reason why the option "RenderAccel" is set to "false" in the Device section? I'd set this to true or delete the option line.

In the MCC there is a flag for Render Acceleration. It is said there that it may hurt the way fonts are displayed and was unchecked by default, so I didn't touch it.

EDIT: I changed it from the MCC, and restarted the computer. This line is not in the file anymore. Still no improvement.

 

Also make sure there's no double entries of options within xorg.conf. Some config program generated these here, located in different sections, but no complaint form Xorg!

No double entries in my file.

 

 

You may also need this entry:

 

Section "Extensions"

Option "Composite"

EndSection

 

Good luck!

I already have this entry in the file. Still no luck though...

Edited by yossarian

Share this post


Link to post
Share on other sites

Yossarian, you're running the new kernel 2.6.22.9-1 now, right? It may not be appropriate to to this in conjunction with the old legacy nvidia modules (96xx) - please correct me if your config is different now.

 

I'd generally adivse either to use the dkms modules for nvida (okay if it works) or download the most recent nvidia driver module from vendor's homepage and install it: Compile the source module by building it against your corresponding kernel sources (best results if it's not too complicated for your liking).

 

When trying out one of these methods *after* the other, carefully uninstall as many as possible remains from your further attempt. If you decided to go building against kernel source, check /usr/src directory for the symbolic link named "linux" correctly pointing to the subdir matching your kernel name.

Edited by scoonma

Share this post


Link to post
Share on other sites
I changed it from the MCC, and restarted the computer. This line is not in the file anymore. Still no improvement.

Try also removing the: Option "AddARGBGLXVisuals" and the: Option "IgnoreEDID" "1" from the device section. So it looks like this

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce 3 - GeForce 4 (96xx)"
Driver "nvidia"
Option "DPMS"
EndSection

Then logout and login again.

 

If that doesn't work (without using the 3D desktop)... please attach your complete xorg.conf file here.

 

@ scoonma- The 96xx are not old legacy modules, legacy modules are 71xx. If he's using a GF 3/4, he has the proper module.

Share this post


Link to post
Share on other sites
If that doesn't work (without using the 3D desktop)... please attach your complete xorg.conf file here.

 

That doesn't work. Tell me the truth, doctor, how much time do I have left? :)

 

xorg.conf:

# File generated by XFdrake (rev 230776)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "Files"
   # font server independent of the X server to render fonts.
   FontPath "unix/:-1"

   # minimal fonts to allow X to run without xfs
   FontPath "/usr/share/fonts/misc:unscaled"
EndSection

Section "Extensions"
   Option "Composite"
EndSection

Section "ServerFlags"
   #DontZap # disable <Crtl><Alt><BS> (server abort)
   AllowMouseOpenFail # allows the server to start up even if the mouse does not work
   #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
   Load "dbe" # Double-Buffering Extension
   Load "v4l" # Video for Linux
   Load "extmod"
   Load "type1"
   Load "freetype"
   Load "glx" # 3D layer
EndSection

Section "InputDevice"
   Identifier "Keyboard1"
   Driver "kbd"
   Option "XkbModel" "pc105"
   Option "XkbLayout" "us,il"
   Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,compose:rwin"
EndSection

Section "InputDevice"
   Identifier "Mouse1"
   Driver "mouse"
   Option "Protocol" "ExplorerPS/2"
   Option "Device" "/dev/mouse"
EndSection

Section "Monitor"
   Identifier "monitor1"
   VendorName "Generic"
   ModelName "1024x768 @ 60 Hz"
   HorizSync 31.5-48.5
   VertRefresh 50-70

   # TV fullscreen mode or DVD fullscreen output.
   # 768x576 @ 79 Hz, 50 kHz hsync
   ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630

   # 768x576 @ 100 Hz, 61.6 kHz hsync
   ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
   Identifier "device1"
   VendorName "nVidia Corporation"
   BoardName "NVIDIA GeForce 3 - GeForce 4 (96xx)"
   Driver "nvidia"
   Option "DPMS"
   Option "RenderAccel" "false"
   Option "AddARGBGLXVisuals"
   Option "IgnoreEDID" "1"
EndSection

Section "Screen"
   Identifier "screen1"
   Device "device1"
   Monitor "monitor1"
   DefaultColorDepth 24

   Subsection "Display"
       Depth 8
       Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
   EndSubsection

   Subsection "Display"
       Depth 15
       Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
   EndSubsection

   Subsection "Display"
       Depth 16
       Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
   EndSubsection

   Subsection "Display"
       Depth 24
       Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
   EndSubsection
EndSection

Section "ServerLayout"
   Identifier "layout1"
   InputDevice "Keyboard1" "CoreKeyboard"
   InputDevice "Mouse1" "CorePointer"
   Screen "screen1"
EndSection

Share this post


Link to post
Share on other sites
That doesn't work.

If you have edited the xorg.conf (the way I have asked), why is the section "Device" unchanged? :rolleyes:

 

How are you editing the file? What desktop are you using, KDE, Gnome, or what?

Share this post


Link to post
Share on other sites
If you have edited the xorg.conf (the way I have asked), why is the section "Device" unchanged? :rolleyes:

 

How are you editing the file? What desktop are you using, KDE, Gnome, or what?

 

Hey, you have a point there.

 

I'm using Gnome. In order to change the file I opened a terminal, logged in as root, edited the file using gedit, saved, and rebooted the computer. I have just repeated this process, this time making sure the file was saved correctly before rebooting, and it was fine. Again the changes were not saved. So I guess something modifies the file during start-up. Does it have a remedy?

Share this post


Link to post
Share on other sites

OK, why don't you just open a terminal and do

gksu gedit

then open and edit your xorg.conf, and save it that way. Then just hit Ctrl + Alt + backspace, and login. Let us know if that works?

Share this post


Link to post
Share on other sites
OK, why don't you just open a terminal and do
gksu gedit

then open and edit your xorg.conf, and save it that way. Then just hit Ctrl + Alt + backspace, and login. Let us know if that works?

 

No. All I get is:

gksu: command not found

(I tried it both as a regular user and as root.)

 

But the weird thing is that I just logged in as another user, and I did have partial effects: The desktop, for example, was 3-D, but the menus were not jumpy. Besides, the fonts were still tiny. I checked the xorg.conf file as the other user, it was the same.

Edited by yossarian

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...