Jump to content
Sign in to follow this  
moskal

Installing NVIDIA drivers

Recommended Posts

I had exactly the same problems with the nvidia 6111 driver installation script. I was able to install the driver successfully by doing the following:

  • run the installer script with the --extract-only option. This will create a directory under your current directory with the unpacked contents of the driver installation script
  • cd into the new directory NVIDIA-Linux-x86-1.0-6111-pkg1
  • as root, type: make install

This should compile and install the drivers (at tleast it worked for me).

 

The error message that you saw instructing you to run make mrproper comes from the /usr/src/linux/ kernel makefile, not the nvidia makefile. You would only get this message if you invoked the kernel make without any target (i.e. running the default target). This is not what is desired. Somehow, running the nvidia makefile directly doesn't trigger that error.

 

Note -- If you ran make mrproper on the kernel source, you will have to re-install a .config file in /usr/src/linux BEFORE you run the nvidia make install.

Share this post


Link to post
Share on other sites

Okay - it seems like although you are prompted to 'make mrproper', this is NOT the correct thing to do anymore. It will remove some configuration file on you (and I can't remember how I got it back, but it was making a copy of some boot file in the root)

 

Here's what I do now - in a terminal (I got this from a board - kudos to the original poster):

 

su
init 3
cd [dir where the NVIDIA installer is]
sh NVIDIA-Linux-x86-1.0-6111-pkg1.run --add-this-kernel
sh NVIDIA-Linux-x86-1.0-6111-pkg1-custom.run
vi /etc/X11/XF86Config-4 [make changes as per doc]
startx

 

Ta-da! You're done.

 

This has to be done EVERY time you update the kernel, and you WILL need the kernel source to do it.

 

p.s. can someone please update the hardware FAQ to reflect this?

Share this post


Link to post
Share on other sites

I installed these nvidia drivers hundreds of times, but I can't get this 6111 version installed either.

 

Here's what is installed:

[scoopy@localhost scoopy]$ rpm -qa | grep kernel
kernel-2.6.3.8mdk-1-1mdk
kernel-2.6.3.16mdk-1-1mdk
kernel-2.6.3.7mdk-1-1mdk
kernel-2.6.3.13mdk-1-1mdk
kernel-2.6.3.15mdk-1-1mdk
kernel-source-2.6.3-16mdk
[scoopy@localhost scoopy]$ uname -r
2.6.3-16mdk

So, yes I have the matching source and also am running a later kernel version than the "-4" and still have the same problem...

ERROR: Unable to build the NVIDIA kernel module.

ERROR: Installation has failed. Please see the file

'/var/log/nvidia-installer.log' for details.

So next I tried bvc's method... both in /usr/src/linux-2.6.3-16mdk and in /lib/modules/2.6.3-16mdk ( wasn't sure which source needed fixin' here )

No errors spit out and so we try again ... still fails.

 

So now I try this other method to:

sh NVIDIA-Linux-x86-1.0-6111-pkg1.run --extract-only

and then "make install"

 

I notice that "rivafb driver" message is gone, but still no go:

[root@localhost NVIDIA-Linux-x86-1.0-6111-pkg1]# make install

cd usr/src/nv; make install

make[1]: Entering directory `/home/scoopy/rpms/misc/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv'

If you are using a Linux 2.4 kernel, please make sure

you either have configured kernel sources matching your

kernel or the correct set of kernel headers installed

on your system.

 

If you are using a Linux 2.6 kernel, please make sure

you have configured kernel sources matching your kernel

installed on your system. If you specified a separate

output directory using either the "KBUILD_OUTPUT" or

the "O" KBUILD parameter, make sure to specify this

directory with the SYSOUT environment variable or with

the appropriate nvidia-installer command line option.

 

*** Unable to determine the target kernel version. ***

 

make[1]: *** [select_makefile] Error 1

make[1]: Leaving directory `/home/scoopy/rpms/misc/NVIDIA-Linux-x86-1.0-6111-pkg1/usr/src/nv'

make: *** [kernel_module_install] Error 2

[root@localhost NVIDIA-Linux-x86-1.0-6111-pkg1]#

 

Seems it is NOT finding the kernel to install to. Guess I try this next ?

sh NVIDIA-Linux-x86-1.0-6111-pkg1.run --add-this-kernel
sh NVIDIA-Linux-x86-1.0-6111-pkg1-custom.run

But I am not sure of the correct syntax here:

sh NVIDIA-Linux-x86-1.0-6111-pkg1.run --add-2.6.3-16mdk

Share this post


Link to post
Share on other sites

The message "If you are using a Linux 2.4 kernel, please make sure you either ..." i s what I got after doing the make mrproper in /usr/src/linux. After reinstalling a config file I was able to compile and install the nvidia driver. BTW I stumbled on this method when I was attempting to debug the original problem (I wanted to see what the scripts were doing in more detail) but since it worked (for me) I didn't analyze it any further. I also tried the --add-this-kernel method that I saw in another post when the 6111 driver was first released, but that method didn't work for me. It's interesting to see all the inconsistencies in the methods that do and don't work for people. I hope Nvidia can find the problem and fix it.

Share this post


Link to post
Share on other sites
Okay - it seems like although you are prompted to 'make mrproper', this is NOT the correct thing to do anymore. It will remove some configuration file on you (and I can't remember how I got it back, but it was making a copy of some boot file in the root)

 

Here's what I do now - in a terminal (I got this from a board - kudos to the original poster):

 

su
init 3
cd [dir where the NVIDIA installer is]
sh NVIDIA-Linux-x86-1.0-6111-pkg1.run --add-this-kernel
sh NVIDIA-Linux-x86-1.0-6111-pkg1-custom.run
vi /etc/X11/XF86Config-4 [make changes as per doc]
startx

 

Ta-da! You're done.

 

This has to be done EVERY time you update the kernel, and you WILL need the kernel source to do it.

 

p.s. can someone please update the hardware FAQ to reflect this?

 

I upgraded to official version and followed your instructions... it was a piece of cake!!! Thank you very much for your help. Unfortunately I didn't tried it on the community version and I don't know if it works there. The driver has worked flawlesslt ... thank you!!

Share this post


Link to post
Share on other sites

Yep... "--add-this-kernel" works just like they said it should. But this seems to be running 30 % slower than the previous driver on my system. And glxgears seems to freeze or skip a beat every second.

 

But it does seem to be running smooth. Oh, and I don't know if it helped any, but I reinstalled the source and also uninstalled all the other kernels I wasn't using.

Share this post


Link to post
Share on other sites

I managed to install the NVIDIA driver from their site but now I have two problems.

First: How do I remove their logo from showing everytime I boot Linux ?

Second: When I shut down my computer, the screen gets corrupted - white with black lines, it's crazy. After a few seconds it shuts down eventually.

 

:wall:

Share this post


Link to post
Share on other sites

In your /etc/X11/XF86Config-4 there is a line that says option "logo" on, change the on to off.

 

In your /etc/lilo.conf there is a line that says vga=788(I guess), change that to vga=normal. Run lilo /sbin/lilo. That should do it.

 

Good luck

Share this post


Link to post
Share on other sites

I use Xorg, so I checked both xorg.conf and xf86config-4 for a 'logo' line (both manually and with Ctrl+F) but couldn't find a thing.

 

In lilo.conf I changed vga=788 to vga=normal but it made no difference.

Share this post


Link to post
Share on other sites

You have to run lilo after you edited the lilo.conf (log in as root and type /sbin/lilo) Then try again.

 

Then the logo=on is the default. Add the line your self (under section devices)

 

Option "NoLogo" "boolean"

                Disable drawing of the NVIDIA logo splash screen at

                X startup.  Default: the logo is drawn.

 

Option "NoLogo" "TRUE"

 

Good luck

Share this post


Link to post
Share on other sites

I've done what you said but now there is no boot theme so neither the nvidia logo is showed nor that crazy corrupted screen at shutdown. But I want to have a graphical theme. When I check the "Use graphical boot" option in MCC's Boot Theme I get this warning: "Your system bootloader is not in framebuffer mode. To activate graphical boot, select a graphic video mode from the bootloader configuration tool" and the option remains unchecked.

Share this post


Link to post
Share on other sites

I don't think that's possible. It's a bug in the nvidia driver so you can't run vga=788 (what you need for the graphical boot) and have a terminal (ctrl-alt-f1, or the problems during shut down). Write to nvidia to complain. Maybe they'll do something about it.

 

Good luck.

Share this post


Link to post
Share on other sites

Yeah right ... as if they care that I don't have a graphical theme at boot ....... Even if they decide to fix it, it will take a lot of time.

 

 

Next time I buy hardware .... I'm dumping them. Bastards .... I'll get myself an ATI :cheeky: I had ATI before and worked excellent ..... this time I wanted to try NVIDIA. I made a bad choice it seems.

Edited by a13x

Share this post


Link to post
Share on other sites
Yeah right ...  as if they care that I don't have a graphical theme at boot ....... Even if they decide to fix it, it will take a lot of time.

 

 

Next time I buy hardware .... I'm dumping them. Bastards .... I'll get myself an ATI  :cheeky: I had ATI before and worked excellent ..... this time I wanted to try NVIDIA. I made a bad choice it seems.

Hi

 

I am not sure if this is the right place for this question but I have installed the Nvidia drivers -I have TNT2- and then ran glxgears to test it and got the following message:

xlib: extension “GLX” missing on display “:0.0”

Error: couldn't get an RGB, Double-buffered visual

What does it mean and what should I do?

 

Hopeful

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...