Jump to content
Sign in to follow this  
moskal

Installing NVIDIA drivers

Recommended Posts

Yeah right ...  as if they care that I don't have a graphical theme at boot ....... Even if they decide to fix it, it will take a lot of time.

 

 

Next time I buy hardware .... I'm dumping them. Bastards .... I'll get myself an ATI  :cheeky: I had ATI before and worked excellent ..... this time I wanted to try NVIDIA. I made a bad choice it seems.

not at all. ati support sucks in linux. I don't use gui boot though. There have been times I would have liked to and couldn't, and that is frustrating.

 

 

 

 

Yeah right ...  as if they care that I don't have a graphical theme at boot ....... Even if they decide to fix it, it will take a lot of time.

 

 

Next time I buy hardware .... I'm dumping them. Bastards .... I'll get myself an ATI  :cheeky: I had ATI before and worked excellent ..... this time I wanted to try NVIDIA. I made a bad choice it seems.

Hi

 

I am not sure if this is the right place for this question but I have installed the Nvidia drivers -I have TNT2- and then ran glxgears to test it and got the following message:

xlib: extension “GLX” missing on display “:0.0”

Error: couldn't get an RGB, Double-buffered visual

What does it mean and what should I do?

 

Hopeful

 

reinstall nvidia with the -ane options and make sure you say tes to install nvidia's gl. Try again.

Share this post


Link to post
Share on other sites

Hey I need help again please.... I had to reinstall my mandrake 10 official but now I have problems installing the NVIDIA driver. Last time I just used the "--add-this-kernel " option and it worked flawlesly... now it doesn't allow me to install the driver... here's my new /var/log/nvidia-installer.log

 

nvidia-installer log file '/var/log/nvidia-installer.log'

creation time: Sat Sep 18 10:22:00 2004

 

option status:

license pre-accepted : false

update : false

force update : false

expert : false

uninstall : false

driver info : false

no precompiled interface: false

no ncurses color : false

query latest driver ver : false

OpenGL header files : false

no questions : false

silent : false

X install prefix : /usr/X11R6

OpenGL install prefix : /usr

Installer install prefix: /usr

kernel source path : (not specified)

kernel install path : (not specified)

proc mount point : /proc

ui : (not specified)

tmpdir : /root/tmp

ftp site : ftp://download.nvidia.com

 

Using: nvidia-installer ncurses user interface

-> License accepted.

-> A precompiled kernel interface for kernel 'Mandrake Linux 10.0 kernel

2.6.3-7mdk i586' has been found here:

./usr/src/nv/precompiled/nv-linux.o-1.0-6106.mdk10.0_2.6.3-7mdk.

executing: 'cd ./usr/src/nv; /usr/bin/ld -d -r -o nvidia.ko precompiled-nv-l

inux.o nv-kernel.o'...

-> Kernel module linked successfully.

ERROR: Unable to load the kernel module 'nvidia.ko'. This is most likely

because the kernel module was built using the wrong kernel source files.

Please make sure you have installed the kernel source files for your

kernel; on Red Hat Linux systems, for example, be sure you have the

'kernel-source' rpm installed. If you know the correct kernel source

files are installed, you may specify the kernel source path with the

'--kernel-source-path' commandline option.

-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':

-1 No such device

ERROR: Installation has failed. Please see the file

'/var/log/nvidia-installer.log' for details. You may find suggestions

on fixing installation problems in the README available on the Linux

driver download page at www.nvidia.com.

 

I've try it declaring the kernel paths and without declaring them, and I've try it also with different versions of the driver. I'm sure I have the right sources installed... but I don't know what happens. I've also tried extracting the archive and doing a make installl but it gives also an error message... I'lll try to install different kernels and their sources.... hope you can help me.

Share this post


Link to post
Share on other sites

are you sure you have the correct sources? from the error log, that looks to be the problem..........

 

ERROR: Unable to load the kernel module 'nvidia.ko'. This is most likely

because the kernel module was built using the wrong kernel source files.

 

in terminal as root do uname -a to get your kernel version. then in terminal as root do urmpi kernel-source-(version number to match your kernel here).

 

Chris

Share this post


Link to post
Share on other sites

That's the weird thing.... the system tells me that I have the right sources... this is what I did:

 

1)installed mandrake 10 official with the 2.6.3-7mdk kernel (the only one you can choose in the installation, I think)

 

2)Installed the sources for it from the cds..

 

3) Tried to install the nvidia drivers...... it showed the error message that I posted.

 

4) Installed the sources for 2.6.3-7mdk from the update packages...

 

5) Same error message.

 

I don't know what's wrong... Are there two versions of the mdk10 official?? because the last time when I installed it , I used my friend's cds and I had no problems. But this time I downloaded the isos myself and reinstalled mandrake and I have this problem. I'm sure the integrity of the cds is ok ( I checked them with the md5sum), but I can't figure out why these cds don't work, and I'm sure both versions are the official ones. Well thank you very much... If it doesn't work I'll need to ask that guy for his cds....

Share this post


Link to post
Share on other sites
Guest bootsy

I'm in the same boat

 

here's my dump of nvidia-installer log

 

nvidia-installer log file '/var/log/nvidia-installer.log'

creation time: Mon Sep 20 22:04:31 2004

 

option status:

license pre-accepted : false

update : false

force update : false

expert : false

uninstall : false

driver info : false

no precompiled interface: false

no ncurses color : false

query latest driver ver : false

OpenGL header files : false

no questions : false

silent : false

X install prefix : /usr/X11R6

OpenGL install prefix : /usr

Installer install prefix: /usr

kernel source path : (not specified)

kernel install path : (not specified)

proc mount point : /proc

ui : (not specified)

tmpdir : /root/tmp

ftp site : ftp://download.nvidia.com

 

Using: nvidia-installer ncurses user interface

-> License accepted.

-> No precompiled kernel interface was found to match your kernel; would you li

ke the installer to attempt to download a kernel interface for your kernel f

rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)

-> No precompiled kernel interface was found to match your kernel; this means

that the installer will need to compile a new kernel interface.

-> Kernel source path: '/lib/modules/2.6.3-4mdk/build'

-> Performing cc_version_check with CC="cc".

ERROR: If you are using a Linux 2.4 kernel, please make sure

you either have configured kernel sources matching your

kernel or the correct set of kernel headers installed

on your system.

 

If you are using a Linux 2.6 kernel, please make sure

you have configured kernel sources matching your kernel

installed on your system. If you specified a separate

output directory using either the "KBUILD_OUTPUT" or

the "O" KBUILD parameter, make sure to specify this

directory with the SYSOUT environment variable or with

the appropriate nvidia-installer command line option.

ERROR: Installation has failed. Please see the file

'/var/log/nvidia-installer.log' for details. You may find suggestions

on fixing installation problems in the README available on the Linux

driver download page at www.nvidia.com.

 

dump of # ls -alc

total 16

drwxr-xr-x 4 root root 4096 Sep 19 21:18 ./

drwxr-xr-x 12 root root 4096 Sep 20 03:11 ../

lrwxrwxrwx 1 root root 16 Sep 19 21:18 linux -> linux-2.6.3-4mdk/

drwxr-xr-x 20 root root 4096 Sep 21 19:46 linux-2.6.3-4mdk/

drwxr-xr-x 7 root root 4096 Sep 20 03:03 RPM/

 

And the gcc version # gcc -v

Reading specs from /usr/lib/gcc-lib/i586-mandrake-linux-gnu/3.3.2/specs

Configured with: ../configure --prefix=/usr --libdir=/usr/lib --with-slibdir=/lib --mandir=/usr/share/man --infodir=/usr/share/info --enable-shared --enable-threads=posix --disable-checking --enable-long-long --enable-__cxa_atexit --enable-clocale=gnu --enable-languages=c,c++,ada,f77,objc,java,pascal --host=i586-mandrake-linux-gnu --with-system-zlib

Thread model: posix

gcc version 3.3.2 (Mandrake Linux 10.0 3.3.2-6mdk)

 

 

Anyone able to point a desperate noobie in the right direction?

pleeeeeeeeeeeeeeease :thanks:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...