Jump to content

uninstalled Pulse Audio, MCC won't launch [solved]


Recommended Posts

Mandriva 2009.1 has been working well since I installed it. Today I was trying to remove programs I'm not using to free disk space. Pulse Audio is on the top of my hit list. I marked it for removal in Install Remove Software, it came up with a long list of packages to remove. I clicked apply, the packages removed without error.


Now MCC will not launch from either the icon, or from a command prompt. Properties of the icon are pointed at /usr/bin/mcc. There is no file there called mcc any more.


I opened a konsole and tried 'urpmi mcc' and got


# urpmi mcc
To satisfy dependencies, the following packages are going to be installed:
Package 	Version 	Release 	Arch 
(medium "Contrib")
pmccabe 	2.3 	1mdv2007.0	i586	
(medium "Contrib2")
pmccabe 	2.3 	1mdv2007.0	i586	
145KB of additional disk space will be used.
60KB of packages will be retrieved.
Proceed with the installation of the 2 packages? (Y/n)


I have no idea if this is the correct thing to install or not. My guess is no, but I don't know.


I then tried 'urpmi pulse' and got


# urpmi pulse
No package named pulse
The following packages contain pulse: alsa-plugins-pulse-config, audacious-pulse, fluxbox-pulseaudio, gstreamer0.10-pulse, ...
You should use "-a" to use all of them


I don't want to re-install pulse audio, how do I find out what package(s) are required to reinstall MCC ?

Link to comment
Share on other sites

Dependencies are packages required for installing the package of your choice, in this instance those extra packages are required by mcc. So the correct answer is to say yes and install them.


You'll probably find that the package is pulseaudio or similar, you can do:


urpmf --name pulse


and it will list all available packages with pulse in the name.

Link to comment
Share on other sites

Well, I installed pmccabe, as you suggested. That is not MCC. Did a google, here is what pcmccabbe is...


pmccabe calculates McCabe-style cyclomatic complexity for C and C++ source code. Per-function complexity may be used for spotting likely trouble spots and for estimating testing effort.


MCC does not work anymore. What I need to find out is what packages do I need to install to get MCC functioning again.


I do not want to re-install Pulse Audio. I will if there is no other way, but I don't want to wast the disk space for a sound server that doesn't work. I have never found a way to have Pulse Audio work with sound apps and system sounds. aRts does it, so I installed aRts...

Link to comment
Share on other sites

Than-you to all that answered my post.


I did a

urpmi drakconf


MCC is back and working. Thank-you!


I have since discovered much more than MCC got blown away. KDE is gonzo, Thunderbird and FIrefox also.


I used to trust urpmi blindly, I will now have a close look for what will be removed. It appears I can fully recover, by re-installing the apps I want. So lets call this thread solved.


Once again, Thank-you to those who have helped.

Link to comment
Share on other sites

Ahhh... I do love Linux, but its sound servers are a pain.

Arts was buggy as hell, gstreamer has loads of issues (mainly with streaming media), PulseAudio should be shot in the head right now, and Phonon is rather OK, but it's using gstreamer as main backend, which is a catastrophic combo. With xine backend it's working much better, but I'd rather use the new Mplayer, or VLC backend (both of them are buggy ATM).

Maybe the real problem is not the sound server, but ALSA and its extremely poor API... but since OSS4 can't do some elementary things yet (e.g. utilize a MIDI I/O properly) I have no real choice...

Edited by scarecrow
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...