Jump to content

installing Mandrake 9.1...help please


Guest Brit
 Share

Recommended Posts

I'm not fluent enough to coach through it...

Its great once we get it running ... but we mighest well use Yahoo for now...

 

Were going to configure your internet update sources first ..

The best way is using easy urpmi

(this will let you update all your packages)

Well use it later (or perhaps when your sleeping) to downlad the updated KDE...

If the present one is corrupt like it looks then this will overwrite it and you get the newer version at the same time:D

 

Im going to set it up for you ... ill explain in a minute...

Meanwhile

Try the menu thing and look for an editor

Link to comment
Share on other sites

  • Replies 90
  • Created
  • Last Reply

Top Posters In This Topic

try Gedit ... its simplest

 

 

In your editor to need to highlight what I put below, copy and paste.

Each line is from the urmpi.add ..... to the hdlist.cz

 

Well also install an instant messenging client for Yahoo if you don't have one... prob. Yahoo messenging is always full of freaks...

Ill be adding you to my contact list.

Mine is stephen_lord@yahoo.com (as per my email)

 

urpmi.addmedia plf http://mandrakeusers.com/PLF/9.1 with hdlist.cz



urpmi.addmedia main ftp://ftp.mirror.ac.uk/sites/sunsite.uio.no/pub/unix/Linux/Mandrake/Mandrake/9.1/i586/Mandrake/RPMS with ../base/hdlist.cz



urpmi.addmedia contrib ftp://ftp.mirror.ac.uk/sites/sunsite.uio.no/pub/unix/Linux/Mandrake/Mandrake/9.1/contrib/RPMS with ../../i586/Mandrake/base/hdlist2.cz



urpmi.addmedia --update updates ftp://ftp.mirror.ac.uk/sites/sunsite.uio.no/pub/unix/Linux/Mandrake/Mandrake/updates/9.1/RPMS/ with ../base/hdlist.cz



urpmi.addmedia texstar ftp://ftp.ibiblio.org/pub/Linux/distributions/contrib/texstar/mandrake/9.1/rpms with hdlist.cz

Link to comment
Share on other sites

Check the networking menu/instant messaging.

If you have a Yahoo client (Im using kopete then you can start it)

If not well just install it once you finish adding the sources.

 

Hope your doing OK in Gedit :D

You just need to copy and paste it...

Let me know as soon as youve done it.

Link to comment
Share on other sites

Did you find a instant messaging client....?

 

Anyway, no matter

Now we will make the file executable

 

OK make sure there are no funny characters from the paste

then

save it ... but remember where.

call it

dourpmi.sh

 

then go back to that first console we started

the one with root access.

 

If you saved it as sue its probably in /home/sue

adjust as appropraite...

 

then as root type

chmod +x /home/sue/dourpmi.sh

(strictly speaking it should have a header line which says

#!/bin/sh

but it will work without it!!!

 

then

sh /home/sue/dourpmi.sh

this will take a while ... its downloading the package lists from the mandrake mirrors. (an index of whats available)

 

Ill be waiting here. Im also having a quick look at the package lists to see what's avaialble for ya... well get you nice fonts and stuff whilst were fixing it...

 

If you have a yahoo client Ive opened an instant message with you...If not don't worry

Link to comment
Share on other sites

We started x OK using xinit and passing icewm as the window manager

So X is working fine

 

It looks like something in the install of the mdkdm/kde startup

 

So bypassing that works OK except the fonts were not loaded.

I guess the font server wasn't started

 

We disabled autologin and made RL3 the default for now.

 

We added urpmi sources BUT every texstar source except the Turksih one was messed up (including this one)

 

From CLI we urpmi'd kopete to use chat.

That went fine

 

Then we tried kdebase (and assoc deps)

Although we installed texstars key we still got an error

 

Since the system was at the point of being reinstalled we went ahead with the bad sig...

But we ended up ith the hole thing locking up

Then my rdio keyb died ..

It is playng with me NOw !

 

later

Link to comment
Share on other sites

oh man - don't stop there! I've been readin through this post - willing Brit to get everything working (kind of like some geeky movie where Brit is the hero(heroine?))

 

I was hoping I'd get to the end and find a happy ending to this story - but I guess I'll have to wait.

 

Sorry - I can't actually help with this problem - I'm purely here as a kind of voyeur :D

Link to comment
Share on other sites

I asked Brit to post the yahoo mess session, so that should give you some satisfaction :D

(brit: maybe cut out my obsession with FOOD :oops: ) I was starving and hadn't eaten for over a day!

 

 

Now I have a keyb. Ill carry on...

 

startx fails .... brit please post ...the following:

at the CLI type

which startx

then

just type (I think its in /usr/X11R6/bin) cat <path>/startx

and you can copy and paste it up.

 

Second.

If you (or anyone) can insall ssh on your MAC life would be easier.

You can open the remote session and just cut/paste.

you might have to alter the firewall on the mac but ssh is pretty secure.

You can probably specify your appt. subnet. (that way only people in the appt could even try and log in via ssh...)

btw: its pretty danmed secure... to the point of being annoying at times :D

 

 

third, I guess we better drop texstar till the mess is sourted out with his packages....

Try and download the same from contribs...

select it as the source in install software (from the tab/dropdown at the bottom)

 

We can try again later....

 

Chris

You were probably right that a reinstall is quicker :D but I think brit learned loads.... she asked where you learn this stuff so I told her my 2 secrets....

Hang round here at MUB and RTFM ....

When all else fails hardcopy and read every last page with a pen and highlighter....

 

For those interested startx is just a wrapper for xinit

It also starts lots of extras so xinit just makes the basic stuff

The default Mandrke xinit thoughfully adds an xterm. (it doesn't have to do anything ...) so from that you can start a window manager...

Link to comment
Share on other sites

oh man - don't stop there!  I've been readin through this post - willing Brit to get everything working (kind of like some geeky movie where Brit is the hero(heroine?))

I know what you mean. I've been pacing up and down outside the delivery room... :lol:

 

Hang on in there, Sue! :wub:

Link to comment
Share on other sites

dammit.......i was hanging by a thread (pun intended) too!!!

 

Brit,

if you & Gowator can't get this worked out & you should decide to go the reinstall route, here's what you need to look for & do.......

 

towards the end of the install, after you've picked your packages & everything's been installed, you get to one final screen that will show all of your settings & configurations. hardware, sound, internet, boot loader, etc. look here for your monitor/video settings. EVEN if it says that your monitor is detected, open up the configuration dialogue for it & double check things & change if necessary. this is where MDK fooled me the first time around. it told me that all was ok, but i learned differently & had the same problems you are having. don't go by how your monitor runs in Window$, because that may not necessarily work in MDK. a couple of things to check are......is the driver correct? if not, change it to something compatable......what is the refresh rate? if it's 70hz, bump it down to 60hz (remember, you can always go to MCC once you're up & running & change & tweak things from there).......what's your screen resolution? if it's 1024x768, try bumping that down to 800x600. and, with my card at least, there was a setting for various 3D excellerators. i can't remember all the particulars right now, but i do remember i had 3 choices & MDK told me that i SHOULD be able to use a particular one, but i may be better off using another, so i chose the safer one.

 

once you configure things, you'll get a chance to test those settings & it will bring up a test screen. if the test screen looks good, then you can save those settings & be on your way!

 

Gowator......by all means keep coaching her if you think you can get this fixed without reinstalling. the only reason i suggested that was because she doesn't have any thing really tweaked or set up in MDK, so it's not much of a loss for her to go the reinstall route right now.

 

Brit......good luck, whatever you decide. you'll get things working, i'm confident of that!

 

Chris

Link to comment
Share on other sites

The main monitor prob is its a SONY LCD/TFT.

 

The driver/timing are working fine at the native resolution but the login screen is probably using a lower resolution.

 

This is handled completely differently on a TFT than a CRT.

 

The TFT has to actually interpolate betweeen pixels but it needs the driver to do the work.

 

Sony's are pretty much appliances, sold with WinBlows...and heavy modification of mobo's and graphics chipsets are the norm.

Use it as Sony intended and they work as well as anything ever does in WinBlows...

BUT...

Hey, you can run linux on an XBOX... hacking through the sony stuff is pretty trivial compared to that....

 

I noticed brit is VERY determined and VERY patient...

From our chat I think she's very interested to learn the stuff too.

Every-time I gave her the option of CLI or graphic she chose CLI..

 

If I thought she wanted the 'easy option' I think the reinstall is the best ... but she seems determined to do it the hard-way and I for one don't have a problem helping her.

In fact from my POV its nice to see a noobie who doesn't want the quick way out.... (she has her Mac too - I very much get the idea this is a learning experience she's enjoying) (She's also got her Mac pretty nicely hacked from the standard Apple settings :D )

 

However: I strongly suspect the next stage after she's confident with Linux someone is going to have to make a dual boot Mac tutorial :D

 

More importantly .... installing/recompiling linux stuff under MAC OS-X/Darwin.... I know its doable but I've no experience.

 

Any takers !!!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share


×
×
  • Create New...