Jump to content

installing Mandrake 9.1...help please

Guest Brit

Recommended Posts


Sorry I went to the cinema then got diverted by a drink or two.

Anyway .. we crossed posts BUT you did it. :P :P :D :P :P


Don't worry to much about the blue screen. You haven't set up your window manager yet becuase its done first time you log into X.


YOU ARE SO CLOSE (/me makes gesture with thumb and first finger)


Now as root you need to copy the /root/XF86Config.new to /etc/X11/XF86Config-4.


Then ..

time to test big time with the login manager...


(If this goes wrong you can't CTRL+ALT+BKSPC it will just keeop restarting SO you need to CTRL+ALT+F1 to console (log in if necassary as root) and type init 3)


But I don't think it will.

So from a root login on a console just type

init 5


You should log in, then the 'first time wizard will set up your desktop'

After that works you can tweak inside of X....

Link to comment
Share on other sites

  • Replies 90
  • Created
  • Last Reply

Top Posters In This Topic

Hi all


I had to work all night so i didnt get a chance to do anything else yesterday. This is where i am up to:


cd /etc/X11

cp XF86Config-4 XF86Config-4-drake

XFree86 --configure


I then tested the Server:


XFree86 -xf86config /root/XF86Config.new


this is what brought me to the blue screen, i pressed CTRL,ALT,BAKSPACE to get to shell.


i was going then going to do what Gawator told me and cp /root/XF86Config-4 /etc/X11/XF86Config-4



init 5


but this is what is on my screen, not sure if i should continue.


" (++) Using config file: "/root/XF86Config.new"

Using vt 7

(EE) MGA(1): Cannot read V_Bios

(EE) RADEON(0): [dri] RADEONInitVisualConfigs failed (depth 8 not supported. Disabling DRI

(EE) MGA(1): [dri] Direct rendering not supported in 16 and 32 bpp modes


will leave it like this, until i hear any more




Link to comment
Share on other sites

First, you copies the original XFree86-4 to a backup... not that is was any use :wink:


Second, it detects the MGS but doesn't look fatal and you will find it easier to edit once you have X running :D


(EE) RADEON(0): [dri] RADEONInitVisualConfigs failed (depth 8 not supported. Disabling DRI

OK, this is a driver limitation of the ati-driver.

It means it can't use the DRI accel in 8 bit mode but that shouldn't bother you becuase we can just dump the 8 bit config once its all working :P


The fact you got a blue screen is good, it started the Xserver but it didn't know what to do next. This is I think prompted by the FirstTimeWizard and perhaps its why they made their own login manager (mdkdm)


Don't worry, we could edit out the 8-bit or comment out the DRI but I guess it will work anyway.


Anyway, it won't hurt...

If it gets stuck again you could actually start a window manger direct.

My choice would be KDE if its a reasonable machine.... Gnome would be perfectly good too.:D


the command for kde is


this should load X then the window manager. A whole load of stuff goes on behind but you can work it all out later.... Its such a pain doing everything in console mode unless your used to it... then it can be very efficient but its not the osrt of thing to start off on :D

Link to comment
Share on other sites



I copied the XF86Config.new to the etc/X11


and then init 5...i had a blue screen then it flashed and i think i had a colourful picture, then back to the blue screen, then back to the picture, then it went to the console again and it is stuck at starting dm:




Link to comment
Share on other sites



i rebooted and got into root shell then used startx


ok instead of a blue screen i have a red one, with a very small task bar at the bottom...this is definately progress :D


I can move the mouse , but thats about it.



Link to comment
Share on other sites

You mighta missed a bit of config on the install but your within inches...


Next time it flashes, you don't need to reboot...

You can go direct to a console....CTRL+ALT+F1 (actually you can have F1 thru F6)


From here you can init 3...

This basically stops the graphical login thing that keeps cycling...


I'll leave you in the capable hands of bvc and Ixthusdan for a while....


bvc has just gone from here to a fully working ATI with everything with Mahiles so don't worry....


p.s. You didn't say what machine it was!!!

In general, ANYTHING with built in graphics can be problematic... its not like you can pull out the card and its gone... its just kinda disabled...


You might (and it depends on your bios) be able to actually use the matrox as a second screen but we'll leave that for now :D

Link to comment
Share on other sites

:D :D :D :lol: :lol: :lol: :lol:


ok logged in normally and yes i have the first time wizard, configured that and then it is defiantely trying to do smething at the moment i have a blue screen with a wave pattern, and my mouse cursor is a watch.


And thats about it...will give it a while and see if it turns into something other than that.


i think it has a problem...oh and i was so close


But i wanted to thank you all so much for helping me and getting me this far.



Link to comment
Share on other sites

Hopefully this will be the last question


Ok i login and get that blue screen, and its defiantely trying to do something, a white box keeps flashing on and off the screen too fast for me to see anything.


Does this mean that the graphic card is configured, and could this new problem be my display settings, can i change the type of display from a command prompt.


What i dont want to do is run XFdrake and mess up everything that you have all done :D



Link to comment
Share on other sites

the blue wave background &/or flashing background with the alternating watch & cursor is indicative of an incompatable video/monitor driver choice &/or incorrect screen resolution & refresh rate. i had that same thing happen to me during my first MDK install. i changed the video driver & bumped my resolution & refresh rate down to 800x600 60hz & it worked & got me into KDE. after that, i played around with the monitor settings in MCC & got the resolution working at 1024x7?? (i forget the 700#). it still wouldn't work with a higher refresh rate or the proper video driver, so i left it as is & things were fine ever since. (BTB.....my video card is an ATI mach 64 rage pro....MDK has a driver for that, but it only works with the ATI (utah) driver for some reason :roll: )


try changing those settings if you're having no other luck.



Link to comment
Share on other sites

hey yet again


Ok went into root and ran XFdrake...the results were strange. This time it recognizes my monitor SBM-Hs73, but the grahics card is set as custom. It no longer shows the ATI Radeon card.


Should i change it from here and hope for the best. If i mess it up i just have to get to this point again dont I???




Link to comment
Share on other sites

i'm at work & not at my Linux box, so i'm doing some guess work here..........i'm also not a terminal command line expert. so, be warned. but........


what i was trying to illustrate to you, was, MDK only works with my ATI card using that ATI (Utah) driver (whatever a "Utah" driver is). even though MDK has an exact driver match for my ATI mach 64 rage pro, it wouldn't work. and, in Window$ i can use a 1024x768 screen res. with a 70hz refresh rate, but that doesn't jibe for me in MDK. i had to bump the refresh rate down to 60hz to get things working, in addition to using the non matching video driver. soooo........you may want to give it a whirl with that "custom" setting but try a lower resolution & refresh rate. oooor........you may want to try another ATI/Radeon driver & see what results you get. oooor........you may want to wait until somebody else comes along with a possitive answer for you. also.......i know i've read about problems with certain ATI Radeon drivers in MDK. i don't know if that's still true, but i know they could be troublesome, as recently as a few months ago.


gotta get back to work now. sorry, but that's the best suggestion(s) i can come up with at the moment. :oops:



Link to comment
Share on other sites

Back in my office :D



Can you answer these definitively ... save me trawling your old posts!

1) The monitor is an LCD/TFT monitor ?

2) If so what's its native resolution (i.e. what was it sold as 1024x768 etc)

3) Can you test your internet connection ...?

the easiest way is possibly just type

ping www.mandrakeusers.org

from the console.

CTRL C if it hangs for 10 secs or more.... or when you wanna stop it.



I want you to go into init 3 (which you should be getting quite good at :wink:)


were going to log in as root - it isn't strictly necassary BUT it will cut out some stages and options like bad file permissions...


It may just be becuase it didn't install properly initially the scripts to start up X etc. are not working or setup correctly BUT its easier for you to get it working first...


Now, go to the console prompt and type (don't hit enter)


now hit TAB

It should tell you all possible options of what to run

Im looking for

startkde, startgnome, starttvwm etc.

Post these back....

Were going to try just reinstalling a very tiny easy one ...


Presuming your internet connection is working .... well set you up a source with mandrake compiled RPM's for something really minimalist.

This should then set up the startup parts of the display manager...



This is all presuming you have the bluescreen and mouse ....

You descibed the hourglass .... to me there are two options ..

First: Your display isn''t starting at all (this is where the login manager just keeps restarting)


I think you chose a autologin ... the flash and too quick to read is you being auto logged in and the display manager starting....

BUT for some reason its hanging ... hence your stuck with hourglass.


Another option is we could create a NEW user.

Presuming the templates are OK we can use DRAKCONF from the console to do this and create a 'clean' user.


You reran drakxconfig so it wrote over the one we generated but you should still have a copy in /root/XF86Config.new


If drak works its fine but if not I think you got further with the one we generated....

Since it didn't work nbefore its unlikely to work again unless you found something in BIOS to disable the matrox....



We also have the option of getting it running under the matrox and configuring .. install latest drivers etc and then but the ATI back in....


Your choice ....

Link to comment
Share on other sites

hey gawator


Ok the answers to the questions:


1. It is a LCD screen by Sony resolution 1280x1024.

2. I have an internet connection and it works


The screen i keep getttting is a blue one with a wave, before i went to work last night i tried every resolution that i was offered from Xdrake. whic got rid of what we did. But i am going to creat a new XF86Config file and get back to what it was doing.


I am using a Sony P11 if that helps and i have been in the Bios and i cant find anything that gives me the option to disable the Matrox card.


After typing start and then tab...this is what i get:


startgnome startkde startx starticewm start windowmaker.


I will do anything that gets it working, even take the ati card out. I thought about doing that this morning at 5.00 after i finished work. But i didnt. I wanted to give it another day and see if WE (well you with your advice could get it to work)


Thanks Sue

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...