Jump to content

k3b help

chris z

Recommended Posts

sorry. in my haste i neglected to mention (don't know if this will help or not) i also tried unmounting my cdroms using the icons on my desktop. when i right click & select unmount, it tells me i need to be root. when i'm in root, i have no icons on my desktop. also, i went to MCC, mount points, but i had no idea what to do once i was there, so i canceled & backed out of that. ok, back to that gin now..........


Link to comment
Share on other sites

  • Replies 61
  • Created
  • Last Reply

Top Posters In This Topic

Breath deep the gathering gloom...........


But seriously, let's do a step-by-step! :wink:


Open a file manager K>Applications>File tools>File Manager-Superuser Mode

type your admin password, hit enter

Navigate to /etc directory

Find the file labled fstab

Double click on it. You should be in an editor, viewing the file

Put a # mark in front of these lines:

#none /mnt/cdrom supermount

#none /mnt/cdrom2 supermount

Write down the last two lines, do not change them.

Save and close.


Run k3b set up again


In the part that says where it is going to mount the drives, make the devices match your fstab, and the corresponding mount points. For the purposes of set up, ignore the "auto ro,noauto,user,exec 0 0"


Save and you're done! :wink:

Link to comment
Share on other sites

did as you instructed. i now have 2 icons on my desktop that each say "hard disc (cd) (not mounted)". through trial & error (by placing cd's with data in each drive & clicking on each icon) i've discovered which icon is for the burner & which one is for the cdrom. great! nope....more confusion. so, in order to even play or use a cd now, i have to insert the cd, right click the icon, click "mount", then i'm able to use the cd. but.....when i try to eject the cd, it won't eject. it's locked. soooo....i now have to right click the icon, click "unmount", & push the eject button, then my cd drive is unusable again until the next time?! okay, so i opened k3b, hoping that would work. nope.....it opens, none of my drives are listed, none are recognized, none are accessable. soooo.......i'll wait a bit more, maybe get another answer or a wap upside the head, & if it still doesn't work, i'll restore the fstab file that i backed up (right???), & forget cd burning in here until i can figure out a way to make it work.

sorry, but this just seems like a huge amount of work for something that should be so simple. frustrated, i am..........


Link to comment
Share on other sites

Your icons are working correctly. That is how you mount and unmount a cdrom device. Music cd's should play on their own because they do not need to be mounted.


Did you re-run k3b set up? Did you fill out the table like i said? Everything should be working.

Link to comment
Share on other sites

Hey chris ... having fun yet ? :-)


I use k3b ocassionally, and mine will only work when I am root

that means

open a terminal (konsole) su - root .. .then enter your admin/root password ... then type k3b<enter>


its a pain, and I'm sure somebody here could think of any easy way to automate this process ... but it list all my drives, and works as I expect it to.


on the other hand, if try running k3b as my user, then I get no drives listed, and error message telling me to run k3bsetup :roll:

Link to comment
Share on other sites

Paul, I forgot!! k3b will setup a user group with access rights in the set up. You must add yourself to the group, or any user you want to be able to use the program. It's all in the set up process.

Link to comment
Share on other sites

In k3b setup there is a section to add users to make it available for them. I think it is the 3rd or 4th screen. Also, make sure you check the box on that screen that says "Let k3b setup make the required changes for cdrecord and cdrdao. The CD Writing group should be cdwriter. You may have to put your user in the cdwriter group using Userdrake. To do that, open a console window and type




hit enter and type in your root password. Then type




and hit enter. Double click the user you want to add to the cdwriter group and click their 'group' tab and highlight cdwriter on the righthand side and click add. If your user is already in the cdwriter group, you won't see cdwriter on the right, but on the left and it is cool. Make sure you click to save the changes before you close userdrake (the floppy icon on the main userdrake window.


Also in k3b setup there is the screen to choose the devices and a place to check that says 'Let k3b edit /etc/fstab' or something like that, that you have to check. If you are not running k3b full screen, it'll be hard to see. At the end, after you click finish, it might say 'Are you sure you want to discard the changes?' make sure you click 'No'.

Link to comment
Share on other sites

AHHHHHHH!!!!!!!!! :evil: (see.....i even used an emoticon!!!) :evil:


ROOT!!!! that's the main part of the puzzle! so, following various instructions, running various commands, running many k3b setups, i'm at this point..........i succesfully unmounted the drives using the fstab entries that Ixthusdan spelled out for me. i ran setup (for the umpteenth time), made the mount points match my fstab, blah, blah, blah. still, nothing was working in k3b when i ran it as user "chris". i followed paul's instuctions to run as root in konsole. WALLA!!! my cdrom drives were listed & usable! :D better yet, i burned the freakin' .iso in no time flat, successfully!!! so, to play some more, for sh*ts & giggles, i re-edited my fstab to reflect supermount. got my working desktop icons back, ran k3b as root, & it still shows my drives & works! soooo...... i can use it currently, even with supermount enabled, only if i run as root in a terminal. i do have "cdwriter" in the userdrake permissions for chris set (per steve's info), but i still can't run k3b & make it work properly as chris. it will only let me run properly as root. and, i did add "chris" to the users at the end of the setup, as cdwriter group. now that i'm 90% there, any suggestions on how to get k3b to function as it should with chris as user, & not only as root? man, this is enough to drive me to drink.......................more!

as always, thanks,


Link to comment
Share on other sites

Set permissions for the group, make sure you are in that group. My users are all in the cdwriter group which was created by k3b.

MCC>System>Userdrake, and edit your user to be a part of this group.

Link to comment
Share on other sites

one final update/comment, before i go to sleep............when i doubt, i rebooted.......(bad Window$ habit, i know). after reboot, k3b now see's my cd drives when i run it as chris, but my recorder is not listed as a recording device. double checked, & yes, chris is listed under the cdwriter group. i even removed chris from cdwriter group, saved, closed userdrake, reopened, added chris to cdwriter group, saved again, & closed. well, at least i'm a h*lluva lot further along then i was 4 hours ago. maybe the Mandrake user Gnomes will stop by when i'm sleeping & make things perfect. sorry to be such a pain, but this is far more of a learning curve then i was expecting. not giving up the ship yet, though.

laters, for now.......


Link to comment
Share on other sites

chris z:

Congrats... you're hanging in there and overcoming the learning curve. It takes some time to change habits. You'll be glad you paid the price to learn though as there are lots of tweaks that you can do yourself.


Also, once Mandrake is setup, it tends to run well without constant naggy BSOD's! :)

Link to comment
Share on other sites

not to beat the proverbial dead horse, but......... i'm so close & yet so far. not being able to use k3b as anything but root bugs me. i was playing around with things before work this morning (went through setup again, re-edited fstab entries again) but it always comes out the same way......my burner & cdrom show under root & i can burn that way, but under chris, only my cdrom is functional. my burner under chris is listed only as "drive" & k3b can't read it. something makes me think it has to do with what was mentioned near the beginning of this saga about scsi emulation, since my cdrom is ide & my burner is scsi.


First, in order to properly use both my cd devices, I had to use scsi emulation. In lilo I added to the "append" section the following: 


hdb=ide-scsi, hdc=ide-scsi 



The ide primary is hda, the slave is hdb, the ide secondary is hdc, and the slave is hdd. The code, then is "hdx=ide-scsi". 


After doing this, k3b should setup with out problems. (Although I edited my /etc/fstab manually, so I'm just guessing!)


if that's the case, could somebody please (again) tell me EXACTLY which line(s) in my fstab (below) to edit & how they should read to do what is described above.


/dev/hdc7 / ext2 defaults 1 1 

none /dev/pts devpts mode=0620 0 0 

/dev/hdc10 /home ext2 defaults 1 2 

none /mnt/cdrom supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0 

none /mnt/cdrom2 supermount dev=/dev/hdb,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0 

none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,sync,codepage=850,umask=0 0 0 

/dev/hdc1 /mnt/win_c vfat iocharset=iso8859-1,codepage=850,umask=0 0 0 

/dev/hdc5 /mnt/win_d vfat iocharset=iso8859-1,codepage=850,umask=0 0 0 

/dev/hdc6 /mnt/win_e vfat iocharset=iso8859-1,codepage=850,umask=0 0 0 

none /proc proc defaults 0 0 

/dev/hdc9 /usr ext3 defaults 1 2 

/dev/hdc8 swap swap defaults 0 0 

/dev/ide/host0/bus0/target1/lun0/cd   /mnt/cdrom2/   auto   ro,noauto,user,exec   0 0 

/dev/scsi/host0/bus0/target0/lun0/cd   /mnt/cdrom/   auto   ro,noauto,user,exec   0 0


i did look at lilo in MCC before i left for work this morning, but i wasn't sure what to append, where to append, & how to append using that.

now that i've giving everyone another headache, i gotta get some work done. thanks to all for putting up with me & helping me through this.


Link to comment
Share on other sites

Launch the gui File Manager in Super User mode. (Previous instructions)

Find the file /etc/lilo.conf and double click on it to open in an editor.



About 15 lines down, as an indented line, you have

append="blah blah"


Here is what mine looks like.

append="devfs=mount hdb=ide-scsi hdc=ide-scsi acpi=off"


Notice the ide-scsi entries. Now before you edit this file, make a copy of it and call it lilo.confback so that if you do something strange to the file, you can restore from backup.


After you save and exit, open a terminal program, su to root, and type "lilo".


Then reboot.

Link to comment
Share on other sites

Q: I cannot select my IDE CDROM as reading device in the cd copy dialog.


A: K3b currently does only support SCSI devices for cd copy. To use your IDE CDROM for reading please enable SCSI emulation.



Ixthusdan is right... the quote above is from the K3b FAQ.


Don't give up on this... I had to fiddle with K3b too and it made a mess out of my /etc/fstab file in the process. But I CAN burn, mount and umount as a regular user! So it will work. It is just a matter of finding what is not set quite right and making the correction. We're here to help you fix that doggy! :wink:

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...