Jump to content

How I Got Wireless Working with ndiswrapper


Recommended Posts

  • Replies 78
  • Created
  • Last Reply

Top Posters In This Topic

arlen, AFAIK it's the pciutils RPM... I'm not at a Linux computer to verify.


In the future, you can do what I did: use rpm.pbone.net to search for "lspci" and see which RPMs come up. Or since we're in Mandrake, you can issue "urpmf lspci" at the CLI which will query the urpmi database for anything containing lspci. Then, "urpmi RPM_NAME" to install. :)

Link to comment
Share on other sites

Guest justyb_1123

Hello everyone!


I just got a RTL8180 chip to work in Mandrake 10.


I noticed that everyone is talking about only being able to enter 10 digits. Well I typed all 26 hex digits of my key in using iwconfig key XXXXXXXXXXXXXXXXXXXXXXXXXX and poof it worked. So the whole thing saying that it only accepts 10 hex digits is a little foobar.


Second I suggest using the source code version of ndiswrapper. I found it to work very well over the packaged ndiswrapper.


Also for some reason wireless-tools is not installed by default (go figure) You'll have to go into the Mandrake Control Center and Install that Package. Should be on CD1 if you wish to do it by hand.


I did not find any of the GUI tools to be at all helpful and sometimes they would go into the config file I just made and overwrite some of the stuff I entered.


Also!!! I almost forgot. You should follow the instructions given to you by the srouce code INSTALL file.


1) make install


then find the INF file and


2) ndiswrapper -i /$THE_PATH_TO_YOUR_INF_FILE/someinf.inf


For some crazy reason (something about how Mandrake implements lspci and it's functions in perl) you can not use ndiswrapper -l (well you can but there is a big mess behind it.) Besides ndiswrapper -l should not do you any good. It just tells you what you can find in /etc/ndiswrapper/


3) modprobe ndiswrapper


check dmesg to see if the device was found


4) iwconfig all of your stuff ESSID and KEY


5) if you are using dhclient then dhclient wlan0




5) ifconfig wlan0 <ipaddress> netmask <somenetmask>


That should allow you to ping the router and then you can setup all of your DNS info and gateway to ping the internet.



Link to comment
Share on other sites

  • 2 weeks later...
Guest jdsharp

I have followed the directions to the letter; however it still does not work.


When I type modprobe ndiswrapper I get:

[root@localhost etc]# modprobe ndiswrapper

Usage: loadndisdriver [-a] [driver]

FATAL: Error running install command for ndiswrapper

[root@localhost etc]#


my modprob.conf file looks like this

alias eth0 e100

alias sound-slot-0 i810_audio

install usb-interface /sbin/modprobe usb-uhci; /bin/true

alias wlan0 ndiswrapper

install ndiswrapper /sbin/modprobe --ignore-install ndiswrapper && { loadndisdriver 14e4:4320 /etc/ndiswrapper/bcmwl5.sys /etc/ndiswrapper/lsbcmnds.inf; }


one other note when I type iwconfig it looks like this

lo no wireless extensions.


eth0 no wireless extensions.


sit0 no wireless extensions.


I don't see the wlan0, but I asume it is because the loadndisriver is erroring.


Thanks for any advise you have.


Jason Sharp

Link to comment
Share on other sites

Guest thisuks

I've been dealing with MandrakeLinux all week using the same card Belkin F5D-7010 as the OP. No luck and very, very frustrating. Anybody care to spoon-feed a Linux-noob or should I just keep paying Mr. Gates and at least I will be able to use my hardware?


It's a shame the instructions don't inlcude the correct syntax (as I can understand the syntax via a text file) because I've tried every single syntax possibility in the OP and I'm obviously missing a MAJOR STEP. C'mon, aty least point some of the Winbloze peeps to a basic tutorial about Unix commands. Yes, I found the FAQ and that did help a bunch but after 20+ hrs. I've just about had enough of Mandrake/Knoppix and all of this BS...


'Sorry for the venting but please understand that I'm TRYING very hard and that sucks if you try so hard and fail because of something very simple...

Link to comment
Share on other sites

  • 2 weeks later...

I too have had a lot of trouble getting ndiswrapper working with my Belkin F5D7000uk PCI card.


If this helps I had the same problem when running IWCONFIG - no wlan0 showing up.


After much trial and error I discovered it was because of the way I had referenced the bcmwl5.inf file (my card driver).


I'd simply pointed ndiswrapper at /mnt/win_c/inf/bcmwl5.inf which didn't work. However I've found that by taking a copy of the bcmwl5.inf file, and the two associated driver files on the Belkin cd (namely: bcm43xx.cat and bcmwl5.sys) and moving them to the /driver folder under the folder I unpacked ndiswrapper to, the driver is now working.


You'll have to use:


ndiswrapper -e bcmwl5.inf


or similar to remove the driver before you point ndiswrapper in the right direction.


I'm not out of the woods yet though. I can set the essid, key and ip address of the card using iwconfig and ifconfig respectively - however I seem unable to ping the router!


Any ideas where I might be going wrong? There must be something I've missed but I'm at a loss to see what I need to do to get the card talking to my router. I'm starting to feel like THISUKS. I'm a newbie to Linux though have years of experience in computing but I find the material available on actually getting Linux up and running extremely esoteric in nature. A few pointers to websites that give guidelines on getting things like network cards and graphics cards working under Linux that don't assume a significant amout of tacit knowledge would be much appreciated.



Link to comment
Share on other sites

Hooray! My first post under Linux.


Have finally got the Belkin wireless card going (and it's quick!).


It's a bit weird really. After hours upon hours with no luck (after getting wlan0 recognised a few days ago) connecting to my router I discovered the problem could be fixed through Linux's Firewall setting. I don't know about anyone else but I chose the minimum security settings when installing 10.0 but did opt for the firewall. If you can get wlan0 recognised but can't see your network I suggest you try the following:


In X under System/Configuration/configure your computer

choose 'Security'

then 'Firewall'

Choose whatever you like settings wise (try 'No Firewall' To begin with to make sure - you can always go back later) then click OK.

You are here asked what 'Net Device' you use to connect to the internet. In the drop down you should see 'wlan0:'. Select this. Now your Wireless connection works! (hopefully for you - it did for me).


My /etc/sysconfig/network-scripts/ifcfg-wlan0 file is as follows (in case this helps):














Link to comment
Share on other sites

For a static IP make ifcfg-wlan0 like:

















Obviously alter your IPADDR as you see fit. Hope this helps some peeps.





Link to comment
Share on other sites

  • 1 month later...

Hello evrybody,

at first: thx beesea for your Howto


now my prob :mr-green:


I followed your instructions and filled the parameters for loadndisdriver.

It started an showed:

Calling putdriver ioctl

Parsing the inf file.

Dirver version: 07/09/2004, 5.170.0709.2004

Calling startdriver ioctl

Segmentation fault <--- there it stops :unsure:


my WLancard is a Netgear MA521 with the RTL 8180 Chipset.

The first time I tried to load the normal MA521 driver, after the fault I used the Chipset driver directly from Realtek. (Always the WinXP/2K versions)


always the same fault.

hope you can help me, but one thing: I'm a real noob in Linux, so plz show mercy :D




Link to comment
Share on other sites

I found I have to put another semi column between the sys driver and the inf file in the modprobe config:


alias wlan0 ndiswrapper
install ndiswrapper /sbin/modprobe --ignore-install ndiswrapper && { loadndisdriver 14e4 4320 /etc/ndiswrapper/bcmwl5.sys; /etc/ndiswrapper/bcmwl5.inf; }


Everthying else work nice, however I have one issue, my wireless AP is running WPA, and i did get the wpa_supplicant working with ndiswrapper, however I have to do this all the time:


dhclient wlan0 & wpa_supplicant -Dndiswrapper -iwlan0 -c/etc/wpa_supplicant.conf -Bw


Does any one know how to have this line run automatically after the ndiswrapper module is loaded?





Link to comment
Share on other sites

:thumbs: Thanks a million, beesea. Excellent, clear instructions, even for a Linux newbie like me.


Followed your instructions, and I am now wireless with my own WMP54G card. It took me about 90 minutes, but that was mainly because I can't count the number of leading '0's when entering a WEP key. {*slaps head*}


A couple of clarifications, based on my experience and questions in the rest of the thread:


1. I did need to run the commands given as root (Post #10 in this thread).

2. I didn't appear to need the colon between the two 4-digit hex numbers in the modprobe.conf configuration file changes (apparently contrary to Post #13).

3. I did need to change the internet connection on the firewall as I was already up and running with a wired connection (Post #23).


Another item which would have saved me some time: restarting the network after changing the settings does not require a complete reboot (I m still "thinking Windows" aren't I?) but can be achieved using "/etc/init.d/network restart" instead, as described in this thread.

Edited by sellis
Link to comment
Share on other sites

  • 3 weeks later...

Hey everything.


I just happen to find this website and decided to upgrade my 10.0 mandrake installation to 10.1 community.


Upgrade went for a long time, urpmi --auto-select did the work and everything looks upgraded.


Now i tried to use the guide in this post to setup the Intel Wireless Adapter and ran in trouble.


No matter what i do, its not working out. Output from dmesg confirms that ndiswrapper is loaded


ndiswrapper version 0.4 loaded


Here is the error part:


iwconfig wlan0 mode Managed

Error for wireless request "Set Mode" (8B06) :

SET failed on device wlan0 ; No such device.


Please help. This is a IBM R50 series laptop. If you need any details please let me know i will post them here.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...