Jump to content
beesea

How I Got Wireless Working with ndiswrapper

Recommended Posts

Whoops! It's on the fritz again.

 

The network connection doesn't stay up more than a few hours.If I run iwconfig, it reports millions (literally) of "Invalid misc" packets. The SSID, router address and WEP key are still reported correctly.

 

At first I thought it might be the router - there are some reports of instability with the WRT54G - but rebooting that didn't do the trick. I thought it might be a problem with getting a new DHCP lease from my cable provider (NTL), but even connecting to the router doesn't work. Running service network restart doesn't clear it, although a complete computer restart does.

 

Now, doing a restart every day is not something I want to have to do! Apart from the inconvenience, I wish to impress my Windows-using friends with tales of 100's of days of uptime, as properly befits a Linux system. It also annoys my wife, who just wants to browse the web.

 

So, once again, any ideas?

Edited by sellis

Share this post


Link to post
Share on other sites
Guest avimd
Thanks for posting this! Very nice! I hope my household shipment arrives soon and I can get my desktop up and running using this.  :D

 

i have ibm r50 with intel wireless 2200 bg

also mdk 10.1

 

do you think that this procedure you are writing about will work for me?

thx

Share this post


Link to post
Share on other sites
i have ibm r50 with intel  wireless 2200 bg

also mdk 10.1

 

do you think that this procedure you are writing about will work for me?

thx

 

I have a r50 as well. I did a scratch install on 10.1 CE and the wireless worked out of the box. It used ipw2100 driver though.

Share this post


Link to post
Share on other sites
anand, I am trying to get my IWP2200 working, where did you copy the firmware? For som reason the firmware will not load.

 

Sorry never saw this message earlier.

 

Anyways what i got running was from a clean 10.1 CE. It like 10.0 Official recognised the wireless and showed ipw2100 module, however i could never got it running in 10.0. When i got 10.1 CE, a clean install and fiddling around with the wireless (nothing much, just that the wireless won't come up on boot up automatically and stuff) i got it running.

 

Though i have a very strange problem, when i shutdown the laptop, the wireless is still ON :furious3: I have to keep the power button pressed in order to shut it down. I can't figure how to shutdown wireless on shutdown.

Share this post


Link to post
Share on other sites

wireless config

 

That was a link that i found incredibly useful as far as installing wireless. I got the source tarball at sourceforge. It works like a champ everytime.

 

I too had to install the wireless tools. I then wrote a little script (which i run as root) that brings down eth0 brings up the wlan0 and then pulls an ip after setting essid, channel. i don't set those in my ifcfg-wlan0 file since i roam to different networks.

 

i got this working on both my dwl-650 (which is a realtek 8180) and my wife's broadcom wireless (94306 or something like this) on her dell.

 

ifup is your friend. :-)

Share this post


Link to post
Share on other sites

oh yeah, one other thing. one problem i had was getting outside the firewall. if you go to /etc/shorewall and then i think the interfaces file, you then change local next to wlan0 to network (or whatever it is that eth0 is set to). then your firewall stays up and you can still get around.

Share this post


Link to post
Share on other sites
Guest pkibbey

I feel like I am almost there, but have not quite managed to get this WPM54G card working.

 

I have managed to get ndiswrapper working, with wireless tools installed, the drivers have loaded successfuly, wlan0 is detected, I can see my wireless router with iwlist, I can set all parameters with iwconfig, but what I can't do is set the ESSID and actually connect to the wireless router.

 

Has anyone else been stuck with this problem and found a way past it? I would really appreciate some help.

Share this post


Link to post
Share on other sites
but what I can't do is set the ESSID and actually connect to the wireless router.

 

To set essid

 

iwconfig wlan0 essid "youressid"

 

I have more problem cause the latest 10.1 have loaded the beta acx111 native driver from the acx100/111 sourceforge project, and I think it cause conflict with ndiswrapper.

 

I am using NETGEAR WG311V2, I have setup ndiswrapper fine, but the iwconfig doesn't take any of the pramameter I setup.

Edited by stevenyu

Share this post


Link to post
Share on other sites

i had to install the wireless tools for it to work. if i don't know the name of software that i want to load, the gurpmi interface is really great about searching using the documentation for rpms. it'll always find what you're looking for. just do the wireless search.

Share this post


Link to post
Share on other sites
i had to install the wireless tools for it to work.  if i don't know the name of software that i want to load, the gurpmi interface is really great about searching using the documentation for rpms.  it'll always find what you're looking for.  just do the wireless search.

 

i'm having the same issues as many people on here - so much for 10.1 working for wireless "out of the box".

 

i've got the IPW2200 intel wireless - the kernel that comes with mdk 10.1 has an ipw2200 drivers built in as a module.

 

anyway - i'm at the ndiswrapper stage where doing ndiswrapper -l shows my driver installed -

w22n51 driver present, hardware present

 

so far so good.

however, when i load the driver with

/sbin/modprobe ndiswrapper , dmesg reports :

 

ipw2200: ipw2200_boot.fw load failed

ipw2200: Unable to load firmware : 0XFFFFFFFE

ipw2200: No space for Tx

ipw2200: failed to send SCAN_REQUEST_EXT command

 

dmesg DOES report that ndiswrapper has loaded ok

 

ndiswrapper: driver w22n51 (intel.... blah blah ) added

Share this post


Link to post
Share on other sites

I have just roll back to MDK 10.0 and still having the iwconfig not taking my configuration problem, I think the problem might not be in the MDK10.1 but in the latest 0.12 build of ndiswrapper it self :cheeky:

Share this post


Link to post
Share on other sites
I have just roll back to MDK 10.0 and still having the iwconfig not taking my configuration problem, I think the problem might not be in the MDK10.1 but in the latest 0.12 build of ndiswrapper it self  :cheeky:

 

i've got everything working via ndiswrapper right now - everything except a network connection.

 

no errors in dmesg, iwconfig and ifup wlan0 (static ip) are fine - even the wireless light on the front of my hp nx9030 laptop lights up.

 

the only thing i can think of is that my wireless base station is one of those 2 aerial belkin 802.11b thing, 11Mb/s rate, connected via rj45 network cable to my hub.

 

the ipw2200 is a 802.11G card - 54Mb/s rate.

 

i'm totally at a loss now as to what to do next , as i'm getting NO errors at all dmesg or anywhere else.

Share this post


Link to post
Share on other sites
Guest c0mm0n

Hi,

 

Just my 2cents with a method i've successfully used with my dell truemobile 1300 with mdk 10.1 Official. I assume you know a bit how ndiswrapper works and what's required (.inf and .sys files)

 

- installed mdk with default options

- went to software installation and asked for ndiswrapper, 0.9.1 is offered install it.

- in the .inf file folder "ndiswrapper -i xxxx.inf" (for me it's bcmwl5.inf)

- then "ndiswrapper -l" to check it's installed and that "hardware present" is mentionned

- "modprobe ndiswrapper" for ndiswrapper to be effective

- "ifconfig wlan0 up" to bring up the wlan interface

- then i don't go crazy with commnd lines to setup my wifi and just head to control center/hardware/network cards ; there you should now see your wireless card, just click the "launch config wizard" button and follow all the steps ; the only things i've mentionned are : ssid, wep key, dhcp server IP all other options were left as they were.

- at the end network interface is restarted, and everything is working fine!

- as i want this to be permanent, i finish with 'ndiswrapper -m"

 

That's all, my wifi is brought up each time i boot, when i go away from home i can easily change my wifi settings with the same wizard described above!

 

i've used this method more than 10times (i reinstalled mdk a lot as a noob i am killed things and couldn't revert to working envrionnment):D

 

I'd been totaly crazy with the wifi setup for months and was about to change the wifi card to be able to discover linux (i can't use ethernet at home, too painful in my flat), my mdk is in french so don't be surprised if u don't exactly have the menu i say but you should find them easily!

 

Hope this can help :)

Edited by c0mm0n

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...