Jump to content

the screen resolution refuses to change


Recommended Posts


after i installed mdv 2009.0 i configured the screen resolution to 1024*768 to fit my monitor

but suddenly i found the screen resolution converted to 800*600 , so i tried to get it back but i couldn't

i'v a nvidia 5200 vga card and compiz, they all working will

but how can i get my screen resolution back ?

any help will be appreciated..



[moved from Software by spinynorman]

Edited by tux_man
Link to comment
Share on other sites

Where did you change the resolution? It should be changed in the Mandriva control centre>hardware>set up the graphical server>resolution, you should also select your monitor in Monitor, if your specific monitor isn't there then choose something under Generic that matches the resolution and refresh rate you want.


What's the output of this in terminal:


Link to comment
Share on other sites

this is the output of the command "monitor-edid"

[root@localhost hossam]# monitor -edid

bash: monitor: command not found

[root@localhost hossam]# monitor-edid

Name: CPD-200EST


Screen size: 33.0 cm x 24.0 cm (16.06 inches, aspect ratio 4/3 or 3/2 = 1.38)

Gamma: 2.5

Analog signal


HorizSync 30-70

VertRefresh 50-120


# Monitor preferred modeline (60.0 Hz vsync, 31.5 kHz hsync, ratio 4/3, 49 dpi)

ModeLine "640x480" 25.18 640 656 752 800 480 490 492 525 -hsync -vsync

Link to comment
Share on other sites

this is the output of the xorg.conf file

# File generated by XFdrake (rev 247269)


# **********************************************************************

# Refer to the xorg.conf man page for details about the format of

# this file.

# **********************************************************************


Section "ServerFlags"

#DontZap # disable <Ctrl><Alt><BS> (server abort)

AllowMouseOpenFail # allows the server to start up even if the mouse does not work

#DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)



Section "Module"

Disable "dri"

Load "dbe" # Double-Buffering Extension

Load "v4l" # Video for Linux

Load "extmod"

Load "type1"

Load "freetype"

Load "glx" # 3D layer



Section "InputDevice"

Identifier "Keyboard1"

Driver "kbd"

Option "XkbModel" "pc105"

Option "XkbLayout" "us,ara(digits)"

Option "XkbOptions" "grp:alt_shift_toggle,grp_led:scroll,compose:rwin"



Section "InputDevice"

Identifier "Mouse1"

Driver "mouse"

Option "Protocol" "ExplorerPS/2"

Option "Device" "/dev/mouse"



Section "Monitor"

Identifier "monitor1"

VendorName "Plug'n Play"

ModelName "CPD-200EST"

HorizSync 30-70

VertRefresh 50-120

Option "PreferredMode" "1024x768"


# TV fullscreen mode or DVD fullscreen output.

# 768x576 @ 79 Hz, 50 kHz hsync

ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630


# 768x576 @ 100 Hz, 61.6 kHz hsync

ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616



Section "Device"

Identifier "device1"

VendorName "nVidia Corporation"

BoardName "NVIDIA GeForce FX series"

Driver "nvidia"

Option "DPMS"

Option "TwinViewOrientation" "Clone"

Option "ModeValidation" "NoWidthAlignmentCheck, NoDFPNativeResolutionCheck"

Option "AddARGBGLXVisuals"

Option "ExactModeTimingsDVI"

Option "TwinView"



Section "Screen"

Identifier "screen1"

Device "device1"

Monitor "monitor1"

DefaultColorDepth 24


Subsection "Display"

Depth 8

Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"



Subsection "Display"

Depth 15

Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"



Subsection "Display"

Depth 16

Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"



Subsection "Display"

Depth 24

Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"




Section "ServerLayout"

Identifier "layout1"

InputDevice "Keyboard1" "CoreKeyboard"

InputDevice "Mouse1" "CorePointer"

Screen "screen1"


Link to comment
Share on other sites

A suggestion is bruteforcing the resolution:


Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"


Replace all those lines in xorg.conf with


Modes "1024x768"


But indeed, either "nvidia-settings" as root or the DE's RANDR manager should amount to the same thing.

Link to comment
Share on other sites

thank you all , but after i ran the nvidai-setteng this message appeared to me

"You do not appear to be using the NVIDIA X driver. Please edit your X configuration file (just run `nvidia-xconfig` as root), and restart the X server. "

so i ran the command nvidia-xconfig

so i got the login window in the required resolution but after i looged in the resolution get back t :wall: o 800*600 again

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...