Jump to content
Sign in to follow this  
Guest mahiles

Why do I bother?!

Recommended Posts

What mb do you have, or what is the computer name and model, or what bios do you have? (the last is the least helpful since bios programs are written for a mb or a brand) Post this info, and I'll look up specifically where to go in the bios setup.

 

com1 is usually reserved for on board modems. com2 is usually the port on the back of the pc. com3 is a variation of com1, and com4 is a variation of com2. I have boards that even have a spot to set which com port for the modem. If you have a serial mouse, then com2 could be reserved for the mouse, but ps/2 removes that issue.

 

Note: since your modem is listed as com3, that means windex is using the com1 varient to load the modem. I am beginning to suspect (which I have really all along) that your problem is related to com port configuration.

Share this post


Link to post
Share on other sites

If it helps to sooth this fustration, I just checked my "unknowns" and found my USB harddrive was listed there and I have been using this for months with no troubles. I am guessing then that your modem just isn't hooked up to the right port yet and not communicating with your OS. Maybe it wants com 1 or 2 then... Nothing hooked up to them (they are unused by anything in Linux, right? I would wait on a second opinion on this idea first before making anything worse.

 

I suggested drakxtools-9.1-31.2mdk.i586.rpm because it contains drakconnect for modems.

 

added: I see BVC seconded this as I was responding (thanks BVC :) )

Share this post


Link to post
Share on other sites

Could also look through /proc with ls and cat

[root@localhost /]# ls /proc

1     2659  2823  2977  3023  7        execdomains  ksyms       pci

10    2695  2824  2990  3026  73       fb           loadavg     self

11    2707  2825  2995  3334  8        filesystems  locks       slabinfo

15    2717  2826  2997  3473  9        fs           mdstat      stat

1901  2726  2878  2999  3514  apm      ide          meminfo     swaps

2     2737  2879  3     3515  bus      interrupts   misc        sys

2073  2794  2901  3001  3516  cmdline  iomem        modules     sysvipc

2092  2812  2961  3013  3532  cpuinfo  ioports      mounts      tty

2098  2820  2964  3016  4     devices  irq          mtrr        uptime

2637  2821  2973  3019  5     dma      kcore        net         version

2641  2822  2975  3021  6     driver   kmsg         partitions

[root@localhost /]# ls /proc/tty

driver  drivers  ldisc  ldiscs

[root@localhost /]# ls /proc/tty/driver

serial

[root@localhost /]# cat /proc/tty/driver/serial

serinfo:1.0 driver:5.05c revision:2001-07-08

0: uart:16550A port:3F8 irq:4 baud:115200 tx:166873 rx:674044 oe:4 RTS|CTS|DTR|DSR|CD

[root@localhost /]#

There's is also a irq and pci in /proc. Tons of info and stuff from the kernel!

Share this post


Link to post
Share on other sites

usb devices are not shown in the bios because they are not kown until they are active. But, the bios does list your usb port settings, which is the potential hardware locations. If the usb settings are not listed in the bios, your usb ports will not work! :wink:

 

And, yes, Scoopy, I suspect that it wants com1, since there is no onboard modem.

Share this post


Link to post
Share on other sites

No, it is not a usb modem. I was going off topic responding to Scoopy's observations about his usb hard drive. :oops:

Share this post


Link to post
Share on other sites
Guest mahiles

Ok I'm getting slightly lost in these posts guys!! lol

 

I don't understand that setserial or whatever it is :? n00bie has no brain

 

My motherboard is a Jetway V266B..

Share this post


Link to post
Share on other sites
Guest mahiles

Just been into Mandrake and when I tell kppp to use COM1 or COM2 it says "The Modem Does Not Respond".. Forgive me if I mis understood but I tried it anyway!

Share this post


Link to post
Share on other sites

setserial is an app. To see if you have it installed, open a terminal (konsole,xterm,rxvt,aterm,Eterm etc...) and su to root

 

su <hit Enter>

enter_roots_password <hit Enter>

 

and type

rpm -q setserial <hit Enter>

 

looks like this

[root@localhost /]# rpm -q setserial

setserial-2.17-12

[root@localhost /]#

If it is not installed, do;

urpmi setserial <hit Enter>

 

then do

setserial -ga /dev/ttySx <hit Enter>

from ttyS0 through ttyS4 til setserial shows a value for UART:

 

My modem is on ttyS0 not ttyS1

[root@localhost /]# setserial -ga /dev/ttyS0

/dev/ttyS0, Line 0, UART: 16550A, Port: 0x03f8, IRQ: 4

       Baud_base: 115200, close_delay: 50, divisor: 0

       closing_wait: 3000

       Flags: spd_normal skip_test



[root@localhost /]# setserial -ga /dev/ttyS1

/dev/ttyS1, Line 1, UART: unknown, Port: 0x02f8, IRQ: 3

       Baud_base: 115200, close_delay: 50, divisor: 0

       closing_wait: 3000

       Flags: spd_normal skip_test

 

I know it is frustrating, but don't give up!

Share this post


Link to post
Share on other sites
Guest mahiles

[root@localhost root]# setserial -ga /dev/ttyS0

/dev/ttyS0, Line 0, UART: 16550A, Port: 0x03f8, IRQ: 4

Baud_base: 115200, close_delay: 50, divisor: 0

closing_wait: 3000

Flags: spd_normal skip_test

 

[root@localhost root]# setserial -ga /dev/ttyS1

/dev/ttyS1, Line 1, UART: 16550A, Port: 0x02f8, IRQ: 3

Baud_base: 115200, close_delay: 50, divisor: 0

closing_wait: 3000

Flags: spd_normal skip_test

 

[root@localhost root]# setserial -ga /dev/ttyS2

/dev/ttyS2: No such file or directory

[root@localhost root]# setserial -ga /dev/ttyS3

/dev/ttyS3: No such file or directory

[root@localhost root]#

 

 

Hope that helps someone 'cos I ain't a clue! :oops:

Share this post


Link to post
Share on other sites

bvc is abba-solutely right - it is frustrating as a newbie, and he's right about not giving up. But to say you have no brain?! CRAM IT mister! You are just new to it, that's all - you should watch my mom try to "surf the net" in windows!!

 

Ah UART: (Universal Asynchronous Receiver/Transmitter) the joys

 

I'd try

 

ln -s /dev/ttyS0 /dev/modem

 

then point kppp to /dev/modem and give it a shot. (Technically /dev/ttyS0 would work too, but lots of apps use the obvious link like /dev/modem or /dev/cdrom and they let the OS install worry about where the link points, like /dev/cdrom is actually /dev/bus/0/target/0 or something but could be different for other hardware setups...)

Share this post


Link to post
Share on other sites

sorry bout the previous confusion :oops:

 

"The Modem Does Not Respond" sounds a lot better than "not found."

 

Hang in there, and follow previous two suggestions. I think your close.

Share this post


Link to post
Share on other sites
Guest mahiles

I tried static's suggestions, tried dialing the internet using kppp and recieved the following:

 

"The Modem Does Not Respond"

Share this post


Link to post
Share on other sites

Well, you've got something at ttyS0 and S1.....do you have 2 modems installed?

 

First thing is to try as root just to see. From a terminal su to root and do;

kppp <hit Enter>

 

 

 

The next thing to try from a terminal is;

 

re -f /dev/modem <hit Enter>

ln -s /dev/ttyS1 /dev/modem <hit Enter>

 

and try kpp as root again

Share this post


Link to post
Share on other sites

I'm reading your manual. First, make sure your modem is not in the 1st or 5th pci slot. Those slots are shared with the agp and cnr slots, respectively. It can cause hazards with irq's.

 

In your bios, goto Onboard Super IO Function>Onboard Serial Port 1>disable

Same place, Onboard Serial Port 2>2E8/IRQ3

 

Next goto PNP/PCI Configuration Setup>Resources Controlled by>Manual

 

Then,goto IRQ Resources>press enter

Make all your irq's lables for pci devices.

 

Last, goto Power Management setup

Look for Modem use---and make it irq 4

 

Save, exit, and see what happens. :mystismiles:

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...