Jump to content
Sign in to follow this  
DaveinSpain

More samba problems

Recommended Posts

I am sure I am missing something fundamental and glaringly obvious, but here goes.

 

I have 2 machines, core 2 duo 1.8GHz, 2GB Ram, 300GB HDD, with Windows Vista Home Premium and Mandriva 2008 (Free), the other with a PIII, 866Mhz, 256MB, 30GB HDD with Windows XP and Linux 2007.1 Spring (free). The two windows systems talk to each other without any problems and the linux systems can access the windows files on their local machines. Here are the problems I have.

 

1. 2008 cannot find any Windows system installed when I try to use the porting tool provided in MCC in 2008.

2. Neither linux system can find the other nor the remote windows system.

3. Neither Windows system can find any linux system, remote or local

4. Boot messages say "Starting lisa.....[OK], but when I try to access the network from linux I get an alert that lisa is not running

5. When I try to install a network printer using cups, the system freezes at the "searching for new printers" stage and needs a hard reset.

 

I have ensured that the host names match (/downstairs/ and /upstairs/ in both windows and linux)

I have tried to configure it with both the KDE tool and MCC with notable lack of success.

The shares are set up on both Windows systems.

I have installed ntfs-3g

 

The configuration tools report 2 network interfaces on each machine, labeled as lo and eth0. I only have one physical interface on each machine so presumably lo is a virtual device, unless it refers to the network switch that both machines connect to each other and the Internet through. I am totally confused here.

 

Also irritating (an admittedly off topic here) is that the graphical boot does not work on the PII machine, despite all the configurations looking correct. Not really important but suggestions here appreciated as well.

 

All comments, suggestions and help, as always, much appreciated.

 

Dave

Edited by DaveinSpain

Share this post


Link to post
Share on other sites

Have you got the samba packages installed on the Linux systems? Also, you can check/test samba connectivity by opening nautilus (gnome) or konqueror (kde) and typing:

 

smb://

 

you should then be presented with a list of workgroups/domains detected on your network. Normally, you will need samba-common and samba-client if you wish to connect to a Windows machine, so:

 

rpm -qa | grep -i samba

 

will show you what samba packages you've got installed on your machines. No results, and you're missing the key components to get you going for connecting to Windows shares.

 

lisa is just a daemon providing information in relation to connections available across the network - like Network Neighbourhood in Windows. Therefore, lisa on it's own won't do anything for you without the additional packages for samba, nfs, etc, etc in terms of displaying what it detected.

Share this post


Link to post
Share on other sites

Have you got the samba packages installed on the Linux systems? Also, you can check/test samba connectivity by opening nautilus (gnome) or konqueror (kde) and typing:

 

smb://

 

This gives me the result "Malformed URL smb://:"

 

However, smb:\\ gives me the result "Timeout on server" It also shows the Windows icon in the location bar

 

This is the same on both machines.

 

 

rpm -qa | grep -i samba

 

Reports:

samba-client-3.0.25b-4.4mdv2008.0

samba-server-3.0.25b-4.4mdv2008.0

samba-common-3.0.25b-4.4mdv2008.0

 

and

 

samba-client-3.0.24-2mdv2007.1

samba-server-3.0.24-2mdv2007.1

samba-common-3.0.24-2mdv2007.1

 

On the respective systems.

 

So it looks as if all the relevant samba packages are installed. (I thought they were as it was the first thing on my checklist when I started)

 

Here are some other configuration settings I have:

 

Only samba (NFS not enabled)

Shared folders:

/var/lib/samba/printers/

/var/spool/samba/

/var/tmp/

+ 2 Users and guest account Documents directories (Guest account necessary for business)

 

On the 2007.1 system, using KDE Control centre, users entered into the Users section in Samba do not "stick", ie when the Users section is viewed after leaving and re-entering the module, all entries have been deleted. This does not happen on the 2008 system. Security level is set to Share on both systems. Default host is set as /downstairs/, workgroup as mdkgroup

 

I have been revisiting this setup for several weeks and still have no idea as to why it doesn't work. I know it can work or the Windows one wouldn't and that is even more frustrating.

Share this post


Link to post
Share on other sites

If I had £1 for every time I have read a post like this I would be able to buy out Microsoft and release it as Open Source.

 

The annoying thing is that I know Samba does not have to be so difficult. About 18 months ago I got hold of a copy of Xandros Open Source Edition and it was mind boggling. Networking just worked straight away without any configuration or effort. Now if they can do it why can't anybody else? And it is definitely not just a problem with Mandriva, every distro I have ever used (except Xandros) is the same. Having said that I don't want you to rush out and download the first copy of Xandros OSE that you find because I definitely do not recommend it. The OSE edition is nothing but a giant advert for the paid for version and is the most blatantly commercial distro I have ever seen (I include Windows in that). When I was using it they even expected you to pay money to install free products such as Amarok and K3b, and although I ran it for about 6 months I never received one update, security or otherwise from the OSE repository. So unless you want to pay for the full version (which I am sure would be good) stay clear.

 

Anyway back to your problem. The only way I can connect to computers on my network with Mandriva is to use ip addresses. So run ipconfig on windows and ifconfig on Linux to find your IP addresses and then try to connect by opening a file manager and typing:

 

smb://192.168.1.100

 

or whatever your ip address is.

 

The other classic issue with this is firewalls, but I am sure you will have thought of that. In case you haven't, unplug your telephone line then disable all installed firewalls and try again.

Share this post


Link to post
Share on other sites

Windows will access Linux files only if samba server is running and properly configured.

Linux clients should access windows shares without samba configuration via the KDE virtual filesystem ( smb:/ at a konqueror/krusader address line), unless the windows firewall is preventing access to the files. You can also use a small fuse module named smbnetfs, which is automounting the windows shares at logon to the Linux box, and it's desktop-unspecific (= can be used under KDE, Gnome, XFCE4, E17 or any other Linux desktop).

Share this post


Link to post
Share on other sites

Thanks for your input. Result of ifconfig is:

eth0 Link encap:Ethernet HWaddr 00:19:21:78:34:51

inet addr:78.136.120.20 Bcast:78.136.120.255 Mask:255.255.255.0

inet6 addr: fe80::219:21ff:fe78:3451/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:178228 errors:0 dropped:0 overruns:0 frame:0

TX packets:48785 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:68098096 (64.9 MiB) TX bytes:5888725 (5.6 MiB)

Interrupt:17

 

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:60948 errors:0 dropped:0 overruns:0 frame:0

TX packets:60948 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:10124600 (9.6 MiB) TX bytes:10124600 (9.6 MiB)

 

Result of

 

smb://192.168.1.100

using these addresses on the 2008 machine is:

 

[root@localhost ~]# smb://78.136.120.20

bash: smb://78.136.120.20: No such file or directory

[root@localhost ~]# smb://78.136.120.20

bash: smb://78.136.120.20: No such file or directory

[root@localhost ~]# smb://78.136.120.255

bash: smb://78.136.120.255: No such file or directory

[root@localhost ~]# smb://255.255.255.0

bash: smb://255.255.255.0: No such file or directory

[root@localhost ~]# smb://127.0.0.1

bash: smb://127.0.0.1: No such file or directory

[root@localhost ~]# smb://255.0.0.0

bash: smb://255.0.0.0: No such file or directory

 

As I said, I am probably missing something fundamental and glaringly obvious (but not to me!)

I disable the firewall every time I start a new configuration attempt and both machines were running linux when I did this.

Edited by DaveinSpain

Share this post


Link to post
Share on other sites

Thank you for taking the time to answer.

 

Windows will access Linux files only if samba server is running and properly configured.

Linux clients should access windows shares without samba configuration via the KDE virtual filesystem ( smb:/ at a konqueror/krusader address line)

 

This gives me the message:

 

Unable to find any workgroups in your local network. This might be caused by an enabled firewall.

 

With all firewalls disabled.

 

What is a "fuse module", please?

Share this post


Link to post
Share on other sites

fuse module is for ntfs-3g and won't be your samba problem. Did you configure samba on the Linux machines and put them in the same workgroup/domain as the other Windows machines? Normally though, you should be able to browse shares but for some reason your system can't see anything maybe being blocked by firewall.

 

Can you post the results of this from both Linux machines, and also ensure that Windows doesn't have a firewall enabled on it's network connections.

 

chkconfig --list | grep -i :on

 

then we'll see what services are enabled in Windows and running, maybe seeing iptables or shorewall somewhere in this list or even mandi-ifw.

Share this post


Link to post
Share on other sites

[root@localhost ~]# smb://78.136.120.20

 

This won't work, of course. The smb virtual filesystem is accessible only via a KDE application, not the bash shell.

(and you should not try such operations as root).

Simply try again

smb://78.136.120.20

in the konqueror address bar, or the krusader one- not bash/konsole.

@ ian1974:

ntfs-3g is just one fuse module out of many. I was talking above about smbnetfs, which is a very easy way to access windows/samba shares as local files.

Share this post


Link to post
Share on other sites

I know, but Dave asked about what is fuse. That is why I answered ;)

Share this post


Link to post
Share on other sites
[root@localhost ~]# smb://78.136.120.20

 

This won't work, of course. The smb virtual filesystem is accessible only via a KDE application, not the bash shell.

(and you should not try such operations as root).

Simply try again

smb://78.136.120.20

in the konqueror address bar, or the krusader one- not bash/konsole.

@ ian1974:

ntfs-3g is just one fuse module out of many. I was talking above about smbnetfs, which is a very easy way to access windows/samba shares as local files.

Sorry, I assumed that anything displayed as "code" went into a cli. I did try it in konqueror anyway and all it brought up were the linux files on the local machine. This did also give me a route to the local windows directories but I had that anyway.

Share this post


Link to post
Share on other sites

Can you post the results of this from both Linux machines, and also ensure that Windows doesn't have a firewall enabled on it's network connections.

 

chkconfig --list | grep -i :on

 

then we'll see what services are enabled in Windows and running, maybe seeing iptables or shorewall somewhere in this list or even mandi-ifw.

 

OK, here is the output and my observations. The problem with disabling firewalls is that my setup gives both machines direct access to the internet via a switchbox . This connects to a telephony modem which also gives me my telephone service via a microwave link to my ISP (no wires here in rural Spain). The same connections via ethernet ports also allow the lan, so opening the physical local network port also gives access to the internet. I notice both machines show a second virtual interface (lo) but have no idea how this works. With Windows I just had to set up the shares and it was up and running, even the printer.

 

This is from the Downstairs machine

 

acpi 0:off 1:off 2:on 3:on 4:on 5:on 6:off

acpid 0:off 1:off 2:off 3:on 4:on 5:on 6:off

alsa 0:off 1:off 2:on 3:on 4:on 5:on 6:off

atd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

avahi-daemon 0:off 1:off 2:off 3:on 4:off 5:on 6:off

consolekit 0:off 1:off 2:on 3:on 4:on 5:on 6:off

crond 0:off 1:off 2:on 3:on 4:on 5:on 6:off

cups 0:off 1:off 2:on 3:on 4:on 5:on 6:off

dkms 0:off 1:off 2:off 3:on 4:on 5:on 6:off

dm 0:off 1:off 2:off 3:off 4:off 5:on 6:off

fuse 0:off 1:off 2:off 3:on 4:on 5:on 6:off

haldaemon 0:off 1:off 2:off 3:on 4:on 5:on 6:off

harddrake 0:off 1:off 2:off 3:on 4:on 5:on 6:off

hcfpci 0:off 1:off 2:on 3:on 4:on 5:on 6:off

hsf 0:off 1:off 2:on 3:on 4:on 5:on 6:off

httpd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

iptables 0:off 1:off 2:on 3:on 4:on 5:on 6:off

keytable 0:off 1:off 2:on 3:on 4:on 5:on 6:off

kheader 0:off 1:off 2:on 3:on 4:off 5:on 6:off

mandi 0:off 1:off 2:on 3:on 4:on 5:on 6:off

mdadm 0:off 1:off 2:on 3:on 4:on 5:on 6:off

messagebus 0:off 1:off 2:on 3:on 4:on 5:on 6:off

netfs 0:off 1:off 2:off 3:on 4:on 5:on 6:off

network 0:off 1:off 2:on 3:on 4:on 5:on 6:off

network-up 0:off 1:off 2:on 3:on 4:on 5:on 6:off

nfs-common 0:off 1:off 2:off 3:on 4:on 5:on 6:off

ntpd 0:off 1:off 2:on 3:on 4:on 5:on 6:off

numlock 0:off 1:off 2:off 3:on 4:on 5:on 6:off

partmon 0:off 1:off 2:off 3:on 4:on 5:on 6:off

pcscd 0:off 1:off 2:on 3:on 4:on 5:on 6:off

resolvconf 0:off 1:off 2:on 3:on 4:on 5:on 6:off

shorewall 0:off 1:off 2:on 3:on 4:on 5:on 6:off

smb 0:off 1:off 2:off 3:on 4:on 5:on 6:off

sound 0:off 1:off 2:on 3:on 4:on 5:on 6:off

syslog 0:off 1:off 2:on 3:on 4:on 5:on 6:off

system-tools-backends 0:off 1:off 2:off 3:on 4:on 5:on 6:off

vboxadd-timesync 0:off 1:off 2:off 3:on 4:off 5:on 6:off

webmin 0:off 1:off 2:on 3:on 4:off 5:on 6:off

wine 0:off 1:off 2:on 3:on 4:on 5:on 6:off

[root@localhost ~]#

 

I note that lisa is not listed downstairs. It is definitely installed, but I have no idea how to get it running - it all happened automatically using 2007.

 

And this from the upstairs machine.

 

[root@localhost ~]# chkconfig --list | grep -i :on

acpi 0:off 1:off 2:on 3:on 4:on 5:on 6:off

acpid 0:off 1:off 2:off 3:on 4:on 5:on 6:off

alsa 0:off 1:off 2:on 3:on 4:on 5:on 6:off

atd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

avahi-daemon 0:off 1:off 2:off 3:on 4:off 5:on 6:off

crond 0:off 1:off 2:on 3:on 4:on 5:on 6:off

ct_sync 0:off 1:off 2:on 3:on 4:on 5:on 6:off

cups 0:off 1:off 2:on 3:on 4:on 5:on 6:off

dm 0:off 1:off 2:off 3:off 4:off 5:on 6:off

haldaemon 0:off 1:off 2:off 3:on 4:on 5:on 6:off

harddrake 0:off 1:off 2:off 3:on 4:on 5:on 6:off

iptables 0:off 1:off 2:on 3:on 4:on 5:on 6:off

keytable 0:off 1:off 2:on 3:on 4:on 5:on 6:off

kheader 0:off 1:off 2:on 3:on 4:off 5:on 6:off

lisa 0:off 1:off 2:off 3:on 4:on 5:on 6:off

mandi 0:off 1:off 2:on 3:on 4:on 5:on 6:off

messagebus 0:off 1:off 2:off 3:on 4:on 5:on 6:off

netfs 0:off 1:off 2:off 3:on 4:on 5:on 6:off

network 0:off 1:off 2:on 3:on 4:on 5:on 6:off

network-up 0:off 1:off 2:on 3:on 4:on 5:on 6:off

nfslock 0:off 1:off 2:off 3:on 4:on 5:on 6:off

numlock 0:off 1:off 2:off 3:on 4:on 5:on 6:off

partmon 0:off 1:off 2:off 3:on 4:on 5:on 6:off

portmap 0:off 1:off 2:off 3:on 4:on 5:on 6:off

postfix 0:off 1:off 2:on 3:on 4:on 5:on 6:off

resolvconf 0:off 1:off 2:off 3:on 4:on 5:on 6:off

rpcgssd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

rpcidmapd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

shorewall 0:off 1:off 2:on 3:on 4:on 5:on 6:off

smb 0:off 1:off 2:off 3:on 4:on 5:on 6:off

sound 0:off 1:off 2:on 3:on 4:on 5:on 6:off

syslog 0:off 1:off 2:on 3:on 4:on 5:on 6:off

ucarp 0:off 1:off 2:on 3:on 4:on 5:on 6:off

xfs 0:off 1:off 2:on 3:on 4:on 5:on 6:off

xinetd 0:off 1:off 2:off 3:on 4:on 5:on 6:off

[root@localhost ~]#

 

It seems impossible to switch the shorewall off completely. The GUI tool allows you to select "No firewall" and deselect eth0, but it doesn't seem to stay switched off - when I go back in, eth0 is checked again and the "No

Share this post


Link to post
Share on other sites
Sorry, I assumed that anything displayed as "code" went into a cli. I did try it in konqueror anyway and all it brought up were the linux files on the local machine. This did also give me a route to the local windows directories but I had that anyway.

 

I am not surprised because I am pretty sure that the 78. address is your public ip address not a private network one. I don't think you want to set up a home network based on that unless you have a very relaxed attitude to personal privacy. Private IP address ranges are 10.0.0.0 - 10.255.255.255, 172.16.0.0 - 172.31.255.255, 192.168.0.0 - 192.168.255.255 and your router should provide an address somewhere in one of those ranges for you to share a network on. I assume you are using a router to connect the machines or is this just a crossover cable?

 

When I run ifconfig I get the private address as allocated from my router not the public one, I am not sure why you don't.(unless you have NAT turned off in the router config or it doesn't provide NAT, but I am really getting a bit out of my depth with NAT - I know how to switch it on and off and I know that in general it is a good thing but that is about as far as my knowledge goes).

Edited by viking777

Share this post


Link to post
Share on other sites

I also notice you have iptables and shorewall services enabled and running on these machines, since they are in the list above. That means firewall is enabled, unless configuration is fully open.

Share this post


Link to post
Share on other sites

The 'lo' network device is loopback and is for linux PC's to talk to themselves (w/o leaving the machine). Its IP address is always 127.0.0.1.

My guess (like ianw) is that both linux machines have the default firewall settings, meaning closed to smb (ports 137-139, 445). Check the logs (/var/los/messages and /var/log/samba/). You can open the firewall for samba by hand by editing /etc/shorewall/rules. You can do the same via the control center (security, setup personal firewall, select Windows file sharing). This will create /etc/shorewall/rules.drakx. Mine looks like follows for CUPS (631), Samba & SSH (22):

 

ACCEPT  net	 fw	  udp	 137,138,139,445,1024:1100,631   -
ACCEPT  net	 fw	  tcp	 22,137,138,139,445,1024:1100,631		-

 

My experience with a windows client (98, 98SE & XP) and Mandriva server is that samba does not give appropriate error messages it if gets blocked by a firewall, be it on the server or on the client (windows or linux client should accept responses from the server).

 

Another problem I have had with Samba is that of the workgroup name. Whatever you have put in /etc/samba/smb.conf behind workgroup = should match with what you have as workgroup on your windows PC (I forgot where you set it, but you can check in under control panel, system, computer name). If these do not match (I do not think case matters to windows), then (my conclusion was) clkient will not see server or vice versa.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...