Jump to content
Sign in to follow this  
DaveinSpain

More samba problems

Recommended Posts

I am not surprised because I am pretty sure that the 78. address is your public ip address not a private network one. I don't think you want to set up a home network based on that unless you have a very relaxed attitude to personal privacy. Private IP address ranges are 10.0.0.0 - 10.255.255.255, 172.16.0.0 - 172.31.255.255, 192.168.0.0 - 192.168.255.255 and your router should provide an address somewhere in one of those ranges for you to share a network on. I assume you are using a router to connect the machines or is this just a crossover cable?

 

When I run ifconfig I get the private address as allocated from my router not the public one, I am not sure why you don't.(unless you have NAT turned off in the router config or it doesn't provide NAT, but I am really getting a bit out of my depth with NAT - I know how to switch it on and off and I know that in general it is a good thing but that is about as far as my knowledge goes).

 

No, I don't get any addresses in the ranges above when I run ifconfig, no, I don't have a router I have a network switch and as far as I know it doesn't provide NAT (whatever that is) and no, it is deifintely not a crossover cable. When switching off (both machines) I get a warning message that "shorewall.conf (something) IP6 but this machine does not appear to have IP6 tables". Neither can I find shorewall.conf on either machine.

I don't know if it is relevant but the 2 machines have different IP addresses. Downstairs has 78.136.120.20 and upstairs has 88.148.50.166. These are the inet addr from ifconfig, so it looks as if I only have 2 Internet addresses and no local ones, although, as I said, it was simplicity itself to set up under Windows.

Edited by DaveinSpain

Share this post


Link to post
Share on other sites
The 'lo' network device is loopback and is for linux PC's to talk to themselves (w/o leaving the machine). Its IP address is always 127.0.0.1.

My guess (like ianw) is that both linux machines have the default firewall settings, meaning closed to smb (ports 137-139, 445). Check the logs (/var/los/messages and /var/log/samba/). You can open the firewall for samba by hand by editing /etc/shorewall/rules. You can do the same via the control center (security, setup personal firewall, select Windows file sharing). This will create /etc/shorewall/rules.drakx. Mine looks like follows for CUPS (631), Samba & SSH (22):

 

ACCEPT  net	 fw	  udp	 137,138,139,445,1024:1100,631   -
ACCEPT  net	 fw	  tcp	 22,137,138,139,445,1024:1100,631		-

 

My experience with a windows client (98, 98SE & XP) and Mandriva server is that samba does not give appropriate error messages it if gets blocked by a firewall, be it on the server or on the client (windows or linux client should accept responses from the server).

 

Another problem I have had with Samba is that of the workgroup name. Whatever you have put in /etc/samba/smb.conf behind workgroup = should match with what you have as workgroup on your windows PC (I forgot where you set it, but you can check in under control panel, system, computer name). If these do not match (I do not think case matters to windows), then (my conclusion was) clkient will not see server or vice versa.

 

Thanks for you help. This is copied from yesterday's entries in /var/log/messages:

 

Mar 25 15:47:34 localhost drakfirewall[7966]: configuring shorewall to allow ports: 137/tcp 137/udp 138/tcp 138/udp 139/tcp 139/udp 445/tcp

445/udp 1024:1100/tcp 1024:1100/udp 631/tcp 631/udp 8/icmp

 

and rules.drakx shows

 

ACCEPT net fw udp 137,138,139,445,1024:1100,631 -

ACCEPT net fw tcp 137,138,139,445,1024:1100,631 -

ACCEPT net fw icmp 8 -

Share this post


Link to post
Share on other sites
I also notice you have iptables and shorewall services enabled and running on these machines, since they are in the list above. That means firewall is enabled, unless configuration is fully open.

 

Output from /etc/firewall/drakx.rules

 

ACCEPT net fw udp 137,138,139,445,1024:1100,631 -

ACCEPT net fw tcp 137,138,139,445,1024:1100,631 -

ACCEPT net fw icmp 8 -

 

Is there anything else I can do? Incidentally, when shutting down I get the message "Warning DISABLE IPV6=Yes in Shorewall.conf but this system does not appear to have IPV6 tables". I can't find Shorewall.conf anywhere and have no idea how to disable IPV6 tables anyway.

 

Dave https://mandrivausers.org/style_emoticons/default/wall.gif

Share this post


Link to post
Share on other sites

Don't know whether this will help, but this is the configuration from the Windows Vista machine, which is talking to the XP machine.

 

Sufijo DNS específico para la conexión: indalotv.net

Descripción: Controladora de Gigabit Ethernet Marvell Yukon 88E8056 PCI-E

Dirección física: 00-19-21-78-34-51

Habilitado para DHCP: Sí

IPv4 Dirección IP: 88.148.50.222

IPv4 Máscara de subred: 255.255.255.0

Concesión obtenida: miércoles, 26 de marzo de 2008 11:43:14

La concesión expira: domingo, 30 de marzo de 2008 10:19:53

IPv4 Puerta de enlace predeterminada: 88.148.50.1

IPv4 Servidor de DHCP: 192.168.1.3

IPv4 Servidores DNS: 212.0.114.244, 80.58.0.33, 212.230.255.1, 80.58.0.33

IPv4 Servidor WINS:

Habilitado para NetBios a través de Tcpip: Sí

Vínculo: dirección IPv6 local: fe80::b518:c010:de98:8a7d%8

IPv6 Puerta de enlace predeterminada:

IPv6 Servidor DNS:

 

(Sorry this is in Spanish, Sufijo is suffix, Dirección is address, Puerta is port, Enlace is connect, Máscara is mask, Habilitado is enabled, Vinculo is link, Predeterminada is default, A tráves is over (via), Red is net (subred=subnet) and I think the rest are either fairly obvious or unimportant). Perhaps I should be doing this via VPN rather than Samba?

 

Here are the XP machine details:

 

Physical Address: 00-20-18-A1-58-7D

IP Address: 88.148.50.33

Subnet Mask: 255.255.255.0

Default Gateway: 88.148.50.1

DHCP Server: 192.168.1.3

Lease Obtained: 26/03/2008 9:31:58

Lease Expires: 30/03/2008 8:08:38

DNS Servers: 212.0.114.244, 80.58.0.33, 212.230.255.1, 80.58.0.33

WINS Server:

 

Hope this can help.

Edited by DaveinSpain

Share this post


Link to post
Share on other sites
No, I don't get any addresses in the ranges above when I run ifconfig, no, I don't have a router I have a network switch and as far as I know it doesn't provide NAT (whatever that is) and no, it is deifintely not a crossover cable. When switching off (both machines) I get a warning message that "shorewall.conf (something) IP6 but this machine does not appear to have IP6 tables". Neither can I find shorewall.conf on either machine.

I don't know if it is relevant but the 2 machines have different IP addresses. Downstairs has 78.136.120.20 and upstairs has 88.148.50.166. These are the inet addr from ifconfig, so it looks as if I only have 2 Internet addresses and no local ones, although, as I said, it was simplicity itself to set up under Windows.

 

Did you try running

ipconfig /all

in a windows command prompt? I am not sure that this is going to tell you anything but you never know.

If you want to know if shorewall is running or not just go into a root terminal and type:

 

shorewall status

 

If it is and you want to switch it off type:

 

shorewall clear

 

followed by

 

shorewall stop

 

At this point your computer will be completely unprotected so make sure you are not connected to the internet (unplug the phone line or modem)

 

When you want to restart it type:

 

shorewall start

 

If you prefer not to use the command line just look in MCC/system/manage services. This can start or stop shorewall but not clear the rules it has created, to do that graphically you have to go into MCC/security/setup firewall and set it to 'no firewall'.

 

I wouldn't worry about the IP6 warning on shutdown btw, I get this every time as well.

Share this post


Link to post
Share on other sites

Thank you everyone for your help.

 

On examining the Windows (both XP and Vista) configurations, I note that I get a DHCP Server address of 192.168.1.3 (within the range for local network provided by viking777) on both machines, additionally labeled as IPv4 from Vista, but it would appear from the output of ifconfig that there there does not appear to be any such address in either of the linux setups, which is probably the problem. Is there some basic step in the setup of the network under linux that I am overlooking? Not being particularly knowledgeable I have taken the advice of the configuration tool and just kept defaults, which I am sure said to use DHCP configuration anyway.

 

Dave

Share this post


Link to post
Share on other sites
Thank you everyone for your help.

 

On examining the Windows (both XP and Vista) configurations, I note that I get a DHCP Server address of 192.168.1.3 (within the range for local network provided by viking777) on both machines, additionally labeled as IPv4 from Vista, but it would appear from the output of ifconfig that there there does not appear to be any such address in either of the linux setups, which is probably the problem. Is there some basic step in the setup of the network under linux that I am overlooking? Not being particularly knowledgeable I have taken the advice of the configuration tool and just kept defaults, which I am sure said to use DHCP configuration anyway.

 

Dave

 

Well if the defaults didn't work you could always try a manual configuration. I'll say right from the outset though that I don't know if this will solve your problem and although I know how my network works I don't know if the same logic can be applied to yours, so keep a note of what you are doing and be prepared to undo it if it doesn't work.

 

If you want to try it open MCC/setup a new network interface/Ehternet/Manual configuration. You will then be asked for IP address which is your choice but it should be in the same range as your dhcp server so for instance you could try 192.168.1.5. you will be asked for netmask which sometimes will fill itself in but is usually 255.255.255.0, gateway, which is where your setup differs from mine because your default gateway from the posts you have given appears to be related to your public ip address whereas mine is related to my internal one. Anyway I have as the gateway the address of my router. In your case I guess this is 192.168.1.3. You will then be asked for 2 dns servers which you can copy from your previous posts, and lastly a hostname which is the name your computer uses on your network. Fill these details in on both computers, reboot and see what happens. NB The ip addresses that you choose must be in the same range on both computers but not exactly the same. For instance if you use 192.168.1.5 for upstairs you could use 192.168.1.6 for downstairs. The hostname must be unique on both machines as well, the other details are the same.

 

Hope it works for you.

 

Don't blame me if it doesn't!!

Share this post


Link to post
Share on other sites
Don't blame me if it doesn't!!

 

It didn't and I dont!, but thanks anyway.

 

Many thanks to everyone who has offered advice and assistance. Today I disconnected the modem and shut down shorewall completely as given above. The results were exactly the same as before. I am knocking this on the head now as there appears to be some basic incompatibility here that seems impossible to resolve and I do not have the patience, time or resources to pursue it further. I do not understand why Windows is assigned DHCP addresses in both the public and private network range but linux only gets them in the public range from exactly the same equipment but I suspect this is at the heart of the problem. Tried also today to set up VPN but the system just freezes at the Installing Packages stage so have decided that is a non starter. My congratulations to everyone who has managed to get a linux network going. I seem doomed to be stuck with Windows, which would be less irritating if it had not been so easy to set up networking with it!

 

Dave

Share this post


Link to post
Share on other sites

Sorry it didn't work for you Dave, but as a parting shot, and only if you are desperate mind, you could always go here:

 

http://www.xandros.com/products/home/home_edition.html

 

Download the 30 day trial and see if it sorts out a network connection for you (I bet it will). When you have it going make careful note of all the settings that you can find and when you delete it (because you will, believe me) try out the same settings with a sensible distro.

 

It is a bit of an extreme tactic I must admit, I am not even sure that I would do it, but then my network is working.

 

All the best anyway.

Share this post


Link to post
Share on other sites
Sorry it didn't work for you Dave, but as a parting shot, and only if you are desperate mind, you could always go here:

 

http://www.xandros.com/products/home/home_edition.html

 

It is a bit of an extreme tactic I must admit, I am not even sure that I would do it, but then my network is working.

 

All the best anyway.

 

Downloaded it, checked the md5 sum, burnt it to disk, didn't work, burnt it to a new disk, hung up halfway through. Burnt it to a 3rd disk with a different (new) drive. At 75% it told me there was an "Unknown Installation Error". Tried to save the details but machine hung completely. I have tried burning it with K3b in linux and Nero and Burn4Free under windows XP and Vista so I don't think that is the problem. There seems to be something very odd about my setup and as near as I can determine, it is not a virus and I don't know of any odd hardware. I should point out that around three quarters of electrical or electronic purchases I make need to be repaired or replaced within a week. In the last 3 years this has been: a food processor (died after 2 days) , Misubishi television (dead on arrival), sky satellite box (DOA), this computer (motherboard failure), kettle (electric shocks), DVD recorder (would not record), washing machine (died halfway through first wash), alarm clock (reset to 0 instead of sounding alarm). The problem could just be me! :D

 

Thanks for all your help.

 

Dave

Share this post


Link to post
Share on other sites

Samba is completely broken and useless at this point, not just in Mandy but most other distros as well. All users want is simple SMB/CIFS file sharing. Nobody wants to emulate an NT 4.0 domain controller. Unfortunately the developers aren't listening.

Edited by Crito

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...