Jump to content
bookie

Sound Problems on 2008 (new title)

Recommended Posts

Hi again, I have restarted this thread and anyone dropping by - please bear in mind that the posts below are from my original thread!! The last entry being mine:

 

 

I have solved the problem with the sound card!! I took the easy way out and went back to 2007.1 powerpack!!

 

I have reprogrammed the computer without my webcam and I still couldn't get sound?!! So until they can make the 2008 version work I'll stay with the old one!

 

bookie

 

Well, as you might have already guessed - I am a stubborn old git who can not quit even when I run out of ideas!!

 

I have been working with you guys and the guys at mandriva.club forum as well as Linux questions to try and solve this problem!! Everything points to a bug but one doesn't want to report a bug until one is absolutely sure about the facts!

 

 

The latest kernel update didn't change the situation either!

 

The thing that is strange about the situation is when I log out I hear some sort of sound like something being turned of or on?!! The sort of sound you can get when turning a radio on or off - if that makes sense?

 

I did not experience this before with2007.1. I suspect that it is inerrant to my present problems?

 

I would appreciate some feedback if only to go through things one more time!!

 

bookie ;)

Edited by bookie

Share this post


Link to post
Share on other sites

With 2008 I have the problem that only about Twice out of every Five reboots ( dual booting Spring and 2008 ) do I get sound.

 

There are no error messages and the correct drivers are selected for the Audio card and the bios disabled (??????) onboard sound chip.

I have even installed the Latest 2008 kernel (not cooker). Still no luck. When the sound works it is solid with all sound applications.

 

Mandriva..............................Back to the drawing board. :D :D :D

 

Cheers. John.

Share this post


Link to post
Share on other sites

All AC97 integrated soundcards should work- although not necessarily right out of the box.

The AC97 chip is surely recognized, but you may have to pass some "model" argument to have the proper mixer settings.

It would be nice to know the exact motherboard/laptop/whatever it is model/revision, but anyway, after running "alsaconf" as root try the usual string of actions:

# lsmod

You should see somewhere "snd-intel8x0" being loaded. If you have also something like "snd-intel8x0m" loaded as well, it SHOULD be unloaded ( # modprobe -r snd-intel8x0m ) and blacklisted.

If it's not loaded, do it manually:

# modprobe snd-intel8x0

And now either

alsamixer

(as root, or user- does not matter that much) to alter the mixer settings, or more automatically

# amixer set Master 90% unmute
# amixer set PCM 90% unmute

(this may not work with some cards which don't have a "Master" channel, but they mainly are of the intel-hda kind)

Try playing a sound. Does it work? If it does,

# alsactl store

and get sure the alsa daemon is loaded at startup, so the mixer settings you have just set will be restored at next boot.

If you still have problems, you must give the exact hardware type you have, so we find the appropriate alsa "model" to configure.

Edited by scarecrow

Share this post


Link to post
Share on other sites

Thanks to AussieJohn and Scarecrow for dropping by! Nice to hear from you again. Have to say I do miss you guys when things are going OK!

 

One sort of tries to think of something to post about just to have a chat with you all!

 

Anyway, silly old git you are probably thinking! Down to business. Scarecrow I have checked the driver in the hardware section and it is the one you mentioned "snd-intel8x0m" and I have tried alsamixer and the settings are all live!

 

Do apologize for not giving that info when I started the thread!

 

Not sitting by that computer at the mo (girlfriend asleep, only 6am here in Sweden) I will give you some more info about the computer later today!

 

What I can tell you it is a Dell Dimension 5000. I did notice that when I checked the hardware section that there were two other drivers mentioned to try. Have noted them down on paper but in the bedroom!!

 

Something that I would like to know while we are on the subject of drivers for different hardware. I haven't had to add a driver in Linux and wouldn't have much of a clue how to go about changing to another one.

 

When I had powerpack 2007 on that computer - it didn't work straight out of the box either, but all I had to do was tick for using the sound system and save and reboot and all was right with the world. If I remember correctly, an error window opened after installing 2007.

 

What I would be interested in knowing - if Adam is around? What driver was used for the intel integrated sound card I have in 2007? I didn't make a note of it when using 2007!!!

 

I do really appreciate the upgrades they do to distros. It's that keeps us coming back for more. Just wish they'd leave alone things that are already working OK!

 

 

bookie

 

PS Did I miss your birthday AussieJohn?

Edited by bookie

Share this post


Link to post
Share on other sites

Hello bookie. My birthday is 4th. January. Will be the big 73 then.

That gives me at least another 27 years. I have had that determination since I was 10-12 years old even though I don't really know why. I think it was the science fiction comics of the future about space ships and so on.

My Dad made 86 so I have a good chance of making the 100+.

 

I hope you stay around more often here again too. :D

 

I think Adam must be extremely busy at the moment because we haven't seen much of him this past week or so but when he does appear he always makes a fantastic contribution. :thumbs:

Cheers. John.

Share this post


Link to post
Share on other sites

actually I wasn't busy at all, I was on holiday. =) went on a nice bus trip to Banff and back:

 

http://www.flickr.com/photos/adamwill/

 

as you can see, the weather's positively tropical here in western Canada :D

 

I think the driver used would not have changed from 2007 to 2008.

 

snd-intel8x0m is a *modem* driver; it's not, AFAIK, intended to work with regular sound cards. I think it should be using snd-intel8x0.

Share this post


Link to post
Share on other sites

Hi Adam, you seem to have had good beach weather!! Nice to hear from you!

 

Nice to know that you have time for us old fogies! Sorry, it is probably a typo! I know that my sound card is a SoundMax integrated digital audio - quite common on Dell computers.

 

Can't understand why I am not getting any sound then? I will check to make sure that I haven't done a typo later today. Time here in Sweden is almost 1 am. While it is not unusual for me to burn the midnight oil - tonight is a bad back night, so I end up in front of the computer!!

 

Sorry, can't check my Dell computer because it is in the master bedroom! Can I reinstall the driver? If so, can you give me some tips on that. I now have alsaconfig installed - which usually works - but not this time.

 

Hope you had a good holiday! We haven't any major snow here in Sundsvall, Sweden. Sundsvall is in about the middle of Sweden by the coast.

 

I have lived here 12 years now and have noticed climate changes! I even experienced my first Christmas last year without snow?!!

 

The snow usually gets here in the end and usually lots of it!

 

Speak to you later.

 

bookie

Share this post


Link to post
Share on other sites

Adam, the fact that you have been on holidays pleases me immensely. I know you have been working hard and I was starting to worry that you might over do it like so many other helpful, enthusiastic and generous people too often tend to do.

 

I plan to have a look at your pics to see what you enjoyed.If you or others are interested in looking at some of the pics that I have taken 30 odd years or more ago and one one taken digitally just recently (Cairns-lights) have a look at KDE-Look site. Presently it will be about 6 or more pages back by now.

 

Welcome back and cheers. John.

 

Just finished looking at your photos. Superb quality shots. Your Mum and Dad make a very lovely couple.

I hope you don't mind, I loved 4 photos so much that I have added them to my Wallpaper Screensaver. They are a7wsvv, 5vxtlb,nkfkfg and ntmc6.

 

JB

Edited by AussieJohn

Share this post


Link to post
Share on other sites

Well, adamw! It was like I said a typo. The driver is as you stated snd-intel8x0. That sort of brings me back to the question "have you any suggestions now".

 

!t is a bit quiet without sound!!

 

bookie

Share this post


Link to post
Share on other sites

bookie,

1. Your typo was obvious. Just notice that i suggested you disabling/blacklisting the modem driver.

2. Try doing what I suggested. Else, do not expect your puter to fallback into "self-healing" mode... this would be too good to be true!

Edited by scarecrow

Share this post


Link to post
Share on other sites

Hi again, well, scarecrow I tried what you said but I am afraid nothing worked!

 

I thought I'd give you the lsmod read out, so you can have a look at it.

 

[root@ROCKY bookie]# lsmod

Module Size Used by

ppdev 7844 0

parport_pc 32004 1

lp 10216 0

parport 31592 3 ppdev,parport_pc,lp

iptable_raw 2688 0

xt_comment 2336 0

xt_policy 4256 0

xt_multiport 3808 4

ipt_ULOG 7748 0

ipt_TTL 2656 0

ipt_ttl 2336 0

ipt_TOS 2560 0

ipt_tos 2176 0

ipt_SAME 2880 0

ipt_REJECT 4288 4

ipt_REDIRECT 2720 0

ipt_recent 8344 0

ipt_owner 2464 0

ipt_NETMAP 2656 0

ipt_MASQUERADE 3872 0

ipt_LOG 6560 10

ipt_iprange 2336 0

ipt_ECN 3200 0

ipt_ecn 2656 0

ipt_CLUSTERIP 7460 0

ipt_ah 2368 0

ipt_addrtype 2336 0

nf_nat_tftp 2208 0

nf_nat_snmp_basic 9732 0

nf_nat_sip 4768 0

nf_nat_pptp 3552 0

nf_nat_proto_gre 3012 1 nf_nat_pptp

nf_nat_irc 2816 0

nf_nat_h323 6720 0

nf_nat_ftp 3424 0

nf_nat_amanda 2560 0

ts_kmp 2592 5

nf_conntrack_amanda 4512 1 nf_nat_amanda

nf_conntrack_tftp 5492 1 nf_nat_tftp

nf_conntrack_sip 8788 1 nf_nat_sip

nf_conntrack_proto_sctp 8520 0

nf_conntrack_pptp 6176 1 nf_nat_pptp

nf_conntrack_proto_gre 5152 1 nf_conntrack_pptp

nf_conntrack_netlink 23936 0

nf_conntrack_netbios_ns 3104 0

i915 22688 2

drm 72628 3 i915

nf_conntrack_irc 6104 1 nf_nat_irc

nf_conntrack_h323 48156 1 nf_nat_h323

nf_conntrack_ftp 8800 1 nf_nat_ftp

xt_tcpmss 2688 0

xt_pkttype 2400 4

xt_physdev 3120 0

xt_NFQUEUE 2496 0

xt_NFLOG 2560 0

xt_MARK 2784 0

xt_mark 2400 0

xt_mac 2400 0

xt_limit 2944 0

xt_length 2464 0

xt_helper 2944 0

xt_hashlimit 8588 0

ip6_tables 12484 1 xt_hashlimit

xt_dccp 3556 0

xt_conntrack 3040 0

xt_CONNMARK 3200 0

xt_connmark 2688 0

xt_CLASSIFY 2368 0

xt_tcpudp 3680 11

xt_state 2752 6

iptable_nat 7396 0

nf_nat 16140 14 ipt_SAME,ipt_REDIRECT,ipt_NETMAP,ipt_MASQUERADE

,nf_nat_tftp,nf_nat_sip,nf_nat_pptp,nf_nat_proto_gre,nf_nat_irc,nf_nat_h323,nf_n

at_ftp,nf_nat_amanda,nf_conntrack_netlink,iptable_nat

nf_conntrack_ipv4 15148 8 iptable_nat

nf_conntrack 54984 29 ipt_MASQUERADE,ipt_CLUSTERIP,nf_nat_tftp,nf_nat

_snmp_basic,nf_nat_sip,nf_nat_pptp,nf_nat_irc,nf_nat_h323,nf_nat_ftp,nf_nat_aman

da,nf_conntrack_amanda,nf_conntrack_tftp,nf_conntrack_sip,nf_conntrack_proto_sct

p,nf_conntrack_pptp,nf_conntrack_proto_gre,nf_conntrack_netlink,nf_conntrack_net

bios_ns,nf_conntrack_irc,nf_conntrack_h323,nf_conntrack_ftp,xt_helper,xt_conntra

ck,xt_CONNMARK,xt_connmark,xt_state,iptable_nat,nf_nat,nf_conntrack_ipv4

iptable_mangle 2976 1

nfnetlink 5080 4 nf_conntrack_netlink,nf_nat,nf_conntrack_ipv4,nf

_conntrack

iptable_filter 3136 1

ip_tables 11396 4 iptable_raw,iptable_nat,iptable_mangle,iptable_f

ilter

x_tables 12036 44 xt_comment,xt_policy,xt_multiport,ipt_ULOG,ipt_

TTL,ipt_ttl,ipt_TOS,ipt_tos,ipt_SAME,ipt_REJECT,ipt_REDIRECT,ipt_recent,ipt_owne

r,ipt_NETMAP,ipt_MASQUERADE,ipt_LOG,ipt_iprange,ipt_ECN,ipt_ecn,ipt_CLUSTERIP,ip

t_ah,ipt_addrtype,xt_tcpmss,xt_pkttype,xt_physdev,xt_NFQUEUE,xt_NFLOG,xt_MARK,xt

_mark,xt_mac,xt_limit,xt_length,xt_helper,xt_hashlimit,ip6_tables,xt_dccp,xt_con

ntrack,xt_CONNMARK,xt_connmark,xt_CLASSIFY,xt_tcpudp,xt_state,iptable_nat,ip_tab

les

af_packet 17960 0

snd_usb_audio 76032 1

snd_seq_dummy 3492 0

ipv6 250084 15 nf_conntrack_h323

snd_seq_oss 29888 0

snd_seq_midi_event 6912 1 snd_seq_oss

snd_seq 46800 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event

snd_pcm_oss 37216 0

snd_mixer_oss 14784 1 snd_pcm_oss

video 15080 0

thermal 11304 0

sbs 16520 0

processor 25796 1 thermal

fan 4260 0

container 4032 0

button 6576 0

dock 7600 0

battery 10344 0

ac 4452 0

ide_cd 35200 0

binfmt_misc 9416 1

loop 14276 0

nls_iso8859_1 4672 1

nls_utf8 2496 1

ntfs 252840 2

dm_mirror 20224 0

dm_mod 48064 1 dm_mirror

piix 9028 0 [permanent]

usb_storage 90276 0

ide_core 99748 3 ide_cd,piix,usb_storage

floppy 54052 0

cpufreq_ondemand 7340 1

cpufreq_conservative 6600 0

cpufreq_powersave 2240 0

p4_clockmod 4996 1

speedstep_lib 5028 1 p4_clockmod

freq_table 4512 2 cpufreq_ondemand,p4_clockmod

pwc 81952 0

compat_ioctl32 1920 1 pwc

videodev 27296 1 pwc

v4l2_common 16064 1 videodev

v4l1_compat 14308 1 videodev

usblp 11936 0

snd_usb_lib 15264 1 snd_usb_audio

snd_rawmidi 19456 1 snd_usb_lib

snd_seq_device 7276 4 snd_seq_dummy,snd_seq_oss,snd_seq,snd_rawmidi

snd_hwdep 7492 1 snd_usb_audio

b44 24304 0

ssb 31364 1 b44

pcmcia 33260 1 ssb

pcmcia_core 33108 1 pcmcia

mii 5280 1 b44

snd_intel8x0 29404 3

i2c_i801 8528 0

i2c_core 20224 1 i2c_i801

snd_ac97_codec 96836 1 snd_intel8x0

ac97_bus 2752 1 snd_ac97_codec

snd_pcm 69636 5 snd_usb_audio,snd_pcm_oss,snd_intel8x0,snd_ac97_

codec

snd_timer 19652 3 snd_seq,snd_pcm

snd 45092 18 snd_usb_audio,snd_seq_oss,snd_seq,snd_pcm_oss,s

nd_mixer_oss,snd_rawmidi,snd_seq_device,snd_hwdep,snd_intel8x0,snd_ac97_codec,sn

d_pcm,snd_timer

soundcore 6624 1 snd

snd_page_alloc 8456 2 snd_intel8x0,snd_pcm

iTCO_wdt 9632 0

iTCO_vendor_support 3940 1 iTCO_wdt

sr_mod 15236 0

intel_agp 22132 1

agpgart 27656 3 drm,intel_agp

tsdev 7104 0

joydev 8800 0

evdev 8448 4

sg 30552 0

ext3 118408 1

jbd 50504 1 ext3

scsi_wait_scan 1984 0

sd_mod 26272 6

ahci 19428 0

ata_piix 12132 4

libata 108848 2 ahci,ata_piix

scsi_mod 125356 6 usb_storage,sr_mod,sg,scsi_wait_scan,sd_mod,liba ta

usbhid 38880 0

ff_memless 5448 1 usbhid

ehci_hcd 30668 0

uhci_hcd 22832 0

usbcore 113576 9 snd_usb_audio,usb_storage,pwc,usblp,snd_usb_lib, usbhid,ehci_hcd,uhci_hcd

[root@ROCKY bookie]#

 

If you have any more ideas, I am all ears - promise!!

 

bookie

Share this post


Link to post
Share on other sites

Hi to you jkerr82508! I do indeed have a web cam on that computer - a logitech quick cam pro 4000.

I haven't had time to check out your link yet! Looking for sympathy!! Having a bad back day can't concentrate so much!!

 

Getting too many such days!! :wall:

 

Thanks for stopping by. I will investigate your link and get back to you soon. :lol2:

 

bookie

Share this post


Link to post
Share on other sites

I was about to ask the same thing (about the USB audio device), but more important is that your soundcard module ( snd-intel8x0 ) is NOT loaded, so you shouldn't have any sound...

Just load it manually ( # modprobe snd-intel8x0 ), and if it just keeps not being loaded automatically, put "snd-intel8x0" at your modules' preload list.

I guess you know where it is- or not?

Perhaps before doing that you could check if you have sound with your webcam disconnected!

There is a chance the system "thinking" the webcam is the actual sound device, and trying to use that one... although this shouldn't really happen.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...