Jump to content
bookie

Sound Problems on 2008 (new title)

Recommended Posts

OK! I tried disconnecting the web cam - nada! I tried # modprobe snd-intel8x0 but still no sound.

 

This is a copy of alsamixer - showing my sound card?

 

 

 

Card: Intel ICH6 ?

? Chip: Analog Devices AD1986 ?

? View: [Playback] Capture All ?

? Item: Master [dB gain=-4.50, -4.50] ?

? ?

? ???? ???? ???? ???? ???? ???? ?

? ? ? ? ? ? ? ? ? ? ? ? ? ?

? ???? ? ? ? ? ???? ? ? ? ? ?

? ???? ???? ???? ???? ???? ???? >

? ???? ???? ???? ???? ???? ???? >

? ???? ???? ???? ???? ???? ???? >

? ???? ???? ???? ???? ???? ???? >

? ???? ???? ???? ???? ???? ???? >

? ???? ???? ???? ???? ???? ???? >

? ???? ???? ???? ???? ???? ???? ?

? ???? ???? ???? ???? ???? ???? ?

? ???? ???? ???? ???? ???? Shared ???? ?

? ???? ???? ???? ???? ???? ???? ???? ?

? ?OO? ?OO? ?OO? ?MM? ?OO? ?OO? ?OO? ?

? ???? ???? ???? ???? ???? ???? ???? ?

? 90<>90 74 74<>74 90<>90 77<>77 77 ?

? < Master >Master M Headphon Headphon PCM Surround Surround Center ?

????????????????????????????

?????????????????????????????

???????????????????????

 

 

 

This is modprobe.config:

 

 

alias eth0 b44

install scsi_hostadapter /sbin/modprobe ata_piix; /sbin/modprobe ahci; /sbin/modprobe usb_storage; /bin/true

install usb-interface /sbin/modprobe uhci_hcd; /sbin/modprobe ehci_hcd; /bin/true

install ide-controller /sbin/modprobe piix; /bin/true

 

 

This is modprobe.preload:

 

 

# /etc/modprobe.preload: kernel modules to load at boot time.

#

# This file should contain the names of kernel modules that are

# to be loaded at boot time, one per line. Comments begin with

# a `#', and everything on the line after them are ignored.

# this file is for module-init-tools (kernel 2.5 and above) ONLY

# for old kernel use /etc/modules

 

intel_agp

 

 

 

 

Well, there would appear to be something wrong with this picture - wouldn't you say!

 

 

OK scarecrow! Can you indicate where I should add my snd-intel8x0?

 

bookie

Share this post


Link to post
Share on other sites

Well, you could say that about now this is getting rather tedious!!

 

I followed the info via jkerr82508's link and rebooted to see what happens. Well, there was a modprob error on boot - and still no sound!!

 

I ran alsaconf again! These two came up on the sound card search:

 

Intel 8x0 Intel corporation 82801 FB/FBM/FR/FW/FRW (ICH6 Family) Ac'97

legacy=probe legacy isa (non-pnp) chips

 

I thought what the hell and ran alsaconf with the second entry and added the changes to modprobe.conf via alsaconf. As you might suspect, nothing happened!!

 

The strange thing is that I ran alsamixer after alsaconf and the same entry comes up whether I choose the first or second from above sound cards.

 

Intel ICH6

Analog Devices AD1986

 

I ran alsaconf again and chose the intel card and again save to modprob.conf via alsaconf. I then opened alsamixer and found the intel ICH6 listed, but when I checked modprob.conf no changes had been registered?!!

 

State of play at the moment - HELP!!

 

 

Sorry, having a bit of a breakdown!

 

 

I am very tempted to go back to the 2007.1 powerpack! Can't understand why I am problems with 2008? Never had to worry about my web cam on 2007.1?

 

 

Well, could do with a bit more advice on what route to take now!

 

 

Thanks :wall:

 

bookie

Share this post


Link to post
Share on other sites

I have solved the problem with the sound card!! I took the easy way out and went back to 2007.1 powerpack!!

 

I have reprogrammed the computer without my webcam and I still couldn't get sound?!! So until they can make the 2008 version work I'll stay with the old one!

 

bookie

Share this post


Link to post
Share on other sites

Not wanting to hijack this thread but just to add that bookie is not alone with this problem. I appear to have the exact same situation with Mandriva ONE 2008. The sound works about about 1 in 4 reboots and sometimes stops working during the session.

 

I can't figure out how to obtain the model of my onboard soundcard in Asus A8F Series laptop, however, it may help you to know that in Windows it was using a driver provided by AnalogDevices and the driver name was ADI UAA Function Driver for High Definition Audio.

 

I added this here, mainly so I can subscribe to the thread in case something is added later. I will start my own thread later regarding this problem. (I'm kind of hoping that a Mandriva update will be issued imminently though, to save me the trouble ;)

 

Regards

 

Peter

Share this post


Link to post
Share on other sites

Quoting Peter Snow ---- "The sound works about about 1 in 4 reboots and sometimes stops working during the session."

 

Exactly my problem from day one with Mandriva 2008 way back. I have the Latest Kernel and that seemed to result in the sound working more times than it failed which is a definite reversal and improvement. I have also done the blacklisting thing of the via driver of the onboard sound and that seems to have completely worked around the problem.

I don't regard this as a satisfactory resolution of the problem though.

 

 

Cheers. John.

Share this post


Link to post
Share on other sites

Hi John,

 

That's interesting that it improved after you installed the latest kernal. I downloaded my disk about 4 weeks ago and run the auto update 'thing' each day. Would that upgrade my kernal to the latest or do I need to do something else to do that?... it would at least be an improvement if I can make the sound work at least 50% of the time :)

 

Sorry if I sound like a bit of a muppet! I'm new to Linux (although been a Windows network eng. for years), I'm still trying to get my head around it all. It's a good thing I've found a great forum here, full of helpful people :)

 

Peter

Share this post


Link to post
Share on other sites

Hello Peter.

I can't say with any real certainty that the newer kernel has fixed the problem because I didn't spend a lot of time proving it out. I have also put the unwanted driver in the black list procedure.

 

The Kernel I am now using in 2008 is ......... 2.6.22.12-desktop586-1mdv.

 

It isn't difficult to install so give it a try. I might fix your problem completely without having to make any file changes.

 

Don't worry about being a Linux newbie. We have ALL been there and still are. If you have a problem then ask the question no matter how silly you might think the question to be.

 

I think you are going to do just fine.

 

Cheers. John.

Share this post


Link to post
Share on other sites

I just found how to check and discovered that I'm already using that Kernal. I guess the Autoupdate took care of it (unless it was the one I burnt on the original CD).

 

Anyway, looks like that's not going to be my solution (at least not this time around!). I'll keep searching for an answer while I'm waiting for Mandriva to release a fixed version :)

 

Going to go back through the posts above and try all the stuff that bookie tried... at the very least, I'll learn a bit about the system and maybe fix some problems I didn't know I had along the way!

 

Thanks for you help there John. Hope to see around.

 

Peter

Share this post


Link to post
Share on other sites

Hi guys, I have tried and tried to get sound working - but it beats me what the problem is?! There is a major fault in 2008 that really needs looking into!

 

What is the point in continuing with a distro that you can't get any sound on?

 

I am seriously thinking of buying a separate sound card and trying that solution. Is there any suggestions to what sound card is readily accepted under Linux? Even more important - it works with Mandriva!!

 

Can't understand why we can't seem to sort this problem?!

 

I am not likely to need a top of the range sound card - just one that works :lol2:

 

Peter, I am quite certain that there are a lot of people in the same boat regarding this version of Mandriva?!

 

What makes me mad is I have 2008 running on an old Pentium 3 without any problems!!

 

bookie

Share this post


Link to post
Share on other sites

Peter if you have the same kernel then you must have downloaded it because it would NOT have been on the install disc.

 

The install disc does not change after it is released.

 

Cheers. John.

Share this post


Link to post
Share on other sites

Thanks everyone for your input. I've tried everyones suggestions so far including some of the one's in the link supplied.

 

I turned off APIC and APCI and rebooted but still no reliable sound. I also found another post where the guy was saying that if he opened Kmix and then rebooted, it fixed it for him until the next boot. However, I tried that and found that by doing that I was getting sound about one in three boots (over a period of more than 20 reboots last night), but then it stopped working altogether, although, I reckon that with a few more reboots it would have returned occasionally!

 

It seems to simply be 'random'! Sometimes it works and sometimes it doesn't. Even if I make no config changes and open no applications before rebooting, I will get a different result often.

 

This really has me baffled. I wish it would either work or not work, but when it's random, it's hard to figure!

 

Regarding the kernel AussieJohn, you said,

Peter if you have the same kernel then you must have downloaded it because it would NOT have been on the install disc.

 

The install disc does not change after it is released.

I was just suggesting that perhaps the new kernel was already included in the .iso that I downloaded to burn my original CD intallation disk. Since I have no idea how to upgrade the kernal if it's not possible to do with the Autoupdate.

 

Anyway, regardless of how I got it, I seem to already be using the one you specified.

 

About installing a new soundcard... I wish that was an option, but unfortunately this is a laptop with onboard sound :(

 

From searching various forums, I can see various others with similar problems but I've yet to see one solved. I really hope I find a solution soon, since this is somewhat dissappointing :(

 

Thanks again everyone for all your help.

 

Peter

Share this post


Link to post
Share on other sites

Hi Peter Snow, I have also tried the ACPI without success!! My only option is a sound card if somebody can give me some hints on what to buy?

 

A comment from Adam about now would be nice - giving us some sort of hope that Mandriva are looking into this problem and trying to sort it out?!! :unsure:

 

bookie :thumbs:

Share this post


Link to post
Share on other sites

Hey!! I might have the solution!!!

 

Check out this page..

 

http://www.linux-on-laptops.com/forum/showthread.php?t=1488

 

This looks really promising but at first reading they are using terms that as a newbie I don't understand.

 

I'm planning to read it again more carefully and follow some of the links on that page too before giving it a try.

 

I'll keep ya-all posted!

 

Pete

Share this post


Link to post
Share on other sites

I tried to follow the instructions here which begin as follows:

 

# cd /usr/src/
# mkdir alsa
# rsync -avz --delete --exclude=.hg* rsync://alsa.alsa-project.org/hg alsa

 

I got as far as the 3rd line and it all fell apart. This is what I got..

# cd /usr/src/
# mkdir alsa
# rsync -avz --delete --exclude=.hg* rsync://alsa.alsa-project.org/hg alsa
rsync: failed to connect to alsa.alsa-project.org: Connection timed out (110)
rsync error: error in socket IO (code 10) at clientserver.c(104) [receiver=2.6.9]

 

My internet / lan connection appears to be fine (I connect through a proxy but every seems to be working OK including the Autoupdate thing). Maybe the location moved? Is there away to find alternative location? According to http://www.alsa-project.org/main/index.php/Download the code/line is correct.

 

Is there a workaround to this problem? I´ve retried this command many times over the last two hours.

 

Regards, Peter

Edited by Peter Snow

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...