Jump to content
sub-zero

Soundcard Driver Problems.

Recommended Posts

Erm Hi again. A couple days ago I wanted to update my sound drivers to work with Auto Zen. Well, at first I installed the oss compatibility module to alsa and it didnt work. I kinda gave up for a while, and hten decided to go to my soundcard maker's site. I downloaded their driver, used the make command to make the install, but it somehow broke.

 

So I had to uninstall ALSA, (and the uninstaller went and uninstalled every other peice of software I had installed, from text editors to audio players) and I reinstalled everything. The drivers for the sound worked for a while. Then I got my new NVIDIA drivers because the OpenGL was slow. But to Install them, I needed a kernel upgrade. I got the new kernel, and compiled the driver for my kernel (thankfully that went off without a hitch :thumbs:)

 

The sound continued to keep working yesterday until I started Mandriva today. I had to delete the .ICEauthority file because an error message about it popped up when I booted. It hasnt had sound since then (but Root doesnt have sound either). All my groups got deleted, including sound. I've enabled most of them again, but I still have no sound.

 

ALSA is installed, with OSS support, and I've ran alsaconfig a few times after quitting X. All the sound processes are running and nothing is Muted, according to alsamixer, gnome-volume-control, and kmix.

 

I've also tried to use the Install cd to set up the sound- Nothing's worked.

 

Am I gunna have to re-install ALSA and about 80% of all my software?

 

 

[[Edit: Eh, sometimes I can be kinda dumb! I forgot to mention my card is described as "ICH4 845G/GL Chipset AC'97 Audio Controller" in harddrake.]]

Edited by sub-zero

Share this post


Link to post
Share on other sites

Here is what it said:

 

Module Size Used by

binfmt_misc 8872 1

nvidia 4069712 12

md5 3584 1

ipv6 233984 10

snd_seq_dummy 2660 0

snd_seq_oss 33376 0

snd_seq_midi_event 5696 1 snd_seq_oss

snd_seq 46960 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event

snd_seq_device 6828 3 snd_seq_dummy,snd_seq_oss,snd_seq

snd_pcm_oss 49248 0

snd_mixer_oss 16896 1 snd_pcm_oss

snd_intel8x0 29696 1

snd_ac97_codec 84892 1 snd_intel8x0

snd_pcm 79784 3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec

snd_timer 20548 2 snd_seq,snd_pcm

snd_page_alloc 8392 2 snd_intel8x0,snd_pcm

snd 47460 12 snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_i

ntel8x0,snd_ac97_codec,snd_pcm,snd_timer

soundcore 7008 1 snd

parport_pc 32612 1

lp 10024 2

parport 31976 2 parport_pc,lp

ipt_IFWLOG 2788 1

ipt_psd 43428 1

ip_set_iptree 5544 2

ipt_REJECT 4256 4

ipt_LOG 6272 8

ipt_state 1312 13

ipt_pkttype 1184 4

ipt_set 1920 2

ipt_CONNMARK 1696 0

ipt_MARK 1984 0

ipt_ROUTE 4260 0

ipt_connmark 1216 0

ipt_owner 2432 0

ipt_recent 9292 0

ipt_iprange 1312 0

ipt_physdev 1744 0

ipt_multiport 2112 1

ipt_conntrack 1792 0

iptable_mangle 2016 0

ip_set_portmap 3872 0

ip_set_macipmap 3780 0

ip_set_ipmap 3872 0

ip_set_iphash 5956 0

ip_set 18908 11 ip_set_iptree,ipt_set,ip_set_portmap,ip_set_macipmap,ip_set_ipmap,ip_set_iphash

ip_nat_irc 1824 0

ip_nat_tftp 1216 0

ip_nat_ftp 2560 0

iptable_nat 20276 3 ip_nat_irc,ip_nat_tftp,ip_nat_ftp

ip_conntrack_irc 70352 1 ip_nat_irc

ip_conntrack_tftp 3088 1 ip_nat_tftp

ip_conntrack_ftp 71408 1 ip_nat_ftp

ip_conntrack 40856 9 ipt_state,ipt_conntrack,ip_nat_irc,ip_nat_tftp,ip_nat_ftp,iptable_nat,ip_conntra

ck_irc,ip_conntrack_tftp,ip_conntrack_ftp

iptable_filter 2080 1

ip_tables 20384 20 ipt_IFWLOG,ipt_psd,ipt_REJECT,ipt_LOG,ipt_state,ipt_pkttype,ipt_set,ipt_CONNMARK

,ipt_MARK,ipt_ROUTE,ipt_connmark,ipt_owner,ipt_recent,ipt_iprange,ipt_physdev,ip

t

_multiport,ipt_conntrack,iptable_mangle,iptable_nat,iptable_filter

tulip 47936 0

8139too 21632 0

mii 4704 1 8139too

af_packet 16392 4

floppy 55444 0

video 14052 0

thermal 10792 0

tc1100_wmi 5092 0

processor 17876 1 thermal

fan 3172 0

container 3008 0

button 4848 0

battery 7460 0

ac 3268 0

ide_cd 37988 0

loop 14504 0

nls_iso8859_1 3680 1

ntfs 212728 1

supermount 31956 1

intel_agp 20636 1

agpgart 29032 2 nvidia,intel_agp

tuner 25736 0

tvaudio 21636 0

bttv 148944 0

video_buf 17092 1 bttv

firmware_class 7424 1 bttv

i2c_algo_bit 8488 1 bttv

v4l2_common 4640 1 bttv

btcx_risc 3912 1 bttv

tveeprom 11512 1 bttv

i2c_core 17360 5 tuner,tvaudio,bttv,i2c_algo_bit,tveeprom

videodev 7104 1 bttv

nvram 7400 0

tsdev 5984 0

usbkbd 5760 0

wacom 13888 0

joydev 8128 0

xpad 9408 0

usbmouse 4160 0

usbhid 44544 0

ehci_hcd 29160 0

uhci_hcd 29168 0

usbcore 108476 8 usbkbd,wacom,xpad,usbmouse,usbhid,ehci_hcd,uhci_hcd

evdev 7648 1

ext3 124840 2

jbd 48568 1 ext3

Share this post


Link to post
Share on other sites

Your card should work fine with alsa. I would be tempted to install alsa, as well as alsa-utils and alsaconf as well.

 

On completion of install, then type "alsaconf" in a console window as root, and then configure accordingly. Afterwards, run alsamixer or kmix within KDE and set your volume levels making sure it's not all muted.

 

Then reboot, and you should hopefully have sound.

Share this post


Link to post
Share on other sites

Alright. I suppose I should just reinstall every other program that has dependencies on ALSA then...

thanks for the help.

 

[EDIT: It stil wont work... I hope its not the speakers... and now XMMS doesnt make any noise when it plays and quits when I use OSS. Now alsaconf and aumix wont work]

Edited by sub-zero

Share this post


Link to post
Share on other sites

The lsmod output shows alsa modules and not oss drivers. Open a console, log in as root and type: service alsa status. If alsa is not running type: service alsa start (do this with every sound application closed, including kmix in the systray). Now logout as root and type: alsamixer. Unmute every channel and you should have sound again.

Share this post


Link to post
Share on other sites

I figure out what's wrong. Something is wrong with my 2.1 speaker system.

I figured out what it is. They have a messed up headphone jack. I had my headphones plugged in two nights ago and when I took them out, I forgot to check if the headphone jack had properly dislodged. (It acts as if there's headphones plugged in even though I take them off).

 

I've had this problem for 8 months now, and I forgot that all I had to do was plug my heaaedphones in and out. Boy I feel stupid.

 

Thanks for the help though. Now I know what to do when ALSA breaks. XP

Share this post


Link to post
Share on other sites

And if it's not started, it could be service is not enabled. So to enable:

 

chkconfig alsa on

 

else you have to manually start at each bootup.

Share this post


Link to post
Share on other sites
I've had this problem for 8 months now, and I forgot that all I had to do was plug my heaaedphones in and out. Boy I feel stupid.

:lol2:

 

I laugh with you, not at you ;). A few years back I was having trouble with my 5.1 speaker system, the back speakers weren't outputting any sound. Went through a bunch of things to try to fix it, just to find out the speakers themselves had gone bad :D

Share this post


Link to post
Share on other sites

Installed LE2005 on my old dual processor Compaq5100 on Saturday. As always Sound card configure showed "Configure later",so whats new 9.0 and 9.2 and 10.1 all did the same. Only difference was sndconfig brought up some other app which did not find the onboard ESS1868, Messed about trying to sort this out - gave up as bad job and went to bed. Who needs sound when you are deaf and wearing hearing aid. Music sounds tinny from everything. Googled for kudzu this am and got a link from LinuxCompatiblle.org

and lo and behold we now have SOUND.. Hooray for Linux and all its many flavours..:-))

 

Phil from Frome. UK

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...