Jump to content

How I Got Wireless Working with ndiswrapper


Recommended Posts

thanks for posting that. however, my HP nx9030 has a on-off button for the internal intel 2200. apparently this tell the card to switch the "radio" on and off.


i'm aware of rfswitch, but the instructions on usage are confusing. anyone else manage to figure out how to switch their card "on" and "off" via software?

Link to comment
Share on other sites

  • Replies 78
  • Created
  • Last Reply

Top Posters In This Topic

For those people who have a ACX111 or ACX100 based WiFi NIC, the 10.1 MDK have intergrated a very old module of the ACX100/111 sourceforge project driver in the module, you will need to remove them before setting up ndiswrapper


I am not sure about whether this will remove it entirly or the symlink still exist:


rm /lib/modules/`uname -r`/kernel/3rdparty/acx100/acx100.ko.gz


Source - http://www.houseofcraig.net/acx100_howto.php

Link to comment
Share on other sites

  • 3 weeks later...

This is off of my little BB, and should possibly work with other .INF drivers (case sensitive when naming your driver to install) that might help some.


I bought myself, quite a while back, an Acer Aspire 1500 notebook. Under Linux, trying to get the wireless adapter to work, was a pain, especially using the ndiswrapper or Linuxant driver. So I'm posting this doc to show how I got it working quite well. It should also work on other notebooks with a similar adapter (and possibly even different adapers). Hope it helps someone.







Installing Wireless Broadcom driver on the Acer Aspire 1501


Mandrake 10.1


This set up is for a static IP (use an address outside of your wireless routers DHCP range - set up your router according to it's specs)






1. If not already installed, install ndiswrapper-0.9-1mdk rpm package from the Mandrake CD. (You can try newer versions, but ndiswrapper 0.12 had some issues for myself so, I went back to the original. It works fine.)

2. Get the BCMWL5.inf file and the BCMWL5.sys files from a windows distribution. Copy them both into the same directory. For our purpose it will be /install.

3. Run... ndiswrapper -i /install/BCMWL5.inf. (The files and commands are case sensitive so see how it was copied in with a ls of the /install directory- use your own path here to wherever you copied the file to.)

4. Run... modprobe ndiswrapper

5. Run... iwconfig wlan0 essid ESSID - ESSID = your wireless routers id name here . - eg. DLink

6. Run... iwconfig wlan0 key restriced XXXXXXXXXX - use this if you use WEP - eg. 2E456A874C - if need be for your routeer add more iwconfig lines in this section

7. Run... ifconfig wlan0 XXX.XXX.XXX.XXX up - use your IP here

8. Run... ndiswrapper -m


9. Edit your /etc/rc.d/rc.local and add all of these lines to the end of the file


modprobe ndiswrapper

iwconfig wlan0 essid ESSID - ESSID = yourroutersidnamehere

iwconfig wlan0 key restriced XXXXXXXXXX - use this if you use WEP

ifconfig wlan0 XXX.XXX.XXX.XXX up - use your IP here

route add -net YYY.YYY.YYY.YYY netmask gw ZZZ.ZZZ.ZZZ.ZZZ dev wlan0

route add -net netmask gw ZZZ.ZZZ.ZZZ.ZZZ dev wlan0

route del -net netmask dev eth0


XXX.XXX.XXX.XXX = your IP you want to assign - eg.

YYY.YYY.YYY.YYY = your routers network - last number is always 0 - eg.

ZZZ.ZZZ.ZZZ.ZZZ = your routers LAN IP number - used for the gateway - eg.







That's it. Reboot. Should be able to connect to the internet.


DHCP was not used for the wireless adapter cause it failed.


If you need to connect with the actaul built in ethernet card, you will need to either use a script or manually delete/comment/uncomment the last route command in the rc.local file. Of course make sure you actually configured it. You may then need to also uncomment the route add line above too. It'll slow down requests having the 2 gateway routes.


Of course you can just write a shell script or even at a terminal prompt type out the route add/del commands as needed without reboots.


Trying to add the card in as an actual loadable module, etc, would intermittently cause a whole bunch of non-working issues, so the adding it to the rc.local file seemed to be the fastest and easiest with the least amount of problems.


This should also work on other distros as all of the files needed, used or edited are all the same.


That's it.



Edited by User
Link to comment
Share on other sites

  • 2 weeks later...
Guest JAllison

This is a very useful thread, but I can't get too far getting the embedded wireless in my Compaq Presario 3050 working.


I just recently installed Mandrake 10.1. When I saw that I couldn't wireless going with the system config, I sought out ndiswrapper on the net. I downloaded it and attempted to get things going. However I can't get it to build. The output I get is shown below. Anyone have a thought on how to fix this? Thanks.



[root@Marlowe ndiswrapper-0.12]# make install

make -C driver install

make[1]: Entering directory `/home/jallison/ndiswrapper/ndiswrapper-0.12/driver'



WARNING: Kernel seems to have 4K size stack option (CONFIG_4KSTACKS) removed; many Windows drivers will need at least 8K size stacks. You should read wiki about 4K size stack issue. Don't complain about crashes until you resolve this.



make -C /lib/modules/ SUBDIRS=/home/jallison/ndiswrapper/ndiswrapper-0.12/driver \



make[2]: Entering directory `/usr/src/linux-2.4.27-0.pre2.1mdk'

make -C /home/jallison/ndiswrapper/ndiswrapper-0.12/driver CFLAGS="-D__KERNEL__ -I/usr/src/linux-2.4.27-0.pre2.1mdk/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -pipe -mpreferred-stack-boundary=2 -march=i586 -DMODULE -DMODVERSIONS -include /usr/src/linux-2.4.27-0.pre2.1mdk/include/linux/modversions.h" MAKING_MODULES=1 modules

make[3]: Entering directory `/home/jallison/ndiswrapper/ndiswrapper-0.12/driver'

make[3]: *** No rule to make target `modules'. Stop.

make[3]: Leaving directory `/home/jallison/ndiswrapper/ndiswrapper-0.12/driver'

make[2]: *** [_mod_/home/jallison/ndiswrapper/ndiswrapper-0.12/driver] Error 2

make[2]: Leaving directory `/usr/src/linux-2.4.27-0.pre2.1mdk'

make[1]: *** [default] Error 2

make[1]: Leaving directory `/home/jallison/ndiswrapper/ndiswrapper-0.12/driver'

make: *** [install] Error 2

Link to comment
Share on other sites

Here's an obvious hint: keep a separate copy of the files you have changed.


I've been off the net for a couple of days trying to debug what happened after running Mandrake Update. It turns out (it seems) that it overwrote my copy of /etc/sysconfig/network-scripts/ifcfg-wlan0, as painstakingly set up according to the instructions in the first post of this thread.


Of course, I'm now happily back in contact with the rest of the world. A minor annoyance, but an annoyance nonetheless.

Link to comment
Share on other sites

Guest milwater

Since I've got a new wireless usb nic, it seems that this ndiswrapper not support yet, or anything I did wrong..?


here is the ndiswrapper-buginfo:


-rwxr-xr-x  1 root root 27852 Feb  3 11:31 /sbin/loadndisdriver

-rwxr-xr-x  1 root root 20544 Feb  3 11:31 /usr/sbin/ndiswrapper



Linux version 2.6.10-1mdk (apatard@n1.mandrakesoft.com) (gcc version 3.4.3 (Mandrakelinux 10.2 3.4.3-3mdk)) #1 Fri Jan 14 14:31:03 CET 2005

kernel sources are in /lib/modules/2.6.10-1mdk/build


gcc --version:

gcc (GCC) 3.4.3 (Mandrakelinux 10.2 3.4.3-3mdk)

Copyright © 2004 Free Software Foundation, Inc.

This is free software; see the source for copying conditions.  There is NO



installed drivers:


total 240

drwxr-xr-x  2 root root  4096 Feb  3 11:41 zd1211u

-rwxr-xr-x  1 root root 237568 Feb  3 11:35 zd1211u.sys



total 256

-rw-r--r--  1 root root    292 Feb  3 11:33 0586:3401.0.conf

-rw-r--r--  1 root root 237568 Feb  3 11:33 zd11uxp.sys

-rwxr-xr-x  1 root root  12943 Feb  3 11:33 zd1211u.inf

Not reloading ndiswrapper...


IPv6 over IPv4 tunneling driver

eth0: no IPv6 routers present

cdrom: This disc doesn't have any tracks I recognize!

cdrom: This disc doesn't have any tracks I recognize!

usb 5-1: new high speed USB device using ehci_hcd and address 3

ndiswrapper version 1.0 loaded (preempt=no,smp=no)

ndiswrapper (import:238): unknown symbol: ntoskrnl.exe:KeDelaaUxecutionThread

ndiswrapper (load_sys_files:450): unable to prepare driver 'zd1211u'

ndiswrapper (ndiswrapper_load_driver:98): loadndiswrapper failed (11); check system log for messages from 'loadndisdriver'

usbcore: registered new driver ndiswrapper

when i plug the usb nic on, `lspci', it doesn't show out my device. unless i use`lspcidrake', it shows `unknown : ZyXEL|ZyAIR G-220'.

My USB NIC is Zyxel ZyAIR G-220, and seems do not support the origin zd1211 driver.


Any idea? :oops:

Link to comment
Share on other sites

Guys, many of you know I have been battling with ndiswrapper for a long time, and now I have a breakthrough after many night of knoppix and mephis. :juggle:


The reason I can't set the WiFi in linux properly is due to the iwconfig is not taking any essid I entered, so I wonder whether it is something to do with the encryption method for the WiFi. :help:


I changed from WEP64, to WEP128, to WPA, still no successes, but about one hour ago I decide is time to see what happen if I use "open" instead of "restricted" in "iwconfig wlan0 key restricted XXXXXXXXXXXX". And BINGO!!! :thumbs:


The iwconfig found my WiFi AP essid, however for some reason when ever I use the DHCP client or ifconfig in knoppix it will hang the system, but in mephis it works without a problem!!! And I am currently posting this message in mephis using wg311v2 windows driver load with ndiswrapper in the latest mephis live cd!!! :twisted:


I will install the MDK 10.1 back on to my system and give it a try, but might move on to Debian :jester:



Edited by stevenyu
Link to comment
Share on other sites

  • 2 weeks later...
Hello everyone!


I just got a RTL8180 chip to work in Mandrake 10.


I noticed that everyone is talking about only being able to enter 10 digits.  Well I typed all 26 hex digits of my key in using iwconfig key XXXXXXXXXXXXXXXXXXXXXXXXXX and poof it worked.  So the whole thing saying that it only accepts 10 hex digits is a little foobar.


Second I suggest using the source code version of ndiswrapper.  I found it to work very well over the packaged ndiswrapper.


Also for some reason wireless-tools is not installed by default (go figure)  You'll have to go into the Mandrake Control Center and Install that Package.  Should be on CD1 if you wish to do it by hand.


I did not find any of the GUI tools to be at all helpful and sometimes they would go into the config file I just made and overwrite some of the stuff I entered.


Also!!!  I almost forgot.  You should follow the instructions given to you by the srouce code INSTALL file.


1)  make install


then find the INF file and


2) ndiswrapper -i /$THE_PATH_TO_YOUR_INF_FILE/someinf.inf


For some crazy reason (something about how Mandrake implements lspci and it's functions in perl) you can not use ndiswrapper -l (well you can but there is a big mess behind it.)  Besides ndiswrapper -l should not do you any good.  It just tells you what you can find in /etc/ndiswrapper/


3) modprobe ndiswrapper


check dmesg to see if the device was found


4) iwconfig all of your stuff ESSID and KEY


5) if you are using dhclient then dhclient wlan0




5) ifconfig wlan0 <ipaddress> netmask <somenetmask>


That should allow you to ping the router and then you can setup all of your DNS info and gateway to ping the internet.




I just got MandrakeLinux 10.1 official and installed it on my HP zx5000 that has the Broadcom wirless G (bcm94306) and setup my system as the first post said and got the same message as you.


Did you ever get it working and if so how? This is my first Linux experience and would love to get the wireless option working. Also this notebook has the switch to turn on/off the radio in the wireless which I heard was software related. How do I go about getting that to work in linux?

Link to comment
Share on other sites

  • 3 weeks later...
Guest LordJaffa

I just recently got Mandrake 10.1 and i've gradually made my way through the configuration process of the drivers for my belkin f5d7000

fortunately for me it seems to be labeled as the same as beesea's (BCM94306, 14e4:4320). i've installed the drivers, but i'm running up against a bit of a problem when i try to modprobe Ndiswrapper.

it always comes up with "Fatal error: could not find Ndiswrapper module" or something similar and if i add the

alias wlan0 ndiswrapper
install ndiswrapper /sbin/modprobe --ignore-install ndiswrapper && { loadndisdriver 14e4 4320 /etc/ndiswrapper/bcmwl5.sys /etc/ndiswrapper/bcmwl5.inf; }

part into modprobe.config then i get another fatal error saing that it cannot use the install directiory.

i know this is probably something i've done wrong being a linux newbie. i just want a shove in the right direction because i've got stuck at this part :wall:

(iwconfig also says it cannot find a wireless conection)


any help would be appreciated please and thankyou

Link to comment
Share on other sites

Try the above in my previous post. It is specifically for the Broadcom wireless adapter (the aspire has the 94306 chip in it.)


You will need the 2 files BCM...


Uninstall the ndiswrapper (if you used a newer one and retry installation of the one that is on the linux CD).


You can also use Linuxants driver install, and those 2 BCM* files.

Link to comment
Share on other sites

im trying to set up a Netgear WG115v2 card and im getting an error when doing modprobe. I used the driver files from the website linked to in the README directions rather than the ones off my CD, but even the included ndiswrapper directions say that you should use those drivers because the ones on the CD could cause crashes and other problems. anyways. this is the error i get when i run modprobe ndiswrapper:


[root@localhost ndiswrapper]# modprobe ndiswrapper
loadndisdriver: loadndisdriver: main(629): version 1.1 doesn't match driver version /etc/ndiswrapper/wg511v2/wg511v2.sys
FATAL: Error running install command for ndiswrapper


does this mean that the drivers on this site are outdated and wont work with this newer version of ndiswrapper?


id also like to point out that the light on my card is now flashing, which it wasnt doing before (no lights were working). also when i run iwconfig i get this message, which leads me to believe that it might be working anyways.


[root@localhost wg511v2]# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

sit0      no wireless extensions.

wlan0     IEEE 802.11b  ESSID:off/any
         Mode:Managed  Channel:0  Access Point: 00:00:00:00:00:00
         Bit Rate:1Mb/s   Sensitivity=-200 dBm
         RTS thr:2346 B   Fragment thr:2346 B
         Encryption key:off
         Power Management:off
         Link Quality:100/100  Signal level:-78 dBm  Noise level:-256 dBm
         Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
         Tx excessive retries:0  Invalid misc:6   Missed beacon:0


------ edit ------


nope. its not working. please help.

Edited by abbot
Link to comment
Share on other sites

  • 4 weeks later...
Guest brianwc
Since I've got a new wireless usb nic, it seems that this ndiswrapper not support yet, or anything I did wrong..?


here is the ndiswrapper-buginfo:




installed drivers:


total 240

drwxr-xr-x  2 root root  4096 Feb  3 11:41 zd1211u

-rwxr-xr-x  1 root root 237568 Feb  3 11:35 zd1211u.sys






when i plug the usb nic on, `lspci', it doesn't show out my device. unless i use`lspcidrake', it shows `unknown        : ZyXEL|ZyAIR G-220'.

My USB NIC is Zyxel ZyAIR G-220, and seems do not support the origin zd1211 driver.


Any idea?  :oops:


You're using the same USB Key as me and there's no reason to use ndiswrapper because there is now a free software driver for zd1211-based adapters. See http://sourceforge.net/projects/zd1211 and how I got the G-220 working at http://www.sharealike.org/index.php?m=200503

Link to comment
Share on other sites

  • 2 months later...
If you're having issues with a particular part of my guide I'd be glad to help, just let me know what the problem is.

:help: I'm using 10.1 and a Linksys WPC-11 version 4 card, and the brick wall I hit is when loadndisdriver responds with "main(616): version 1.0 doesn't match driver version 8180"


I downloaded the driver for XP from RealTek, so it's the right version, and "ndiswrapper -l" does show "net8180 driver present, hardware present"


Is there some other step that's missing? Is the XP edition the wrong driver?


Finally, and maybe most important of all, RealTek's own downloads page lists a real endorsed vendor driver for Fedora 3! Has anyone tried modifying this driver for use with Mandrake?

Edited by teledyn
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...