Jump to content
dude67

Huawei E367 not detected in Mageia [solved]

Recommended Posts

My ISP sent me a Huawei E367 3G usb-dongle. I've never used one before, so this is all new to me. In my laptop (ACER w/ Mageia1 - see my sig) it was just Plug&Play. It works very well, no problem. It was correctly detected as a 3G modem.

 

Now in my wife's notebook it's a different story. The dongle will not be correctly detected as a 3G modem, but instead a CD-Rom drive. I've tried with Network Center and with Network & Internet Configuration tool. All it says is that no devices detected.

 

In my laptop, where it's detected correctly, it is detected as USB ID 12d1:1506.

$ sudo lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 0bda:0158 Realtek Semiconductor Corp. USB 2.0 multicard reader
Bus 001 Device 003: ID 5986:0105 Acer, Inc
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 008: ID 12d1:1506 Huawei Technologies Co., Ltd.
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 002: ID 046d:c526 Logitech, Inc. Nano Receiver
$

But in the notebook it is detected as USB ID 12d1:1446 (w/ additional note: E1552 (HSPA modem))

$ sudo lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 007: ID 058f:6387 Alcor Micro Corp. Transcend JetFlash Flash Drive
Bus 001 Device 004: ID 174f:5933 Syntek
Bus 001 Device 008: ID 12d1:1446 Huawei Technologies Co., Ltd. E1552 (HSPA modem)
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 002: ID 0a5c:2151 Broadcom Corp.
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
$

 

How can I get this detected correctly in the notebook?

 

 

[moved from Hardware by spinynorman]

Edited by dude67

Share this post


Link to post
Share on other sites

Found in the Mageia-forum more messages concerning Huawei-3G-dongles.

And for the Huawei E367, there is this one topic:

https://forums.mageia.org/en/viewtopic.php?f=25&t=732&p=5355&hilit=huawei#p5355

 

Hope it gives you some useful information.

Sorry, can not do better than this.

Share this post


Link to post
Share on other sites

Thanks Isadora.

 

It may be that the kernel versions differ - at least I know that for some reason my laptop has a server kernel version (I don't know why). I'll check that at home.

Share this post


Link to post
Share on other sites

These are the kernels. I don't think it's about the kernel version as someone suggested in that thread.

 

Laptop: 2.6.38.8-server-6.mga

netbook: 2.6.38.8-desktop-8.mga

Share this post


Link to post
Share on other sites

OK. Finally I managed to make the system recognize the dongle!

 

I did a whole bunch of things, but in the end I did this:

# usb_modeswitch -c /usr/share/usb_modeswitch/12d1:1446

 

The only problem I still have with this is that I seem to need to do that all over again if I detach the dongle at any time. How can I make that choice to stick? Or is it something that I need to run (always as a root) whenever I (or my wife) plug it in?

Share this post


Link to post
Share on other sites

Try installing usb-modeswitch (if that package name exists for Mandriva). This is because some USB devices are known as "zerocd" so that when you plug it in in Windows, the drivers can be installed, and so the USB device appears as storage. Installing usb-modeswitch solves this problem, and will save you writing UDEV rules, or amending them.

 

Easier option :)

Share this post


Link to post
Share on other sites

Ian: I do have usb_modeswitch installed. But still it seems I need run that command again each time I plug the dongle back in.

Share this post


Link to post
Share on other sites

Is there a usb-modeswitch-data package? I have this under Debian/Ubuntu based systems, maybe that would help.

Share this post


Link to post
Share on other sites

Is there a usb-modeswitch-data package? I have this under Debian/Ubuntu based systems, maybe that would help.

usb_modeswitch requires usb_modeswitch-data so you can't have one without the other.

 

This is for Ubuntu but shows you how to make a udev rule for your modem.

 

Edit: I forgot the link :wall:The link

Edited by K Bergen

Share this post


Link to post
Share on other sites

I don't know if what I did was done correctly. It didn't help, so could someone see there's something wrong with this. I want this dongle to automatically be recognized as a modem instead of harddrive or cd rom.

 

I wrote a new rule to udev. Should this rule automatically run the command whenever this dongle is plugged in?

# cat /lib/udev/rules.d/huawei_e367.rules
SUBSYSTEM=="usb",SYSFS{idProduct}=="1446",SYSFS{idVendor}=="12d1",RUN+="usb_modeswitch -c /usr/share/usb_modeswitch/12d1:1446"

Share this post


Link to post
Share on other sites

A shot in the dark as I don't have anyway to test but do you have file /etc/usb_modeswitch.conf on the problem computer and if so what are the contents of said file.

Edited by K Bergen

Share this post


Link to post
Share on other sites

I don't know if what I did was done correctly. It didn't help, so could someone see there's something wrong with this. I want this dongle to automatically be recognized as a modem instead of harddrive or cd rom.

 

I wrote a new rule to udev. Should this rule automatically run the command whenever this dongle is plugged in?

# cat /lib/udev/rules.d/huawei_e367.rules
SUBSYSTEM=="usb",SYSFS{idProduct}=="1446",SYSFS{idVendor}=="12d1",RUN+="usb_modeswitch -c /usr/share/usb_modeswitch/12d1:1446"

 

Maybe try formatting the same as the guy in the link that was provided by Ken, does it work any better?

 

SUBSYSTEM=="usb",SYSFS{idProduct}=="1446",SYSFS{idVendor}=="12d1",RUN+="/lib/udev/modem-modeswitch --vendor 0x12d1 --product 0x1446 --type option-zerocd"

 

do you have modem-modeswitch on your system? Or maybe you need to put the full path to usb_modeswitch. And is /usr/share/usb_modeswitch/12d1:1446 a file? Just curious.....

Share this post


Link to post
Share on other sites

K: Here's the file. I've added my modem version to the conf file:

 

$ cat /etc/usb_modeswitch.conf
# Configuration for the usb_modeswitch package, a mode switching tool for
# USB devices providing multiple states or modes
#
# This file is evaluated by the wrapper script "usb_modeswitch_dispatcher"
# in /usr/sbin
# To enable an option, set it to "1", "yes" or "true" (case doesn't matter)
# Everything else counts as "disable"


# Disable automatic mode switching globally (e.g. to access the original
# install storage)

   	DisableSwitching=0


# Enable logging (results in a extensive report file in /var/log, named
# "usb_modeswitch_<interface-name>" (and probably others)

EnableLogging=1

DefaultVendor= 0x12d1
DefaultProduct=0x1446

TargetVendor=  0x12d1
TargetProductList="1001,1406,1446,140b,140c,1412,141b,1433,14ac,1506"

CheckSuccess=20

MessageContent="55534243123456780000000000000011062000000100000000000000000000"

 

Ian: there is no file "/lib/udev/modem-modeswitch". I just changed that to what was working for me in Mageia1. Do you think it would make a difference?

 

 

In Mageia the usb_modeswitch data files are at /usr/share/usb_modeswitch/ directory (all different types having their own files like /usr/share/usb_modeswitch/12d1:1446

 

$ cat /usr/share/usb_modeswitch/12d1:1446
########################################################
# Huawei, newer modems

DefaultVendor= 0x12d1
DefaultProduct=0x1446

TargetVendor=  0x12d1
TargetProductList="1001,1406,140b,140c,1412,141b,1433,14ac,1446,1506"

CheckSuccess=20

MessageContent="55534243123456780000000000000011062000000100000000000000000000"

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...