Jump to content



Recommended Posts

I have tried unsuccessfully, to set up a dhcp server giving out tcp/ip addresses to 5 computers on my home network. The server is also the gateway to the internet. One box runs Mandrake 9.2 the server also is running that, and the rest are running win 98 and 2000.


I have tried using drakwizard which says that I have been successful insetting up a dhcp server. Nope, doen't work! I have tried using webmin, but again it doesn' t work!

I don' t really know what I am doing although I have some basic understanding.

I have set up the server with a static ip of

Yet within webmin, it says I have a subnet of ?????????????????

At this stage dhcp server started but the rest of the boxes didn't get their tcp/ip addresses.

So, I changed the subnet from to and now the dhcp server won't even start!

I wanted the domain to be called kowbouys but it called it localhost.


HELP I am getting brain addled. I have been at this for 3 days.

If you can at least send me to a tutorial I will be pleased, but I canot even find one of those.

Link to comment
Share on other sites

i would suggest you do some reading on setting up a dhcp server. you basically set the server to your router. that ip address is that of your router. the subnet is also that of your router. changing it from to wont help.

Link to comment
Share on other sites

Also check your firewall settings, it is possible that your other computers cannot connect to the dhcp server because your firewall is blocking it. Turn your firewall off completely and then if it works, start looking at ipchains, etc.

Link to comment
Share on other sites



I don't have a router. I have a 8 port switch. I thought that that was all that I needed. Mmmm, I noticed within the settings of squid or the dhcp settingsthere was a setting that asked "do you want this to act as a router"

Mightthat work??


The squid proxy setup is confusing too but I am reading up a bit on that. Does anyone know where there is some tutorial on setting up a dhcp network. Be buggered if I can find one.


Thanks so far.

Link to comment
Share on other sites


1) How many NIC's do you have (ethn)

2) Are you also connected to the internet ? or is this a completely internal NW.


'The server is also a gateway to the internet'

The Mandrake setup uses shorewall. Shorewall documentaiton says 'DO NOT USE THE SAME HUB/SWITCH for the internet as the internal NW'



Changing your hostname REQUIRES a REBOOT. Probably stops the dhcpd from starting. Alt (but not officially recommended it from Init 1 to echo the new hostname to /etc/hostname)



I say this a lot BUT.....

I honestly recomend you go tot he shorewall site. Read the docuemntaiton for Mandrakeusers and then do as they suggest and overright ALL the Mandrake settings.


This WAY REQUIRES a second NIC.... The mandrake way doesn't. I couldn't make the mandrake one work for me after a weekend and then solved it in 10 mins with the shorewall 'quickstart'


Go and have a read and see if it makes sense....

Link to comment
Share on other sites

Thanks I'll give it a go gowator!


I do seem to have it up and running now, but it is a little sloooow!


My setup is. The server is a gateway to the net via a usb adsl modem. It runs on a eciadsl driver and doesn't even show up as a eth(anything)

I then have one nic for the network going through the switch with the other 5 boxes hooked up to that.

As I understand what you have said, I should not fit into the classification that you spoke about. Is that right??


The immediate problem that I had was the static address on the server (I think) I changed it from to I made the gateway on the other boxes Then, the problem seemed to be the squid proxy settings. I fiddled around with them, and bingo, it is working.


NOW, I have to work out how to access the server from my other mandrake box as I want to be able to save, write files to the server from my other mandrake box as well as update via urpmi as well. Can I do that or am I 'dreamin'???


Then, after all that..... a mail server. God help me! and you guys too hopefully!!!


thanks so far

Link to comment
Share on other sites



I had shorewall set up on both my Mandrake boxes, which led me to drop the one which was a client. Everything seems to be working now on the two Mandrake boxes but I CANNOT get the win2k box on the net!

The win2k box can see all the computers in network neighbourhood and acces them all including the server. I have the proxy settings correct in Internet Explorer, but it just can't get on. It goes to connect, says it found the site, but just fails to connect.

I have the understanding that the win2k box connect to the network via samba. But how does it share an internet connection??????????????????????????



Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...