Jump to content

Got a New PC [solved]


Recommended Posts

Splashed out and got myself a built for me computer comprising of :-

Tower Case

Processor AMD Athlon X2 3000GHz/2MB cache

Ram 4GB Dual DDR 800MHZ

Motherboard ASUS M4N Dual DDR2

USB x 6

250 GB ata Hard Drive with 8MB cache

Graphics Nvidia Geforce 8400GS Pci Express

Sound card Onboard 6 Channel (5.1) High Def : More on this later

Memory card reader 52 in 1

And of course Mandriva 2010 OS.


What can I say but it flies.


The only downside is the sound card. I have been busy with google and there seems to be plenty of problems but no conclusive answers.

The card is recognised as requiring the snd_hda_intel driver. Without Pulse I can get the sound working of a fashion. The Line input doesn't work, and can't seem to arrange a Master volume control for kmix.

I have a feeling that the sound card may be a bit advanced for the Linux Kernel. I'll keep digging and hopefully come up with a solution. In the mean time if anyone has ideas as to what can try I will be grateful. Thank you in advance.


02:00.0 VGA compatible controller: nVidia Corporation GT200 [GeForce 210] (rev a2)
02:00.1 Audio device: nVidia Corporation Device 0be3 (rev a1)

The relevant lines from lspci. Rather cryptic Audio Device clue :huh:

Edited by SilverSurfer60
Link to comment
Share on other sites

Sound chip-set for the M4N78-AM: VIA VT1708S (6 - Channel)

Edited by JillSwift
Link to comment
Share on other sites

Thank you for that Jill, however I keep going in circles and end up with the system chosen snd_hda_intel.

This works somewhat but some of the channels are mapped to the wrong volume control and regardless the 'Line' channel does not work at all. I have (a rather ancient) tv card, brooktree, which works fine and I have to take an internal connector from this card and use the CD connector on the main board. The downside to that is I can't play CD's without going in to the box and swapping the cables about.

As you can imagine there are a number of remedies out on the net, but not one is a definitive answer. It does appear as though I may have to wait for Alsa to catch up with the times.

Link to comment
Share on other sites

It would appear that I have libalsa2 installed. I have just compiled and installed a new release of alsa version 1.0.22 from the website. There is a slight increase in volumes, yet the channel map is the same. I have found that I don't actually need a sound input to the main board from the cdrom to provide sound from an audio cd. :unsure: They still play without one.

Link to comment
Share on other sites

Can you filter dmesg to see if there is anything there.


dmesg | grep -i alc


replace alc with intel as well as snd, and see if we can find out if something is amiss. I had problems with sound on a Toshiba laptop, which showed a problem with a codec. Although maybe nothing will show, and then that'll make it hard.

Link to comment
Share on other sites

# lsmod | grep snd
snd_pcsp               10256  1
snd_hda_codec_via      53764  1
snd_seq_dummy           2984  0
snd_hda_intel          26144  2
snd_seq_oss            30368  0
snd_seq_midi_event      7428  1 snd_seq_oss
snd_seq                52528  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7600  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            38208  0
snd_hda_codec          86048  2 snd_hda_codec_via,snd_hda_intel
snd_hwdep               7752  1 snd_hda_codec
snd_pcm                78024  4 snd_pcsp,snd_hda_intel,snd_pcm_oss,snd_hda_codec
snd_timer              21836  2 snd_seq,snd_pcm
snd_mixer_oss          16644  1 snd_pcm_oss
snd                    62564  19 snd_pcsp,snd_hda_codec_via,snd_seq_dummy,snd_hda_intel,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer,snd_mixer_oss
soundcore               8128  1 snd
snd_page_alloc          9452  2 snd_hda_intel,snd_pcm

The modules seem to be loaded. I have not tried running OSS yet.

Link to comment
Share on other sites

Blacklist the module snd_pcsp and try again.

I had some trouble with it in my laptop, but somehow this module doesn't exist anymore in the stock Archlinux kernels. Funnily enough, I can see it being present at the Mandy ones, although I'm pretty sure it's deprecated (most likely as a potential troublemaker).

The above blacklisting may fix the "azx_get_response timeout" dmesg, which shouldn't happen.

Edited by scarecrow
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...