Jump to content

Samsung NC20 with Mandriva 2010


Recommended Posts

One discovery is the Aurorae theme decoration engine which can be found under System Settings>Appearance>Windows. As well as providing a number of very slick window styles this rendering engine seems to out perform the older native window styles. The themes which do not require window transparency are noticeably quick such as the Chrome like styles. I settled for the Chrome Greyscale which provides nice shiny curved window headers. You can adjust these themes under /home/myhome/.kde4/share/apps/aurorae/themes/ and probably /usr/share/themes/Aurora/gtk-2.0/ .


Though the Aurora themes seem to work OK. I added gtk-aurora-engine from the 2010.1 MIB repos choosing the version 1.5.1. Again difficult to measure but this may explain the improved rendering performance.

Edited by CxOrg
Link to comment
Share on other sites

  • Replies 50
  • Created
  • Last Reply

Top Posters In This Topic



Your experience and helpfulness in posting here has made me think about getting a netbook - primarily because I like the idea of portability versus a laptop. Although currently, I'm still using a laptop because here where I live in Poland, the price for a netbook is still really expensive compared to getting a laptop.


However, I'm considering it for my wife when she's due for a replacement :) I just doubt she'll be too enthusiastic about Linux although I've been pushing it for ages because she just causes too many problems with Windows.

Link to comment
Share on other sites

You are right. I have found the larger 12" screen NC20 (Netbook?) both more usable and portable especially while travelling. There are now a number of options with this spec now including Intel Atom powered machines.


I will be interested to see when the dual core Nano ships in a netbook. The single core does suffer slowdowns due to tasks hogging the processor with too many windows open.


The big revelation is Linux (Mandriva) is a better OS than Windows to run on lower powered processors. The trade off is better battery life due to the processor running mostly at its lowest speed.


You may be able to pick up some bargains on Ebay and install any well supported Linux distribution.


Install all the usual applications Openoffice, Chrome, Thunderbird, SMplayer, Amarok, K3B, Gimp, Pidgin, Skype and Wine for running any Windows apps. Any configuration controls which could break anything are safely behind the admin level login so it should not degrade or break in normal use, month in month out.

Edited by CxOrg
Link to comment
Share on other sites

Problems with Nepomuk/Strigi. The KDE search and indexing mechanism. Ever since this feature appeared it seems to have had a mind of its own and worked and then for no apparent reason stopped working. It is not specific to the NC20 installation as I experience it from time to time on all my 3 Mandriva 2010.1 installations. Again from trawling the net for clues as to how it can be fixed I can give you the essential bits which at least repaired my 2 installations where Strigi refused to start.


Essentially we must delete the search database then rebuild the environment.


To be sure we have all the components installed, check you have the following: Search in software manager for "soprano" and check you have all the soprano-plugins installed, common, redland, virtuoso and sesame2 though redland and sesame2 are not used now virtuoso is used exclusively for search and indexing. You should also have a Java package installed, I am using java-1.6.0-openjdk and java-1.6.0-openjdk-devel though I expect the Sun versions also work. It is probably a good idea to only have one or the other OpenJDK or Sun installed.


Then delete the contents of ~/.kde4/share/apps/nepomuk/repository/main/data/ (~ being your home folder). You could simply empty the data files from each data folder. virtuosobackend seems to be the one used.


Rebuild the environment from a terminal session (su) using:


$ kbuildsycoca4 --noincremental


Then reboot


Once KDE is back set the search controls in Configure>Advanced user setings>Desktop Search


Make sure you select only the essential folders you want searched for content otherwise Strigi will be working too much.


I found the desktop search icon appeared in the system tray after a short time.


Credit to this link mostly: http://forum.kde.org/viewtopic.php?f=20&t=84500&start=10

Edited by CxOrg
Link to comment
Share on other sites

Having made the effort to get Strigi/Nepomuk working here is a quick note on finding stuff. It was not obvious to me at the start how this works.


Firstly there is a search bar in Dolphin which will find results from I guess a number of sources. It is not clear how this can be configured.


I have found the desktop plasma command line interface and search bar (Krunner) to be the most useful. This is accessed either through <alt>+<F2> or by the "Run command" context menu item. It is a multi-purpose entry point which can be used for command line entry and search. In the configuration of the bar you can select from many sources one of which is Strigi. This is where it is important to have all the soprano plugins as I found that to search the Amorok music data sesame2 is needed.


I use a small number of sources or the results window is flooded with too many results. Resizing the search bar and results area helps. Experimentation here will give you what you want with the sources. Some seem to cause the plasma panel to crash so test the ones you want to use.


Maybe the display will become more intelligent as in Mac OSX Spotlight grouping the results by source. The "Task" oriented layout is just plain weird so the plain "Command" layout is still better. Lets hope the developers have spotted this already! Integration of a selectable web search engine would be nice.


I have not yet experimented with more complex search terms or regular expressions yet.


So now we have desktop search which at least needed some explanation.

Edited by CxOrg
Link to comment
Share on other sites

The stability of the "Run Command" Plasma panel leads on to this item.


Being bold I followed the following to upgrade KDE from 4.4 to 4.5 http://pbs01.wordpress.com/2010/08/15/install-kde-sc-4-5-on-mandriva-linux-spring-2010/ this upgrade went well it is generally an upgrade with a seemingly improved interface.


One benefit is the Run Command searches are now much more stable. Though 2 things should be noted. The first being many parts of the KDE Control and Configure panels have been updated to make them more logical. Some small things may revert to default. I found that all the power profiles have to have the "CPU and System" "Enable system power saving" checked. This seemed to have affected suspend to ram which failed to complete until I fiddled with these controls. It may be that a fresh set of parameters are written.


The second thing is if you have Window behaviour>moving set to not show its contents when moved for lower video overhead. This no longer works correctly. No doubt this will be fixed. Since 4.5 gives an advantage in desktop speed I have found allowing the contents to be shown and even the desktop effects "Translucency" can be switched on.


In general the upgrade is an improvement so go for it!

Edited by CxOrg
Link to comment
Share on other sites

  • 1 month later...

Things have been running well for a while now. Just a note for anyone who experiences a problem with an application/service which stops working as you would expect.


I had this problem with the VPN control GUI KVPNC. Initially on launching it would crash but not every time then the crash became like a memory leak which filled up the user memory then the swap space before eventually opening. This was not good so to find a solution I tried the pre-compiled RPMs from the KVPNC site. The closest match to Mandriva is Fedora but the resulting app did not match my VPN configurations and the user interface appears to use different display libraries (QT?).


The solution was to rebuild from source. The latest version 9.6 builds using the standard "./configure" then "make" then "make install" commands in a terminal. Take note of any errors in the configure process to add any missing libraries. I needed QT3 and another ARTS then it built OK. The make process seemed to throw up some warnings but these did not prevent it building and then installing. The result is a perfectly working KVPNC which uses all the previous VPN configurations. I use OpenVPN mainly. The impression is it works better than before.


This approach may work for you for other errant applications. These applications may not be fully compliant with KDE 4.5 and re-compiling should make them so.

Link to comment
Share on other sites

Just an update that I am still using the older kernel Any later kernel results in the Suspend to RAM or Disk not working. As I have said before this seems to be a kernel issue. The shutdown scripts complete correctly and pass control to the kernel then with the screen shut down the final sleep state never happens.


I have posted a bug report to the kernel guys some time ago but still no solution??

Edited by CxOrg
Link to comment
Share on other sites

My issues with OpenVPN, OpenSwan and Kvpnc were solved properly when updates arrived for all 3. Updating and restarting and it all works better than ever. Though it is not clear which app was to blame. My compiled version is probably replaced. I prefer to use the distribution version and only compile when I have to. Thanks guys for the fix!

Edited by CxOrg
Link to comment
Share on other sites

  • 4 weeks later...

Having had the time this weekend to do a bit of maintenance I took the time to grab the latest source for the Openchrome video driver (X11). There are a number of small fixes which have taken place since the version released on the Mandriva repos. None of these seem to be relevant to the NC20 Via chipset however on compiling there was a noticeable improvement in speed in applications. It may of course simply be compiling with the actual kernel source used ( and maybe libraries on which KDE depends.


I would recommend following the instructions here Openchrome. The usual "./configure" then "make" then "make install" works fine as long as all the required dev sources are present. I had to copy the resulting driver files (as root) "openchrome_drv.so and openchrome_drv.la" from /usr/local/lib/xorg/modules/drivers/ to /usr/lib/xorg/modules/drivers/ . I could probably have made an entry in the configure file to tell it where they should go. It is probably a good idea to save your current files in case you need to revert to them. Note where they are and where they need to go as if KDE does not start you will have to copy the files at the command console.


Restart KDE and you should be done. I generally reboot the machine to be sure everything works. It is just a pity we don't have 3D rendering with OpenGL and probably never will on this machine. I have an older EeePC 900 with an a Celeron/intel graphics which works great with the rotating cube desktop switch though the processor is no match for the Via in the NC20. I read good things about both the newer dual core Nano and even AMD Fusion. Maybe this will produce some lightweight laptop/nettops for my next linux machine.

Link to comment
Share on other sites

  • 3 weeks later...

Good news a new official kernel has arrived kernel-desktop- and what is more it now works for suspend-resume!!


You may have to search for un-installed kernels and it claims to be the kernel for the forthcoming 2010.2 release. Once it was working I took the opportunity to clean up some of the kernels I don't need leaving only installed just in case. You should remove with the MadWifi module as it is now part of the most recent kernels.


Note: This is an update on a few days ago as I found that the latest kernel was trying to install the older MadWifi module at boot time and failing. Booting on the older kernel then removing the 2.6.36 kernel and reinstalling by adding only the "latest" for installer for both the kernel and the development files. This will ensure the latest is always installed.


Suspend-resume works fine but not the bluetooth at startup. I use my previous method of starting it manually or plugging in a spare USB BT dongle.

Edited by CxOrg
Link to comment
Share on other sites

Just one discovery:


I have tried a few music player apps and settled for Amarok despite its defects. Mostly going into unresponsive states with a large music library accessed across a network.


I've tried Songbird which looks good but will never be completed due to the developers stopping support of Linux. Nightingale may eventually appear which is derived from this as an independent open source intitiative.


In the meantime I've found Audacious which is a straightforward player which is simply based on playlists. For the NC20 it fits the bill being light on resources and uses high quality codecs. It works well with remote libraries saved to playlists and streaming radio URLs also save to playlists. What is more it is being actively developed so the interface and plugins can only get better.


For some reason I had to install initially from a backports version, but once installed it updates to the recent version.

Edited by CxOrg
Link to comment
Share on other sites

  • 2 weeks later...

Problems with bluetooth not starting at boot time with Mandriva 2010.1 or .2

A fix (work around) to get bluetooth to start at login is to add a small script to KDE's /home/myuser/.kde/Autostart folder. This is to unload btusb and reload it. This will not be necessary once btusb loads correctly the first time!


The script which I've called bt-reload should be owned by your user and given execute permissions.

sudo rmmod btusb
sudo modprobe btusb


The next step if you have not done this already is to add yourself to the sudoers list so this file will run using sudo at login. Follow the instructions here http://linux4us.org/sudo.php.


Re-booting should run this script on loading your KDE environment and bluetooth should run as normal. I have re-installed Blueman now I have this fix.


An update to this entry:


I found that the fix above was unreliable and often becoming "most of the time" BT would not start. I have done some more snooping about to find a better fix. I should have remembered this from my days struggling with Xandros on the EeePC.


Simply use /etc/rc.d/rc.local which runs after all other startup scripts have run.


It is in fact bluetoothd which does not run on the initialisation of the internal Broadcom BT device. This should be run according to the udev control processes. See /etc/udev/rules.d/97-bluetooth.rules

# Run helper every time a Bluetooth device appears
# On remove actions, bluetoothd should go away by itself
ACTION=="add", SUBSYSTEM=="bluetooth", RUN+="/usr/local/sbin/bluetoothd --udev"
ACTION=="change", SUBSYSTEM=="bluetooth", RUN+="/usr/local/sbin/bluetoothd --udev"


So using the udev command to run bluetoothd but in rc.local makes sure it does start. So updating it so:

/usr/local/sbin/bluetoothd --udev
touch /var/lock/subsys/local


Probably there will be a fix in the real udev method in these rules. I notice that my aging EeePC900 has no such problem with the BT mouse BT works even in the KDE boot splash screen. If a fix comes through it will show up with the mouse working in this splash screen.

Edited by CxOrg
Link to comment
Share on other sites

In my search for solutions I discovered the latest KDE incremental release KDE 4.5.5 . Not being able to resist an upgrade I configured the repositories from the MIB site. These commands will configure the repos for you. (copied from the MIB site)

urpmi.addmedia --update MIB-KDE455_release http://mib.pianetalinux.org/MIB/2010.2/others/kde/4.5.5/32/release
urpmi.addmedia --update MIB-KDE455_others http://mib.pianetalinux.org/MIB/2010.2/others/kde/4.5.5/32/others
urpmi.addmedia --update MIB-KDE455_updates http://mib.pianetalinux.org/MIB/2010.2/others/kde/4.5.5/32/updates
urpmi.addmedia --update MIB-KDE455_extras http://mib.pianetalinux.org/MIB/2010.2/others/kde/45X-extras/32/
urpmi --auto-select --auto-update
urpmi --auto-select --auto
urpmi --auto-select --auto
urpmi --auto-select --auto
# bye, bye from mikala, NicCo and all MIB Team

These commands remove all the currently configured repos so I would suggest re-adding these using the online site: http://urpmi.mandriva.ru/ . Add the Official Medias and the PLF Medias. The version should be 1010.2 and i586 on the selectors.


This upgrade can take some time and make sure you have some space on your partition where /usr is located. I removed some development applications which I do not use and deleted the application folders which should be in /usr/share. It seemed to need up to 4Gb during download and installation which reduced as the KDE code and applications replaced the old ones. I use the "update system" Draktools panel to perform the update as we get the nice progress bars. KdiskFree gives a nice view on disk space. Install this if you don't have it. Verify that all updates are completed in the "Install and Remove Applications" panel. Again I had to remove some old applications which were blocking the install of some new packages.


It is wise to verify that the boot system will default to the newly installed upgrade though it seems to use the same 2.6.36 kernel as before.


Rebooting offers no great surprises except a much more fluid performance for handling applications and windows. Bluetooth works straight away on boot using a plug in BT dongle however the internal BT device still requires the previous fix to get it going but once launched it does not seem to fail and need re-initialising even after suspend to ram. Suspend to ram works nicely and seems to be a bit quicker to go to sleep.


The conclusion is that this KDE 4.5.5 version is much improved with probably many fixes which contribute to the stability and speed. The internal bluetooth device (Broadcom BCM92045NHD) has been flagged as causing similar problems on other laptops - Acer etc so since it works (after a delay) with the /etc/rc.d/rc.local fix. I can live with that.

Edited by CxOrg
Link to comment
Share on other sites

  • 2 weeks later...

On discovery of the excellent kde4-style-qtcurve to style application windows and features, I became more interested in getting all applications to use this same styling. I had added gtk-qt-engine to get GTK+ applications to take up the main styling but this is problematic and unnecessary when using qtcurve. This installation does add the configuration panel "GTK Styles and fonts". Removing gtk-qt-engine again leaves this control panel in place so that qtcurve can be selected as the GTK style.


The principal application I use is Pidgin which is a GTK+ app so by setting the GTK styles and fonts control panel in system settings qtcurve is available to GTK apps.


If you use Skype it has its own selector for themes in the configuration where qtcurve can be selected,


The last thing was to persuade the KDE/Mandriva "Configure your computer" and "Network manager" to play also with the same theme. Some of the default themes when selected seem to be used. Nothing seemed to work for qtcurve until I realised that these applications are looking in the /root account for the style information.


The modifications made to qtcurve are stored in /home/youraccount/.config/qtcurve/stylerc . These don't seem to be applied to the root account /root/.config/qtcurve/stylerc . So all that needs to be done is to copy this file from the home account to the root account. I use mucommander (http://www.mucommander.com) started as root though Dolphin started as root or copy in a terminal session (su or sudo) will of course work.


As a starting point you could use my stylerc:



Now most things look consistent in most applications. Wine/Windows apps need to depend on Wine's own basic windows sourced themes. I do not know if this is a bug in the qtcurve control panel which does not also apply the style changes to the root account. It would prompt for a password to do this as the change of login theme does.


The KDE/Mandriva panel has one annoying issue that the left hand selector menu uses a white roll over in this menu and white text so the text disappears on mouse over. If anyone knows how to style this please let me know?

Edited by CxOrg
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...