Jump to content
CxOrg

Samsung NC20 with Mandriva 2010

Recommended Posts

Having chosen Mandriva as my preferred distribution of Linux I found that the install of Mandriva Spring 2010 on the NC20 is mostly painless. It is best if you have an external USB CD drive and you also have a standard Ethernet cable connecting your NC20 to your hub or router and everything will go smoothly. The resulting installation is fully working except the Nano processor frequency control and some aspects of the ViaChrome video driver ie no 3D, problems with screen power saving and external screen support missing or not working. Not many distributions are this complete!

 

PS: I would suggest once the install is complete adding the PLF repos using Easy Urpmi. The Official repos should already be in place with the install. Once all updates are done using these PLF sources then you could add as I have the MIB group repos this will give you access to many other more up to date applications such as Skype. It is best to keep "backport" repos disabled unless you know what you are doing. With these enabled there is a risk of allowing new buggy versions to be installed as updates. You have been warned!

 

I hope to build up a list of fixes for the NC20 and the new Mandriva 2010 Spring (One) distribution.

 

Here is the list so far of problems which need to be fixed:

 

- Frequency scaling of the processor which out of the box runs at 1.5Ghz all the time.

- Find or compile a better ViaChrome9 video driver for passable support for desktop 3D animation. (*)

- Get that driver to work with external screens. (*)

- Get that driver to wake up the back-light after power saving switches off the screen. (*)

- Bluetooth pairing with proper pin exchange.

- Get all the FN keys to work

- The Windows program environment Wine installs OK but freezes the machine on launching Wine. (*)

- Samba does not seem to be functioning even after installing and providing a conf file.?

 

Getting an updated video driver could/should fix the (*) items.

 

Other contributions to make this more complete welcome! Contribute your success with any of these issues or new ones for the NC20 configuration in this topic. Do add any details or variations on these fixes which I have missed!

 

[moved from Laptops etc by spinynorman - welcome aboard :)]

Edited by CxOrg

Share this post


Link to post
Share on other sites

The first problem to solve was the power saving feature of frequency scaling does not work out of the box. We should get frequency scaling with the VIA Nano-U2250 cpu from 851Mhz - 1.702 Ghz depending on the load.

 

The support for frequency scaling has changed in the most recent kernels certainly the latest kernel-2.6.31.13 . The kernel now supports 800Mhz - 1.6Ghz frequency scaling through the kernel module acpi-cpufreq. . I am adding a few notes here so you can migrate gracefully to using this module. It seems we are to be limited to 1.6Ghz and not 1.702Ghz as the maximum speed. It is difficult to tell if the previously reported frequencies were correct or not or we are now to loose about 5% in speed. This in practice is probably insignificant and may trade-off for slightly better battery life.

 

I experienced sporadic behavior you may have experienced any of the following:

 

1) The frequencies reported became the double of what must have been the real frequency.

2) The frequency became fixed at 1.6Ghz

3) Problems at login to KDE4 with an error "Process for Desktop protocol died unexpectedly". Removing the CPU frequency widget seemed to help avoid this.

 

I felt the need to solve the growing problem. I principal replace e_powersaver in the /etc/modprobe.preload file.

 

----------------------------------------------

 

What I did here may not be the only solution but I settled for using the first frequency scaling demon which worked gracefully and worked with the Draktools configuration user panels. It was nice to get the full range from 851Mhz right up to the officially overclocked 1.7Ghz. (Now reported as 800Mhz-1.6Ghz withacpi-cpufreq)

 

I did the following:

 

Modified /etc/modprobe.preload adding the line "e_powersaver". (added acpi-cpufreq and commented out e_powersaver)

 

# /etc/modprobe.preload: kernel modules to load at boot time.
#
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a `#', and everything on the line after them are ignored.
# this file is for module-init-tools (kernel 2.5 and above) ONLY
# for old kernel use /etc/modules
# e_powersaver
acpi-cpufreq
nvram
padlock-aes
padlock-sha
evdev

 

You may find the default file has evdev twice this is probably not necessary and and has been removed. I borrowed starting the power scaling kernel extension in this file from someone's experience with an HP Mini-Note 2133 but his sugestion of using the cpufreqd scaling demon did not work for me.

 

I found "powernowd" to be the only frequency scaling demon to function correctly. cpufreqd and cpydyn did not seem to function other than select 1.7Ghz ie full speed when on mains power. powersave works but is not compatible with the Power management part of System Settings. So these demons and any associated lib files should be uninstalled. (No need for this now with acpi-cpufreq)

 

Then in the handy GUI Draktools Software management make sure these are the only RPMs installed.

 

Software management search on "cpu"

cpufrequtils - 005 - 4mdv2010.0 (not 100% necessary but provides some command line tools)
cpufreq - 1.0 - 32mdv2010.0
libcpufreq0 - 005 - 4mdv2010.0 (used by command line tools) 
plasma-applet-system-monitor-cpu - 4.3.2 - 10mdv2010.0 *

 

Software management search on "power"

plasma-krunner-powerdevil - 4.3.2 - 10mdv2010.0 *
powernowd - 1.00 - 3mdv2010.0 (Again not necessary with acpi-cpufreq)

 

Software management search on "battery"

plasma-applet-battery - 4.3.2 - 10mdv2010.0 *

 

The plasma-applets are included as they should be there by default. During installs/uninstalls and testing of the other demons seemed to have uninstalled the battery-applet.

 

Do a reboot to make sure everything is loaded. Add the system-load-viewer widget to your desktop. It is nice to see the scaling in action. Mousing over it gives the actual frequency details.

 

You may need to adjust your power profiles to use Userspace, Dynamic On Demand or Performance. Use Userspace if you want to control the speed from the command line. Dynamic On Demand seems to work fine for me.

 

I hope this helps users get their NC20s back in good working order?

Edited by CxOrg
applied proper formatting

Share this post


Link to post
Share on other sites

Following the last post I tested the resulting battery life. Not a very scientific test but simply using the usual web applications Firefox and Thunderbird with WiFi switched on. Most of the time the processor was at 851Mhz. I did in fact do 2 re-boots during this time which would have the processor working flat out for a couple of minutes each time. The screen was set to dim after a few minutes as additional power saving. However since the screen blanking fails to wake up the backlight this was disabled.

 

The result was continuous working if not intensive use for 4 hours at which time the battery showed 10% remaining.

 

This I think may be consistent with results obtained by Windows XP users. At least we Linux users are not at any disadvantage here! Screen blanking would improve the on time but of course if the screen cannot be read no real work can be done! Later in this thread screen blanking is restored by upgrading the video driver.

 

Maybe a DVD result would be useful too for comparison.

Edited by CxOrg

Share this post


Link to post
Share on other sites

An update on the video driver:

 

Looking at this I had the option of following some Ubuntu users and compile from Via source with uncertain results or to simply switch to using the OpenChrome project driver. There are also some security concerns with this Via driver.

 

Reading the OpenChrome project site http://www.openchrome.org/trac/wiki/About It seems they are the best hope for a decent driver. However they may not add all the features until they have achieved a good base driver. Switching to using this driver in the Graphical Server setup in Draktools. Select the Unichrome-based cards driver in the "S3" manufacturers branch rather than the default set in "Other". This version is currently 0.2.903 in the Mandriva 2010 repos which is 1 minor release behind the OpenChrome site 0.2.904. I think I may simply wait for their incremental releases to filter through to the Mandriva repos!

 

This driver is certainly pretty good for 2D rendering and plays full screen video (DVD in SMplayer) without any problems or slowdowns. The 3D rendering has still some way to go as the desktop becomes too slow and it lacks support necessary for 3D desktop animation. Of the other features still missing is external screen use. I may experiment with some scripts I wrote for an EeePC (Xandros) for switching and controling resolutions.

 

For the screen blanking power saving not waking up the backlight: From the bugfix list below from OpenChrome we can guess this is a video driver issue and possibly fixed.

Edited by CxOrg

Share this post


Link to post
Share on other sites

Looks like good news!

 

Here are the latest bug fixes in the latest release. Note the backlight fixes and hints at external screen support. So I have started to try to get a compile under 2010 on the NC20 but ran into some dependency issues.

 

Here are the fixes

 

openchrome 0.2.904 (09/10/2009)

-------------------------------

* New features :

- Basic VX855 support.

- VX800 support.

- CX700, VX800 integrated TMDS support.

- ARGB cursor support.

- Panel modesetting code rework.

 

* Bug fixes and enhancements :

- Add checking of the initialization of the XFree86 framebuffer manager.

- Save/restore ECK Clock Synthesizer.

- Fix bug with panel autodetection.

- Fixed problem with backlite (Ticket #308).

- Better VT1625 chipset support.

- Cursor support speedup.

- Fix bug with wrong panel size (Ticket #301).

- Remove build warnings and removed unused variables.

- Unified variable names with RandR.

- RandR initial support.

- Updated manpage.

- Add rotate upside-down and remove "Magic numbers".

- Disable TMDS by default for now, output detection is not working properly.

- Fix hardlock on resolution change.

- Remove loader symbol lists.

- XO-1.5 panel patch and dot clock fixup.

- Switch on LVDS pads only for active channel.

- Modify PLL generation and add VX855 support.

- Fix cursor on secondary.

- Fix a segfault on shutdown in ViaCleanupXVMC when there's no Xv.

- Fix null pointer dereference in viaExaCheckComposite.

- Clean up duplicate defines in via_regs.h.

- Remove VT8454B LCD flag.

- Make sure Chrome9 chipsets use software rasterizer for 3D.

- Cosmetic fix for ViaMMIODisable.

- Fix DFP pad mask.

- Fix possible use of uninitialized variable (ticket#292).

- Fix use of uninitialized variable.

- Fix 2D engine init.

- ViaPanelGetIndex: 1 bugfix and 1 cosmetic fix.

- Set P4M890 primary FIFO.

- Initialize CRTC before a mode switch. Fix bug #260.

- Small bug fixes for XAA and EXA.

- Minor bug fixes and tweaks.

- Remove support for old EXA.

- Fix 2d initialization for P4M900.

- Temporary workaround for freedesktop bug 21563.

- Adjust monitor values to handle preset LCD panel and TV modes.

- Fix placement of pVia->FrameBufferBase to MapFB.

- Clean up compile warnings.

- Fix crash worked around by XaaNoImageWriteRect.

- Restore panel backlight after VT switch (Ticket #29).

- XvMC Unichrome Pro allocation fixes.

- Add more needed modes to ViaPanelModes.

- XvMC symbol visibility.

- Properly link XvMC.

- Hide overlay when video is invisible (ticket #266).

- Allow FullHD with DDR400.

- Add missing 640x480 PAL mode for VT1625.

- Remove support for pre-xorg 7.1rc1 Xv ABI.

 

* New boards :

- Axper XP-M8VM800, Gigabyte M704 / RoverPC A700GQ, IBM AnyPlace Kiosk 3xx,

ECS P4M890T-M v2.0, Foxconn P4M800P7MB-RS2H, Haier A60-440256080BD,

Lenovo S12, Mitac 8624 (w/ P4M890), MSI K8M Neo-V (broken pci id),

MSI P4M900M3-L, Packard Bell Lima (ASUS MBP5VDZ-NVM), Samsung NC20,

Twinhead H12V, Twinhead M6, VIA Epia M700. VIA Openbook, Sharp PC-AE30J.

Edited by ianw1974
applied proper formatting

Share this post


Link to post
Share on other sites

Encouraged by the promise of a number of fixes and improvements I set to to do a compile of the latest release of the OpenChrome driver 0.2.904.

 

Grabed the source from http://openchrome.org/releases/. Choose the latest version in this case xf86-video-openchrome-0.2.904.tar.gz.

 

( PS: This version 0.2.904 is now available directly through the Mandriva repostiories, so users who do not wish to go through the build process can check for this driver as an upgrade in Draktools software management and upgrade if it has not been done automatically The guide below should still help with upgrades in advance of Mandriva's releases )

 

Then following the instructions on http://www.openchrome.org/trac/wiki/Installation

 

Make sure a backup is made of the existing driver

 

   cp /usr/lib/xorg/modules/drivers/openchrome_drv.* /home/

 

I needed to provide the xorg libraries for compilation so install the packages libxorg-x11-static-devel, libxorg-x11-devel, libxorg-x11, x11-proto-devel, libdrm-static-devel and allow the dependencies of these packages to be installed.

 

from their site:

 

    wget http://www.openchrome.org/releases/xf86-video-openchrome-some.version.tar.gz
   tar xvzf xf86-video-openchrome-some.version.tar.gz
   cd xf86-video-openchrome-some.version
   ./configure --prefix=/usr
   make
   sudo make install

 

This should complete without problems and replace the openchrome driver. It may be worth checking the contents of /etc/X11/xorg.conf that the following sections are as follows:

 

Section "Module"
   Load "dbe" # Double-Buffering Extension
   Load "v4l" # Video for Linux
   Load "extmod"
   Load "glx" # 3D layer
   Load "dri" # direct rendering
EndSection

Section "Device"
   Identifier "device1"
   BoardName "S3 UniChrome-based cards with 3D support"
   Driver "openchrome"
   Option "DPMS"
   Option "SWcursor"
EndSection

 

The additional "Option" parameters suggested by the OpenChrome site seemed to degrade performance or even prevent the driver from starting. There is also no need to add DRM as it is already included and up to date in recent kernels.

 

Make sure you are prepared to re-copy the old driver files back from a console if for any reason the xserver interface fails to start. Test the driver in the X-server management control panel and use this to initiate a re-start of the X system. I prefer to force a reboot rather than simply relogging in.

 

The result:

  • The user inteface is smoother and probably quicker with less orphaned window elements which fail to refresh.
  • Wine now runs without freezes of the video.
  • Screen power saving now wakes the backlight.
  • No external screen handling but this is aparently in the pipeline of development for a later release. Xrandr support is anticipated.
  • The transparency effects work without noticable slowdown but I found it is best to use as few of the screen effects as possible to avoid slow-downs in responsiveness. 3D effects/acceleration are not yet working. Compositing set to XRender for now.
  • My suggested list of desktop enhancements which do not slow down the interface are: Window switching - no effect, Desktop switching - no effect, Animation speed - instant, Shadows - None, Compositing - xrender enabled, Login/Logout fade - on, Translucancy - on, Dialogeue parent - on, Desktop grid - on, Present windows - on.

If it helps I have attached my compiled files. These may work for you but only if you have the same NC20 and Spring 2010 (kernel 2.6.31.5-desktop586-1mnb). Compiling may still be more sure.

 

PS: For the adventurous you can go further and compile the current development version from the OpenChrome site. I found the version from 30/11/2009 is a bit quicker but with no noticable new features. There are a string of fixes noted. I'll wait for progress in 3D acceleration and external screen handling before I update again.

driver-openchrome-0.2.904.tar.gz

Edited by CxOrg
applied proper formatting

Share this post


Link to post
Share on other sites

wget http://www.openchrome.org/releases/xf86-video-openchrome-0.2.904.tar.gz
   tar xvzf xf86-video-openchrome-0.2.904.tar.gz
   cd xf86-video-openchrome-0.2.904

 

I get errors when I add the next

./configure --prefix=/usr
make
sudo make install
do i need to change something?

Edited by ianw1974
applied proper formatting

Share this post


Link to post
Share on other sites

It is not clear what errors you are seeing but I guess it would be unsatisfied packages which the compile process needs to complete at least the configure part. There will be some clue in the error messages as to the names of the missing packages. Check you have installed the packages I have listed. I notice I just coppied the steps shown on the openchrome site.

 

I tend to start a root session in a terminal window first, so:

 

su 
(then enter your root pasword) 
./configure --prefix=/usr
make
make install

 

"su" has the same effect as "sudo" but leaves you in a root session until you exit/close the terminal window.

 

It is worth trying to get this to work as it will help you install any upgrades to this driver in the future.

 

You may want to try the compiled driver I posted above if that is not working for you.

 

do this when logged in as root or use sudo before the next lines.

 

cp /usr/lib/xorg/modules/drivers/openchrome_drv.* /home/

 

this saves your current driver (2 files)

 

cd /home/yourname/Downloads/

 

This is where you downloaded to.

 

tar xvzf  driver-openchrome-0.2.904.tar.gz

 

Unpack it.

 

cd  driver-openchrome-0.2.904.tar.gz

 

go to that folder

 

cp * /usr/lib/xorg/modules/drivers/

 

Select and test the OpenChrome driver under the S3 branch in the Xterminal configuration panel.

 

If that works reboot your NC20. If it does not re-copy your saved versions. to the drivers folder.

 

You will know you have the right version if screen blanking etc start to work.

Edited by ianw1974
applied proper formatting

Share this post


Link to post
Share on other sites

Some comments about Bluetooth:

 

These are probably not specific to Madriva 2010 but more general in using Bluetooth under KDE.

 

The specific things I want to use for now are a BT mouse and dial up to 3G data through my mobile. Other things like BT audio or BT networking I'll leave for another day.

 

Make sure you have the following packages installed. (search on "blue") I have installed everything in case I need other services like audio or printing.

 

bluez
bluez-alsa
bluez-cups
bluez-firmware
bluez-gstreamer
bluez-hcidump
kbluetooth
libbluez3
pulseaudio-module-bluetooth
blueman

 

 

KBluetooth is largely the problem and caused connection failures with most of my BT devices except the BT mouse. To get round this I included in the list above the blueman blutooth manager intended for use with Gnome. As a result you have to add it to the KDE menu launching /usr/bin/bluetooth-manager use the KDE BT icon. Launch it and you will have a BT icon in the system tray.

 

Using this app adding the mouse is a breeze as was most other devices just search and then connect using the usual PIN exchange.

 

However to get the N79 Nokia to work for 3G data it needs to be connected using the netowrk tray application.

 

Start with "configure network"

Choose "bluetooth dial up networking"

It will find your phone if it is discoverable.

Choose your network

Enter your network details. This should be either the url or data service name as shown in your mobile setup menus. The username and password may or may not be required.

Blueman then tries to complete and make a connection. In my case it connected without any problems asking for a pin at the phone which should then prompt for a PIN on the NC20. The connction is then made. Authorise the connection as you prefer at the phone end.

 

You can control this connection through the networking tray appliaction using the active interfaces "Analogue Telephone Modem (Pots) (ppp0)" menu item. The previously configured N79 shows up and can be checked as trusted in blueman without breaking the dial-up configuration. It is now listed along with a GPS BT device, a Palm TX, an audio headset, a Windows PC, an OSX Mac and a SonyEricsson k660i which can can even connect for pan network access.

 

The only thing which does not work straight away is the serial conection to the N79. From a Windows PC 2 serial ports can be detected and used by default. The issue here is the N79 returns no serial ports when scanned but shows services which may depend on a serial connection. The serial (OBEX) connection identified shows as a "data transfer" port. Launching a freeware Symbian app ExtGPS on the N79 which connects the internal GPS to a bluetooth serial port then makes another serial port available but this time marked as "EXT GPS". The SonyEricsson K660i always returns a serial port. Maybe the Windows bluetooth simply recognises these ports as "serial ports" rather than the application name.

 

Having compiled and installed blueman 1.12 (blueman-project.org) Blueman Bluetooth is now pretty good and compares well with any Windows BT app. Why Mandriva does not include this by default in their distribution is a mystery?

Edited by CxOrg
applied proper formatting

Share this post


Link to post
Share on other sites

checking for gawk... gawk

 

checking whether make sets $(MAKE)... no

 

checking whether to enable maintainer-specific portions of Makefiles... no

 

checking build system type... i686-pc-linux-gnuoldld

 

checking host system type... i686-pc-linux-gnuoldld

 

checking for style of include used by make... none

 

checking for gcc... no

 

checking for cc... no

 

checking for cl.exe... no

 

configure: error: in `/home/yoshiki2/xf86-video-openchrome-0.2.904':

 

configure: error: no acceptable C compiler found in $PATH

 

See `config.log' for more details.

 

[yoshiki2@localhost xf86-video-openchrome-0.2.904]$

 

 

that's my terminal..

Share this post


Link to post
Share on other sites

When an output tells you that you do not have "make, gcc, cc, cl" it means you need to install these! You have probably never compiled anything before on your PC. In the software installation control panel look for "gcc" and install gcc, gcc-c++ and gcc-pp. Look for "make" and add this if it is not installed then try again. Take note of anything else missing and install these.

 

It would help other readers if you re-edit your post and remove everything but the lines I quoted as errors.

Edited by CxOrg

Share this post


Link to post
Share on other sites

No problem, just tidying it up so it's much easier to read :)

Share this post


Link to post
Share on other sites

There is an issue which relates to power management:

 

I have found that if the individual profiles for power management, "Performance" and "Powersave" switch between enable and dis-able of desktop effects, the result seems to be a failure of control over screen brightness and a loss of detection, in the power management control panel, that frequency scaling of the processor is available. Screen dimming and blanking no longer happen but the "system load viewer" plasma applet still shows frequency scaling is working independently.

 

The simple answer is to decide if you are going to use desktop effects for all profiles or not and set all profiles to that setting. It is not clear if this is something which will be resolved by the video dirver or if it is something to do with the "PowerDevil" power management.

Edited by CxOrg

Share this post


Link to post
Share on other sites

The last issue of getting Samba file sharing working is a question of configuring it correctly and not forgetting to add "SMB" and "Network services autodiscovery" as exceptions in the firewall (Shorewall). The wizards provided by Draktools seem to do this quite well for both. Switching off the notifications for these added ports including CUPS saves constant notifications popping up.

 

I have user share level working with Mac OSX and Windows for now. When I get the Samba on the OSX machine to work as a domain server I'll be able to report more about domain authentication and if "Active Directory" works.

Edited by CxOrg

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...