Jump to content
CxOrg

Samsung NC20 with Mandriva 2010

Recommended Posts

The special function keys which work:

 


  •  
  • Lid closed switch - If set to go to suspend works fine. The time to go to sleep could be quicker??
  • Fn + Esc - Suspend mode works OK
  • Fn + F6 - Speaker mute is in fact volume to 0. Toggles on and off.
  • Fn + F10 - Toggles the touchpad on and off.
  • Fn + F11 - Number lock is probably hardwired in the keyboard itself.
  • Fn + Left arrow key - Lowers the volume OK
  • Fn + Right arrow key - Raises the volume OK
     

 

That leaves some function keys to fix. It is probably a quiestion of mapping the key to an appropriate script.

 

  • Fn + F2 - Battery or power use - Toggle the Power management panel?
  • Fn + F3 - Euro key - Nice to have but not essential
  • Fn + F4 - Internal external screen - This depends on RandR support in the OpenChrome driver so we can use RandR commands to control it.
  • Fn + F5 - Backlight on/off toggle - This may be another RandR command. Find out what power management is calling to blank the screen.
  • Fn + F7 - Simply launch the configuration panel.
  • Fn + F8 - Toggle the power saving profiles? Power saving and Performance would be sufficient.
  • Fn + F9 - Toggle WiFi radio - Find out how the hardware can be switched.
  • Fn + Up arrow key - Brightness up - Find out how the Power management panel does this.
  • Fn + Down arrow key - Brightness down - Find out how the Power management panel does this.

 

So 9 keys to fix!!

Edited by CxOrg

Share this post


Link to post
Share on other sites

Skype (v2.1.0.47) started playing up with the arrival of a number of system updates included with kernel update 2.6.31.6-desktop586-1mnb. Skype started to freeze each time a call was started.

 

Reading on the Skype site there may be some issues with "Pulse Audio". So since I do not need the audio streaming features of Pulse Audio I simply cancelled this "wrapper" audio system and allowed the real audio driver (HDA VIA VT8200 ALC272 Analog) to be used directly. You can find this in "Sound and Video Configuration". Then configure Skype to use this driver ( HW:0,0 version for the microphone "default audio" for outputs). An external microphone is better than the internal one due to analogue noise. I have also got a USB VOIP handset to work with the USB VOIP drivers installed for this device. A USB device avoids the analog interferance and the audio for Skype and VOIP calls can be separate from the audio card which may be used for Music or Video. Pulse Audio is supposed to provide source mixing and switching but fails to work for the moment with Skype. Maybe with future versions of Skype and Pulse Audio we can use it again.

 

Another issue is the Webcam which by default Skype uses the top left quarter of the picture. To fix this define in the /home/youraccount/.Skype/youraccount/config.xml

 

Find </StatSender> and insert the video definition.

   </StatsSender>
   <Video>
     <Autosend>0</Autosend>
     <CaptureHeight>120</CaptureHeight>
     <CaptureWidth>160</CaptureWidth>
   </Video>

 

The result is a more centered image. It is not perfect but much better.

Edited by CxOrg

Share this post


Link to post
Share on other sites

Skype seems to be playing up again! This time with 2.1.0.81, The mic input as configured above has become unintelligable and the webcam does not get recognised at all in the Skype configuration panel.

 

After trying several guides to get Pulse Audio to work with this version I have reverted to simply using the USB handset audio device for the microphone which works. For audio out either the USB device or the default device both work. Strangely doing this allows Skype to detect and use the webcam again.

 

There are many variables as to why this should have occured as I have the MIB repos enabled which has provided me with the latest kernel 2.6.31.12 and an updated KDE as well as the latest version of Skype(2.1.0.81) . As a result the user interface seems quicker and more responsive. Almost everything works well including Nepomuk desktop indexing which was a bit flakey up till now. 1 thing which remains unstable is the backup "Snapshots" which becomes unstable if any USB device is unplugged while it is active.

 

After more experimention trying Pulse Audio as the Audio subsystem I find I can use Pulse Audio using the USB audio device but not the internal sound card ‎(VT1708/A [Azalia HDAC]). Using the configuration settings in "Multimedia system settings" control panel (Sound and Video Configuration). Moving the "USB audio device" to the top of the list in both communications categories ensures this device is used by Skype. This is a workable solution for those who prefer to keep Pulse Audio. Though conferencing in Skype is not the same having a USB handset pressed to your ear!

Edited by CxOrg

Share this post


Link to post
Share on other sites

KDE 4.4 has been out for a little while, a month or so, and is reported to be stable. There are some good reasons to upgrade but a few things to bear in mind.

 


  1.  
  2. Make sure you have at least 10Gb available to your /usr folder or if it is with everything in / then 15Gb is comfortable. This is probably because of the accumulation of RPMs. I will be trying to free some space by removing out of date RPMs.
     
  3. Going from the quite responsive MIB version to the official KDE 4.4 release means some slow down in response. This is an issue for the NC20 Via Nano processor/chipset good as it is for a netbook. I am sure a dual core would not even blink at the load.
     
  4. Against that there are some definite improvements in look and layout of the interface. Notably the mixer console and more complete Plasma desktop integration. I have yet to try the tabbed application grouping which may or may not help with use of the screen real estate.
     
  5. One thing which seems to be better is the success of wireless network negotiation which seems to now be able to switch networks and connect better first time.
     

 

How to update to KDE 4.4

 

One thing to note: I've upgraded some other machines and found that you should check that all updates are done using the ususal Draktools "Install and Remove Software" before rebooting. 1 or 2 MIB sourced versions may have to be removed before completing the upgrade. I bricked an installation on a P4 box having not done this. The upgrade on my EeePC 900 went well by paying attention to this.

 

One interesting thing about the EeePC 900 is that the responsiveness improves with KDE 4.4. This may be because the video driver for the Intel chipset works fully with OpenGL acceleration. If and when the Openchrome driver can do this we should see similar improvement. I suspect we have yet to see th full capabilities if the Via chipset. Until then MIB may improve KDE 4.4 code providing some better responsiveness.

 

Some may want to go for this upgrade while others may want to wait till it appears in the mainstream repos.

Edited by CxOrg

Share this post


Link to post
Share on other sites

I seem to be getting problems with loading Blueman bluetooth.

 

Currently I cannot load the blueman-applet and when run from a terminal gives:

 

[myaccount@localhost ~]$ blueman-applet
Loading configuration plugins
Using gconf config backend
Traceback (most recent call last):
 File "/usr/bin/blueman-applet", line 364, in <module>
   BluemanApplet()
 File "/usr/bin/blueman-applet", line 297, in __init__
   check_single_instance("blueman-applet")
 File "/usr/lib/python2.6/site-packages/blueman/Functions.py", line 270, in check_single_instance
   pid = int(f.readline())
ValueError: invalid literal for int() with base 10: ''

 

blueman-manager loads but gives:

 

[myaccount@localhost ~]$ blueman-manager
Loading configuration plugins
Using gconf config backend
_________
on_bluez_name_owner_changed (/usr/bin/blueman-manager:104)
org.bluez owner changed to  :1.7
Using gconf config backend
ERROR:dbus.proxies:Introspect error on org.blueman.Applet:/: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1
Traceback (most recent call last):
 File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 586, in msg_reply_handler
   reply_handler(*message.get_args_list(**get_args_opts))
 File "/usr/bin/blueman-manager", line 132, in on_bluez_name_owner_changed
   if not self.Applet.GetBluetoothStatus():
 File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 68, in __call__
   return self._proxy_method(*args, **keywords)
 File "/usr/lib/python2.6/site-packages/dbus/proxies.py", line 140, in __call__
   **keywords)
 File "/usr/lib/python2.6/site-packages/dbus/connection.py", line 630, in call_blocking
   message, timeout)
dbus.exceptions.DBusException: org.freedesktop.DBus.Error.Spawn.ChildExited: Launch helper exited with unknown return code 1

 

Any ideas anyone?

 

I have an almost identical configuration running on an EeePC 900 which still works fine.

Edited by CxOrg

Share this post


Link to post
Share on other sites

Though I am answering my own problem above I have solved the problem. However many updates and manipulations have taken place since this post.

 

1 issue I resolved which at least advanced the process of starting up was to remove orphaned Blueman-applet and Blueman-manager files from the /tmp directory.

 

Removing all bluetooth configurations may also help. I use a bluetooth mouse so I removed this using kdebluetooth which works fine for simple devices.

 

Now by using the source build blueman-1.21 from http://blueman-project.org/downloads.html and building and then removing and reinstalling. I could then start blueman-applet from a user terminal session.

 

To build use "su" for a root terminal session then:

./configure --prefix=/usr --sysconfdir=/etc
make
make install
make uninstall
./configure --prefix=/usr --sysconfdir=/etc
make
make install

From a user terminal session run:

blueman-applet

The applet should start then use <ctrl>C to terminate. You should then be able to configure a menu item to run blueman-applet in the normal way.

 

/usr/bin/blueman-applet

 

I hope this helps?

Edited by CxOrg

Share this post


Link to post
Share on other sites

The newest set of problems arrived with the official upgrade to the latest Mandriva Spring 2010.1 release which comes with the 2.6.33.5 kernel.

 

If you don't want to suffer the early adopters problems I would hold off for a while before going for this official upgrade. The apparent improvements in desktop speed and Wifi connection speed are outweighed by the problems particularly suspend no longer completing.

 

My experience so far:

 

The upgrade/install went generally well only using about 400 Mb of additional space.

 

Once complete it booted OK and the desktop seemed a little quicker. I found the install had selected the i686 version of the kernel and madwifi kernel module.

 

The Wifi appeared to work showing a list of router ids but could not connect and as I use a bluetooth mouse, bluetooth seemed to be having problems detecting and using the internal Broadcom device. More about the Bluetooth later. The most serious is that suspend to ram or to disk no longer completes. It was slow to go to sleep state before but now it never completes leaving no option other than power off/power on!!

 

To sort out the WiFi issue I had to remove all network connections except eth0 (LAN) which seems to function normally. You may loose any stored connection passphrases/keys by doing this. Now re-create ath0 and WiFi connections will work normally.

 

The Bluetooth problem needs further investigation. Strangely plugging in another USB BT dongle gets the Bluetooth started then the mouse connects to the internal Broadcom BT.

 

What is clear is the btusb does not load correctly. After booting I get the state of the internal BT device as.

# hciconfig -a
hci0:   Type: BR/EDR  Bus: USB
       BD Address: 00:00:00:00:00:00  ACL MTU: 0:0  SCO MTU: 0:0
       DOWN 
       RX bytes:0 acl:0 sco:0 events:0 errors:0
       TX bytes:0 acl:0 sco:0 commands:0 errors:0 

I have to issue

# rmmod btusb
then
# modprobe btusb
Then I get
# hciconfig -a
hci0:   Type: BR/EDR  Bus: USB
       BD Address: 00:24:2C:CE:EA:E3  ACL MTU: 1017:8  SCO MTU: 64:8
       UP RUNNING PSCAN 
       RX bytes:1248 acl:0 sco:0 events:31 errors:0
       TX bytes:376 acl:0 sco:0 commands:31 errors:0
       Features: 0xff 0xff 0x8f 0xfe 0x9b 0xf9 0x00 0x80
       Packet type: DM1 DM3 DM5 DH1 DH3 DH5 HV1 HV2 HV3 
       Link policy: RSWITCH HOLD SNIFF PARK 
       Link mode: SLAVE ACCEPT 
       Name: 'NC20'
       Class: 0x5a010c
       Service Classes: Networking, Capturing, Object Transfer, Telephony
       Device Class: Computer, Laptop
       HCI Version: 2.0 (0x3)  Revision: 0x2162
       LMP Version: 2.0 (0x3)  Subversion: 0x41d3
       Manufacturer: Broadcom Corporation (15)

There is something preventing btusb from loading correctly at boot time. I have experimented with adding btusb to /etc/modprobe.preload with no success!? To make things easier I would suggest un-installing blueman if you use it and use kbluetooth for now. Blueman gets into a bit of a state when it cannot manage the bluetooth device.

 

I have found hints on the net that the new speedboot is casing problems which may affect the suspend/hibernate. So far adding speedboot=no to the GRUB config does not seem to make any difference.

 

Looks like there is some research to do to get these working again or waiting for kernel/system updates. I'll post any findings here.

Edited by CxOrg

Share this post


Link to post
Share on other sites

A fix (work around) to get bluetooth to start at login is to add a small script to KDE's /home/myuser/.kde/Autostart folder. This is to unload btusb and reload it. This will not be necessary once btusb loads correctly the first time!

 

The script which I've called bt-reload should be owned by your user and given execute permissions.

#!/bin/bash
sudo rmmod btusb
sudo modprobe btusb

 

The next step if you have not done this already is to add yourself to the sudoers list so this file will run using sudo at login. Follow the instructions here http://linux4us.org/sudo.php.

 

Re-booting should run this script on loading your KDE environment and bluetooth should run as normal. I have re-installed Blueman now I have this fix.

 

Let's hope we get a proper fix for this and for the suspend resume. I have read here the suspend issue is due to Powerdevil not loading or not loading correctly, as Powerdevil is now part of KDE it is difficult to know if it is loaded or operating. There are no start up messages to indicate any failures for this or for btusb. Suspend gives what appears to be a normal log in /var/log/pm-suspend.log

 

this is the end of my log:

/usr/lib/pm-utils/sleep.d/15sound suspend suspend: success.
/usr/lib/pm-utils/sleep.d/30pcmcia suspend suspend: success.
/usr/lib/pm-utils/sleep.d/40xlock suspend suspend: success.
/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend: success.
/usr/lib/pm-utils/sleep.d/75modules suspend suspend: success.
/usr/lib/pm-utils/sleep.d/90clock suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/91laptop-mode suspend suspend: success.
/usr/lib/pm-utils/sleep.d/92disk suspend suspend: success.
/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend: success.
/usr/lib/pm-utils/sleep.d/95led suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/98smart-kernel-video suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/99laptop-mode suspend suspend: success.
/usr/lib/pm-utils/sleep.d/99video suspend suspend: Allocated buffer at 0x2010 (base is 0x0)
ES: 0x0201 EBX: 0x0000
success.
Sun Aug  1 23:46:03 BST 2010: performing suspend

The problem being that it does not shut down after the last line which says it is "performing suspend". Does it in fact hang here and we should see some more output on success??

 

Any contributions welcome?

Edited by CxOrg

Share this post


Link to post
Share on other sites

I have found someone else with a similar problem but here their pm-suspend.log gives a few more steps so I would suggest in my case there is some problem in communicating with the video driver (latest Openchrome) for the step "Get video state buffer size failed". Though in this case video suspend is disabled. This step to retrieve the video state buffer probably results in a hung state in my case. I will post something on the OpenChrome problems list to see if there is any solution there.

http://forum.mandriva.com/viewtopic.php?t=124268

...
/usr/lib/pm-utils/sleep.d/15sound suspend suspend: success.
/usr/lib/pm-utils/sleep.d/30pcmcia suspend suspend: success.
/usr/lib/pm-utils/sleep.d/40xlock suspend suspend: success.
/usr/lib/pm-utils/sleep.d/49bluetooth suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/55NetworkManager suspend suspend: success.
/usr/lib/pm-utils/sleep.d/75modules suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/90clock suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/91laptop-mode suspend suspend: success.
/usr/lib/pm-utils/sleep.d/92disk suspend suspend: success.
/usr/lib/pm-utils/sleep.d/94cpufreq suspend suspend: success.
/usr/lib/pm-utils/sleep.d/95led suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/98smart-kernel-video suspend suspend: not applicable.
/usr/lib/pm-utils/sleep.d/99video suspend suspend: disabled.
Mon Feb 1 21:54:52 MST 2010: performing suspend
Get video state buffer size failed
Allocated buffer at 0x2010 (base is 0x0)
ES: 0x0201 EBX: 0x0000
Save video state failed 

Share this post


Link to post
Share on other sites

Now I'm getting to understand how ACPI is used to manage all the power and suspend/hibernate scenarios. These are kicked off in /etc/acpi /events contains the events which trigger /actions . The real meat of the process takes place in /usr/lib/pm-utils . /bin contains the active executables and /sleep.d contains the scripts to shut down and revive each hardware element.

 

Re-examining results in /var/log/pm-suspend.log on this system and another EeePC with 2010 installed shows that everything goes well until "performing suspend". The EeePC shuts down fine and the NC20 hangs with the screen off. So no clues in this log file.

 

Trying a direct approach I installed acpitool then using $ acpitool -s in a terminal does suspend the NC20 correctly but it will not wake. Maybe reverting to older kernel versions may have the solution as once the PM scripts have done their bit control is apparently passed to the kernel.

 

Checking this out!

Edited by CxOrg

Share this post


Link to post
Share on other sites

Here finally we have the solution to suspend resume.

 

Re-install the kernel-desktop586-2.6.31.13-1 .

 

Using Easy URPMI http://easyurpmi.zarb.org/ I loaded the standard repos for 2010.0 for i586 (Media sources). These repos show as second versions of the mirror repositories and are marked "2". For the purposes of this re-installation of the older kernel files, in media manger unselect the more recent mirror repos. (not marked as "2" Main, Contrib and Non-Free)

 

Update the repos (Media sources) then you will be able to find the 2.6.31-1 kernel. Install both the kernel and the development package. If you can find the MadWiFi version also install this. Selecting MadWiFi-kernel-desktop586-latest should do the trick. It will be installed anyway the first time you boot with this kernel and try to refresh the WiFi networks.

 

Set the boot default selection to use this kernel.

 

Rebooting now check you can connect to WiFi this may install the MadWiFi module. Make sure you have a LAN connection so this is sure to work.

 

It may be worth rebooting again to be sure the WiFi works. Now suspend resume should work as before. Remember to re-enable the 2010.1 repos and unselect the 2010.0 versions. Update the Media sources of course. If a new kernel version arrives allow it to install but you may want to keep this 2.6.31 kernel as default until suspend works with any new kernel.

 

Interestingly bluetooth now works on resume though I think it may still be necessary to use my bt-reload script to ensure the bluetooth is loaded after login.

 

Now I will submit a bug report against the newer kernel in the hope we get a fix in a later version. At least we can use our NC20s in the meantime!!

Edited by CxOrg

Share this post


Link to post
Share on other sites

Here are 2 great tips for improving your networking:

 

The networking always seemed a bit slow with both DNS lookups of web pages and negotiation of wireless connections.

 

This is from 2 other sources so I'll give them the credit with links to their advice.

 

http://fixunix.com/mandriva/248983-mandriva-2008-slow-internet.html

 

https://mandrivausers.org/index.php?/topic/84434-error-message-during-shutdown-solved/

 

The key is in the file /etc/sysconfig/network

 

My file is now:

HOSTNAME=localhost.localdomain
NETWORKING=yes
FORWARD_IPV4=true
#CRDA_DOMAIN=GB
NETWORKING_IPV6=no # speedup DNS lookups <==========
NOZEROCONF=yes # no doze lookups needed <==========
NEEDHOSTNAME=no # I'll use my own hostname

 

Lookups for anything for web and mail are quite snappy I did not realise it was not just the Nano being a bit slow. After a few tests wireless connections seemed quicker to get connected with no failure messages. Often I have had failure messages even though the connection is made.

 

All credit to the 2 sources for this. thanks!

 

PS: After a number of weeks and re-configurations of networks. 3G USB using ppp and OpenVPN /etc/sysconfig/network has been rewritten by Draktools. The result is:

HOSTNAME=localhost.localdomain
NETWORKING=yes
FORWARD_IPV4=true
CRDA_DOMAIN=GB

This does not seem to have a detrimental effect on network connections or performance. I can only assume recent updates to networking have fixed the problems which required the explicit networking parameters.

Edited by CxOrg

Share this post


Link to post
Share on other sites

Reading more on the http://fixunix.com/mandriva/248983-mandriva-2008-slow-internet.html link I spotted some advice on tuning the HD access.

 

My/etc/sysconfig/hardisks is now:

# These options are used to tune the hard drives -
# read the hdparm man page for more information

# Set this to 1 to enable DMA. This might cause some 
# data corruption on certain chipset / hard drive
# combinations. This is used with the "-d" option

USE_DMA=1

# Multiple sector I/O. a feature of most modern IDE hard drives,
# permitting the transfer of multiple sectors per I/O interrupt,
# rather than the usual one sector per interrupt.  When this feature
# is enabled, it typically reduces operating system overhead for disk
# I/O by 30-50%.  On many systems, it also provides increased data
# throughput of anywhere from 5% to 50%.  Some drives, however (most
# notably the WD Caviar series), seem to run slower with multiple mode
# enabled. Under rare circumstances, such failures can result in
# massive filesystem corruption. USE WITH CAUTION AND BACKUP.
# This is the sector count for multiple sector I/O - the "-m" option
#

MULTIPLE_IO=16

# (E)IDE 32-bit I/O support (to interface card)
#

EIDE_32BIT=3

# Enable drive read-lookahead
#
LOOKAHEAD=1

# Add extra parameters here if wanted
# On reasonably new hardware, you may want to try -X66, -X67 or -X68
# Other flags you might want to experiment with are -u1, -a and -m
# See the hdparm manpage (man hdparm) for details and more options.
#
EXTRA_PARAMS=

The basic included lines seems to improve application launch times and I suppose boot time, though I have no timings for this. Just the subjective impression, mostly once KDE is launched and applications are auto started. It may be possible to improve on this with other params but the improvements made to networking and HD performance are enough for 1 day. B)

 

Both these fixes work a treat on my old EeePC900. I never thought I could mention snappy and EeePC in the same sentence!!

Edited by CxOrg

Share this post


Link to post
Share on other sites

Hello CxOrg.

 

You are to be congratulated on your patience and doggedness in fixing your problems. :thumbs: You are to be even more commended in the way you have detailed all that you did, tried and succeeded with. This is must be tremendously helpful to anyone else in seeking solutions to similar problems. It is just a shame that no one was able to assist you at all but that is the way the cookie crumbles.

 

Great stuff. Cheers. John.

Share this post


Link to post
Share on other sites

Many thanks for your words of encouragement. I feel that if I solve some problems for myself I may as well share the solutions with other users of the same slightly unusual laptop with Mandriva Linux. This is in the spirit of the "open source" way. If we all contribute something the "sum is greater than the parts".

 

I write this using the same NC20/Mandriva2010.1 on a 3g connection whilst on holiday in the Mediterranean. This is the freedom we can now enjoy through the collaboration of the commercial and GPL systems see the Clue Train Manifesto http://en.wikipedia.org/wiki/The_Cluetrain_Manifesto

 

Cheers!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...