Jump to content
Sign in to follow this  
rldev

Font Troubles after 2010 upgrade

Recommended Posts

My fonts look terrible after 2010 update. I have no problem with my laptop that updated last night, but my desktop looks terrible, no matter what I change. I have the same exact settings on both my laptop(looks great) and desktop. The resolution for my monitor is set correctly (1920 x 1080 24 inch screen). I'm not sure what else I can try. Any ideas besides reinstalling? Thanks.

 

 

[moved from Software by Greg2]

Share this post


Link to post
Share on other sites

Check on both machines, and see what font packages you might have installed, for example:

 

rpm -qa | grep -i font
rpm -qa | grep -i ttf

 

and compare the results of the both commands. If anything missing from the desktop that appears on the laptop, install the respective package, restart X and then see how things look.

Share this post


Link to post
Share on other sites

I think I have it ok now after tweaking every app. The main problem I still see is coloration around letters like "a". I do not see this on my laptop(which 3 years old).

Share this post


Link to post
Share on other sites

The main problem I still see is coloration around letters like "a". I do not see this on my laptop(which 3 years old).

Sounds like a different setting for hinting (sub-pixel addressing, i.e. switching on/off the individual RGB pixels to get higher resolution and better approximate round shapes like o, a, e etc. I can tweak this in my desktop settings (using Xfce), but no doubt Gnome & KDE will have ways of tweaking this.

Share this post


Link to post
Share on other sites

I would also suggest checking what libfreetype package you have installed with

rpm -qa | grep libfreetype

if it's a plf rpm, you may want to replace it with the mdv rpm. The plf package (rpm) has bytecode interpreter and subpixel hinting enabled. So unless you know how to set up your subpixel rendering properly, you may want to use the mdv rpm and the default font system settings.

Share this post


Link to post
Share on other sites

If you have an nvidia card and you are using the proprietary driver then you may have better luck applying antialiasing settings from there ( alt+ F2 and "nvidia-settings" ) overriding the application settings.

Share this post


Link to post
Share on other sites

I would also suggest checking what libfreetype package you have installed with

rpm -qa | grep libfreetype

 

rpm -qa | grep libfreetype

libfreetype6-2.3.11-1mdv2010.0

libfreetype6-2.3.9-1.2mdv2009.1

 

How do you set font to default in Mandriva Gnome?

Share this post


Link to post
Share on other sites

Before you change any settings, I would suggest removing libfreetype6-2.3.9-1.2mdv2009.1. It may be causing a conflict with your 2010.0 system. Then reboot the system and see if that helps.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...