Jump to content

System Notifications, Alsa, and Pulse Audio


Recommended Posts

I'm have problems trying to get system notifications to play a sound fine, ( .wav files ) while I have an audio stream palying, or playing music files.


First off, I'm running Mandriva 2009.1 with a stock kernel.


I have several system notifications set up to play .wav files, including Thunderbird, for arriving mail. The system notifications work, if I'm not playing a audio stream, or musinc files on my system. Once I start up Xmms, or RealPlayer 11, then I do not hear the notifications.


Pulse Audio is enabled in MCC. Other options I have selected are: Automatic Routing from ALSA to Pulse Audio, and Enable user switching for Audio Applications. Other items are not selected.


Sound driver:

snd_hda_codec_realtek 194272 1

snd_hda_intel 25064 5

snd_hda_codec 68828 2 snd_hda_codec_realtek,snd_hda_intel

snd_hwdep 6880 1 snd_hda_codec

snd_seq_dummy 2464 0

snd_seq_oss 29536 0

snd_seq_midi_event 6812 1 snd_seq_oss

snd_seq 48976 5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event

snd_seq_device 6728 3 snd_seq_dummy,snd_seq_oss,snd_seq

snd_pcm_oss 37632 0

snd_pcm 74432 4 snd_hda_intel,snd_hda_codec,snd_pcm_oss

snd_timer 20900 2 snd_seq,snd_pcm

snd_mixer_oss 14460 1 snd_pcm_oss

snd 56516 20 snd_hda_codec_realtek,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq_oss,snd_seq,


soundcore 6976 1 snd

snd_page_alloc 8708 2 snd_hda_intel,snd_pcm


I have spent a lot of time on www.pulseaudio.org, and at this point have not found a lot of help there. It appears to me as a lot of the setup on Mandriva 2009.1 is different than what they list.


I have installed 'padevchooser' 'paman' 'paprefs' 'pavucontrol' and 'pavumeter' to try and help sort out how Pulse Audio works, and hoe to configuer the beast.


The problem as I see it, if I have XMMS or RealPlayer running, and I try to play a .wav file, with aplay at a command prompt, XMMS will continue to play, but I get silence from the .wav file. The wav files are fine, if you play them by themselves.


This all worked when aRts was the sound server, on older versions of Mandriva. I know I could remove Pulse, and install aRts, but that would be giving up, and if PA is the future, I would lkie to understand it better.


Any thoughts on what I coyuld try???

Link to comment
Share on other sites

Pulseaudio is not the future, all over forums (Ubuntu, Fedora, etc) people say they uninstalled (or disabled) it to get rid of sound problems and suggest it as a solution to others.

Eventually distros will realise this too and not install it by default anymore.


One of the top voted and commented items on the Mandriva 2010 Ideas site is to make pulseaudio optional:



I would suggest you to get rid of Pulseaudio, your sound problems will likely be solved too.


xmms is really ancient now, try Audacious which is very similar and much better!

Link to comment
Share on other sites

Thank-you for your comments.


XMMS has a Pulse Audio plugin, and does work with it.


I understand people are not thrilled with Pulse Audio, neither am I. However, my interest is to see what can I do with it. Since it is GPL, like other linux software, and several distros are moving toward it, I would like to see if I can get it to work. The problem I have is not a show stopper, by any means. I know I could blow it away, but that would not help to define any problem, or to fix it. So I will continue as far as I can to learn, and help fix...


Here is one thing I tripped across, looking to learn...


E: modinfo.c: Failed to open module "/lib/module-init-tools": file not found


I get this error message when I run the command 'pulseaudio --dump-modules', at the end of the module listings. I went into Install/Remove software, and listed the installed module, 'module-init-tools version 3.6' It is installed. I looked at the files, and sure enough, module-init-tools is installed in the path specified.


So, the question is why do I get the error message it can not be found? Possibly this has something to do with problem I have described? Don't know for now.

Link to comment
Share on other sites

Well, after spending way too much time on Pulse Audio, I had no success in getting system sounds to work, with other applications running.


For now I have given up. I disabled Pulse in MCC. I installed aRts, and voila, system sounds with other audio applications running.

Link to comment
Share on other sites

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...