Jump to content
Sign in to follow this  
Guest oberon

NVIDIA driver

Recommended Posts

Guest oberon

Hello everybody!

I am having a problem - my ML9.1 hangs unexpectedly - and there is a suspicion that this is because of my NVIDIA card's driver.

Reading this forum I figured out that I should install NVIDIA driver myself. However, when X starts, I see the splash screen of NVIDIA, and my card is properly detected during the installation. Does this still mean that I need to install the new driver?

Also, I just found that my card was detected as GeForce2 DDR, while in fact it is GeForce2 GTS. Is it a different thing? Could this create a problem?

I tried to set it as just GeForce, relogged, and it works OK, so I'll wait and see if there will be a hang again... And still, do I need to install the new driver? The process of installation as it described sounds difficult for me.

...

 

It hanged with 'GeForce' also. Now I am trying what was advised somewhere else in the case of a problem like mine: I set my videocard

as just 'vesa'. The image lost that 'glamour' which it had previously. Also the screen resolution became lower, probably 1024 x 768 instead of the normal 1152 x 864 (although the system says that it makes my normal resolution). Nasty thing...

Thanks!

Share this post


Link to post
Share on other sites

There is a good tutorial to install the Nvidia drivers here. As far as I know this is a universal driver for all geforce cards on Linux.

 

It would help if you could post your XF86Config file. (/etc/X11/XF86Config-4)

Share this post


Link to post
Share on other sites
Guest oberon

Thank you! Yes, this tutorial is excellent. I was very impatient, so just went forward with the driver installation according to this tutorial and other advices I found here on this forum. Everything went very easily, and now I am waiting if my system will hang again or not...

Share this post


Link to post
Share on other sites
Guest oberon

No, it hanged again. But the problem is most probably in the video card. Now I again set the video card driver as 'vesa' and it works, although only in 1024 x 768 resolution...

 

What can be the reason, why my videocard works fine under RedHat and creates a problem under Mandrake?

Share this post


Link to post
Share on other sites

I have a gf2gts. There is no problem with mandrake identifying it properly, and the nvidia drivers will identify it properly. You may have done an edit that is still sticking. Completely uninstall the nvidia, set it to the default mandrake, and install nvidia again. Also, make sure your vid card irq is not shared with any other devices.

Share this post


Link to post
Share on other sites
Guest oberon

Eeeeh... Could you please give me more details about these things:

1. Completely uninstall the nvidia
2. Make sure your vid card irq is not shared with any other devices

Thanks! :oops:

Share this post


Link to post
Share on other sites
Guest oberon

This is what I have now. Before everything was according to the directions re: driver installation.

 

Section "Files"

   # Multiple FontPath entries are allowed (they are concatenated together)

   # By default, Mandrake 6.0 and later now use a font server independent of

   # the X server to render fonts.

   FontPath "unix/:-1"

EndSection



Section "ServerFlags"

   #DontZap # disable <Crtl><Alt><BS> (server abort)

   AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work

   #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)

EndSection



Section "Module"

   Load "dbe" # Double-Buffering Extension

   Load "v4l" # Video for Linux

   Load "extmod"

   Load "type1"

   Load "freetype"

   Load "glx" # 3D layer

EndSection



Section "InputDevice"

   Identifier "Keyboard1"

   Driver "Keyboard"

   Option "XkbModel" "pc105"

   Option "XkbLayout" "us,ru(winkeys)"

   Option "XkbCompat" "default+group_led"

   Option "XkbOptions" "grp:ctrl_shift_toggle"

EndSection



Section "InputDevice"

   Identifier "Mouse1"

   Driver "mouse"

   Option "Protocol" "IMPS/2"

   Option "Device" "/dev/psaux"

   Option "ZAxisMapping" "4 5"

EndSection



Section "Monitor"

   Identifier "monitor1"

   VendorName "Plug'n Play"

   ModelName "Iiyama MA901U, VisionMaster Pro 452"

   HorizSync 30.0-96.0

   VertRefresh 50.0-180.0



   # Sony Vaio C1(X,XS,VE,VN)?

   # 1024x480 @ 85.6 Hz, 48 kHz hsync

   ModeLine "1024x480"    65.00 1024 1032 1176 1344   480  488  494  563 -hsync -vsync



   # TV fullscreen mode or DVD fullscreen output.

   # 768x576 @ 79 Hz, 50 kHz hsync

   ModeLine "768x576"     50.00  768  832  846 1000   576  590  595  630



   # 768x576 @ 100 Hz, 61.6 kHz hsync

   ModeLine "768x576"     63.07  768  800  960 1024   576  578  590  616

EndSection



Section "Device"

   Identifier "device1"

   Driver "vesa"

   Option "DPMS"

EndSection



Section "Screen"

   Identifier "screen1"

   Device "device1"

   Monitor "monitor1"

   DefaultColorDepth 24



   Subsection "Display"

       Depth 8

       Modes "1024x768" "800x600" "640x480"

   EndSubsection



   Subsection "Display"

       Depth 15

       Modes "1024x768" "800x600" "640x480"

   EndSubsection



   Subsection "Display"

       Depth 16

       Modes "1024x768" "800x600" "640x480"

   EndSubsection



   Subsection "Display"

       Depth 24

       Modes "1024x768" "800x600" "640x480"

   EndSubsection

EndSection



Section "ServerLayout"

   Identifier "layout1"

   InputDevice "Keyboard1" "CoreKeyboard"

   InputDevice "Mouse1" "CorePointer"

   Screen "screen1"

EndSection

Share this post


Link to post
Share on other sites

If your driver is "vesa", you are not using the nvidia driver. That line must say "nvidia". Try that before we go on to more fun stuff! :lol:

Share this post


Link to post
Share on other sites
Guest oberon

I reinstalled the new driver again, but now I can hang at any moment :evil:

Now the appropriate pieces look like this:

 

Section "Module"

   Load "dbe" # Double-Buffering Extension

   Load "v4l" # Video for Linux

   Load "glx"

   Load "extmod"

   Load "type1"

   Load "freetype"

   Load "/usr/X11R6/lib/modules/extensions/libglx.so"

EndSection

Section "Device"

   Identifier "device1"

   VendorName "nVidia Corporation"

   BoardName "NVIDIA GeForce2 DDR (generic)"

   Driver "nvidia"

   Option "DPMS"

EndSection

 

It was so stupidly safe with vesa! :?

Share this post


Link to post
Share on other sites
Guest oberon

Also I tried glxgears. It is still running and producing the output like this:

 

6424 frames in 5.0 seconds = 1284.800 FPS

7155 frames in 5.0 seconds = 1431.000 FPS

7227 frames in 5.0 seconds = 1445.400 FPS

7221 frames in 5.0 seconds = 1444.200 FPS

7223 frames in 5.0 seconds = 1444.600 FPS

7216 frames in 5.0 seconds = 1443.200 FPS

7224 frames in 5.0 seconds = 1444.800 FPS

7224 frames in 5.0 seconds = 1444.800 FPS

7227 frames in 5.0 seconds = 1445.400 FPS

7212 frames in 5.0 seconds = 1442.400 FPS

7227 frames in 5.0 seconds = 1445.400 FPS

 

... and so forth. Will it ever stop? :x

Share this post


Link to post
Share on other sites

Your glx is loading twice, which could be a problem. As root, edit your file by putting a # in front of the last glx line. (the one that starts with /usr/...) Your XF85Config-4 will be similar to mine, which works good enough for RTCW, QuakeII, and QuakeIII.

 

Another thought: list the contents of the /usr/X11R6/lib/modules/extensions/ directory.

Share this post


Link to post
Share on other sites
Guest oberon

This line /usr... appeared after the last installation. And I added Load "glx" manually.

 

After the previous installation of the same driver there was already the Load "glx", but there was no that long line. And anyway, it hanged after less than an hour of work. Everything works fine, but then everything hangs.

 

At the same time when I set 'vesa', there were no hangs yet. And there were no hangs in Red Hat...

Share this post


Link to post
Share on other sites

Hey there...

just question.

what drivers are you using??

the ones i got are this:

NVIDIA-Linux-x86-1.0-4363.run

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...