Jump to content

k3b help

chris z

Recommended Posts

A how-to? Did I hear my name? I'm on it!


<Rushes off to start a K3B How-to>


BTW, for the record:


reboot and halt ARE commands.


lilo.conf is easy to edit, just run lilo after to send changes to your MBR (master boot record). If ever mandrake's not bootable, you can boot off your install cd, hit F2, and type rescue. You'll get a menu where repair Bootloader (MBR) is one of the options. So you're pretty safe. (I'm also half done a how-to for booting, chroot-ing, and fixing config files)


hd_=ide-scsi is needed under "Append" in lilo.conf for both drives to be able to burn from one cd to another. When you reboot - mandrake recognizes that an ide drive has diappeared, and that a scsi drive has appeared. In other distros, you must change your cdrom link manually to reflect that cdrom is now scsi instead of ide ... see - /dev/cdrom is just a link (pointing to) /dev/ide/host0/bus0/target0/lun0/cd, so you need to remove that old link and make a new one pointing to /dev/scsi..yaddayadda


Supermount I leave on as it works great for me.


The first time I get mandrake installed, or k3b installed when it doesn't come preinstalled in my distro of the week, I su, give root passwd, and type k3b. Then I go through the setup and add static to my users. Note I only do this AFTER I've editing my lilo.conf to include hd_=ide-scsi for my reader drive, changed my link, and rebooted. That way k3b starts off seeing things the way I want it too.


Congrads on getting it working! The linux community, and even more so, the mandrake community, is here for you. Welcome! Soon ye shall be M$ free. I now watch dvd's and everything!! (that was my last step - turned out to be easy with 9.1)

Link to comment
Share on other sites

  • Replies 61
  • Created
  • Last Reply

Top Posters In This Topic

Hay! Well done! Good for you!


Now, you have mastered a steep learning curve (permissions, root 'power', system setup, file ownership, device==file idea, etcetc). Now that you have climbed it--



Hope you are enjoying it, reading your words I'm sure about it.

Get the rest of your system sorted as necessary (ask here again if needed), and help others that are still on the lower end of the curve!

Link to comment
Share on other sites



just when you thought it was all over........ (actually, NOW it is)


i was wrong! when i posted (with glee) about how i had things figured out by adding administrative priviledges, that wasn't the answer, after all. but, i have it now! see, when i thought (the first time) that k3b was working properly for user "chris", it really wasn't 'cause what i was doing was running k3b using the "most frequently used" shortcut in the KDE kicker. the most frequently used shortcut for k3b turned out to be linked to when i was running it as root in terminal. when i tried running k3b in terminal, under chris, i was back to square one........no burner listed! :banghead: so, i started looking through everything.....again. ran setup, several times........again. then, the words of aRTee & hea echoed in my foggy mind about permissions....again...but this time i looked at the cdrecord, cdrdao, & mkisofs permissions. sure as sh*t, user "chris" didn't have permissions for any of those groups. sooo....... i added those three groups in kuser, gave chris permissions for them, saved the profile. fired up k3b as chris in terminal, but still no burner listed!!! didn't panic, though. i thought, let's try rebooting. rebooted, fired up k3b as user chris from terminal...........TADA!!!! i can now say, without a doubt, that k3b works as it should as user chris (supermount still enabled). sooo......to all who care, after configuring k3b make sure your user has permissions to cdrecord, cdrdao, & mkisofs, then reboot for the settings to take effect, & you'll be good to go. now i can put this thread to rest for good. (finally!)


Link to comment
Share on other sites

  • 2 months later...

... see - /dev/cdrom is just a link (pointing to) /dev/ide/host0/bus0/target0/lun0/cd, so you need to remove that old link and make a new one pointing to /dev/scsi..yaddayadda


I've been exploring this for two days, and haven't found a way to remove and install a new link. I don't understand kate, and ln won't cooperate.

Hope this doesn't turn out to be too obvious, but could someone tell me how to do this in /dev/cdroms/cdrom0.

What's there now is:

cd '/dev/ide/host0/bus1/target0/lun0'

[william@localhost william]$ cd '/dev/ide/host0/bus1/target0/lun0'

[william@localhost lun0]$


A long way to go on the learning curve... :(

Link to comment
Share on other sites


i'm not exactly sure what you're asking. :? are you talking about K3b setup when it's trying to detect your drives? what link are you trying install & for what purpose? please elaborate.



Link to comment
Share on other sites

Guys, really, the k3b setup is only slightly cryptic, not completely cryptic. For example, adding your user to the permissions group is a part of setup! You should not need to make any links!


1) Emulate scsi in lilo for your cdroms devices.


2) Make your folders in /mnt. Name them what you want.

3) Run k3b setup. Use your /mnt folder names to direct k3b where to mount what.

4) Allow k3b to edit /etc/fstab. When setup is done, place hash marks in front of the original entries for your cdrom devices.


That's it. Your permissions are fine, your fstab is fine, and everything will work. It will also scramble your eggs for breakfast. Well, mine does anyway! :twisted:

Link to comment
Share on other sites

Hi Chris;

I've been trying to follow static's way of making k3b copy disks, but don't know how to overwrite /dev/cdroms/cdrom0, which is the ide (reader).


Hello Ixthusdan;

Your 1) is somwhat cryptic, in that I'm not sure what emulate means - is it this?

append="devfs=mount hdc=ide-scsi hdd=ide-scsi acpi=off quiet"


Your 2) and 3) is new to me, will have to try it and see.



(where is that head-scratching smily?)

Link to comment
Share on other sites

Yes, according to your append entry, your cdrom devices are on secondary master and secondary slave. Is that correct? (this is scsi emulation!)


Would you post your /etc/fstab?


Another little note, which I have seen effect things on some machines, I never put two cdrom devices on the same ide channel. I would put one on the master channel and the other on the secondary channel. The controller can muddle the information.

Link to comment
Share on other sites

Yes, both cdroms are on secondary ide cable. Two hard drives on primary.

Here's my fstab:

/dev/hdb4 / ext3 defaults 1 1

none /dev/pts devpts mode=0620 0 0

#none /mnt/cdrom supermount dev=/dev/hdc,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0

#none /mnt/cdrom2 supermount dev=/dev/scd0,fs=auto,ro,--,iocharset=iso8859-1,codepage=850,umask=0 0 0

none /mnt/floppy supermount dev=/dev/fd0,fs=auto,--,iocharset=iso8859-1,sync,codepage=850,umask=0 0 0

/dev/hdb1 /mnt/windows vfat iocharset=iso8859-1,codepage=850,umask=0 0 0

none /proc proc defaults 0 0

/dev/hdb3 swap swap defaults 0 0

/dev/ide/host0/bus1/target0/lun0/cd /mnt/k3b.reader/ auto ro,noauto,user,exec 0 0

/dev/scsi/host0/bus0/target0/lun0/cd /mnt/k3b.writer/ auto ro,noauto,user,exec 0 0


Maybe the ide should be scsi? But that's what I don't know how to do. :?

Link to comment
Share on other sites

Here's the output - means not much to me...


[william@localhost william]$ cdrecord -scanbus

Cdrecord 2.0 (i586-mandrake-linux-gnu) Copyright © 1995-2002 Jörg Schilling

Linux sg driver version: 3.1.24

Using libscg version 'schily-0.7'


0,0,0 0) 'ASUS ' 'CRW-2410A ' '1.0 ' Removable CD-ROM

0,1,0 1) *

0,2,0 2) *

0,3,0 3) *

0,4,0 4) *

0,5,0 5) *

0,6,0 6) *

0,7,0 7) *

[william@localhost william]$

Link to comment
Share on other sites

hey WilliamS,

ok.......let me try to make things more confusing for ya! :shock:


i started this thread ages ago. since then, with the help of Ixthusdan, aRTee, & a few others, i mastered k3b & it's been working fine ever since. first, what i would suggest (probably much to the changrin of others) is doing this.........


first, get rid of those last 2 lines in your fstab:

/dev/ide/host0/bus1/target0/lun0/cd /mnt/k3b.reader/ auto ro,noauto,user,exec 0 0

/dev/scsi/host0/bus0/target0/lun0/cd /mnt/k3b.writer/ auto ro,noauto,user,exec 0 0

they are the lines that k3b writes to your fstab. i found by letting k3b do that, it makes things screwey, in that you can only see both your cd drives if you run it as root. also, look in your /etc directory & if you see a file (or files) like fstab-k3b or k3b-fstab, delete them. they are fstabs that k3b writes to your /etc directory that further tend to confuse things. the only fstab file you need is the /etc/fstab file.


second, make SURE that you have scsi emulation enabled correctly. it looks like you have that already, but to make sure, here's how the lines in your lilo.conf should read, under the "append" section.........

append="devfs=mount hdX=ide-scsi hdX=ide-scsi acpi=off"

where the hdX should be the letter of YOUR corresponding cd drives. after you edit lilo.conf, go to terminal, su to root, then type:

lilo -v

hit enter, then reboot for the changes to take effect.


third, start the k3b setup program. read through these very well written instructions for k3b setup procedures:

how to set up K3B

some words of note. DO NOT let K3b write to your fstab. it just tends to screw things up. when you get to the part of k3b setup that asks for your cd mount points, make sure they are correct. you're mount points are currently reading "k3b.reader" & "k3b.writer". they should point to "cdrom" & "crom2". at the end of setup, make sure you give permisions to you (IE: user) for cdrecord & cdrdao. let k3b make THOSE changes when it asks. next, after all is said & done & you click "apply" or "save" (i forget the final button to click) when k3b asks you that poorly worded & confusing question at the end "do you really want to discard changes?" answer YES. i know it sounds illogical to do that, but that's what you gotta do. like i said, it's a stoopid, misleading question.


finally........REBOOT. yes, again, it sounds horrific in Linux, but you must reboot for all this to take effect.


so.......between what i just gave you & the other bits of info in this thread, you should be able to have k3b rockin' & rolling in a matter of minutes. please post back if it isn't so i can bang my head against a wall! :banghead: :lol:



one final, FINAL, thing........when you reboot after k3b setup, BEFORE running k3b, go to terminal, su to root, & type:


& hit "enter". that will bring up the user permissions dialogue box. look for user WilliamS, click "edit" & another box will pop up with 2 columns. in the left column will be groups that you are already a member of. in the right column will be groups you can be added to. if you see any of the following in the right column, make sure you add them to the left as a group you belong to:






after you add any of them, click "save" & close the userdrake dialogue box. THEN run k3b..........


(i really gotta get some work done now :shock: )



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...