Jump to content

Recommended Posts

So I went to the "add remove progams" in Man 2008.1. Now is there a good tutorial I can read. I tried google already. Maybe with the wrong parameters. I'll try the forum search.

 

Also can WINE give me a virus? Since it is winflow...?

 

 

[moved from Software by spinynorman]

Share this post


Link to post
Share on other sites

Wine isn't Windows. There was a test a while ago when someone tried to infect their wine install - it crashed a load of things but didn't infect anything. It emulates Windows, it doesn't use the same binaries.

 

If you ran vmware with a Windows virtual machine, then your virtual machine would become infected with a virus since it is a real version of Windows running in a vmware environment. Wine is completely different.

Share this post


Link to post
Share on other sites

I tried to get wine infected, had to go to some trouble of installing because of some missing dll's, else the malware wouldn't even run but I did get it to run causing a lot of network trafic and spawning lots of new processes. It was very easy to kill and get rid off however by killing all wine processes and deleting the hidden wine directory ~/.wine ...

Share this post


Link to post
Share on other sites

If you're worried about the issue, don't configure wine so that your entire /home (or even worse, your entire filesystem) is represented as a 'drive' in wine. That way, malware can theoretically attack your whole Linux system. If you keep it configured so that the only 'drive' available to wine is actually just a subdirectory of ~/.wine , then that's all any Windows malware can attack, as it doesn't see anything else.

Share this post


Link to post
Share on other sites

Where is config for WINE?(~/.wine) I install game without problem, when i have run this game, i have announcement "insert cd in drive etc.." ...Lex

Share this post


Link to post
Share on other sites

I read the Wiki on winehq, but I can't install Office 2007!

I have a Hebrew installation cd, and when I try to run it I get an error message, all in blocks!

My linux supports Hebrew, I even set the system language to be Hebrew, but it still didn't work.

I am using Mandriva 2009 and Wine 1.19.

Share this post


Link to post
Share on other sites

MSO 2007 is installable and running rather well in the latest Crossover Office (which is a customized wine), but the latter is commercial.

Edited by scarecrow

Share this post


Link to post
Share on other sites
MSO 2007 is installable and running rather well in the latest Crossover Office (which is a customized wine), but the latter is commercial.

Thanks, that worked.

Sorta.

My install disc is in Hebrew, and I have an English MUI disc that (when run in Windows) converts the Office interface to English.

But, when I put it in my drive, it doesn't rcognize any files on the disc! For some reason Linux doesn't read the disc. It can read the disc label, but claims there are no files on the disc! Even in a terminal! I think it is because the filenames might be in Hebrew. I noticed that Linux does not recognize Hebrew file names, even if the locale is set to Hebrew/Israel.

So, uh, what to do?

Edited by Max2009

Share this post


Link to post
Share on other sites

For anybody who is reading this, I resolved the problem.

The problem is not because the filenames are in Hebrew (they aren't) but because (I think) of the Autorun.inf file on the disc.

What I did was deleted the Hebrew install of Office 12 from the .cxoffie folder, and copied over the English install that I had on my Windows partition.

That worked.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...