Jump to content

USB problem


Recommended Posts



I bought the powerpack, but now my 60-day support is over and I got a problem...


The problem I have is with USB.

Whenever I plug in a USB device, my system locks up completely. I read a post on this Forum describing similar problems because it is using USB 2.0; the devices that do this are my intel pro/wireless network adapter (not that I think it will work, but it *does* lock up. Not when connected, only when plugged in).

Also, my Trust 720 (730?) LCD POWERC@M, which I *do* use. I wouldn't mind using USB 1.1 because speed is not really an issue for me. It's not intensive hardware stuff, just some pictures. I've regularly get all patches and updates through MandrakeUpdate.



Do you think executing following steps would solve this problem (as suggested elsewhere on the forum)?


- As root, type "rmmod ehci-hcd" to remove it

- In your modules.conf file, in the line that says: probeall usb-interface usb-uhci usb-ohci ehci-hcd


All of my other hardware works fine: DVD/CD-Rom, DVD-RW, floppy disk, keyboard, Monitor, Nvidia Drivers, Soundcard, ...



All help and tips are greatly appreciated.




Link to comment
Share on other sites

Well, I cannot find any 'probeall' command. I am guessing what you are referring to is 'modprobe' I removed the line that said


''probeall usb-interface usb-uhci usb-ohci ehci-hcd" (commented it out using # sign).


But now there is NO USB support at all! As soon as I try modprobe ehci-hcd or modprobe usb-ohci it freezes on me. When I issue modprobe usb-uhci it gives me an error, doesn't freeze though.


I also tried to mount /proc/bus/usb, only to discover there *was* no such directory.


mount -t usbdevfs usbdevfs /proc/bus/usb does not work either (I suppose you issue this to mount a filesystem before you can browse to it?).


the program USBview locks up also when I enable USB.


I'm kind 'a scared to experiment with this again. It always gives me a nasty 'system shutdown uncleanly' error when booting.



I'm using Mandrake for about 1/2 a year now, so I know how to try some things and give feedback. Unfortunately, I won't be able to make much sense of the error messages themselves... :(



Link to comment
Share on other sites

My mandrake usb works ok, and I have usb 2.0, but gentoo is not working. As root, do a lsmod and post here what mods you are loading.

Link to comment
Share on other sites

Hi, I got the output from lsmod, like you asked, but also included the output from dmesg, which it seems is another good analysis tool.


Output from LSMOD:


[root@localhost wouter]# lsmod

Module Size Used by Tainted: P

sr_mod 16920 0 (autoclean) (unused)

floppy 55132 0 (autoclean)

nvidia 1592928 10 (autoclean)

i810_audio 26248 0

soundcore 6276 0 [i810_audio]

ac97_codec 12488 0 [i810_audio]

af_packet 14952 0 (autoclean)

8139too 17160 1 (autoclean)

mii 3832 0 (autoclean) [8139too]

ohci1394 19048 0 (unused)

ieee1394 45900 0 [ohci1394]

nls_cp850 4316 2 (autoclean)

vfat 11820 2 (autoclean)

fat 37944 0 (autoclean) [vfat]

nls_iso8859-15 4092 3 (autoclean)

ntfs 76812 1 (autoclean)

supermount 15296 3 (autoclean)

ide-cd 33856 0

cdrom 31648 0 [sr_mod ide-cd]

ide-scsi 11280 0

scsi_mod 103284 2 [sr_mod ide-scsi]

prism2_usb 69776 0 (unused)

p80211 22156 1 [prism2_usb]

usb-ohci 20584 0 (unused)

usbcore 72992 1 [prism2_usb usb-ohci]

rtc 8060 0 (autoclean)

ext3 59916 1

jbd 38972 1 [ext3]

[root@localhost wouter]#




Output from DMESG


I have minimal knowledge about Linux, but the parts that seemed strange to me, I put an asteriks (*) in front of them




Found and enabled local APIC!

Initializing CPU#0

Detected 1670.481 MHz processor.

Console: colour dummy device 80x25

Calibrating delay loop... 3335.78 BogoMIPS

Memory: 255756k/262064k available (1410k kernel code, 5920k reserved, 1118k data, 136k init, 0k highmem)

Dentry cache hash table entries: 32768 (order: 6, 262144 bytes)

Inode cache hash table entries: 16384 (order: 5, 131072 bytes)

Mount cache hash table entries: 512 (order: 0, 4096 bytes)

Buffer-cache hash table entries: 16384 (order: 4, 65536 bytes)

Page-cache hash table entries: 65536 (order: 6, 262144 bytes)

CPU: L1 I Cache: 64K (64 bytes/line), D cache 64K (64 bytes/line)

CPU: L2 Cache: 256K (64 bytes/line)

Intel machine check architecture supported.

Intel machine check reporting enabled on CPU#0.

CPU: After generic, caps: 0383fbff c1c3fbff 00000000 00000000

CPU: Common caps: 0383fbff c1c3fbff 00000000 00000000

CPU: AMD Athlon XP 2000+ stepping 02

Enabling fast FPU save and restore... done.

Enabling unmasked SIMD FPU exception support... done.

Checking 'hlt' instruction... OK.

POSIX conformance testing by UNIFIX

enabled ExtINT on CPU#0

ESR value before enabling vector: 00000000

ESR value after enabling vector: 00000000

Using local APIC timer interrupts.

calibrating APIC timer ...

..... CPU clock speed is 1670.4796 MHz.

..... host bus clock speed is 267.2766 MHz.

cpu: 0, clocks: 2672766, slice: 1336383


mtrr: v1.40 (20010327) Richard Gooch (rgooch@atnf.csiro.au)

mtrr: detected mtrr type: Intel

ACPI: Subsystem revision 20030122

ACPI: Disabled via command line (acpi=off)

PCI: PCI BIOS revision 2.10 entry at 0xf1690, last bus=2

PCI: Using configuration type 1

PCI: Probing PCI hardware

PCI: ACPI tables contain no PCI IRQ routing entries

PCI: Probing PCI hardware (bus 00)

PCI: Using IRQ router default [10de/01b2] at 00:01.0

isapnp: Scanning for PnP cards...

isapnp: No Plug & Play device found

Linux NET4.0 for Linux 2.4

Based upon Swansea University Computer Society NET3.039

Initializing RT netlink socket

apm: BIOS version 1.2 Flags 0x03 (Driver version 1.16)

Starting kswapd

VFS: Disk quotas vdquot_6.5.1

devfs: v1.12c (20020818) Richard Gooch (rgooch@atnf.csiro.au)

devfs: boot_options: 0x1

vesafb: framebuffer at 0xf0000000, mapped to 0xd0800000, size 65536k

vesafb: mode is 800x600x16, linelength=1600, pages=2

vesafb: protected mode interface info at c000:e6b0

vesafb: scrolling: redraw

vesafb: directcolor: size=0:5:6:5, shift=0:11:5:0

Looking for splash picture.... found (800x600, 25593 bytes).

Console: switching to colour frame buffer device 80x16

fb0: VESA VGA frame buffer device

pty: 256 Unix98 ptys configured

Serial driver version 5.05c (2001-07-08) with HUB-6 MANY_PORTS MULTIPORT SHARE_IRQ SERIAL_PCI ISAPNP enabled

ttyS00 at 0x03f8 (irq = 4) is a 16550A

ttyS01 at 0x02f8 (irq = 3) is a 16550A

* Redundant entry in serial pci_table. Please send the output of

* lspci -vv, this message (134d,7892,134d,0001)

* and the manufacturer and name of serial board or modem board

* to serial-pci-info@lists.sourceforge.net.

* register_serial(): autoconfig failed

RAMDISK driver initialized: 16 RAM disks of 32000K size 1024 blocksize

Uniform Multi-Platform E-IDE driver Revision: 7.00beta-2.4

ide: Assuming 33MHz system bus speed for PIO modes; override with idebus=xx

NFORCE: IDE controller at PCI slot 00:09.0

NFORCE: chipset revision 195

NFORCE: not 100% native mode: will probe irqs later

ide0: BM-DMA at 0xb800-0xb807, BIOS settings: hda:DMA, hdb:pio

ide1: BM-DMA at 0xb808-0xb80f, BIOS settings: hdc:DMA, hdd:DMA

hda: MAXTOR 4K080H4, ATA DISK drive

blk: queue c03cb420, I/O limit 4095Mb (mask 0xffffffff)


hdd: ASUS CRW-3212A, ATAPI CD/DVD-ROM drive

ide0 at 0x1f0-0x1f7,0x3f6 on irq 14

ide1 at 0x170-0x177,0x376 on irq 15

hda: host protected area => 1

hda: 156301488 sectors (80026 MB) w/2000KiB Cache, CHS=9729/255/63, UDMA(33)

Partition check:

/dev/ide/host0/bus0/target0/lun0: p1 p2 < p5 p6 p7 >

md: md driver 0.90.0 MAX_MD_DEVS=256, MD_SB_DISKS=27

md: Autodetecting RAID arrays.

md: autorun ...

md: ... autorun DONE.

NET4: Linux TCP/IP 1.0 for NET4.0

IP Protocols: ICMP, UDP, TCP, IGMP

IP: routing cache hash table of 2048 buckets, 16Kbytes

TCP: Hash tables configured (established 16384 bind 32768)

Linux IP multicast router 0.06 plus PIM-SM

NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.

RAMDISK: Compressed image found at block 0

Freeing initrd memory: 108k freed

VFS: Mounted root (ext2 filesystem).

Mounted devfs on /dev

Journalled Block Device driver loaded

kjournald starting. Commit interval 5 seconds

EXT3-fs: mounted filesystem with ordered data mode.

Mounted devfs on /dev

Freeing unused kernel memory: 136k freed

spurious 8259A interrupt: IRQ7.

Real Time Clock Driver v1.10e

usb.c: registered new driver usbdevfs

usb.c: registered new driver hub

PCI: Setting latency timer of device 00:02.0 to 64

usb-ohci.c: USB OHCI at membase 0xd4932000, IRQ 10

usb-ohci.c: usb-00:02.0, PCI device 10de:01c2 (nVidia Corporation)

usb.c: new USB bus registered, assigned bus number 1

hub.c: USB hub found

*hub.c: 3 ports detected

PCI: Setting latency timer of device 00:03.0 to 64

usb-ohci.c: USB OHCI at membase 0xd4934000, IRQ 10

usb-ohci.c: usb-00:03.0, PCI device 10de:01c2 (nVidia Corporation)

*usb.c: new USB bus registered, assigned bus number 2

hub.c: USB hub found

*hub.c: 3 ports detected

*** usbdevfs: remount parameter error

EXT3 FS 2.4-0.9.19, 19 August 2002 on ide0(3,6), internal journal

hub.c: new USB device 00:02.0-2, assigned address 2

* usb.c: USB device 2 (vend/prod 0x8086/0x1111) is not claimed by any active driver.

init_module: prism2_usb.o: 0.1.16-pre5 Loaded

init_module: dev_info is: prism2_usb

usb.c: registered new driver prism2_usb

SCSI subsystem driver Revision: 1.00

scsi0 : SCSI host adapter emulation for IDE ATAPI devices

Vendor: ASUS Model: CRW-3212A Rev: 1.0

Type: CD-ROM ANSI SCSI revision: 02

hdc: ATAPI 48X DVD-ROM drive, 512kB Cache, UDMA(33)

Uniform CD-ROM driver Revision: 3.12

NTFS driver 2.1.1a [Flags: R/O MODULE].

NTFS volume version 3.1.

MSDOS FS: IO charset iso8859-15

MSDOS FS: Using codepage 850

MSDOS FS: IO charset iso8859-15

MSDOS FS: Using codepage 850

ohci1394: $Rev: 693 $ Ben Collins <bcollins@debian.org>

ohci1394_0: OHCI-1394 1.1 (PCI): IRQ=[5] MMIO=[ec000000-ec0007ff] Max Packet=[2048]

ieee1394: SelfID completion called outside of bus reset!

ieee1394: Host added: Node[00:1023] GUID[00e018000200d262] [Linux OHCI-1394]

8139too Fast Ethernet driver 0.9.26

eth0: RealTek RTL8139 Fast Ethernet at 0xd4a00000, 00:e0:18:5d:84:61, IRQ 5

eth0: Identified 8139 chip type 'RTL-8139B'

eth0: Setting half-duplex based on auto-negotiated partner ability 0000.

Intel 810 + AC97 Audio, version 0.24, 15:29:58 Mar 14 2003

PCI: Enabling device 00:06.0 (0005 -> 0007)

PCI: Setting latency timer of device 00:06.0 to 64

i810: NVIDIA nForce Audio found at IO 0xe000 and 0xe100, MEM 0x0000 and 0x0000,

IRQ 11

i810_audio: Audio Controller supports 6 channels.

i810_audio: Defaulting to base 2 channel mode.

i810_audio: Resetting connection 0

ac97_codec: AC97 Audio codec, id: 0x8384:0x7609 (SigmaTel STAC9721/23)

i810_audio: only 48Khz playback available.

i810_audio: AC'97 codec 0 supports AMAP, total channels = 2

0: nvidia: loading NVIDIA Linux x86 nvidia.o Kernel Module 1.0-4191 Mon Dec 9 11:49:01 PST 2002

Linux agpgart interface v0.99 © Jeff Hartmann

agpgart: Maximum main memory to use for agp memory: 203M

agpgart: unsupported bridge

agpgart: no supported devices found.

0: NVRM: AGPGART: unable to retrieve symbol table

inserting floppy driver for 2.4.21-0.13mdk

Floppy drive(s): fd0 is 1.44M

FDC 0 is a post-1991 82077

Attached scsi CD-ROM sr0 at scsi0, channel 0, id 0, lun 0

sr0: scsi3-mmc drive: 40x/40x writer cd/rw xa/form2 cdda tray




First of all, I got 4 USB ports, not three. 2 at the back of my case, next to the network cable port, and 2 in front, next to the firewire port.


Also, the line 'usbdevfs: remount parameter error' does not seem right to me. I hope I have encluded enough information in here to be helpful. I'd put in in an attachment, but that does not seem to be possible on these boards. Sorry if I cluttered your screen :o


On a side note, there are 2 books I am interested in to get to learn more about Linux:


"A Practical Guide to Linux" by Mark G. Sobell

"Peter Norton's Complete Guide to Linux" by Peter Norton (duh)

"Practical Linux" by M. Drew Streib (and a bunch of other ppl)


Can anyone recommend/comment on 1 of these?





Link to comment
Share on other sites

I placed the 'probeal ...' line back to its original place to see what happens. During boottime, it says the USB filesystem is successfully mounted. And now, there is an entry (directory I believe) for USB in /proc again.


Yet it still crashes whenever a plug in a USB device. I believe it also says something about it having loaded 'OHCI'.


Any ideas? Cause I'm out of them.



Link to comment
Share on other sites

I temporarily gave up on USB2 becuase of similar problems.


Your problem is probably in the deps but without sitting at my linux box i wouldn't want to tell you exactly what to type.


if you rmmod usb-ehci it should disable the USB2 support.


However if this has a dep on usb-uhci it might remobve it too.


One option would be to disable USB2 support in Bios if you can.

Then the kuzdu hardware detection should redo the depmod for you.


Its not perfect but it might get you stable until you are ready to tackle it.

Another thing. On my shuttle it locks up with any serial devices, including an old mouse. I had the whole thing in peices trying to fix it before changing the mouse to PS2 ....


Now I disabled serial support for COM in bios. I don't know why but this solved USB lockup.

Link to comment
Share on other sites

USB is giving me headaches. I don't bother with it anymore. It only makes for system freezes and more headaches. Everything else runs just smoothly.


Can we expect improvements in this area in the near future?




Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

  • Create New...