Jump to content
Sign in to follow this  
xboxboy

Nvidia card Install

Recommended Posts

Hi guys,

A friend just gave me a video card with a NVIDIA GeForce4 MX440 AGPX8 chipset. I managed to track down the right drivers for it (I think, from the legacy section of NvidiaÅ› website), but it failed to install and gave the following in the log:

 

Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':
  -1 Invalid module format
-> Kernel messages:
  bootsplash 3.1.6-2004/03/31: looking for picture...<6>...found (800x600,
  14966 bytes, v3).
  bootsplash: status on console 2 changed to on
  bootsplash 3.1.6-2004/03/31: looking for picture...<6>...found (800x600,
  14966 bytes, v3).
  bootsplash: status on console 3 changed to on
  bootsplash 3.1.6-2004/03/31: looking for picture...<6>...found (800x600,
  14966 bytes, v3).
  bootsplash: status on console 4 changed to on
  bootsplash 3.1.6-2004/03/31: looking for picture...<6>...found (800x600,
  14966 bytes, v3).
  bootsplash: status on console 5 changed to on
  eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
  eth0: no IPv6 routers present
  usb 1-2: new full speed USB device using uhci_hcd and address 2
  usb 1-2: configuration #1 chosen from 1 choice
  drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 2 if 1 alt
  0 proto 2 vid 0x03F0 pid 0x3F11
  parport_pc 00:09: reported by Plug and Play ACPI
  parport0: PC-style at 0x378 (0x778), irq 7, dma 3
  [PCSPP,TRISTATE,COMPAT,EPP,ECP,DMA]
  lp0: using parport0 (interrupt-driven).
  lp0: console ready
  ppdev: user-space parallel port driver
  ppdev0: registered pardevice
  ppdev0: unregistered pardevice
  ppdev0: registered pardevice
  ppdev0: unregistered pardevice
  ppdev0: registered pardevice
  ppdev0: unregistered pardevice
  nvidia: version magic '2.6.22.9-1mdvcustom SMP mod_unload 686 ' should be
  '2.6.22.9-desktop-1mdv SMP mod_unload 686 '

 

Now, I am not all that sure what that all means. Any help would be appreciated.

 

Thanks all

Share this post


Link to post
Share on other sites

Are I unable to use the general NVIDIA driver kernel? Do I have to use a mandriva one?

Share this post


Link to post
Share on other sites

It is certainly a lot easier if you use the Mandriva driver as the ones from else where need to be compiled into the kernel. It can be done as this is how I used to do it before the drivers where added to the repos.

Share this post


Link to post
Share on other sites

The dkms-nvidia-current rpm works well - just install this and reboot and it will compile for you, then reconfigure X to use this driver (either manually or via MCC) restart X and away you go.

Share this post


Link to post
Share on other sites

I afraid I cant find this dkms-nvidia-current rpm. Where can I find this?

Share this post


Link to post
Share on other sites

I think I have managed to install the driver now. Here is the etc/x11/xorg.conf file

 

# File generated by XFdrake (rev 230776)


Section "Extensions"
Option "Composite"
EndSection
# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerFlags"
#DontZap # disable <Ctrl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
#DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "us(alt-intl)"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
EndSection

Section "InputDevice"
Identifier "Mouse2"
Driver "evdev"
Option "bustype" "0x0003"
Option "relBits" "+0+1+2"
Option "product" "0x0006"
Option "vendor" "0x09da"
Option "HWheelRelativeAxisButtons" "7 6"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "E653	"
HorizSync 30-70
VertRefresh 50-120

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576"	 50.00  768  832  846 1000   576  590  595  630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576"	 63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce 3 - GeForce 4 (96xx)"
Driver "nv"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
	Depth 8
	Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
	Depth 15
	Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
	Depth 16
	Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
	Depth 24
	Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
InputDevice "Mouse2" "SendCoreEvents"
Screen "screen1"
EndSection

 

If this is right, why am I unable to select 3d effects?

Share this post


Link to post
Share on other sites

Make sure your non-free repositories are set, use Easy-Urpmi for good results. Then go to the Mandriva linux control center > Hardware > set up the graphical server, your video card should be highlighted, pick it again and you'll be asked if you want to use the proprietary driver. Tick yes and the driver will be downloaded and installed and you will have to restart the graphic server, I usually reboot. Also when your in hardware there is a box to configure the 3d effects. Your current xorg.conf is using the generic nv driver so you wont get any 3d action.

Good luck

Mike

Share this post


Link to post
Share on other sites

Hi all. I tried as above, but I dont have the option of using the propriety driver. This is the first driver I have tried to install, and I not that great at it. :P Please bear with me.

 

Thanks

Share this post


Link to post
Share on other sites
Do I not have the proprietory driver installed?

 

Whether or not you have installed the nvidia proprietary driver, I don't know, but you certainly do not have it set up to use. If you notice the section in the xorg.conf file you posted above, it says,

 

Section "Device"

Identifier "device1"

VendorName "nVidia Corporation"

BoardName "NVIDIA GeForce 3 - GeForce 4 (96xx)"

Driver "nv"

Option "DPMS"

 

Notice where it says Driver "nv"

 

That means you are using the free driver, not the nvidia/proprietary driver, and hence you will not have any 3d acceleration available to you.

 

You best bet is to follow the advice given above about setting up your repositories, and installing the nvidia dkms stuff. If you cant find it in your MCC/software installer thingy, then you don't have all/the correct repo's set up.

Edited by jagwah

Share this post


Link to post
Share on other sites
You best bet is to follow the advice given above about setting up your repositories, and installing the nvidia dkms stuff. If you cant find it in your MCC/software installer thingy, then you don't have all/the correct repo's set up.

 

Ive tried as above, but to no avail. I am so sorry guys, can someone please guide me step by step? I would really like to get this card running the 3d stuff. Thank you all

Share this post


Link to post
Share on other sites

I've been using these instructions for a few years now and they've never failed me :) Maybe they'll help you. The credits go to somebody I can't remember :)

 

/etc/modprobe.preload is the file you'll need to edit when you get to that stage.

 

 

 

If you have Xwindows running open a Console...

 

At the prompt type

 

su

 

Give it the root password.

 

Then type

 

/sbin/service dm stop

 

After a few seconds you'll be at a text screen with the display manager stopped.

 

Stopping the DM is quite important!

 

Now log in as root giving the password you initially set up.

 

now...

 

lsmod | grep nv

 

If you see anything which says nvidia or nv remove it from memory with

 

rmmod nvidia nv

 

etc... This unloads the OLD kernel module.

 

I'm assuming that you've already installed the CORRECT kernel sources for your install, if not search on this subject...

 

NOW run the nvidia script

 

e.g.

 

sh ./nvidia-xxxx-xxx.run

 

It will compile and install a NEW kernel module.

 

Once it's done type

 

 

depmod -a

 

modprobe nvidia

 

Make the required change(s) to /etc/X11/XF86Config

 

The type

 

X

 

to test it.

 

If you get a graphical screen with a movable mouse you are just about done.

 

Stop the graphical screen by pressing [CTL][ALT][bACKSPACE] which will put you back to the text console.

 

Edit /etc/modprobe.conf, /etc/modules.conf & /etc/modprobe.preload remove any existing NV entries and add a line which merely says

 

nvidia

 

At this point you are done.... time to restart the DM...

 

To do so type

 

 

service dm start ; exit

 

And you'll be logged out and brought back to the graphical login with your shiny new drivers now installed.

 

Open a console and type glxgears and be amazed at the FPS...

Share this post


Link to post
Share on other sites

Sorry speedball2, Ive tried but I get the following error after I try to compile the new kernel module

 

   NVIDIA: left KBUILD.
-> done.
-> Kernel module compilation complete.
ERROR: Unable to load the kernel module 'nvidia.ko'.  This happens most
   frequently when this kernel module was built against the wrong or
   improperly configured kernel sources, with a version of gcc that differs
   from the one used to build the target kernel, or if a driver such as
   rivafb/nvidiafb is present and prevents the NVIDIA kernel module from
   obtaining ownership of the NVIDIA graphics device(s).

   Please see the log entries 'Kernel module load error' and 'Kernel
   messages' at the end of the file '/var/log/nvidia-installer.log' for
   more information.
-> Kernel module load error: insmod: error inserting './usr/src/nv/nvidia.ko':
  -1 Invalid module format

 

From what I understand, using this method do I have to do this everytime I do a kernel update?

Share this post


Link to post
Share on other sites

I think it means that you have not installed the kernel-devel or kernel-source (either) that Exactly matches the kernel version you are using. Install one or the other, I am not certain but I do not think it requires both but the version number MUST match the kernel you are using, then retry.

 

Requiring less typing :- Open Konsole and type in su, press enter. then your root password, press enter.Type in ....init 3.....(note the space) and press enter which takes you to a black screen. Type in root, enter. then your password.

 

type in...... ls /<where you nvidia driver is located>. (Example mine is located in zstore so I use ls /zstore), then enter.

this will show you what is in that place so you should see the nvidia driver there.

 

Now type in cd /<driver location> ,then enter.

Type in sh NVIDIA and press the tab button and it will complete the line with the full wording of the driver title.

Press enter and it will start the driver install. Select YES to all questions.

 

To check that xorg.conf has been changed appropriately then type in vim /etc/X11/xorg.conf and press enter. use the arrow buttons to move the cursor around (scroll uses up/down arrow buttons) look to see if the driver is now listed as "nvidia" and no longer as "nv". If there was nothing indicating that the driver install was not successful then you can change the "nv" to "nvidia" by pressing the i key only (to insert or delete text) then maneuver the cursor so that you can add the extra letters. Completing this, click the esc button to prevent any further changes. Then type in :wq (means write and quit).

 

When the install completes (hopefully successfully), then simply type in reboot and press ,enter.

 

Cheers. John.

 

P.S. Have used this routine for the past 2years.

Edited by AussieJohn

Share this post


Link to post
Share on other sites
From what I understand, using this method do I have to do this everytime I do a kernel update?

 

Yes. It's not a problem when you get the hang of it. :)

 

I think it means that you have not installed the kernel-devel or kernel-source (either) that Exactly matches the kernel version you are using.

 

I think that's the problem. Kernel and source have to match.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...