Jump to content
wahur

Cannot get samba working [solved]

Recommended Posts

Hi!

What I have:

Mandriva 2008 box running samba, to be serving files for small home network of other Mandriva/WinXP computers.

My primary workstation running dualboot WinXP Pro/Linux.

 

I partitioned the server to have large /home, with user directories, plus I wish to set up one public directory for music, pictures etc.

Then I set up samba using how-to from this forum, i.e using drakwizard. I must say that this how-to is not fully applicable to Mandriva 2008 anymore, MCC has multiple points for configuring this file sharing and altogether it gets somewhat confusing.

 

First task was to get sharing with own primary WinXP workstation working.

I do have the same user names and passwords on both computers.

Everything worked up to the point where how-to says that on Win computer I browse to the server and it will ask me for a password.

It does not. Samba server is visible in Network Neighbourhood, but when I click on it, all I get is complaint that I have no access rights, no password is asked. When I checked the server properties it says something along the lines that server cannot be found in the network.

 

What is probably relevant is that server cannot be pinged from the Win computer. By name it does not find it, by ip it times out. Pinging Winbox from the server works just fine.

 

Oh, and another weird thing. Server hostname is 'laaneserver', workgroup is 'laanetalu', but Winbox "sees" the server also as 'Laanetalu' - in Network Neighborhood the server name is 'Samba Server 3.0.25b (Laanetalu)'.

 

Wahur

Edited by wahur

Share this post


Link to post
Share on other sites

The MCC samba tool ain't good at all.

Use either the KDE Samba configurator, or even better the Samba module of webmin- the latter is complete, and working flawlessly.

Edited by scarecrow

Share this post


Link to post
Share on other sites
The MCC samba tool ain't good at all.

Use either the KDE Samba configurator, or even better the Samba module of webmin- the latter is complete, and working flawlessly.

It starts looking more like some other networking issue, as webmin works in server, but I cannot get to it from winbox.

Or maybe I have lost all my linux skills after 3 years on windows. Problem is, I know even less about Windows networking than that of linux. I attempted to switch firewall off, that did not change anything.

 

And editing samba config from webmin locally, i.e. straight on the server did not change anything. Still server is visible from winbox Network Neigborhood and still its not acessible from there.

 

Hmm... btw, does Mandrake One install some firewall by default?

[edit] Answer my own Q: yes it does, but killing shorewall did not change anything - I still cannot ping server from Winbox, no access to samba or webmin.

 

Wahur

Edited by wahur

Share this post


Link to post
Share on other sites

Ensure that the workgroup name listed in smb.conf matches with what the workgroup name defined in networking oif the Windows box. If not, then they are not talking...

Share this post


Link to post
Share on other sites

Workgroup names match. Usernames match. User passwords match. Unless there is some black magic with upper/lower case.

Server has been restarted after changes.

I was also able to access shared folders of my winbox from server side and LinNeighborhood allowed me to mount Samba folder on server and those on winbox. So it seems to be working ok.

What keeps puzzling me is why I can ping, samba, whatever from linbox to winbox, but none of these work the other way. It might not be samba problem after all.

 

And smb.conf is (after throwing all the commented stuff out) like that:

[global]
printcap cache time = 60
log file = /var/log/samba/%m.log
dns proxy = no
netbios name = LAANESERVER
load printers = yes
smb passwd file = /etc/samba/smbpasswd
netbios aliases = laaneserver
server string = Samba Server %v
printing = cups
socket options = TCP_NODELAY
dos charset = 850
workgroup = LAANETALU
os level = 20
map to guest = bad user
printcap name = cups
encrypt passwords = yes
security = share
unix charset = ISO8859-1
max log size = 50

[homes]
   comment = Home Directories
   browseable = yes
   writable = yes
   create mode = 0755

[muusika]
   browseable = yes
   public = yes
   create mask = 664
   directory mask = 775
   comment = muusika
   path = /home/muusika
   writable = yes

[VLO]
comment = VLO asjad
path = /home/VLO

Edited by wahur

Share this post


Link to post
Share on other sites
Workgroup names match. Usernames match. User passwords match. Unless there is some black magic with upper/lower case.

Hopefully this question doesn't come off as an insult to your intelligence, but ... you did set the Samba passwords with the smbpasswd tool, right? Samba ignores the Linux system username/password combinations.

Share this post


Link to post
Share on other sites
It starts looking more like some other networking issue, as webmin works in server, but I cannot get to it from winbox.

Webmin allows access by default only from localhost.

Just edit miniserv.conf and add the hosts you wish to have access to it. It can be done either via ssh/console texteditor, or via the webmin UI.

Share this post


Link to post
Share on other sites
Hopefully this question doesn't come off as an insult to your intelligence, but ... you did set the Samba passwords with the smbpasswd tool, right? Samba ignores the Linux system username/password combinations.

 

:P

No insult taken. Yes I did. Since morning an interesting development came. All of a sudden I am able to see the existing shares, although accessible is only the public one. And all of a sudden I am able to connect to the server remotely using webmin (that yesterday constantly timed out).

 

All is not ok, though, as I still cannot log into my private share, meant for business things - I get password dialog, but username is guest greyed out and cannot be changed. Windows magic...

 

Wahur

Share this post


Link to post
Share on other sites

OK, so if that's not it, have you tried watching some of the log files? Maybe you can get some clues by watching /var/log/messages, or doing the same with smbd.log, log.nmbd, or <hostname>.log in the /var/log/samba directory, where <hostname> is the name of your Windows box.

 

Try opening up a bunch of console windows and using the "tail -f" command to watch all of those logs simultaneously, and then try to access the box and see if anything comes up.

Edited by Darth Wong

Share this post


Link to post
Share on other sites

All I have now is access through webmin, so I checked logs this way. It is full of:

[2008/02/20 00:02:09, 0] printing/print_cups.c:cups_connect(69)
 Unable to connect to CUPS server localhost:631 - Connection refused

And nothing much else. Why the hell it is so desperate about cups when I even dont have print shares? There are like 2 such lines per minute!

I did another unsuccessful login attempt to my business folder and there is no trace of it in the logs.

 

Wahur

Share this post


Link to post
Share on other sites

OK, looks like I got it working now. Did some more experimenting with webmin user management options and something there did the trick ;)

Logs showed that I was really logging in with proper username and it did not even ask for my pwd.

Although I still need to check and recheck that kids do not have access to it from the other box. And this cups thingy keeps me bugging as well.

Looks like I just can never be content ;)

 

Anyway, thanks to everybody, I have really forgotten my ways around in linux. Hopefully it will get better now again.

 

Wahur

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...