Jump to content

Problem with ATI driver and logout


CarlJF
 Share

Recommended Posts

Hi guys,

 

I've just installed Mandriva One 2008 and have an embarassing problem. Everything works fine until I logout. Then the screen goes blank and the monitor enter sleep mode, as if the video card or X server were shutdown. Only thing thing I could do then is to press the reset button... :wall: It's very embarassing since, with this versino of Mandriva, you have to logout to shutdown the computer.

 

I've done some test and found out that this happens only with the firegl driver. The open source "ati" and "vesa" work fine, although without 3D acceleration. If it can help, I've notice that if I boot with the open source "ati" driver, the change the video card to ATI Radeon 9600 from the control center, I can logout and login again without any problem. :huh: Also, everything was just working fine with Mandriva 2007. So, I suppose it's not a hardware compatibility problem but just something in the configuration of X. I've also try the xorg.conf I was using with Mandriva 2007 but X just won't start up at all with it.

 

Actually, I plan to try the drivers available at the ATI website with the installer instead of using the rpm ones. Another thing I think to try is using GDM instead of KDM, just in case the problem is with KDM and not X or the drivers. But it also may be just a line missing or bad in the xorg.conf file. I've checked it and everything seems fine but I'm not an expert at this...

 

Any ideas or suggestion on what could be wrong ?

 

For information, here's my xorg.conf file:

 

# File generated by XFdrake (rev 230776)

# **********************************************************************
# Refer to the xorg.conf man page for details about the format of
# this file.
# **********************************************************************

Section "ServerFlags"
#DontZap # disable <Ctrl><Alt><BS> (server abort)
#DontZoom # disable <Ctrl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse does not work
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
Load "dri" # direct rendering
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "kbd"
Option "XkbModel" "pc105"
Option "XkbLayout" "ca"
Option "XkbOptions" "compose:rwin"
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "ExplorerPS/2"
Option "Device" "/dev/mouse"
EndSection

Section "Monitor"
Identifier "monitor1"
HorizSync 30-87
VertRefresh 50-160

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576"	 50.00  768  832  846 1000   576  590  595  630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576"	 63.07  768  800  960 1024   576  578  590  616
EndSection

Section "Device"
Identifier "device1"
VendorName "ATI Technologies Inc"
BoardName "ATI Radeon 9500 - X850"
Driver "fglrx"
Option "DPMS"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
	Depth 8
	Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
	Depth 15
	Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
	Depth 16
	Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection

Subsection "Display"
	Depth 24
	Modes "1024x768" "832x624" "800x600" "640x480" "480x360" "320x240"
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"
EndSection

Link to comment
Share on other sites

did you reboot?

 

Okay, by looking again at the file, found out that the argument was present on many lines... :woops: Removing them all solved the problem. :thumbs: Boot screen is now basic text mode, but at least things are okay.

 

Do you know if using LILO instead of Grub could make things works better ?

Link to comment
Share on other sites

propably not, the bootscreen is not affected by the type of bootloader you use

 

I've found out another way of correcting the problem. :idea2: Instead of removing the VGA=7xx argument, it seems to work better if the 7xx is replaced by the number corresponding to the screen resolution used by X. You still have a text bootscreen, but fonts and everything looks way much better than by removing the argument.

 

To know which value should be used, first look at your screen resolution on this page and note the hexadecimal value for yout resolution.

Then, open a terminal and type the following command, where xxxx is the hexadecimal value for your screen:

 

printf '%d\n' xxxxx

The answer is the value you should used for the vga=7xx argument.

 

I suppose that, from there, it may be possible the get a graphical boot screen but don't know how to do it.

Link to comment
Share on other sites

Instead of removing the VGA=7xx argument, it seems to work better if the 7xx is replaced by the number corresponding to the screen resolution used by X.

 

Hardly so. In some cases this is simply not possible- e.g. I'm running a single head vga at 1680*1050 32-bit color... There's no way to pass such parameters to framebuffer.

Edited by scarecrow
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...