Jump to content
bookie

Sound Problems on 2008 (new title)

Recommended Posts

After several hours more research, I find that rsync is not capable of working through my Proxy (ccproxy). Therefore, I removed the proxy, reconfigured the machine and connected directly to the internet and it still fails.

 

I read up about rsync and set the proxy environment variable according to the instructions but it still failed. I can't be sure I cleared the variable afterwards as the instructions didn't mention how to do that. However, I did reboot before I tried it again without the proxy.

 

One can't help wondering if this operating system is ready for general release? If Windows was such a challenge as most peoples linux experience seems to be, I'm sure computers would be very uncommon today! I really want to stop giving my money to Bill Gates, but at what personal cost to me will it be? I'm thinking of the number of hours of my time which is wasted, just because I want my wifes laptop to run linux. Anyway, I digress.. sorry.

 

Does anyone know of alternative way of doing

# rsync -avz --delete --exclude=.hg* rsync://alsa.alsa-project.org/hg alsa

which does not involve using rsync?

 

I really appreciate you being there! I'd have no hope without you all. Thanks.

 

Peter

Share this post


Link to post
Share on other sites
I got as far as the 3rd line and it all fell apart. This is what I got..

# cd /usr/src/
# mkdir alsa
# rsync -avz --delete --exclude=.hg* rsync://alsa.alsa-project.org/hg alsa
rsync: failed to connect to alsa.alsa-project.org: Connection timed out (110)
rsync error: error in socket IO (code 10) at clientserver.c(104) [receiver=2.6.9]

Regards, Peter

 

Try using the full path to the target directory. This worked for me. (I used a temporary directory in my ~, since I don't really want this stuff.)

 

Jim

 

Edit: Sorry, I posted this before I read your post about the problems with the proxy.

 

ftp access might be available, if you can identify the directory that contains the files that you want.

 

Jim

Edited by jkerr82508

Share this post


Link to post
Share on other sites

OK Jim, thanks for your help. I´m checking at http://www.alsa-project.org/main/index.php...load#FTP_Access for what I need but to be honest, I can figure it out. I think I need a driver but the post with the instructions that I´m following is refering to something called HG and I´ve no idea what that is. I followed a link on the page above to the HG repository but what I need from there I have no idea.

 

It´s annoying since it´s beginning to feel like nothing works in Linux, My sound doesn´t work, so after 2 weeks trying several hours a day I find what is reported as a solution, only to find that it involves using rsync which doesn´t work on my installation either. I´m wondering whether the ftp utility is going to work when I get that far. I haven´t even started looking into the fax modem and built-in webcam yet, although I gave up with the wireless already :( I´m trying hard to remain positive and committed to a successful migration but hope is in short supply here.

 

Thanks for bearing with me. Is anybody able to identify the name of the file that I need to download. I believe it is an Alsa Driver from the ´HG´'repository?

 

Regards to everyone

 

Pete

Share this post


Link to post
Share on other sites

I'm pushing at the outer edges of my expertise here, but this is what I got when I ran the rsync command.

 

./	 alsa-driver/	alsa-kernel/  alsa-plugins/  alsa-utils/   hgwebdir.cgi*
../	alsa-firmware/  alsa-lib/	 alsa-python/   hg-rsync*	 .htaccess
alsa/  alsa-git/	   alsa-oss/	 alsa-tools/	hgweb.config  .htaccess~

 

Most of these directories contained numerous files and/or directories, e.g.

 

[alsa-driver]# ls -lt
total 184
-rw-r--r--  1 50100 50100 74123 2007-11-20 18:25 configure.in
-rw-r--r--  1 50100 50100   215 2007-11-14 11:25 kconfig-vers
drwxr-xr-x 24 50100 50100  1024 2007-11-12 09:25 pci/
-rw-------  1 50100 50100  2222 2007-10-18 16:25 Makefile.conf.in
-rw-------  1 50100 50100   268 2007-10-18 16:25 SUPPORTED_KERNELS
-rw-r--r--  1 50100 50100  9226 2007-10-15 08:55 Makefile
drwxr-xr-x  4 50100 50100  1024 2007-09-21 07:25 include/
drwxr-xr-x 11 50100 50100  1024 2007-09-11 21:25 isa/
drwxr-xr-x  2 50100 50100  1024 2007-08-02 14:25 arm/
-rw-------  1 50100 50100  8915 2007-07-27 11:25 Rules.make
drwxr-xr-x  2 50100 50100  1024 2007-05-21 12:09 sh/
drwxr-xr-x  7 50100 50100  1024 2007-05-14 18:25 soc/
drwxr-xr-x  4 50100 50100  1024 2007-04-10 15:58 usb/
drwxr-xr-x  7 50100 50100  1024 2007-01-25 13:00 drivers/
drwxr-xr-x  2 50100 50100  1024 2006-12-19 13:00 misc/
drwxr-xr-x  5 50100 50100  1024 2006-12-15 14:00 acore/
-rw-------  1 50100 50100 10159 2006-11-24 13:00 INSTALL
drwxr-xr-x  6 50100 50100  1024 2006-09-05 20:00 aoa/
drwxr-xr-x  2 50100 50100  1024 2006-08-09 06:49 ppc/
drwxr-xr-x  4 50100 50100  1024 2006-06-29 22:22 utils/
-rw-------  1 50100 50100	21 2006-06-29 22:22 version.in
drwxr-xr-x  4 50100 50100  1024 2006-06-29 22:22 pcmcia/
-rw-------  1 50100 50100  6729 2006-06-29 22:22 snddevices.in
drwxr-xr-x  2 50100 50100  1024 2006-06-29 22:22 sparc/
drwxr-xr-x  4 50100 50100  1024 2006-06-29 22:22 support/
drwxr-xr-x  3 50100 50100  1024 2006-06-29 22:22 synth/
drwxr-xr-x  2 50100 50100  1024 2006-06-29 22:22 test/
drwxr-xr-x  3 50100 50100  1024 2006-06-29 22:22 doc/
drwxr-xr-x  2 50100 50100  1024 2006-06-29 22:22 hal2/
-rwx------  1 50100 50100  1238 2006-06-29 22:22 hgcompile*
drwxr-xr-x  4 50100 50100  1024 2006-06-29 22:22 i2c/
-rw-------  1 50100 50100  5585 2006-06-29 22:22 install-sh
drwxr-xr-x  2 50100 50100  1024 2006-06-29 22:22 mips/
drwxr-xr-x  2 50100 50100  1024 2006-06-29 22:22 modules/
drwxr-xr-x  2 50100 50100  1024 2006-06-29 22:22 parisc/
-rw-------  1 50100 50100  4753 2006-06-29 22:22 CARDS-STATUS
-rw-------  1 50100 50100 18009 2006-06-29 22:22 COPYING
-rwx------  1 50100 50100  1239 2006-06-29 22:22 cvscompile*
-rw-------  1 50100 50100  3059 2006-06-29 22:22 FAQ
-rw-------  1 50100 50100  1171 2006-06-29 22:22 README
-rw-------  1 50100 50100  1603 2006-06-29 22:22 Rules.make1
-rw-------  1 50100 50100  1188 2006-06-29 22:22 TODO
-rw-------  1 50100 50100   219 2006-06-29 22:22 WARNING

 

Some of this may help you to identify the directory that you want.

 

 

Sometimes one version of linux just doesn't work well with a particular combination of hardware. Although Mandriva is my preferred distro, and it has always worked for me, you may find that another distro works better with your hardware. Some of them produce live CD's which give you a chance to test before installing. (K)ubuntu, Fedora and Suse might be worth trying.

 

Jim

Share this post


Link to post
Share on other sites

Nice work Jim, I think I've found the directory containing those files now. I'm downloading via http using wget. Not sure where it's downloading to(!) but assuming I can find it afterwards, I'll try moving to the directory created earlier and continue with the instructions :)

 

Regarding the other distros, I tried Linspire previously and found a similar situation with that, but the difference there seemed to be that the Linspire forums were full of people in the same boat with no Linux knowledge but there only seemed to be about two pro's answering posts. What I do like about Mandriva is that in the forums, I find many Linux guru's and hardcorers which is a great help when you're new :)

 

I'll persever with this now I think, since I'm so far down the road with it. I really don't want to start again with another distro. If I really can't make it work, I'll return to windows, but I don't want that to happen.

 

Will let you know how I get on with the rest of the solution. If it works for me, it might work for bookie too :)

 

Regards and thanks

 

Pete

Share this post


Link to post
Share on other sites

hmm... I think something must be wrong since it? been downloading for the last 5hours now. According to the graph on the proxy, there is plenty of download activity and has been all along. I wondering whether I messed up the command for wget?

 

This is what I used,

# wget -i FILE -r http://hg-mirror.alsa-project.org/alsa-driver/file/231c3e78143b

 

I think I´m supposed to be downloading all the files and all the directories but it seems like I´m downloading the entire web!

 

Can anyone check my wget command line please?

 

Regards

 

Pete

Share this post


Link to post
Share on other sites

Hello Peter.

 

Just so you know how the Final Release ( the Official version) of the iso works. When a version is finally released as an official and final settling of the iso then the iso remains unchanged until the next version of the OS is eventually released. It does NOT matter therefore when you download the iso whether it be weeks or months after the iso version release it stays the same, it is NOT continuously updated.

 

Cheers. John.

Share this post


Link to post
Share on other sites

Ah!, Thanks for the info about the .iso's. I didn't realise that I always assumed it was pretty much upto date. I'm wondering what command I would have run on the command line to update it (for future ref). I don't remember doing it for Mandriva but guess I must have!

 

Must be getting old here! :cry2:

 

Pete

 

I'm still trying to download that directory and contents by the way. I cancelled the download after 11hours as it showed no signs of ever completing and I only have 20Gb partition! I'm gonna try downloading it with Window's since my FTP in Window's has GUI then port the files to Linux to continue with the trying the solution.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...