Jump to content
jagwah

Mandriva Using all RAM

Recommended Posts

I had great problems with the FF2 from Mozilla ... and because of the Debian/Firefox issue I had to wait until today to get FF2 aka Iceweasel from the debian repo's....

What a HUGE difference.... many if not all the problems I have been having are suddenly solved!

No problems with FF2 from Mozilla here. As for IceWeasel, right now that's nothing more than a rebuild of Firefox without some of the artwork and minus the Firefox branding. Aside from that it's the exact some code as Mozilla's FF2 - so if it's running fine on your system, FF2 should also run perfectly fine.

 

But let's avoid that debate and stick to the RAM topic, please.

Share this post


Link to post
Share on other sites

Well I got around to trying out the latest Kubuntu, and it does the same thing as in the RAM usage continually climbing, but as pointed out by Iphitus this is probably just caching/buffering, and a normal thing, however I do not get the noticeable performance hit that occurs with Mandriva, with Kubuntu it is business as usual.

 

(With Kubuntu it would seemingly dig into the swap more than Mandriva did, although still very small amount, Kubuntu-8324KB as apposed to Mandriva-100 to 200KB after similar testings).

Share this post


Link to post
Share on other sites
Guest Gonzalo

as root execute this command

 

echo 3 > /proc/sys/vm/drop_caches

 

and it'll give you more exactly free memory and then make a free -m and tell us!

Share this post


Link to post
Share on other sites

The first thing I'd try would be to turn off Clam AV. I guess if you download a x GB file Clam will try to scan it for viri before it touches the hard disc. I always wondered why we have scanners for windows viri on our linux boxes by default now... That's like having an airbag on a kitchen sink. :-)

Cya.

PeterPanic

Share this post


Link to post
Share on other sites
as root execute this command

 

echo 3 > /proc/sys/vm/drop_caches

 

and it'll give you more exactly free memory and then make a free -m and tell us!

 

Thanks, I will try that next time I boot up Mandriva, I have been using Kubuntu for a while now, and haven't fired up Mandriva since :unsure: Just out of curiosity I tried the command in Kubuntu and it gave me the following

 

bash: /proc/sys/vm/drop_caches: Permission denied

 

 

The first thing I'd try would be to turn off Clam AV. I guess if you download a x GB file Clam will try to scan it for viri before it touches the hard disc. I always wondered why we have scanners for windows viri on our linux boxes by default now... That's like having an airbag on a kitchen sink. :-)

 

What ... you mean you don't have an airbag on your kitchen sink? :blink:

 

Well, as above, if/when I boot up Mandriva I'll try it, however I get the same symptoms with Kubuntu, however without the performance hit that I get with Mandriva, and I don't believe Kubuntu has a virus scanner by default(could be wrong though), at least it doesn't have ClamAV by default, so I don't think that would be it, I will try it however, so thanks for the suggestion. :thumbs:

 

It all may be a bit academic now, as it looks as if I may go the Kubuntu way, I am liking it quite a bit, and it doesn't have this problem, or another little problem I was having with Mandriva 2006/2007,

https://mandrivausers.org/index.php?showtopic=37376

Plus I'm very interested in Mubuntu/ubuntustudio, however time will tell...

Share this post


Link to post
Share on other sites

This problem also seems to have vanished with my new installation of 2007. I have learned a little of how Linux uses Ram, and not to worry if it appears that it is all being used up, this it seems is how it is supposed to be (as was mentioned earlier in the thread), however I couldn't overlook the performance hit I was getting. I had read somewhere, Mandriva Club forums I think, of a KDE Memory leak, but whatever was causing my problem is gone now, for good I hope :)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...