Jump to content

small problem updating alsa


Recommended Posts

ok i dont know if this goes here or not but here it goes, so im trying to install an updated version of alsa and when i go to install it and i do the ./configure commmand i get this

checking for kernel linux/version.h... no
The file /usr/src/linux/include/linux/version.h does not exist.
Please install the package with full kernel sources for your distribution
or use --with-kernel=dir option to specify another directory with kernel
sources (default is /usr/src/linux).


can anyone tell me what this means and how to fix it? and thanks in advance for any help/advice

Link to comment
Share on other sites

ok after getting the above error fixed im not getting more, as there to many to post heres a couple of them

*** Assuming the same compiler is used with the current system compiler.

*** Please make sure that the same compiler version was used for building kernel.

make[4]: *** [/home/trey/alsa-driver-1.0.13/acore/sound.o] Error 1
make[3]: *** [/home/trey/alsa-driver-1.0.13/acore] Error 2
make[2]: *** [_module_/home/trey/alsa-driver-1.0.13] Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux-'
make: *** [compile] Error 2


snyonr know this means?

Link to comment
Share on other sites

Pray tell why you are using or trying to use a compile version rather than use MCC to help you install an rpm off the Alsa update.


Are you a masochist or something ??? :D :D :D


You are obviously having a dependency problem here of some sort.

Installing an rpm using MCC would take care off any dependencys by downloading them for you as required.


Cheers. John.

Link to comment
Share on other sites



Why do you need the latest version of ALSA?* Because it is far easier just updating through the mandriva control center or urpmi. Type mcc from a console to start the control center and use easy-urpmi to set up sources.


(*edit: I see you are using a very old kernel, I wasn' t very happy with alsa version < 1.0.12 either....)

Edited by ffi
Link to comment
Share on other sites

hey all sorry for not updatting but i been sick and stuff so yeah but anyway, i have following this page to get alsa updated click here

also sorry for any typos in this post, now im not able to update my copy of mandriva cause of my processer, i think thats the error i get when i try to update, its a 600mhz P3

Link to comment
Share on other sites



Not sure how far you got with the install, but doing the following might help (its helped me a few times when I've had that error)

1st. You should have a file called /etc/asound.state. If so as root do

cp /etc/asound.state /etc/asound.state.old

then remove the /etc/asound.state file

rm  /etc/asound.state

2nd Shutdown the PC & then restart it (I found if I do a reboot I still get the error, but if I shutdown then restart the error goes!)


Also open mcc & go to hardware from there check your sound card is using the correct module (driver)



Link to comment
Share on other sites

now im not able to update my copy of mandriva cause of my processer


I doubt that's the problem - you should be able to run 2006 or even 2007 on this machine. I was running at least LE2005 on a AMD K6-2 450MHz with hardly any ram in it. And it worked fine.


You'd be better off trying a newer version to obtain your newer version of alsa. Your kernel is very old, and to me looks like you are running Mandrake 10.0 or 10.1.

Link to comment
Share on other sites

I seem to remember something (unless I'm dreaming) that it's not possible to upgrade alsa beyond a certain point in 10.1. I can't honestly remember but I'm pretty sure I read it in a post here as I don't frequent any other forums.


And I have a feeling your only way forward if your card won't work with the alsa on 10.1 is to try LE2005 or even better 2006. You could try 2007, but I think you'd be better with 2006 at least for the time being as I don't know how 2007 would perform on your machine.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...