Jump to content

alternative ways to install


Recommended Posts

I having quite a bit of a problem with a rack server I newly purchased.


It appears to be a clone server so there is no mdel # to refer to the system in general.


Now I tried to install mandrake 9.0 and 10.1 both from setting the cdrom as the first boot option and neither work.

I had to use the rawwritewin to create boot disks for the both and so far for the 9.0 it works. For 10 it tells me that I need to isert another disk cuz there is an issue with this one (to note 10.1 is a dvd copy).

So as I proceed with the install of 9.0 when I choose all my options and it starts to copy the packages to the hdd (scsi) it eventually freezes up at about the 22% range and I am forced to reboot.

I have tried several install methods by changing the size of the partitions and letting the system auto choose as well and I always get the freezing situation.


Now I have other cds' of other distro's and also live cd's ...these ones appear to not have a rawrite utility on them and so I need to get the system to boot from the cdrom in order to boot them to really tell if the issue is a hdd problem or what...

I have a windows boot disk that works fine but when I "dir" the distro cd I do not know what or how to have the cd perform an install as though I would be installing a windows product.


are there universal boot disks that would allow me to boot any distro and if not how can I go about to install another distro or my mandrake then on this box.


Already I have installed winnt 2k on it and it works fine so I doubt there really is a hdd issue, however I have 5 disks for it and all are seen fine from witihn NT2k, so i do not understand why my distro is giving me issues like this since I already have it running on other boxes...


Any help would be appreciated.


Note** my other distros are:

PClinux, Ubuntu, redhat, slackware, isolinux, & klinux....



Link to comment
Share on other sites

Have you tried installing one of the live CDs to the HD? Only Mandrake doesn't boot from the CD or nothinng boots from the CD? If the first it's rather a bad burn than a bad HD especially if other CDs can boot on it.

Both 9.0 and 10.1 are old and unsupported. You should try a newer release.

Link to comment
Share on other sites

What server do you *think* you have? The other thing I would check if Windows 2000 works is go into Device Manager and make a note of your hardware. In particular your hard disks as to whether IDE or SCSI and what IDE/SCSI controller. This will help to get you working. The more you know about the hardware installed, will help you during your installation process.


If new hardware, I wouldn't use anything less than Mandriva 2006.

Link to comment
Share on other sites

With regards to the 9.0 I already have a server with it installed and it works fine. I still get support for the packages with urpmi by stating that I have version 9.1 and grab sources from US sites.


So when I use the same cd that is bootable I get the installation going with the boot disk because for some reason the system ignores or is unable to detect my IDE cdrom which is set in the bios as the first boot device. As it boot with the boot disk it does detect my hdd being scsi and my scsi controller and actually starts the install fine, except when I get to about 22% of the install from the first cd, then the whole system freezes up.


I have a newer release (mandriva 2006, 4cd set) but I think the first cd is a bad burn & and so errors on me when I try an install.



For the type of server I only know that it is a p3 1.0 ghz processor, about 1-2 gig of ram, 4 hot swappable fujitsu scsi hdd (about 18gigs each), the scsi controller is an adaptec (ver# --will edit this here when I get home from work). Has a seagate dat tape drive, 1 ide cd/dvdrom, video card is an ATI version, no sound card, it does have a raid software---firmware vers 5.xx, intel boot agent -- but will have to state that info again when I get home, I do gain access to that, the scsi utility, bios during bootup, however the error that I get in the post bootup is pertaining to the raid controller. It says that there is an error with the disk volume 2 and then continues to tell me that it is going to use volume 2 ---I will edit when I get home...


Off the bat I have tried older versions of redhat with a boot disk, ubuntu live cd, pclinuxos, mandrake, slackware...all of them have issues with the boot disk...not that the bootdisk is errored but from reading the instructions on the boot disk and then trying to access the cdrom seems to be the issue except for mandrake 9.0.

Now I am thinking that maybe I should get a scsi CDROM and retry to see if it can boot off that. Thing is I have not dealt with scsi peripherals in over several years, so knowledge is very limited. I even tried using an old hdd which seemed to posibly work, but the drive was making clicking noises so I stopped the install thinking that the hdd was corrupted. however I would rather have the os installed on the hdd.


I was also thinking of trying to find a distribution that fits on a diskette and then when installed and ran I could tell it to download packages from the net (similar to gentoo min cd install - from what I hear). but have had no luck so far in finding one....been reading up on coyote linux, damn small linux, even slim linux which I just found now (http://slim.cs.hku.hk/).

thing is that if there is an actually software out there that allows one, thru floppy, to choose his boot device and in turn have that device start let's say a linux cd by right away autodetecting it, as a pose to the windows boot disk that only gains drive access with a letter and then you having to run the executeable manually to start the install, would be amazing. However what one would call an app as such eludes. closest searches always bring me to boot disks or partition managers.


I have even thought about a network install but I am not good with getting nic cards to work from prompts. for something as such I would really need guided help with that. This is why I was thinking and going towars Gentoo.


In case I never stated here, Live cd's don't work....which makes sense since no cd autoboots from the cdrom. Even from my NT2K server install, I had to use the win98 bootdisk and then run then winnt command from the prompt.


**hope my compaq ML370 gives me less issues than this baby when she comes.

I will see if I can grab a pic from my quick cam and add it to the post so you can see this system.

Link to comment
Share on other sites

I'm just wondering if your drive needs cleaning perhaps. It could have a dirty lens or something, which is easily cleanable with a CD-ROM cleaning kit.


Or if you have a spare IDE CD-ROM, try sticking this in and see if it improves any?




I'm surprised such a system won't boot directly from the CD drive. Is there a BIOS update available that might provide the functionality for it.

Link to comment
Share on other sites

was thinking about that but that may be a lil challlenge in itself. the I would have to dismantle the whole system to gain access to the mother to get the schem info and then do a search online for the comp...unless you know of a program that would tell you....or is the info from windows device manager good enough?



thing is that I don't see dev mgr showing motherboard information so I think I will have to dismantle the system and rebuild it. I did want to try and remove all the software from completely with the bios as is but was kinda nervous because I do not have the scsi utility software that detects my hard drive and dat tape.


I'll try what you suggest by swapping the cdrom with another one. I doubt that is the issue cause I was able to install NT Server with it. I think I may just have to purchase a new ide hdd and find a way to mount it in there with brackets and install the os to it if possible and then use the scsi drives as a backup alternative or simply for space....If that works I would be content in having it as an apache/ftp server with linux....If I have to leave the NT server on it then I will custom it for

IIS and then have another linux box diverted to it to for my web and ftp storage space or maybe just a simple mp3 streaming box for the lan.

Link to comment
Share on other sites

Depends on the BIOS's. Normally with Award BIOS's etc, which end up in most white box PC's you can get this from the boot screen when it's detecting HDD's etc.


But with manufacturers, you usually have to go direct to Compaq/HP or whoever depending on who made the system. Just thought it was odd you couldn't boot from the CD considering the specs, most if not all, even prior to this were bootable, which leads me to think the BIOS doesn't support it.


Your winnt install was done booting a DOS floppy and loading a driver to access the CD-ROM, which is slightly different to booting directly from the CD.

Link to comment
Share on other sites

yeah that is the beauty of a manufactured system...enter the model # and your igood to go.. but with this system I haven't the foggiest clue. There is a sticker on it but this looks to refer to the company that had owned the box prior.

For the Bios. Yeah I tried to see what it was from boot but the screen flickers so fast with 2 words of something on the screen and then starts the intel boot agent (press ctrl-S to enter setup). After that I get prompted to enter the kscsi utility (ctrl-c ...i believe...). .. for the lat option, the raid controller. That would be ctrl M, I think. then of course I can press the F2 option at any point to get the bios or F12 for network boot. Do you think that the bios would tell me about the boot agents and/or further info about the bios itself?


But ultimatelyI think I really should just dismantle it and put it back together again.may be a lil pain with the way the server is built, but in the end I'll end up knowing more about the system.


Oh btw...funny thing too. I had to pull a mcgyver on it. there were 2 scsi controller cards in it and for some reason when I started tinkering with the system at my house only 1 was working fine. I had to remove the other one and then take the cable that was attached to the removed one (for the dat tape) and pass it throught he opening in the back where a pci card would be and then taper it to the adaptec scsi controller port on the back. then the system saw my hdd's and the tape drive. but when I was at the store the system showed the information fine so I am wondering if that may be the issue. someone pointed out to me that I need to terminate my scsi cable for the system to work. So maybe that is the case of the freeze during install or the fact that I made a mcgyver move and mandrake cannot get past the dat tape.


I'll try the install again but with minimal things attached to it and take a closer look at that other scsi controller....

Link to comment
Share on other sites

Not all SCSI devices need to be terminated. Some self-terminate, and others don't. Usually the terminator is just a block on the end of the cable from when I've used them, or a block you attach to a tape drive, etc.


I'd be tempted to take back to the shop if one of the scsi cards has stopped working. Unless of course there is no warranty or 30 day return on failure of components.

Link to comment
Share on other sites

not worth it really for just that one scsi card...plus I got some in the ol treasure trove box of nic, vga's and other cards. but the system seems to be running fine off this one card and I like things simple. not sure why these guys had an extra card in there when one is good enough. and the store is a used pc store so i get things so cheap that it would not really make sense to gripe over an extra scsi card malfuntioning. especially when I might setup and ebay store for the used stuff, lol.


Nah I'll just keep with this issue until I eventually get it to work. I know a buddy that is somewhat experienced with this so I may have him take a look at it as a last resort, but the linux install is what is really getting to me. funny thing is that I always get other ppls pc's to work and now I can't even get my own to work, hahaha :P

Link to comment
Share on other sites

Ok well I think I kind of isolated the issue. think it was a jumper issue.

I finally was able to get the cdrom to boot as default by using another jumper plug and setting it again as master. By doing this I was able get it recognized automatically in the bios and also able to get cd's booted up by it.

The problem with the install of certain distros such as ubuntu is due to my tape drive. Either it needs to be terminated on its end or there is a driver issue with it and the distrobution.

With regards to the mandrake distro (9.0), it still locks up on the install so I am down to either ubuntu, redhat, slackware, or pclinuxos. I already know that ubuntu should work because I was able to get the live cd to run fine as long as the tape drive was disconnected from the system. But the issue I have with it is configuring the raid and the grub (I believe to setup my partitions and filesystems). I should be able to get the necessary howto info on their site.

Now with the tape drive issue, how would I terminate it. What is the specific name for the terminating cable, plug.... for it. That way I can search for one at local pc stores.


I think that the whole issue has to be with the terminator and/or the tape drive.


When I get back I will check in to that a lil more cuz I kdo believe the tape drive should work with any distro.



For the motherboard I got this info from it INTEL SERVER BOARD G7ESZ - VERTEX M1 ( APTL 13101457 / PBA A28808-305)




This is a pdf file that details the motherboard itself >> http://support.intel.com/support/motherboa...b/cs-007531.htm <<



The STL2 motherboard's scalability provides the performance needed for today's unpredictable e-Business economy. It supports up to two Intel Pentium III processors with 133MHz system bus and six PCI slots. Two of the PCI slots are on an independent, 64-bit/66MHz PCI bus, which provides added I/O throughput. Additional server technologies include the Intel PRO/100+ Fast Ethernet Controller, Ultra160 SCSI storage, 4GB of PC133 ECC SDRAM memory capacity and Intel server management. Order yours now!



• Intel STL2 Dual Socket 370 Server Board w/VRM

• General Features:

• Intel STL2 Dual Socket 370 server board

• Supports Dual Pentium III CPU 133FSB 667 MHz to 1 GHz

• Supports up to 4 GB Registered ECC SDRAM

• Installed voltage regulator module

• Integrated Intel 82559 (10/100 Ethernet)

• Motherboard Features:

• ATX form factor

• Two (2) socket 370 sockets

• Two (2) 66 MHz/64-bit PCI slots

• Four (4) 33 MHz/32-bit PCI slots

• Four (4) 164-pin DIMM sockets

• One (1) x IDE, UDMA 100/66 connector

• One (1) Ultra single ended SCSI connector

• One (1) Ultra 160 LVD SCSI connector

• I/O ports:

• Two (2) USB ports

• Two (2) 9-pin serial ports

• Two (2) PS/2 ports

• One (1) Parallel port

• One (1) 15-pin VGA port

• One (1) RJ-45 Ethernet jack

• Regulatory Approvals:

• CE

• UL

• Gost-R

• C-Tick

• Package Includes:

• Intel STL2 Barebones system

• Drivers CD

• Users Manual (on the drivers CD)

• Floppy cable

• LVD 68-pin SCSI cable

• IDE cable

• I/O plate

• Notes:

• Model: STL2

• P/N: G7ESZ

• This motherboard requires a power supply with a 24-pin ATX power connector

Additional Information:



Information Links:




Edited by gem-in-eyez
Link to comment
Share on other sites

They are just called scsi terminators as far as I know, this is what I've always known them as. You'll of course need the correct one as per your SCSI architecture, SCSI2, SCSI3, etc.


In terms of raid, are you attempting software raid configuration? If so, I can help you there. If hardware raid, it should be done from the controller for the disks.

Link to comment
Share on other sites

They are just called scsi terminators as far as I know, this is what I've always known them as. You'll of course need the correct one as per your SCSI architecture, SCSI2, SCSI3, etc.

In this make sure you use a good terminator....

I went through stuff a while ago turned out to be the HP provided terminator that was causing the problems


Switched it for a different terminator and problems solved.

Link to comment
Share on other sites

awesome, thnx for the heads up on the scsi terminators... I forgot to write down the model for my scsi controller, but when I get home I will research in to it and make some calls to locals stores.

Odd thing though is that in windows the tape drive works fine without any issues. I even tested it by running an NTBackup command that allowed me to backup the data to my a tape my cousin passed me, until I buy my own.


also from what I read from those links above, I seem to have 2 types of scsi connectors on the motherboard. Are these just like the scsi controllers themselves too?

-One (1) Ultra single ended SCSI connector

-One (1) Ultra 160 LVD SCSI connector


http://www.ramelectronics.net/html/scsi_connecters.html (just a link that I found that explains the connectors I was researching)...



From what I recall, they are not in use and no cables are at all attached to them. So I am wondering just off the bat like that. I remembered a long time ago that to terminate you would take the end of a scsi cable and connect it to itself.... I take it that this option is no longer effective since my connectors on the cables are all the same?


For the raid, As it boots the system prompts me to press ctrl-key to access the Raid configuration. I still need to look up on that because I still cannot tell if it is software or hardware. If hardware is this something that is built in to the slots where the scsi hdd's slide into? & if software how does one go about to remove and re-install it? I figure this would be the best way for me to understand how it truly works and how to configure it.


also when I install Ubuntu, during the install process it prompts me to create, remove, edit ..I suppose, the raid volumes on the system. So I also need to read up on the ubuntu install process to comprehend this part of the install.


Either way it sure feels good to finally be able to atleast boot and get the server going this far.

Thnx for the help!

Edited by gem-in-eyez
Link to comment
Share on other sites

Software is when the raid config is done by Linux, or Windows or the operating system that you choose to use. So what ubuntu is showing is software configured.


Since you have a raid controller in your system, its much faster to use hardware raid than software raid. So use the CTRL key to get in, and then depending on how many disks you have, you can configure Raid1 for mirroring or Raid5 arrays if you have 3 or more disks. Raid 5 is cool.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...