Jump to content
ianw1974

PLF/PLF-Free Issues

Recommended Posts

Some of you may or may not have noticed, but the plf easy-urpmi entries seem to be busted. I have managed to get my specific mirror to work because of an error trying to detect $ARCH when selecting the appropriate mirror source. The mirrors are still there, it's just easyurpmi isn't generating the code correctly, or something has been changed on the mirrors, or something on the distro isn't listing $ARCH.

 

Easyurpmi on zarb's website seems to have a very very small list of plf mirrors, of which I couldn't even get the code to add them to my machine anyway. So it seems like easyurpmi as whole no matter what the easyurpmi mirror is.

 

I can expect that your existing mirrors will work, just connect to it directly, and then find out where the synthesis.hdlist.cz file is, and make sure you edit the path so that it's updated, and you should be able to add without any problems.

 

Any existing plf sources will have to be removed, since they no longer point to the correct place.

 

If your plf sources are working, then great, I'm no idea why half a dozen sources I've chosen are all busted. Something has gone wrong somewhere, and no idea where. But the problem can be overcome easily enough.

Share this post


Link to post
Share on other sites

I noticed this yesterday while updating my sources. (I update them occassionally so as to not get into trouble.)

Share this post


Link to post
Share on other sites

I do it quite regularly too. Looking at it when adding, you can see problems with $ARCH, or at least I did for the particular mirror I'd chosen.

 

I simply added the i586 to the end of the line, and it would pull the synthesis.hdlist.cz from within here, and add to my sources. Of course, it's nice for auto-detect to attempt to get the right version, but this is how I got around it anyhow.

 

Now I can carry on with PLF normally :P

Share this post


Link to post
Share on other sites

Have you tried reporting it to the easy-urpmi gang? I guess they will be aware of it, but you never know.

Share this post


Link to post
Share on other sites

Strange, but for me, the PLF mirrors don't cause any problems. I installed them yesterday evening on my laptops and they worked instantly. :unsure:

Share this post


Link to post
Share on other sites
Strange, but for me, the PLF mirrors don't cause any problems. I installed them yesterday evening on my laptops and they worked instantly. :unsure:

 

That's because this topic was from april :)

Share this post


Link to post
Share on other sites

But eternal's links are current and probably useful for those who need a quick fix and are a bit lost to configuring urpmi by hand. ;)

Share this post


Link to post
Share on other sites

Ai, I have all my 2007 sources, main/contrib/updates/plf-free/plf-nonfree and all looking good.

 

At work, cos I have nice fast connection, I mirrored main/contrib/updates so I don't have to keep downloading everything twice. At home I only have updates mirrored :P

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...