Jump to content
Sign in to follow this  
ianw1974

Quick and Easy Kernel Compile Upgrade

Recommended Posts

Aha - here it is:

# ifconfig -a

eth0 Link encap:UNSPEC HWaddr 00-11-D8-00-00-E9-5D-57-00-00-00-00-00-00-00-00

UP BROADCAST RUNNING MULTICAST MTU:1008 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

 

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:402 errors:0 dropped:0 overruns:0 frame:0

TX packets:402 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:160852 (157.0 KiB) TX bytes:160852 (157.0 KiB)

 

sit0 Link encap:IPv6-in-IPv4

NOARP MTU:1480 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

 

When I'm runing

Mandriva Linux Control Center -> Network & Internet -> Set up a new network interface(LAN, ISON, ADSL...) -> LAN connection

it shows Net Devices:

eth0: IEEE 1394 IPv4 Driver (IPv4-over-1394 as per RFC 2734)

eth1: nVidia Corporation|MCP51 Ethernet Controller

& by default Mandriva trying establish connection throug eth0...

& trying to change configuration of IEEE 1394 was realy bad idea... - it causes kernel panic...

Share this post


Link to post
Share on other sites

You can disable the ifcfg-eth0 file by editing /etc/sysconfig/network-scripts/ifcfg-eth0 file and changing onboot=yes to onboot=no. Then eth1 will only be active.

 

I would do this next. Go into System/Configuration/Configure Your Computer. Then select hardware, and you need to view your hardware. Look at your network card, and it should say what module is loaded for this card. The module is effectively a driver in Windows terms.

 

Then, from the command line, you can see if this module is loaded, by doing:

 

lsmod | grep modulename

 

replacing modulename, with what you found in the network card details for your nvidia card.

 

Also, please post the contents of /etc/sysconfig/network-scripts/ifcfg-eth1 file in case it's not configured properly. Although if you've gone through the settings in Configure Your Computer for the LAN connection for this card, then it should have the settings you set in this file.

Share this post


Link to post
Share on other sites

ian, when I've reload system the a result from "ifconfig -a" was as in my last post, but now I'got another one :

 

eth0 Link encap:UNSPEC HWaddr 00-11-D8-00-00-E9-5D-57-00-00-00-00-00-00-00-00

BROADCAST MULTICAST MTU:1008 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

 

eth1 Link encap:Ethernet HWaddr 00:18:F3:7B:87:10

inet6 addr: fe80::218:f3ff:fe7b:8710/64 Scope:Link

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:1 errors:0 dropped:0 overruns:0 frame:0

TX packets:6 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:1000

RX bytes:73 (73.0 b) TX bytes:468 (468.0 b)

Interrupt:16 Base address:0xc000

 

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

inet6 addr: ::1/128 Scope:Host

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:388 errors:0 dropped:0 overruns:0 frame:0

TX packets:388 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:148368 (144.8 KiB) TX bytes:148368 (144.8 KiB)

 

sit0 Link encap:IPv6-in-IPv4

NOARP MTU:1480 Metric:1

RX packets:0 errors:0 dropped:0 overruns:0 frame:0

TX packets:0 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)

 

so, one device is added, but it gives little help

Share this post


Link to post
Share on other sites

Well, eth1 as you mentioned before is your true network card, whereas eth0 is your firewire card apparently.

 

Easy way to tell is take a look in /etc/modprobe.conf. There will be lines like:

 

alias eth0 modulename
alias eth1 modulename

 

you can then find out which one of these is firewire and which one is your network card. So, now you have both cards detected, now we need to get an IP address on the network card.

 

Do you have a DHCP server? Or do you have a router that is offering DHCP? Do you know what IP address is assigned to this router?

 

Did you run the commands I gave from the previous post to see what module is for your network card, and if it is loaded?

Share this post


Link to post
Share on other sites

2 ian

 

Hi again !

So, one by one:

in etc/.../ifcfg_eth1:

DEVICE=eth1

BOOTPROTO=none

IPADDR="No IP"

NETMASK="No Mask"

BROADCAST=255

MII_NO_SUPPORTED=yes

PEERDNS=yes

NETMASK="No Mask"

IPADDR="No IP"

 

I've put "ONBOOT=no" to ifcfg-eth0 - it seems that nothing changed after rebooting - when I look Control Center, I'm again suggested, that ethernet-connection will be through eth0;

 

Yes, I hav DHCP-server number, IP-address (as far I'd read them from Windows)

 

For eth1 is "forcedeth"-module, but I didn't understand - what to do with this ?

 

In etc/modprobe.conf I can see:

alias eth1 forcedeth

alias eth0 eth1394

 

Say, how to change quickly system-files, like "ifcfg-eth0" - through "vi-redactor" ?

Share this post


Link to post
Share on other sites

BOOTPROTO should have been something like DHCP or STATIC. This is why you're not getting an IP address. I think you need to go in and configure this interface. Of course, the system configuration utility will always try to default to the eth0, but this is not important. If eth1 is configured properly then it will work with this and ignore eth0.

 

If you want eth1 to be eth0, then it's easy enough to change. First, delete these two files:

 

rm /etc/sysconfig/network-scripts/ifcfg-eth0
rm /etc/sysconfig/network-scripts/ifcfg-eth1

 

now, edit /etc/modprobe.conf so it looks like this:

 

alias eth0 forcedeth
alias eth1 eth1394

 

and reboot your system. Now, you'll need to go into Configure Your Computer, and create a new LAN interface. And make sure you configure it correctly, selecting the options you need.

Share this post


Link to post
Share on other sites

It still doesn't work.

I made changes in /etc/modprobe.config and reboot system, the now if I look /etc/modprobe.config, there:

alias eth0 forcedeth

alias eth1 eth1394

 

But when I'm looking Control Center - no changes there - in New Connection -> LAN Connection

eth0: IEEE 1394 IPv4 Driver (....)

eth1: nVidia Corporation|MCP51 ....

 

How it is possible ?....

 

Well, maybe there is another way to decide problem - nVidia supplies drivers for Linux, the only problem, that I've met before is that installing-program looks for kernel-sources in /usr/src...

Maybe I should find a kernel with exactly matching kernel-sources, compile them & try to install those files from nVidia ?

Share this post


Link to post
Share on other sites

Either that, or try a more up-to-date Mandriva kernel to save compiling your own. There is kernel-2.6.17.8 out now that you can install with urpmi or the Install Packages tools. And if you set up your easyurpmi sources you can even get 2.6.18 kernels too easy enough without having to compile.

 

Maybe try one of these. However, it shouldn't matter whether one is listed as eth0 or eth1, you can still select it, go to the next screen and configure it. Just make sure you change /etc/modprobe.conf back to what it was before changing it. so that eth1 is the forcedeth and the eth0 is the eth1394.

 

And if it's not configuring properly with the wizard, then it's either not working correctly, or something is being done wrong somewhere. The wizards almost always work.

Share this post


Link to post
Share on other sites

Hi, ian !

it works - I hardly can believe it, but indeed... :lol2:

 

- I've install linux-2.6.18;

- then go KDE -> Control Center -> Network & Internet -> Set up a new network interface -> LAN connection - You can see what is output on

http://www.mandrake.tips.4.free.fr/installmdv2006.html

(in the chapter "Summary -- Network"...)

- then "Net device" (my case - eth1: nVidia Corporation|MCP51...) -> Manual Configuration -> enter IPadreess & Netmask -> enter DNS server 1, Gateway (same as DNS) and !! - on 2.6.18 there is an option "Gateway device" (wich wasn't on previous versions) !! - so choose here "eth1..." and that's it !

- reboot

 

it works.... at last ...

Share this post


Link to post
Share on other sites
Guest ppera
...

I didn't bother to update my symlinks for config, etc, etc. I could do, but for now, I've installed it as it. The last command also modified my lilo configuration and created an entry called "26156".

...

 

 

I'm new here. Went to kernel compile because need some extra in (Atari partition system support).

So, I made it by guide, only difference is that I ran config to check couple items, what I need.

It all went fine and new kernel is loadable and practically everything works (including Atari support), except supermountm but it is not important to me.

 

What I can't do is compiling of Nvidia driver modul. I tried with latest 9631, but first it complained about missing version.h of kernel, so I 'made' it. Now can't find kernel sources. Is it because of not updated symlinks, configs? What should I do to update them?

Edited by ppera

Share this post


Link to post
Share on other sites

Kernel source should always be in /usr/src and normally should have a symlink pointing to it which is called linux.

 

Where did you extract the kernel you downloaded? Did you delete this directory after compiling your kernel? If you did, that's bad, as the /lib/modules/kernel-version directory refers back to the /usr/src/kernel-version directory.

 

I always extract the kernel I downloaded into /usr/src

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...