Jump to content
mmodem

New kde-3.5.1 by MDE

Recommended Posts

I get the following error when trying to install the latest kdebase (kdebase-3.5.1-9.mdk2006.0.mde.i586):

 

cat: /home/mmodem/rpm/SOURCES/kdebase-3.5.1-MDE-kdeglobals: file or directory not found

error: %pre(kdebase-3.5.1-9.mdk2006.0.mde.i586) scriptlet failed, exit status 1

error: install: %pre scriptlet failed (2), skipping kdebase-3.5.1-9.mdk2006.0.mde

 

does anybody know how to fix that?

Share this post


Link to post
Share on other sites
I get the following error when trying to install the latest kdebase (kdebase-3.5.1-9.mdk2006.0.mde.i586):

 

cat: /home/mmodem/rpm/SOURCES/kdebase-3.5.1-MDE-kdeglobals: file or directory not found

error: %pre(kdebase-3.5.1-9.mdk2006.0.mde.i586) scriptlet failed, exit status 1

error: install: %pre scriptlet failed (2), skipping kdebase-3.5.1-9.mdk2006.0.mde

 

does anybody know how to fix that?

Im doing some changes (moving some files and adding/fixing some defaults) due to this i created this error, but this will be fixed now.

Share this post


Link to post
Share on other sites
Im doing some changes (moving some files and adding/fixing some defaults) due to this i created this error, but this will be fixed now.

 

ah great to hear ... ;-) thx for your excellent work btw ... keep it up!

Share this post


Link to post
Share on other sites

hi, Thac, Zé,

I installed KDE 3-5, x86_64 version, and it works! It's great, it's beautiful! It is indeed great work of yours, thank you very much!

 

I had to start installation a few times, because of unresolved dependencies. With each new run I got less and less of conflicts & failed transactions, and eventually it converged to success. I am not sure this was the right way to update :) I had some issues with kmail, kontact, korganizer, during and after the update, so the advice to copy .kde is very useful!

Share this post


Link to post
Share on other sites

Greetings. I installed 3.5.1 with your rpms yesterday. Instead of reading, ( :lol: ) I did what I normally do, which is go to a different wm and uninstall/reinstall.

First, x wanted to be updated, so I did that and rebooted x. Then I started again. Because of Mandriva tools relying heavily upon kde, it was necessary to uninstall/reinstall chunks of kde. What I did to get urpmi to assist was add your repository into the updates. Then I updated whatever would not give me errors. I actually did this using a combination of command line and MCC. The kdebase needed to be forced because of a missing j2re file. It was not on any of the repositories (I have them all in my setup) and I finally had to go to Sun's site and get the generic self extracting rpm. After all that, things went typically via urpmi. But, I think there should be a j2re rpm available somewhere other than hunt and search.

 

Your kde rpms are very nice. In fact, kde is truly smoother now than previously. (I had the Mandriva 3.4 running) I also like the mde splash; it is nice to get away from blue! :P

 

Oh, yeah, this was on my laptop rather than my desktop, so for what it's worth, the laptop works fine. I did not lose my wireless network or any of my configuration files. The initial problems were related to the kdebase and the icon set that is default. All in all, the install was not a beginner's sort of thing to do, but lots of fun playing! ;)

Share this post


Link to post
Share on other sites

Installed latest build but it has lots of bugs. In kdeaddon packages metabar is no longer there, the system monitor applet is gone. In kdepim: Kontact doesn't work because the sidebar doesn't show. Individial kmail/akregator work. In kde network kopete is broken. Accounts don't show. And Kttsd no longer works.

Share this post


Link to post
Share on other sites
Installed latest build but it has lots of bugs. In kdeaddon packages metabar is no longer there, the system monitor applet is gone. In kdepim: Kontact doesn't work because the sidebar doesn't show. Individial kmail/akregator work. In kde network kopete is broken. Accounts don't show. And Kttsd no longer works.

thats not true, i ave all the apckages i made yesterday installed and all runs smothly, and to remember that before packages go public all is first tested.

There is some lib packages that dont exist anymore since some files were bad position since we did follwoed how mandriva put files but again all were wrong...

Share this post


Link to post
Share on other sites

Installed latest build but it has lots of bugs. In kdeaddon packages metabar is no longer there, the system monitor applet is gone. In kdepim: Kontact doesn't work because the sidebar doesn't show. Individial kmail/akregator work. In kde network kopete is broken. Accounts don't show. And Kttsd no longer works.

thats not true, i ave all the apckages i made yesterday installed and all runs smothly, and to remember that before packages go public all is first tested.

There is some lib packages that dont exist anymore since some files were bad position since we did follwoed how mandriva put files but again all were wrong...

Almost the same here :

- System monitor applet is shown in "add applet" dialog, but can't be loaded

- kdeaddons-akregator is there, but doesn't run

- Search bar in konqueror is missing

- libkdeaddons1-searchbar and libkdeaddons1-sidebar do not exist anymore

Absence of problems on your computer doesn't guarantee absence of problems on other computers, you know.

Share this post


Link to post
Share on other sites

I have now seen that kde is done/coded in a different way, since to work does need the dynamic lib files *.la and *.so , but these files should be devel files but in kde its not the case.

 

So to know you have things working you must install devel packages until i put/move lib dynamic files back to previous places.

 

I didnt know about this, thats why i did moved those files to devel files, since that is how is done in the generall.

 

Im very very surprised with this...

Share this post


Link to post
Share on other sites
I have now seen that kde is done/coded in a different way, since to work does need the dynamic lib files *.la and *.so , but these files should be devel files but in kde its not the case.

I believe you are very seriously mistaken here. *.so shouldn't mandatorily belong to -devel packages. It's exactly the other way around, they are a crucial part of regular packages. OTOH, *.a and maybe *.la belong to -devel.

Edited by chalex20

Share this post


Link to post
Share on other sites

I have now seen that kde is done/coded in a different way, since to work does need the dynamic lib files *.la and *.so , but these files should be devel files but in kde its not the case.

I believe you are very seriously mistaken here. *.so shouldn't mandatorily belong to -devel packages. It's exactly the other way around, they are a crucial part of regular packages. OTOH, *.a and maybe *.la belong to -devel.

Wrong again, .so files do belong/are devel files, please read and check about it, and in kde they are/were always in devel packages.

The problem here in kde is that .la files that also should be in devel packages, but these to the way kde is coded must be in lib packages, this is the problem.

 

Im going to build a new kde to fix this issue, meanwhile install devel packages.

Share this post


Link to post
Share on other sites
Im very very surprised with this...

 

Wihout surprises life would be boring.. :) Installed the devel packages and everything works again. Anyway thanks for the quick response: I post a bug report last night and when I wake up the next morning the problems are solved. :D

Share this post


Link to post
Share on other sites
Wrong again, .so files do belong/are devel files, please read and check about it

Where can I read about it? All I've read suggests me that you need .so files to run applications rather than to develop extensions for them.

 

Just a little example :

rpm -ql libgtkhtml2_0
/usr/lib/libgtkhtml-2.so.0
/usr/lib/libgtkhtml-2.so.0.0.0

 

rpm -ql libgtkhtml2_0-devel
...
/usr/lib/libgtkhtml-2.a
/usr/lib/libgtkhtml-2.la
/usr/lib/libgtkhtml-2.so

 

If someone argues that there is ".so" file in the devel- package, here it goes for him :

ls -l /usr/lib/libgtkhtml-2.so
lrwxrwxrwx  1 root root 21 Nov  5 22:47 /usr/lib/libgtkhtml-2.so -> libgtkhtml-2.so.0.0.0*

This .so is but a symlink.

So, what we see in this little example ? All the versioned .so files are in the regular package, while .la, .a and unversioned .so ( that are but symlinks) are in the -devel package.

Edited by chalex20

Share this post


Link to post
Share on other sites
If someone argues that there is ".so" file in the devel- package, here it goes for him :

ls -l /usr/lib/libgtkhtml-2.so
lrwxrwxrwx  1 root root 21 Nov  5 22:47 /usr/lib/libgtkhtml-2.so -> libgtkhtml-2.so.0.0.0*

This .so is but a symlink.

So, what we see in this little example ? All the versioned .so files are in the regular package, while .la, .a and unversioned .so ( that are but symlinks) are in the -devel package.

And i didnt take a good look before, this is no exception as i said in previous post, this is correct since there are files libgtkhtml-2.so.0.0.0* that point to libgtkhtml-2.so, wich is a devel file in a devel package.

But for example you can see exceptions for example in libqt3 in wich you see that in /usr/lib/qt3/plugins/lib/styles exist some .so files that are files needed to run plugins, and in this case they are correct to exist in a lib package.

 

The other .so.* files are in lib package that are correct in wich have nothing to do to the .so files.

 

Thanks for giving an example that reflects so well what i have said :)

Edited by mmodem

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...