Jump to content
mmodem

New kde-3.5.1 by MDE

Recommended Posts

And i didnt take a good look before, this is no exception as i said in previous post, this is correct since there are files libgtkhtml-2.so.0.0.0* that point to libgtkhtml-2.so,

It's exactly the other way around. libgtkhtml-2.so ( in development package ) points to libgtkhtml-2.so.0.0.0 ( in regular package). libgtkhtml-2.so is not a library per se, but a symlink.

To formulate what I've said in a bit different way : one may use .so for development, but it is generally used for running applications. One doesn't generally use .a for running an application. So, .so may be present either in regular packages or in development packages, whereas .a are not generally present in regular packages, but are widely present in development packages.

Share this post


Link to post
Share on other sites

Wasn't sure where to post this, but I discovered it during my kde upgrade and so here it is. I think your ndiswrapper rpm is broken. I just spent several days messing with it and only fixed the problem after removing your rpm and reinstalling the Mandriva rpm. However, kde is great!!

Share this post


Link to post
Share on other sites

I do not know what problem you had with the 1.7 driver i have been using it until today.

But now i have upgraded to ndiswrapper-1.10 and also made that available both in 32bit and 64bit.

I am actually running through ndiswrapper-1.10 now, in 64bit.

Share this post


Link to post
Share on other sites

Actually, I have since experienced problems with the stock rpm as well. So since I upgraded kde and the kernel, ndiswrapper is not working correctly. It is probably configuration rather than the driver itself.

 

The problem is that it will not work automatically. I have to initiate it and set it up everytime, despite the fact I have it listed in the configuration file. There seems to be an issue with eth0 and wlan0 both being configured at boot.

Share this post


Link to post
Share on other sites

KDE 3.5.1 and -devel packages?

 

On Jan 19 I upgraded my Mandriva 2006.0 to KDE 3.5 and in Feb. upgraded to KDE 3.5.1 (urpmi --auto-select) and I have noticed that several -devel packages are installed. Some pulled in from Mandriva official repositories. I am wondering why it is necessary to have so many -devel packages installed. I thought that the -devel packages are generally only needed if you are compiling or developing additional modules. Before I upgraded to KDE 3.5 and 3.5.1 I had very few -devel packages installed on this system. Since I am not compiling or developing packages or modules, why are many -devel packages required to be installed with your KDE 3.5.1?

 

It seems to me that the discussion by chalex20 and mmodem left the issue of what should be in -devel packages unresolved.

 

For your info here is output of:

$ rpm -qa -last | grep devel

libkdebase4-kate-devel-3.5.1-10.mdk2006.0.mde Thu 16 Feb 2006 08:04:56 AM CST

libkdebase4-devel-3.5.1-10.mdk2006.0.mde Thu 16 Feb 2006 08:04:51 AM CST

libkdecore4-devel-3.5.1-10.mdk2006.0.mde Wed 15 Feb 2006 07:13:46 PM CST

libarts1-devel-1.5.1-5.mdk2006.0.mde Wed 15 Feb 2006 07:00:26 PM CST

libqt3-devel-3.3.5-7.mdk2006.0.mde Wed 15 Feb 2006 06:59:28 PM CST

libxorg-x11-devel-6.9.0-36.mdk2006.0.mde Wed 15 Feb 2006 06:58:12 PM CST

libxorg_Mesaglut3-devel-6.5.0-36.mdk2006.0.mde Wed 15 Feb 2006 06:52:00 PM CST

libxorg_MesaGLU1-devel-6.5.0-36.mdk2006.0.mde Wed 15 Feb 2006 06:52:00 PM CST

libalsa2-devel-1.0.10-1.mdk2006.0.mde Tue 07 Feb 2006 02:13:26 PM CST

libmas1-devel-0.6.3-1mdk Tue 07 Feb 2006 02:13:19 PM CST

libgtk+2.0_0-devel-2.8.3-4.2.20060mdk Tue 07 Feb 2006 02:13:15 PM CST

libgdk_pixbuf2.0_0-devel-2.8.3-4.2.20060mdk Tue 07 Feb 2006 02:12:56 PM CST

libacl1-devel-2.2.31-1mdk Tue 07 Feb 2006 02:12:49 PM CST

libattr1-devel-2.4.23-1mdk Tue 07 Feb 2006 02:12:47 PM CST

libpcre0-devel-6.3-1mdk Tue 07 Feb 2006 02:12:43 PM CST

libmad0-devel-0.15.1b-3mdk Tue 07 Feb 2006 02:12:41 PM CST

libgamin-1_0-devel-0.1.5-3mdk Tue 07 Feb 2006 02:12:39 PM CST

libidn11-devel-0.5.18-2mdk Tue 07 Feb 2006 02:12:37 PM CST

libmng1-devel-1.0.8-1mdk Tue 07 Feb 2006 02:12:28 PM CST

libatk1.0_0-devel-1.10.1-1mdk Tue 07 Feb 2006 02:12:27 PM CST

libpango1.0_0-devel-1.10.0-3mdk Tue 07 Feb 2006 02:12:25 PM CST

liblcms1-devel-1.14-1mdk Tue 07 Feb 2006 02:12:23 PM CST

libcairo2-devel-1.0.0-8mdk Tue 07 Feb 2006 02:12:21 PM CST

libnas2-devel-1.7b-1mdk Tue 07 Feb 2006 02:12:18 PM CST

libart_lgpl2-devel-2.3.17-3mdk Tue 07 Feb 2006 02:12:16 PM CST

libesound0-devel-0.2.36-1mdk Tue 07 Feb 2006 02:12:14 PM CST

libaudiofile0-devel-0.2.6-3mdk Tue 07 Feb 2006 02:12:12 PM CST

libjpeg62-devel-6b-37mdk Tue 07 Feb 2006 02:12:10 PM CST

libglib2.0_0-devel-2.8.1-1mdk Tue 07 Feb 2006 02:12:07 PM CST

libpng3-devel-1.2.8-1mdk Tue 07 Feb 2006 02:10:55 PM CST

libvorbis0-devel-1.1.1-1mdk Thu 19 Jan 2006 08:58:26 PM CST

libogg0-devel-1.1.2-1mdk Thu 19 Jan 2006 08:58:25 PM CST

libfreetype6-devel-2.1.10-9.1.20060mdk Thu 19 Jan 2006 08:57:04 PM CST

libfontconfig1-devel-2.3.2-5mdk Thu 19 Jan 2006 08:57:04 PM CST

libexpat0-devel-1.95.8-1mdk Thu 19 Jan 2006 08:57:04 PM CST

zlib1-devel-1.2.3-1mdk Thu 19 Jan 2006 08:57:03 PM CST

libcdda0-devel-IIIa9.8-10mdk Thu 19 Jan 2006 08:51:59 PM CST

liblua5-devel-5.0.2-7mdk Thu 19 Jan 2006 08:18:51 PM CST

libncurses5-devel-5.4-1.20050108.1mdk Wed 26 Oct 2005 09:33:08 PM CDT

libstdc++6-devel-4.0.1-5mdk Wed 26 Oct 2005 03:23:54 PM CDT

glibc-devel-2.3.5-5mdk Wed 26 Oct 2005 03:23:39 PM CDT

libmDNSResponder1-devel-98-4mdk Wed 26 Oct 2005 03:23:38 PM CDT

 

Note:

26 Oct 2005 installation of 2006.0

19 Jan 2006 upgrade to KDE 3.5

07 Feb 2006 upgrade to KDE 3.5.1 (urpmi --auto-select)

15, 16 Feb 2006 urpmi --auto-select

 

Just wondering? Thanks for your good work!

CarLash

Share this post


Link to post
Share on other sites

There was a wrong move of some lib files that caused this, but it is fixed now in the latest rpms.

So you should be able to uninstall the devel rpms again.

Share this post


Link to post
Share on other sites
There was a wrong move of some lib files that caused this, but it is fixed now in the latest rpms.

So you should be able to uninstall the devel rpms again.

 

Thanks for your reply.

 

For your info, I did a urpmi --auto-select to upgrade to latest KDE 3.5.1.

 

Ran into a snag that I was able to work around.

 

71 of 81 packages were installed. The following 10 packages were not installed:

 

kdebase-kdm-3.5.1-12.mdk2006.0.mde

libkdebase4-kate-3.5.1-12.mdk2006.0.mde

kdebase-kdm-config-file-3.5.1-12.mdk2006.0.mde

kdebase-3.5.1-12.mdk2006.0.mde

kdebase-kdeprintfax-3.5.1-12.mdk2006.0.mde

libkdebase4-3.5.1-12.mdk2006.0.mde

libkdebase4-devel-3.5.1-12.mdk2006.0.mde

kdebase-progs-3.5.1-12.mdk2006.0.mde

kdebase-kate-3.5.1-12.mdk2006.0.mde

libkdebase4-kate-devel-3.5.1-12.mdk2006.0.mde

 

The error message was something like, "libkdeinit_konsole.so is needed by libkdebase4-3.5.1-12.mdk2006.0.mde.i586."

 

I typed:

 

# urpmi -v libkdebase4-konsole

 

and 11 packages were installed (the 10 packages that had previously not been installed and libkdebase4-konsole-3.5.1-12.mdk2006.0.mde).

 

I'll try later to remove some of the devel rpms.

 

CarLash

Share this post


Link to post
Share on other sites

There was a wrong move of some lib files that caused this, but it is fixed now in the latest rpms.

So you should be able to uninstall the devel rpms again.

 

<snip>

 

I'll try later to remove some of the devel rpms.

 

CarLash

 

Still unable to remove devel rpms. Maybe the following is useful for you:

 

# rpm -ev libkdebase4-devel

error: Failed dependencies:

libkdebase-devel >= 1:3.5.1-1.mdk2006.0.mde is needed by (installed) libkdeutils1-3.5.1-4.mdk2006.0.mde.i586

 

CarLash

Share this post


Link to post
Share on other sites
Still unable to remove devel rpms. Maybe the following is useful for you:

 

# rpm -ev libkdebase4-devel

error: Failed dependencies:

libkdebase-devel >= 1:3.5.1-1.mdk2006.0.mde is needed by (installed) libkdeutils1-3.5.1-4.mdk2006.0.mde.i586

 

CarLash

 

Yes, libkdeutils should not require libkdebase-devel, i have fixed it.

This error appeared because due to move files in the other release i had to change some things in specs, so my mistake to put that wrong require.

Share this post


Link to post
Share on other sites
Yes, libkdeutils should not require libkdebase-devel, i have fixed it.

This error appeared because due to move files in the other release i had to change some things in specs, so my mistake to put that wrong require.

Removed libkdebase4-devel, but still unable to remove libxorg-x11-devel-6.9.0-39.mdk2006.0.mde

 

# rpm -ev libxorg-x11-devel

error: Failed dependencies:

X11-devel is needed by (installed) libxpm4-devel-3.4k-31mdk.i586

devel(libX11) is needed by (installed) libkdemultimedia1-3.5.1-6.mdk2006.0.mde.i586

devel(libXext) is needed by (installed) libkdemultimedia1-3.5.1-6.mdk2006.0.mde.i586

devel(libXv) is needed by (installed) libkdemultimedia1-3.5.1-6.mdk2006.0.mde.i586

devel(libXxf86vm) is needed by (installed) libkdemultimedia1-3.5.1-6.mdk2006.0.mde.i586

 

TIA - CarLash

:o

Share this post


Link to post
Share on other sites
Yes, libkdeutils should not require libkdebase-devel, i have fixed it.

This error appeared because due to move files in the other release i had to change some things in specs, so my mistake to put that wrong require.

Removed libkdebase4-devel, but still unable to remove libxorg-x11-devel-6.9.0-39.mdk2006.0.mde

 

# rpm -ev libxorg-x11-devel

error: Failed dependencies:

X11-devel is needed by (installed) libxpm4-devel-3.4k-31mdk.i586

devel(libX11) is needed by (installed) libkdemultimedia1-3.5.1-6.mdk2006.0.mde.i586

devel(libXext) is needed by (installed) libkdemultimedia1-3.5.1-6.mdk2006.0.mde.i586

devel(libXv) is needed by (installed) libkdemultimedia1-3.5.1-6.mdk2006.0.mde.i586

devel(libXxf86vm) is needed by (installed) libkdemultimedia1-3.5.1-6.mdk2006.0.mde.i586

 

TIA - CarLash

:o

This was already fixed, there is a new kdemultimedia release.

Share this post


Link to post
Share on other sites
Yes, libkdeutils should not require libkdebase-devel, i have fixed it.

This error appeared because due to move files in the other release i had to change some things in specs, so my mistake to put that wrong require.

Removed libkdebase4-devel, but still unable to remove libxorg-x11-devel-6.9.0-39.mdk2006.0.mde

 

# rpm -ev libxorg-x11-devel

error: Failed dependencies:

X11-devel is needed by (installed) libxpm4-devel-3.4k-31mdk.i586

devel(libX11) is needed by (installed) libkdemultimedia1-3.5.1-6.mdk2006.0.mde.i586

devel(libXext) is needed by (installed) libkdemultimedia1-3.5.1-6.mdk2006.0.mde.i586

devel(libXv) is needed by (installed) libkdemultimedia1-3.5.1-6.mdk2006.0.mde.i586

devel(libXxf86vm) is needed by (installed) libkdemultimedia1-3.5.1-6.mdk2006.0.mde.i586

 

TIA - CarLash

:o

This was already fixed, there is a new kdemultimedia release.

 

Sorry to keep complaining, but should libkdemultimedia1-3.5.1-7.mdk2006.0.mde.i586 still require many -devel rpm packages?

 

Today I did urpmi -v --auto-select and here is result.

 

# urpmi -v --auto-select

 

To satisfy dependencies, the following 24 packages are going to be installed (48 MB):

kdemultimedia-3.5.1-7.mdk2006.0.mde.i586

kdemultimedia-kmix-3.5.1-7.mdk2006.0.mde.i586

kdemultimedia-kscd-3.5.1-7.mdk2006.0.mde.i586

libalsa2-devel-1.0.10-1.mdk2006.0.mde.i586

libarts1-devel-1.5.1-8.mdk2006.0.mde.i586

libatk1.0_0-devel-1.10.1-1mdk.i586

libaudiofile0-devel-0.2.6-3mdk.i586

libcairo2-devel-1.0.0-8mdk.i586

libesound0-devel-0.2.36-1mdk.i586

libgdk_pixbuf2.0_0-devel-2.8.3-4.2.20060mdk.i586

libglib2.0_0-devel-2.8.1-1mdk.i586

libgtk+2.0_0-devel-2.8.3-4.2.20060mdk.i586

libjpeg62-devel-6b-37mdk.i586

libkdemultimedia1-3.5.1-7.mdk2006.0.mde.i586

libkdemultimedia1-kmix-3.5.1-7.mdk2006.0.mde.i586

libkdemultimedia1-kscd-3.5.1-7.mdk2006.0.mde.i586

liblcms1-devel-1.14-1mdk.i586

libmad0-devel-0.15.1b-3mdk.i586

libmas1-devel-0.6.3-1mdk.i586

libmng1-devel-1.0.8-1mdk.i586

libnas2-devel-1.7b-1mdk.i586

libpango1.0_0-devel-1.10.0-3mdk.i586

libpng3-devel-1.2.8-1mdk.i586

libqt3-devel-3.3.5-10.mdk2006.0.mde.i586

Is this OK? (Y/n) y

 

18 of the 24 packages installed are -devel packages.

 

And still cannot remove libxorg-x11-devel-6.9.0-39.mdk2006.0.mde

 

# rpm -ev libxorg-x11-devel

error: Failed dependencies:

XFree86-devel is needed by (installed) libgtk+2.0_0-devel-2.8.3-4.2.20060mdk.i586

XFree86-devel is needed by (installed) libmas1-devel-0.6.3-1mdk.i586

X11-devel is needed by (installed) libxpm4-devel-3.4k-31mdk.i586

devel(libICE) is needed by (installed) libnas2-devel-1.7b-1mdk.i586

devel(libICE) is needed by (installed) libqt3-devel-3.3.5-10.mdk2006.0.mde.i586

devel(libICE) is needed by (installed) libarts1-devel-1.5.1-8.mdk2006.0.mde.i586

devel(libICE) is needed by (installed) libkdemultimedia1-3.5.1-7.mdk2006.0.mde.i586

devel(libSM) is needed by (installed) libnas2-devel-1.7b-1mdk.i586

devel(libSM) is needed by (installed) libqt3-devel-3.3.5-10.mdk2006.0.mde.i586

devel(libSM) is needed by (installed) libarts1-devel-1.5.1-8.mdk2006.0.mde.i586

devel(libSM) is needed by (installed) libkdemultimedia1-3.5.1-7.mdk2006.0.mde.i586

devel(libX11) is needed by (installed) libnas2-devel-1.7b-1mdk.i586

devel(libX11) is needed by (installed) libcairo2-devel-1.0.0-8mdk.i586

devel(libX11) is needed by (installed) libpango1.0_0-devel-1.10.0-3mdk.i586

devel(libX11) is needed by (installed) libgdk_pixbuf2.0_0-devel-2.8.3-4.2.20060mdk.i586

devel(libX11) is needed by (installed) libgtk+2.0_0-devel-2.8.3-4.2.20060mdk.i586

devel(libX11) is needed by (installed) libmas1-devel-0.6.3-1mdk.i586

devel(libX11) is needed by (installed) libqt3-devel-3.3.5-10.mdk2006.0.mde.i586

devel(libX11) is needed by (installed) libarts1-devel-1.5.1-8.mdk2006.0.mde.i586

devel(libX11) is needed by (installed) libkdemultimedia1-3.5.1-7.mdk2006.0.mde.i586

devel(libXcursor) is needed by (installed) libgtk+2.0_0-devel-2.8.3-4.2.20060mdk.i586

devel(libXcursor) is needed by (installed) libmas1-devel-0.6.3-1mdk.i586

devel(libXcursor) is needed by (installed) libqt3-devel-3.3.5-10.mdk2006.0.mde.i586

devel(libXcursor) is needed by (installed) libarts1-devel-1.5.1-8.mdk2006.0.mde.i586

devel(libXext) is needed by (installed) libcairo2-devel-1.0.0-8mdk.i586

devel(libXext) is needed by (installed) libpango1.0_0-devel-1.10.0-3mdk.i586

devel(libXext) is needed by (installed) libgtk+2.0_0-devel-2.8.3-4.2.20060mdk.i586

devel(libXext) is needed by (installed) libmas1-devel-0.6.3-1mdk.i586

devel(libXext) is needed by (installed) libqt3-devel-3.3.5-10.mdk2006.0.mde.i586

devel(libXext) is needed by (installed) libarts1-devel-1.5.1-8.mdk2006.0.mde.i586

devel(libXext) is needed by (installed) libkdemultimedia1-3.5.1-7.mdk2006.0.mde.i586

devel(libXfixes) is needed by (installed) libgtk+2.0_0-devel-2.8.3-4.2.20060mdk.i586

devel(libXfixes) is needed by (installed) libqt3-devel-3.3.5-10.mdk2006.0.mde.i586

devel(libXfixes) is needed by (installed) libarts1-devel-1.5.1-8.mdk2006.0.mde.i586

devel(libXft) is needed by (installed) libpango1.0_0-devel-1.10.0-3mdk.i586

devel(libXft) is needed by (installed) libmas1-devel-0.6.3-1mdk.i586

devel(libXft) is needed by (installed) libqt3-devel-3.3.5-10.mdk2006.0.mde.i586

devel(libXft) is needed by (installed) libarts1-devel-1.5.1-8.mdk2006.0.mde.i586

devel(libXi) is needed by (installed) libgtk+2.0_0-devel-2.8.3-4.2.20060mdk.i586

devel(libXi) is needed by (installed) libmas1-devel-0.6.3-1mdk.i586

devel(libXinerama) is needed by (installed) libgtk+2.0_0-devel-2.8.3-4.2.20060mdk.i586

devel(libXinerama) is needed by (installed) libmas1-devel-0.6.3-1mdk.i586

devel(libXinerama) is needed by (installed) libqt3-devel-3.3.5-10.mdk2006.0.mde.i586

devel(libXinerama) is needed by (installed) libarts1-devel-1.5.1-8.mdk2006.0.mde.i586

devel(libXrandr) is needed by (installed) libgtk+2.0_0-devel-2.8.3-4.2.20060mdk.i586

devel(libXrandr) is needed by (installed) libmas1-devel-0.6.3-1mdk.i586

devel(libXrandr) is needed by (installed) libqt3-devel-3.3.5-10.mdk2006.0.mde.i586

devel(libXrandr) is needed by (installed) libarts1-devel-1.5.1-8.mdk2006.0.mde.i586

devel(libXrender) is needed by (installed) libcairo2-devel-1.0.0-8mdk.i586

devel(libXrender) is needed by (installed) libpango1.0_0-devel-1.10.0-3mdk.i586

devel(libXrender) is needed by (installed) libgtk+2.0_0-devel-2.8.3-4.2.20060mdk.i586

devel(libXrender) is needed by (installed) libmas1-devel-0.6.3-1mdk.i586

devel(libXrender) is needed by (installed) libqt3-devel-3.3.5-10.mdk2006.0.mde.i586

devel(libXrender) is needed by (installed) libarts1-devel-1.5.1-8.mdk2006.0.mde.i586

devel(libXt) is needed by (installed) libnas2-devel-1.7b-1mdk.i586

devel(libXt) is needed by (installed) libqt3-devel-3.3.5-10.mdk2006.0.mde.i586

devel(libXt) is needed by (installed) libarts1-devel-1.5.1-8.mdk2006.0.mde.i586

devel(libXt) is needed by (installed) libkdemultimedia1-3.5.1-7.mdk2006.0.mde.i586

devel(libXv) is needed by (installed) libkdemultimedia1-3.5.1-7.mdk2006.0.mde.i586

devel(libXxf86vm) is needed by (installed) libkdemultimedia1-3.5.1-7.mdk2006.0.mde.i586

libxorg-x11-devel >= 11:6.9.0-34.mdk2006.0.mde is needed by (installed) libqt3-devel-3.3.5-10.mdk2006.0.mde.i586

libxorg-x11-devel >= 12:6.9.0-36.mdk2006.0.mde is needed by (installed) libarts1-devel-1.5.1-8.mdk2006.0.mde.i586

 

--

CarLash

Share this post


Link to post
Share on other sites

This happened because i put a kdemultimedia-3.5.1-7 in www.mde.djura.org/2006.0/RPMS/ that was overwrtting the good kdemultimedia-3.5.1-7 in www.mde.djura.org/2006.0/RPMS/kde-3.5.1-7

 

When i did this i was very tired and mixed things, sorry.

 

Anyway im doing a new release increase and ill upload it.

Share this post


Link to post
Share on other sites

Thanks for all your work making KDE 3.5.1 available. Today I did urpmi --auto-select and the following 6 packages were installed:

 

kdemultimedia-3.5.1-8.mdk2006.0.mde.i586

kdemultimedia-kmix-3.5.1-8.mdk2006.0.mde.i586

kdemultimedia-kscd-3.5.1-8.mdk2006.0.mde.i586

libkdemultimedia1-3.5.1-8.mdk2006.0.mde.i586

libkdemultimedia1-kmix-3.5.1-8.mdk2006.0.mde.i586

libkdemultimedia1-kscd-3.5.1-8.mdk2006.0.mde.i586

 

Then I was able to remove 27 devel packages: :D

 

libxpm4-devel-3.4k-31mdk removed

libqt3-devel-3.3.5-10.mdk2006.0.mde removed

libgtk+2.0_0-devel-2.8.3-4.2.20060mdk removed

libxorg-x11-devel-6.9.0-39.mdk2006.0.mde removed

libgdk_pixbuf2.0_0-devel-2.8.3-4.2.20060mdk removed

libarts1-devel-1.5.1-8.mdk2006.0.mde removed

libmas1-devel-0.6.3-1mdk removed

libcairo2-devel-1.0.0-8mdk removed

libpango1.0_0-devel-1.10.0-3mdk removed

libnas2-devel-1.7b-1mdk removed

libvorbis0-devel-1.1.1-1mdk removed

libalsa2-devel-1.0.10-1.mdk2006.0.mde removed

liblcms1-devel-1.14-1mdk removed

libmng1-devel-1.0.8-1mdk removed

libmad0-devel-0.15.1b-3mdk removed

libatk1.0_0-devel-1.10.1-1mdk removed

libglib2.0_0-devel-2.8.1-1mdk removed

libaudiofile0-devel-0.2.6-3mdk removed

libesound0-devel-0.2.36-1mdk removed

libjpeg62-devel-6b-37mdk removed

libexpat0-devel-1.95.8-1mdk removed

libfontconfig1-devel-2.3.2-5mdk removed

libogg0-devel-1.1.2-1mdk removed

libpng3-devel-1.2.8-1mdk removed

libfreetype6-devel-2.1.10-9.1.20060mdk removed

zlib1-devel-1.2.3-1mdk removed

libcdda0-devel-IIIa9.8-10mdk removed

 

However, there is one more -devel package I cannot remove -- liblua5-devel-5.0.2-7mdk.

 

# rpm -ev liblua5-devel

error: Failed dependencies:

liblua.so is needed by (installed) libkdecore4-3.5.1-12.mdk2006.0.mde.i586

liblualib.so is needed by (installed) libkdecore4-3.5.1-12.mdk2006.0.mde.i586

 

--

Thanks again - CarLash

Share this post


Link to post
Share on other sites

rpm -e --test liblua5-devel

erro: Failed dependencies:

liblua.so is needed by (installed) libkdecore4-3.5.1-12.mdk2006.0.mde.i586

liblualib.so is needed by (installed) libkdecore4-3.5.1-12.mdk2006.0.mde.i586

liblua5-devel is needed by (installed) libkdecore4-devel-3.5.1-12.mdk2006.0.mde.i586

 

Its a fact that liblua.so and liblualib.so are required by libkdecore, but as you see liblua5-devel is only required by libkdecore-devel.

 

Here i dont see any error, i even take a look to liblua mandriva packages and all files seams to be in correct places, so i only see one explication for this, its how kdelibs code is done that makes libkdecore require devel files, in this case you have to speak with kde developers.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...