Jump to content

Font rendering very poor


Recommended Posts



Ever since I started using Linux (MDK 10.0) I've wondered why the fonts rendered so badly on screen. I see people's screenshots and everything looks so crisp and smooth, but I can never match this.


I've diddled with the anti-alias and sub-pixel hinting settings in KDE and tried every possible combination (I think), but the results never seem to change.


Anti-alias on = 'dense' characters like 'a' and 's' badly blurred, hard on the eyes

Anti-alias off = BADLY pixellated characters (actually look distorted in some cases)


I turn hinting off in Windows on the same laptop because it renders blurry on my LCD, but I guess it is still anti-aliased because there's no pixellation, and the fonts look fine. But this middle-ground doesn't seem possible under Mandrake/KDE.


Can anyone teach me more about this? Does being on an LCD screen mean this is the best it's gonna get, or is there anything else I can try?


Thanks in advance...


[moved from Laptops by spinynorman]

Link to comment
Share on other sites

Thanks devries, that seems the best setting I've tried yet. There is still some blurring, especially in the titlebar text, but a bit less hard on the eyes at least. The window contents (esp. in Firefox as I type this) seem to show the greatest improvement. Why such difference between the different areas of the UI?

Link to comment
Share on other sites

Probably something to do with the 'shade' setting in the windeco. Go to the kde control center, look and feel, window decoration and check/uncheck the 'textshade' option. If that doesn't work try a different font. Under fonts change windowfont to something else. (some fonts don't look good with aa)


Difference: probably a font issue. Click standard (don't forget to uncheck exclude fontsize afterwards) and restart X.

Link to comment
Share on other sites

  • 2 weeks later...

Thanks, I spent some time playing around with different fonts but sans still seems best for readability (Arial, Verdana and a couple of others are not bad too, but no better).


It's the actual text content inside various windows that really seems to suffer. Prime examples are Kwrite, and the majority of web content in both Konq and Firefox.


Is there something 'Global' in the X server setttings that I could try tinkering with? All the window-decor is tolerable now, it's just the things that (maybe) aren't covered by the WM that still suck.

Link to comment
Share on other sites

Can you please share a screenshot, so we can better see what exactly are you talking about?

There can be various 'bad font rendering'

One I noticed is that MDK usually screws up fonts after installing freetype and fontconfig. For me at least.


p.s. Fonts have become better, sharper in each new Mandriva version.

Edited by solarian
Link to comment
Share on other sites



One I noticed is that MDK usually screws up fonts after installing freetype and fontconfig. For me at least.




I have exactly the same problem at each time!


All is fine and when urpmi install freetype (from plf) fonts becomes ugly! :huh:


Then I configure gnome-font-properties & mcc to ajust my fonts settings.


But there I have a new bug @ every reboot -> I have to launch gnome-font-properties before all others applications to fix this problem (fonts sizes are buggy/crappy/ugly before I launch gnome-font-properties).


Another way I found to fix this problem is to launch the gnome-settings-daemon but I don't know how to do this automatically as a daemon ...


So ... not estethic but it works for me => first of all, gnome-font-properties in my .xinitrc file (I'm using blackbox) then I click on 'OK' and all other auto-start apps in my xinitrc file look nice (and apps I launch manually after my system initialisation too).




My xinitrc file (launched when I start BlackBox from KDM because I re-wrote the mandriva startblackbox sh file):



#2005-03 Theo

#Starting the WM ...
/usr/local/bin/blackbox & wmpid=$! # (from source)
#/usr/X11R6/bin/blackbox & wmpid=$! # (from RPM)

#Launch system apps
devilspie & dppid=$! &
gnome-font-properties #to resolve the GTK/KDE fonts rendering bug...

#Launch favorites apps
/usr/bin/gkrellm -w &
konsole --vt_sz 125x12 --geometry +0+709 --workdir ~ --type shell &
knotes &
amarok -p -a http://www.shoutcast.com/sbin/shoutcast-playlist.pls?rn=3537&file=filename.pls &
/usr/share/thunderbird/thunderbird &

#Launch temporary apps
#d4x &

#Launch background apps
sleep 5 & xscreensaver -nosplash &

#Terminate useless apps
kill $dppid

#... and finally waiting before exiting
wait $wmpid


My startblackbox file (modified):


#2005-03 Theo


if [ -e ~/.xinitrc ]
exec /usr/X11R6/bin/blackbox


Link to comment
Share on other sites

hope this works out for you!


I think that freetype messes up xorg-x11-75dpi-fonts, but I'm not sure that it doesn't mess up any other xorg packages, therefore I've always done a complete reinstall just to be safe.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...