Jump to content

salvage screwed hdd [solved]


Recommended Posts

Ok...here's the story...I got a new hard drive so I put it in and started formatting and stuff...installed a few OSes...then I put my old ones back for the night so my mom could use it the next day and stuff (this was late at night), so then today I pulled 'em back out, installed windoze on the new one, then plugged in the old one to grab the data off it...and it didn't work. I tried a buncha different stuff, figuring it was just a bootloader problem or something, but no install discs would even load up fully. So then I put both my old ones back, reinstalled the bootloader....and windoze wouldn't boot. So, I open up Linux to try to pull my stuff over that way...and I find that my C partition is totally screwed. Odd thing is, the other 2 on that drive are fully intact...but the C drive...well...

[root@localhost root]# dir /mnt/win_c
!×\r.#×\r        \001á\r.\003á\r  íí\r.úí\r        q£\r.s£\r
!?\r.#?\r        \tá\r.\vá\r      i×\r.k×\r        q£\r.s£\r
!£\r.#£\r        \021á\r.\023á\r  i?\r.k?\r        qü\r.sü\r
?×\r.?×\r        \031á\r.\033á\r  i?\r.k?\r        qü\r.sü\r
?×\r.?×\r        aá\r.cá\r        i£\r.k£\r        ßá\r.òá\r
?×\r.?×\r        aá\r.cá\r        i£\r.k£\r        ßí\r.òí\r
?×\r.?×\r        a×\r.c×\r        iø\r.kø\r        ß×\r.ò×\r
?×\r.?×\r        a×\r.c×\r        iø\r.kø\r        ß?\r.ò?\r
??\r.??\r        a?\r.c?\r        iø\r.kø\r        ß£\r.ò£\r
??\r.??\r        a?\r.c?\r        iø\r.kø\r        ßø\r.òø\r
??\r.??\r        a£\r.c£\r        íø\r.úø\r        ßø\r.òø\r
??\r.??\r        a£\r.c£\r        íø\r.úø\r        ßü\r.òü\r
??\r.??\r        æá\r.ôá\r        í×\r.ú×\r        ®ü\r.½ü\r
?£\r.?£\r        æí\r.ôí\r        í?\r.ú?\r        ±ü\r.¾ü\r
?£\r.?£\r        æ×\r.ô×\r        í£\r.ú£\r        ¨ü\r.¹ü\r
?£\r.?£\r        æ?\r.ô?\r        iü\r.kü\r        ü×\r.â×\r
?£\r.?£\r        æ£\r.ô£\r        iü\r.kü\r        ü?\r.â?\r
)×\r.+×\r        æø\r.ôø\r        íü\r.úü\r        ü£\r.â£\r
)?\r.+?\r        æü\r.ôü\r        ®ø\r.½ø\r        üá\r.âá\r
)£\r.+£\r        aí\r.cí\r        ®ø\r.½ø\r        úá\r.ùá\r
\001×\r.\003×\r  aí\r.cí\r        ±ø\r.¾ø\r        üí\r.âí\r
\001?\r.\003?\r  aø\r.cø\r        ±ø\r.¾ø\r        úí\r.ùí\r
\001£\r.\003£\r  aø\r.cø\r        ¨ø\r.¹ø\r        üø\r.âø\r
\t×\r.\v×\r      aø\r.cø\r        ¨ø\r.¹ø\r        üø\r.âø\r
\t?\r.\v?\r      aø\r.cø\r        öá\r.øá\r        \016ú\r.ôø\r
\t£\r.\v£\r      aü\r.cü\r        öí\r.øí\r        úø\r.ùø\r
\021×\r.\023×\r  aü\r.cü\r        ö×\r.ø×\r        úø\r.ùø\r
\021?\r.\023?\r  ðá\r.ëá\r        ö?\r.ø?\r        ú×\r.ù×\r
\021£\r.\023£\r  ð×\r.ë×\r        ö£\r.ø£\r        ú?\r.ù?\r
\031×\r.\033×\r  ð?\r.ë?\r        !ø\r.#ø\r        ú£\r.ù£\r
\031?\r.\033?\r  ð£\r.ë£\r        !ø\r.#ø\r        !ü\r.#ü\r
\031£\r.\033£\r  ðí\r.ëí\r        ?ø\r.?ø\r        ?ü\r.?ü\r
®?\r.½?\r        ðø\r.ëø\r        ?ø\r.?ø\r        ?ü\r.?ü\r
®£\r.½£\r        ðø\r.ëø\r        ?ø\r.?ø\r        ?ü\r.?ü\r
±×\r.¾×\r        ðü\r.ëü\r        ?ø\r.?ø\r        ?ü\r.?ü\r
±?\r.¾?\r        ëá\r.ïá\r        ?ø\r.?ø\r        ?ü\r.?ü\r
±£\r.¾£\r        êã\r.sø\r        ?ø\r.?ø\r        )ü\r.+ü\r
¨×\r.¹×\r        ë×\r.ï×\r        ?ø\r.?ø\r        \001ü\r.\003ü\r
¨?\r.¹?\r        ë?\r.ï?\r        ?ø\r.?ø\r        \tü\r.\vü\r
¨£\r.¹£\r        ë£\r.ï£\r        ?ø\r.?ø\r        \021ü\r.\023ü\r
1×\r.3×\r        ëí\r.ïí\r        ?ø\r.?ø\r        \031ü\r.\033ü\r
1?\r.3?\r        ëø\r.ïø\r        )ø\r.+ø\r        üü\r.âü\r
1£\r.3£\r        ®×\r.éú\r        )ø\r.+ø\r        úü\r.ùü\r
1á\r.3á\r        ëü\r.ïü\r        \001ø\r.\003ø\r  y×\r.[×\r
1í\r.3í\r        ®í\r.½í\r        \001ø\r.\003ø\r  y×\r.{×\r
1ø\r.3ø\r        ±í\r.¾í\r        \tø\r.\vø\r      y?\r.[?\r
1ø\r.3ø\r        ¨í\r.¹í\r        \tø\r.\vø\r      y?\r.{?\r
1ü\r.3ü\r        i×\r.a?\r        \021ø\r.\023ø\r  y£\r.[£\r
9×\r.;×\r        iá\r.ká\r        \021ø\r.\023ø\r  y£\r.{£\r
9£\r.;£\r        iá\r.ká\r        \031ø\r.\033ø\r  yá\r.[á\r
9á\r.;á\r        íá\r.úá\r        \031ø\r.\033ø\r  yá\r.{á\r
9í\r.;í\r        !í\r.#í\r        öø\r.øø\r        yí\r.[í\r
9ø\r.;ø\r        ?í\r.?í\r        öø\r.øø\r        yí\r.{í\r
9ü\r.;ü\r        ?í\r.?í\r        öü\r.øü\r        yø\r.[ø\r
®á\r.½á\r        ?í\r.?í\r        qá\r.sá\r        yø\r.[ø\r
±á\r.¾á\r        ?í\r.?í\r        qá\r.sá\r        yø\r.{ø\r
¨á\r.¹á\r        ?í\r.?í\r        qí\r.sí\r        yø\r.{ø\r
!á\r.#á\r        )í\r.+í\r        qí\r.sí\r        yü\r.[ü\r
?á\r.?á\r        \001í\r.\003í\r  qø\r.sø\r        yü\r.{ü\r
?á\r.?á\r        \tí\r.\ví\r      qø\r.sø\r           \017:?\r.;?\r
?á\r.?á\r        \021í\r.\023í\r  q×\r.s×\r           \017:ø\r.;ø\r
?á\r.?á\r        \031í\r.\033í\r  q×\r.s×\r           \017rø\r.sø\r
?á\r.?á\r        ií\r.kí\r        q?\r.s?\r
)á\r.+á\r        ií\r.kí\r        q?\r.s?\r

so...anything I could try? I normally wouldn't even ask...I'd just assume it was all gone...but why the heck are the other partitions fine?



awww hell...those files total about 200megs...

:furious3::wall: :unsure: :huh: :wacko: :sad: :help::end::cry:



and they're rapidly disappearing! 150MB now! *unplugs hdd* *realizes I unplugged the linux one* *unplugs the right one* (wow...and it didn't crash...that's what I can stable!)

Crap...I'm screwed, aren't I?

Edited by Urza9814
Link to comment
Share on other sites

You sure you put things back exactly ? same IDE... same place on cable... same jumpers ? If this windows is XP... I noticed it is very particular about these things. I just installed XP on a brand new disc (to replace my dead one) and it installed on F: even tho it was a brand new drive with nothing else ??? and guess what ? you can't change it without reinstalling XP.


I can only offer guesses and suggestions here. I would try running partition magic and hope that clears this "glitch." If that is not available* I would try booting a startup disc and trying fdsk or scandisk (worth a shot I guess).


Could it be reading C: as another format type? Maybe hook it up as a slave elsewhere... just to see if you can save the data (worse case).



*PM ?

Link to comment
Share on other sites

I'm inclined to say yes, you're screwed. HOwever, there's some things to check.


It is 'possible' that with certai incorrect jumper setting, that thing like this can appear, when in reality there's nothing wrong. That's a sctretch, as usualy bad jumpers mean the drive is not reccognized at all, or in some cases, the system won't post, but it is 'possible" And since both of these were isntalled as single drives, and you're now trying to install them as master and slave, you would need to change the jumpers.


It goes without saying however, that unplugging the ribbon cable from a drive that is powered up, is probably the very worst hing you could do. So don't do that anymore, it's really not smart. It should also go without saying that changing the jumpers requires a cold reboot.


Now, check your jumpers, master set to master, slave set to slave. Make sure you cabels are connected properly, long end to the mobo, middle to master, short to slave.


If you're connecting them with seperate cables, so that each is a single drive, and the jumper settings wouldn't have changed, then I'm pretty sure you're screwed.

Link to comment
Share on other sites



don't run fdisk. Bad.

And if you try partition magic, be damn careful. Most anything you could do with partition magic would make it worse unles you used parttion magic to back-up the drive.

Link to comment
Share on other sites

aight, something is seriously wrong here...I realized the drive was losing data INSANELY fast, so I unplugged it...then about 2 minutes later Linux started getting read write and bus errors everywhere...couldn't even shut down properly, just got a mass of never-ending errors...so then I decide to go to the new drive and just boot off that...I get an 'hal.dll is missing or corrupt' error...so I try to reinstall the bootloader for MDK 10.1 (already installed it earlier, before windoze), and it didn't work. So I try to reinstall MDK 10.1, and I get an error with hda5. So right now I'm trying to reinstall windoze...hoping that'll work...but I'm really scared now...it appears that any hdd I plug in starts losing data at an insane rate...

One thing I did remember is that when I went to install windoze on the new drive the first time, my mobo started beeping and a message came up that said something was trying to modifiy the MBR...I figured it was just the windoze install and hit ok...but...it didn't do that any other time...maybe it was just 'cause it was a new drive...but...I dunno...the fact that none of three drives and multiple OSes seem to be working is kinda scary.

Edited by Urza9814
Link to comment
Share on other sites

I think your mainboard has carked it (died).


If it was memory failure you would have different symptoms.


Or maybe you actually got a bios virus.


I do not think the problem is with your drives.




Link to comment
Share on other sites

Well when the Bios was telling you something was trying to write to the MBR, That means to me that in your bios the option for virus scanning is on (or) you are running Mcafee or Norton and it warning you about the attemped mbr writing. Like everyone said check to make sure that the window drive is on Master not Slave or Select. Also you may want to try and make sure that LBR is On in the Bios. As for the Data being erase ... GOT me but i remember in the 90's a bios virus that did a low level format of all HD's. You also my want to try a LIVE CD and mount the partitions.


Link to comment
Share on other sites

You also my want to try a LIVE CD and mount the partitions.


This would be my preferred option, mount ro and just check about a bit...

if its a Win virus its disabled because your not running Windows... if its a bios virus then seriously not much you can do that way...it seems a bit late... but it also seems unlikely...


most likely like John and others say is a borked mobo OR you just changed the partition OR the partition table didn't finish being written too...


what was happening when you got the message ...??

Link to comment
Share on other sites

Well, my windoze install survived the night, so, that's probably a good sign...lol...it's not a windoze virus, I know that, because data was disappearing when I was in Linux...

what was happening when you got the message ...??

The WinXP installer was just starting up...

Hmmm...if it IS a BIOS virus, could flashing the BIOS fix it? And the MBR...is that stored on the mobo? I always thought it was a part of the HDD....

I'm thinking I'm gonna try this again when I get home from school today...try plugging the old windoze drive in and installing MDK 10.1, and if it doesn't work I'll try using the Norton Antivirus disc's thing...it's got a scanner you can boot off the CD...set the 'bloodhound' really high...lol...

Also think I might reboot right now, and if I can still boot up then it's not a virus in the mobo anywhere, becuase if it was it'd take out this drive too...only thing I got on here is windoze, so it's not like it'll get slowed down with other crap...

Link to comment
Share on other sites

Ok...the good news is, my computer has reparied itself yet again...everything boots fine...and the old hdd's C partition has all the data it should on it.

The bad news is, that data is still all screwed up. It says there's almost 10GB there (445 free, exactly as it should be), but only about 200MB of that shows up in those weird files. I try windoze's scan disc program, but that didn't do anything. I don't yet have Linux on this drive, so I can't do anything with that yet...so...I think I'm gonna try googling for some windoze tools right now...

Link to comment
Share on other sites

did you ever check your jumper settings? Just about everyone ehere suggested it, and I haven't seen you post anything about doing it, maybe I'm just blind. Anyway, it could be that still. If not, you need a new motherboard would be my assesment. I reccomend soyo.

Link to comment
Share on other sites

did you ever check your jumper settings? Just about everyone ehere suggested it, and I haven't seen you post anything about doing it, maybe I'm just blind. Anyway, it could be that still. If not, you need a new motherboard would be my assesment. I reccomend soyo.

Yup...I checked 'em...

I don't need a new mobo...it's working fine now...I dunno...yea, this mobo is a $30 POS, but it seems fine now, so...

Link to comment
Share on other sites

Well, let me say this, and you can do what you want with my advice. Computers are dumb. I mean, profoundly stupid. They only know how to do what theya re told to do. I guarantee you, that you computer, has not been told how to automaticaly repair the kinds of errors you reported. It just doesn't happen.


What that means is that the problem is still there, whatever caused it. Yea for you, there's no bad symptoms right now, but this is a temporary state. I Strongly reccomend, you do whatever is needed to find and fix the problem, or next time, instead of mysterious errors, you might loose data for real. I tend to agree with the others here. It sounds like you motherboard, particularly the ide controller or bios, are headed south. By replacing your motherboard now, while you haven't lost anything, you are buying relatively cheap insurance.


If money is an issue (and when is it not an issue?) got to http://www.newegg.com and check out their prices.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...