Jump to content
Sign in to follow this  
Guest joehill

check out Waimea

Recommended Posts

Guest joehill

Well, it's no cure for cancer, but it has some cool features, at least one kinda funny bug, and...

 

transparency!

 

check out my transparent slit/dock...

 

click

 

get it here

Share this post


Link to post
Share on other sites

what are you using to display the icons? idesk? or something else?

 

i was attempting to use idesk, but it was being qwerky and not doing the icon transparency right.

 

and whats the kinda funny bug? i haven't found it...

Share this post


Link to post
Share on other sites
Guest joehill

actually, the icons are bbbutton, a dockapp. since the dockapp holder (slit, dock, etc.) is totally transparent, the icons seem to just be floating, like a "normal" desktop.

 

the funny bug was if you use a 1x3 virtual desktop and start some apps on different "screens", some might disappear if you do a reload config, say from switching themes.

 

i lost xmms, could not find it on any screens. weird.

 

the themeing engine is wicked. support for pixmaps (someone will do an aqua window decoration no doubt). text shadows. wow.

 

still I miss the simplicity of fluxbox. this waimea could be a bitch to configure from the looks of it. check out the actions file...

Share this post


Link to post
Share on other sites

A screenshot I saw somewhere showed the tittlebars and menus transparent (translucent). Have you tried to figure that out yet, or seen anything to that effect?

Share this post


Link to post
Share on other sites
Guest joehill

yep it's all in the style file. here is my dock/slit:

 

dockappholder.*.frame:           raised gradient vertical

 dockappholder.*.frame.color:   #fbfbfb

 dockappholder.*.frame.colorTo: #f1f1f1

 dockappholder.*.frame.opacity: 100

 

the frame opacity is set to 100, totally transparent.

 

for the menu:

 

menu.title:                     raised gradient vertical

 menu.title.color:             #fbfbfb

 menu.title.colorTo:           #f1f1f1

 menu.title.textColor:         black

 menu.title.textShadowColor:   #a1a1a1

 menu.title.textShadowXOffset: 1

 menu.title.textShadowYOffset: 1

 menu.title.opacity:           0



menu.frame:             raised gradient vertical

 menu.frame.color:     #fbfbfb

 menu.frame.colorTo:   #f1f1f1

 menu.frame.textColor: black

 menu.frame.textShadowColor:   #a1a1a1

 menu.frame.textShadowXOffset: 1

 menu.frame.textShadowYOffset: 1

 menu.frame.opacity:   0

 

mine is set to opaque, but you could just change the 0 to whatever percentage.

 

you can also see in there how the text shadow is set.

Share this post


Link to post
Share on other sites
A screenshot I saw somewhere showed the tittlebars and menus transparent (translucent). Have you tried to figure that out yet, or seen anything to that effect?

that's basically a default look in all of the styles i've used. not many _don't_ use it, as it looks so damn cool...

 

question:

i don't use virtual desktops much, so i figured how to only have one. but my question is, where can i modify the extended desktop size? I think mine is at 1x6 or something...i can go 2 screens more to the right. and there is a whole set of 3 other screens if i take my mouse down to the bottom. I wouldn't mind keeping them, but i tire of getting too close to an edge and switching to the next desktop.

 

maybe if there was a way for the mouse to "pause" on the edge? so that I have to really intend to go to the next desktop?

 

hopefully you know what i mean.

Share this post


Link to post
Share on other sites
Guest joehill

I know exactly what you mean, dude.

 

Make sure which config file is being loaded, ie. the one in your home directoy (you must create it).

 

For setting the virtual desktop size, 1st num is width, second num is height, so I use 6x1, that way I have 6 virtual dtops horizontally.

 

It does take some getting used to, I keep switching dtops accidentally. Strangely, the vertical shifts seem to take an extra nudge, did you notice that?

 

also, I cannot seem to get the styles directory in my ~/.waimearc/styles to show in the menu, it's totally empty. so far it seems i've gotta edit some perl script.

 

sheesh, fluxbox is childsplay compared to this.

Share this post


Link to post
Share on other sites
also, I cannot seem to get the styles directory in my ~/.waimearc/styles to show in the menu, it's totally empty. so far it seems i've gotta edit some perl script.

 

it should be ~/.waimea/styles not .waimearc (that's the file, not the dir :) )

i'm sure that was just a typo up above, but just thought I'd mention it. also make sure that in your .waimearc file you have the styles dir set to ~/.waimea/styles/

 

also: what are you using to startup programs when you login? are you coming from a console, and putting them in .xinitrc, or coming from a graphical login and using something else?

Share this post


Link to post
Share on other sites
Guest joehill

hmmmm, coulda sworn I posted a reply already...

 

thanks, that fixed it right up.

 

ya, I login from text mode and use an .xinitrc file to launch all of my goodies.

 

I found this:

 

https://sourceforge.net/forum/forum.php?for...forum_id=126645

 

I'm joining the mailing list as well.

 

got this useful tip:

 

By: hrglgrmpf ( Johannes Weißl )

RE: Viewport-switching sensitivity

2002-11-17 09:35

well, there is one. replace the four lines in your action-file

with the four lines written below:

 

westedge { ViewportLeft : EnterNotify [300 : LeaveNotify] }

eastedge { ViewportRight : EnterNotify [300 : LeaveNotify] }

northedge { ViewportUp : EnterNotify [300 : LeaveNotify] }

southedge { ViewportDown : EnterNotify [300 : LeaveNotify] }

 

 

cheers!

Share this post


Link to post
Share on other sites

i see you...

Users browsing this forum: joehill

 

mua ha ha ha ha!!

Share this post


Link to post
Share on other sites
I can't stop playing with this thing! Waimea I mean...

 

riiiiiiiigggghhttt.............we all know you love your........

 

 

 

WAFFLE!!

 

 

you thought i was gonna say...............didn't ya?

Share this post


Link to post
Share on other sites

i can't seem to get bbbuttons to compile on my system...not sure what the deal is, missing some file i think..

Share this post


Link to post
Share on other sites

Sorry for the earlier post about transparency :oops: The monitor on the pc at work is so bad, I couldn't even see the trans in the menus of joehills screenshot. *sigh* I'm home now...I'll give it a whirl tonight or tomorrow :wink:

Share this post


Link to post
Share on other sites

joe: did bbbuttons compile fine for you? i seem to be missing a header file:

 

In file included from bbbutton.c:13:

bbbutton.h:9:21: X11/xpm.h: No such file or directory

bbbutton.c: In function `int main(int, char**)':

bbbutton.c:106: `XpmCreatePixmapFromData' undeclared (first use this function)

bbbutton.c:106: (Each undeclared identifier is reported only once for each function it appears in.)

bbbutton.c:108: `XpmReadFileToData' undeclared (first use this function)

make: *** [bbbutton] Error 1

 

odd :-/

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...